WindowsFormsCalendar Namespace

WindowsFormsCalendar Namespace A Sandcastle Documented Class Library
Send Feedback
The WinFormsCalendar
Classes
 | Class | Description
Public class | Calendar | Hosts a calendar view where user can manage calendar items.
Public class | CalendarColorTable | Provides color information of calendar graphical elements
Public class | CalendarDay | Represents a day present on the Calendar control's view.
Public class | CalendarDayEventArgs | Event data with a CalendarDay element
Public class | CalendarDayTop | Represents the top area of a day, where multiday and all day items are stored
Public class | CalendarHighlightRange | Represents a range of time that is highlighted as work-time
Public class | CalendarItem | Represents an item of the calendar with a date and timespan
Public class | CalendarItemCancelEventArgs | Event arguments for calendar cancel item event
Public class | CalendarItemCollection | A collection of calendar items
Public class | CalendarItemEventArgs | Event arguments for the calendar item events.
Public class | CalendarLoadEventArgs | Holds data of a Calendar Loading Items of certain date range
Public class | CalendarProfessionalRenderer | Renders the professional calendar control
Public class | CalendarRenderer | Base class that renders visual elements of Calendar control
Public class | CalendarRendererBoxEventArgs | Contains information about something's bounds and text to draw on the calendar
Public class | CalendarRendererDayEventArgs | Contains information about a day to draw on the calendar
Public class | CalendarRendererEventArgs | Contains basic information about a drawing event for CalendarRenderer
Public class | CalendarRendererItemBoundsEventArgs | Event arguments for calendar renter item bounds
Public class | CalendarRendererItemEventArgs | Contains information to render an item
Public class | CalendarRendererTimeUnitEventArgs | Contains information about a CalendarTimeScaleUnit that is about to be painted
Public class | CalendarSelectableElement | Implements a basic ICalendarSelectableElement
Public class | CalendarSystemRenderer | CalendarRenderer that renders low-intensity calendar for slow computers
Public class | CalendarTextBox | A text box control used in the calendar
Public class | CalendarTimeScaleUnit | Represents a selectable timescale unit on a CalendarDay
Public class | CalendarWeek | Represents a week displayed on the Calendar
Public class | MonthView | Hosts a month-level calendar where user can select day-based dates
Public class | MonthViewBoxEventArgs | Holds data about a box of text to be rendered on the month view
Public class | MonthViewDay | A class that represents a month view day
Public class | MonthViewMontEventArgs | Month view event argument data
Public class | MonthViewMonth | Represents a month displayed"/>
Interfaces
 | Interface | Description
Public interface | ICalendarSelectableElement | Interface implemented by every selectable element of the calendar
Public interface | ISelectableElement | Represents a clickable element of MonthView control
Delegates
 | Delegate | Description
Public delegate | Calendar CalendarDayEventHandler | Delegate that supports CalendarDay-related events
Public delegate | Calendar CalendarItemCancelEventHandler | Delegate that supports cancelable item-related events
Public delegate | Calendar CalendarItemEventHandler | Delegate that supports item-related events
Public delegate | Calendar CalendarLoadEventHandler | Delegate that supports LoadItems event
Enumerations
 | Enumeration | Description
Public enumeration | CalendarDaysMode | Enumerates the possible modes of the days visualization on the Calendar
Public enumeration | CalendarItemImageAlign | Possible alignment for CalendarItem images
Public enumeration | CalendarScrollBars | Enumeration for the different type of scroll bars
Public enumeration | CalendarState | Possible states of the calendar
Public enumeration | CalendarTimeFormat | An enumeration that represents the time format of the calendar
Public enumeration | CalendarTimeScale | Enumerates possible timescales for Calendar control
Public enumeration | Corners | Possible corners to pass to the RoundRectangle method
Public enumeration | MonthViewSelection | Represents the different kinds of selection in MonthView

Justin LeCheminant

Send Feedback on this topic.


Calendar Class

Calendar Class A Sandcastle Documented Class Library
Hosts a calendar view where user can manage calendar items.
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.ComponentModel Component
Online System.Windows.Forms Control
Online System.Windows.Forms ScrollableControl
WindowsFormsCalendar Calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class Calendar _
    Inherits ScrollableControl
Public Class Calendar _
    Inherits ScrollableControl
public class Calendar : ScrollableControl
public class Calendar : ScrollableControl
public ref class Calendar : public ScrollableControl
public ref class Calendar : public ScrollableControl
See Also
Calendar Members
WindowsFormsCalendar Namespace


Calendar Members

Calendar Members A Sandcastle Documented Class Library

The Calendar type exposes the following members.
Constructors
 | Name | Description
Public method | Calendar | Creates a new Calendar control
Back to Top
Methods
 | Name | Description
Protected method | Online AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified Online AccessibleEvents for the specified child control. (Inherited from Online Control.)
Protected method | Online AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified Online AccessibleEvents for the specified child control . (Inherited from Online Control.)
Public method | ActivateEditMode | Activates the edit mode on the first selected item
Public method | ActivateEditMode(CalendarItem) | Activates the edit mode on the specified item
Protected method | Online AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Online ScrollableControl.)
Public method | Online BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Online Control.)
Public method | Online BeginInvoke(Delegate, Object ) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Online Control.)
Public method | Online BringToFront | Brings the control to the front of the z-order. (Inherited from Online Control.)
Public method | Online Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Online Control.)
Protected method | Online CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Online Control.)
Public method | Online CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Online Control.)
Protected method | Online CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Online Control.)
Public method | Online CreateGraphics | Creates the Online Graphics for the control. (Inherited from Online Control.)
Protected method | Online CreateHandle | Creates a handle for the control. (Inherited from Online Control.)
Public method | CreateItemOnSelection | Creates a new item on the current selection. If there's no selection, this will be ignored.
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
 | DateIntersects | Returns a value indicating if two date ranges intersect.
Protected method | Online DefWndProc | Sends the specified message to the default window procedure. (Inherited from Online Control.)
Protected method | Online DestroyHandle | Destroys the handle associated with the control. (Inherited from Online Control.)
Public method | Online Dispose | Releases all resources used by the Online Component. (Inherited from Online Component.)
Protected method | Online Dispose(Boolean) | Releases the unmanaged resources used by the Online Control and its child controls and optionally releases the managed resources. (Inherited from Online Control.)
Public method | Online DoDragDrop | Begins a drag-and-drop operation. (Inherited from Online Control.)
Public method | Online DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Online Control.)
Public method | Online EndInvoke | Retrieves the return value of the asynchronous operation represented by the Online IAsyncResult passed. (Inherited from Online Control.)
Public method | EnsureVisible | Ensures the scrolling shows the specified time unit. It doesn't affect View date ranges.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Releases unmanaged resources and performs other cleanup operations before the Online Component is reclaimed by garbage collection. (Inherited from Online Component.)
Public method | FinalizeEditMode | Finalizes editing the EditModeItem.
Public method | FindDay | Finds the CalendarDay for the specified date, if in the view.
Public method | Online FindForm | Retrieves the form that the control is on. (Inherited from Online Control.)
Public method | Online Focus | Sets input focus to the control. (Inherited from Online Control.)
Protected method | Online GetAccessibilityObjectById | Retrieves the specified Online AccessibleObject. (Inherited from Online Control.)
Protected method | Online GetAutoSizeMode | Retrieves a value indicating how a control will behave when its Online AutoSize property is enabled. (Inherited from Online Control.)
Public method | Online GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Online Control.)
Public method | Online GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Online Control.)
Public method | Online GetContainerControl | Returns the next Online ContainerControl up the control's chain of parent controls. (Inherited from Online Control.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Online Control.)
Public method | Online GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Online Control.)
Protected method | Online GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Online Control.)
Protected method | Online GetScrollState | Determines whether the specified flag has been set. (Inherited from Online ScrollableControl.)
Public method | GetSelectedItems | Gets the items that are currently selected
Protected method | Online GetService | Returns an object that represents a service provided by the Online Component or by its Online Container. (Inherited from Online Component.)
Protected method | Online GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Online Control.)
Public method | GetTimeUnit | Gets the time unit that starts with the specified date
Protected method | Online GetTopLevel | Determines if the control is a top-level control. (Inherited from Online Control.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online Hide | Conceals the control from the user. (Inherited from Online Control.)
Public method | HitTest(Point) | Searches for the first hitted ICalendarSelectableElement
Public method | HitTest(Point, Boolean) | Searches for the first hitted ICalendarSelectableElement
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online InitLayout | Called after the control has been added to another container. (Inherited from Online Control.)
Public method | Online Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Online Control.)
Public method | Online Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Online Control.)
Public method | Invalidate(CalendarDay) | Invalidates the bounds of the specified day
Public method | Invalidate(CalendarItem) | Invalidates the area of the specified item
Public method | Invalidate(CalendarTimeScaleUnit) | Ivalidates the bounds of the specified unit
Public method | Online Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Online Control.)
Public method | Online Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Online Control.)
Public method | Online Invoke(Delegate, Object ) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Online Control.)
Protected method | Online InvokeGotFocus | Raises the Online GotFocus event for the specified control. (Inherited from Online Control.)
Protected method | Online InvokeLostFocus | Raises the Online LostFocus event for the specified control. (Inherited from Online Control.)
Protected method | Online InvokeOnClick | Raises the Online Click event for the specified control. (Inherited from Online Control.)
Protected method | Online InvokePaint | Raises the Online Paint event for the specified control. (Inherited from Online Control.)
Protected method | Online InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Online Control.)
Protected method | Online IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Online Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Overrides Online Control IsInputKey(Keys).)
Public method | ItemAt | Returns the item hitted at the specified location. Null if no item hitted.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online NotifyInvalidate | Raises the Online Invalidated event with a specified region of the control to invalidate. (Inherited from Online Control.)
Protected method | Online OnAutoSizeChanged | Raises the Online AutoSizeChanged event. (Inherited from Online Control.)
Protected method | Online OnBackColorChanged | Raises the Online BackColorChanged event. (Inherited from Online Control.)
Protected method | Online OnBackgroundImageChanged | Raises the Online BackgroundImageChanged event. (Inherited from Online Control.)
Protected method | Online OnBackgroundImageLayoutChanged | Raises the Online BackgroundImageLayoutChanged event. (Inherited from Online Control.)
Protected method | Online OnBindingContextChanged | Raises the Online BindingContextChanged event. (Inherited from Online Control.)
Protected method | Online OnCausesValidationChanged | Raises the Online CausesValidationChanged event. (Inherited from Online Control.)
Protected method | Online OnChangeUICues | Raises the Online ChangeUICues event. (Inherited from Online Control.)
Protected method | OnClick | Raises the Online Click event. (Overrides Online Control OnClick(EventArgs).)
Protected method | Online OnClientSizeChanged | Raises the Online ClientSizeChanged event. (Inherited from Online Control.)
Protected method | Online OnContextMenuChanged | Raises the Online ContextMenuChanged event. (Inherited from Online Control.)
Protected method | Online OnContextMenuStripChanged | Raises the Online ContextMenuStripChanged event. (Inherited from Online Control.)
Protected method | Online OnControlAdded | Raises the Online ControlAdded event. (Inherited from Online Control.)
Protected method | Online OnControlRemoved | Raises the Online ControlRemoved event. (Inherited from Online Control.)
Protected method | OnCreateControl | Raises the Online CreateControl method. (Overrides Online Control OnCreateControl .)
Protected method | Online OnCursorChanged | Raises the Online CursorChanged event. (Inherited from Online Control.)
Protected method | OnDayHeaderClick | Raises the [E:DayHeaderClick] event.
Protected method | Online OnDockChanged | Raises the Online DockChanged event. (Inherited from Online Control.)
Protected method | OnDoubleClick | Raises the Online DoubleClick event. (Overrides Online Control OnDoubleClick(EventArgs).)
Protected method | Online OnDragDrop | Raises the Online DragDrop event. (Inherited from Online Control.)
Protected method | Online OnDragEnter | Raises the Online DragEnter event. (Inherited from Online Control.)
Protected method | Online OnDragLeave | Raises the Online DragLeave event. (Inherited from Online Control.)
Protected method | Online OnDragOver | Raises the Online DragOver event. (Inherited from Online Control.)
Protected method | Online OnEnabledChanged | Raises the Online EnabledChanged event. (Inherited from Online Control.)
Protected method | Online OnEnter | Raises the Online Enter event. (Inherited from Online Control.)
Protected method | Online OnFontChanged | Raises the Online FontChanged event. (Inherited from Online Control.)
Protected method | Online OnForeColorChanged | Raises the Online ForeColorChanged event. (Inherited from Online Control.)
Protected method | Online OnGiveFeedback | Raises the Online GiveFeedback event. (Inherited from Online Control.)
Protected method | Online OnGotFocus | Raises the Online GotFocus event. (Inherited from Online Control.)
Protected method | Online OnHandleCreated | Raises the Online HandleCreated event. (Inherited from Online Control.)
Protected method | Online OnHandleDestroyed | Raises the Online HandleDestroyed event. (Inherited from Online Control.)
Protected method | Online OnHelpRequested | Raises the Online HelpRequested event. (Inherited from Online Control.)
Protected method | Online OnImeModeChanged | Raises the Online ImeModeChanged event. (Inherited from Online Control.)
Protected method | Online OnInvalidated | Raises the Online Invalidated event. (Inherited from Online Control.)
Protected method | OnItemClick | Raises the [E:ItemClick] event.
Protected method | OnItemCreated | Raises the [E:ItemCreated] event.
Protected method | OnItemCreating | Raises the [E:ItemCreating] event.
Protected method | OnItemDatesChanged | Raises the [E:ItemDatesChanged] event.
Protected method | OnItemDeleted | Raises the [E:ItemDeleted] event.
Protected method | OnItemDeleting | Raises the [E:ItemDeleting] event.
Protected method | OnItemDoubleClick | Raises the [E:ItemDoubleClick] event.
Protected method | OnItemEdited | Raises the [E:ItemEdited] event.
Protected method | OnItemEditing | Raises the [E:ItemEditing] event.
Protected method | OnItemMouseHover | Raises the [E:ItemMouseHover] event.
Protected method | OnItemSelected | Raises the [E:ItemSelected] event.
Protected method | OnItemsPositioned | Raises the [E:ItemsPositioned] event.
Protected method | OnKeyDown | Raises the Online KeyDown event. (Overrides Online Control OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the Online KeyPress event. (Overrides Online Control OnKeyPress(KeyPressEventArgs).)
Protected method | Online OnKeyUp | Raises the Online KeyUp event. (Inherited from Online Control.)
Protected method | Online OnLayout | (Inherited from Online ScrollableControl.)
Protected method | Online OnLeave | Raises the Online Leave event. (Inherited from Online Control.)
Protected method | OnLoadItems | Raises the [E:LoadItems] event.
Protected method | Online OnLocationChanged | Raises the Online LocationChanged event. (Inherited from Online Control.)
Protected method | Online OnLostFocus | Raises the Online LostFocus event. (Inherited from Online Control.)
Protected method | Online OnMarginChanged | Raises the Online MarginChanged event. (Inherited from Online Control.)
Protected method | Online OnMouseCaptureChanged | Raises the Online MouseCaptureChanged event. (Inherited from Online Control.)
Protected method | Online OnMouseClick | Raises the Online MouseClick event. (Inherited from Online Control.)
Protected method | OnMouseDoubleClick | Raises the Online MouseDoubleClick event. (Overrides Online Control OnMouseDoubleClick(MouseEventArgs).)
Protected method | OnMouseDown | Raises the Online MouseDown event. (Overrides Online Control OnMouseDown(MouseEventArgs).)
Protected method | Online OnMouseEnter | Raises the Online MouseEnter event. (Inherited from Online Control.)
Protected method | Online OnMouseHover | Raises the Online MouseHover event. (Inherited from Online Control.)
Protected method | Online OnMouseLeave | Raises the Online MouseLeave event. (Inherited from Online Control.)
Protected method | OnMouseMove | Raises the Online MouseMove event. (Overrides Online Control OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the Online MouseUp event. (Overrides Online Control OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the Online MouseWheel event. (Overrides Online ScrollableControl OnMouseWheel(MouseEventArgs).)
Protected method | Online OnMove | Raises the Online Move event. (Inherited from Online Control.)
Protected method | Online OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Online Control.)
Protected method | Online OnPaddingChanged | Raises the Online PaddingChanged event. (Inherited from Online ScrollableControl.)
Protected method | OnPaint | Raises the Online Paint event. (Overrides Online Control OnPaint(PaintEventArgs).)
Protected method | Online OnPaintBackground | Paints the background of the control. (Inherited from Online ScrollableControl.)
Protected method | Online OnParentBackColorChanged | Raises the Online BackColorChanged event when the Online BackColor property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentBackgroundImageChanged | Raises the Online BackgroundImageChanged event when the Online BackgroundImage property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentBindingContextChanged | Raises the Online BindingContextChanged event when the Online BindingContext property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentChanged | Raises the Online ParentChanged event. (Inherited from Online Control.)
Protected method | Online OnParentCursorChanged | Raises the Online CursorChanged event. (Inherited from Online Control.)
Protected method | Online OnParentEnabledChanged | Raises the Online EnabledChanged event when the Online Enabled property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentFontChanged | Raises the Online FontChanged event when the Online Font property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentForeColorChanged | Raises the Online ForeColorChanged event when the Online ForeColor property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentRightToLeftChanged | Raises the Online RightToLeftChanged event when the Online RightToLeft property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentVisibleChanged | Raises the Online VisibleChanged event when the Online Visible property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnPreviewKeyDown | Raises the Online PreviewKeyDown event. (Inherited from Online Control.)
Protected method | Online OnPrint | Raises the Online Paint event. (Inherited from Online Control.)
Protected method | Online OnQueryContinueDrag | Raises the Online QueryContinueDrag event. (Inherited from Online Control.)
Protected method | Online OnRegionChanged | Raises the Online RegionChanged event. (Inherited from Online Control.)
Protected method | OnResize | Raises the Online Resize event. (Overrides Online Control OnResize(EventArgs).)
Protected method | Online OnRightToLeftChanged | (Inherited from Online ScrollableControl.)
Protected method | Online OnScroll | Raises the Online Scroll event. (Inherited from Online ScrollableControl.)
Protected method | Online OnSizeChanged | Raises the Online SizeChanged event. (Inherited from Online Control.)
Protected method | Online OnStyleChanged | Raises the Online StyleChanged event. (Inherited from Online Control.)
Protected method | Online OnSystemColorsChanged | Raises the Online SystemColorsChanged event. (Inherited from Online Control.)
Protected method | Online OnTabIndexChanged | Raises the Online TabIndexChanged event. (Inherited from Online Control.)
Protected method | Online OnTabStopChanged | Raises the Online TabStopChanged event. (Inherited from Online Control.)
Protected method | Online OnTextChanged | Raises the Online TextChanged event. (Inherited from Online Control.)
Protected method | Online OnValidated | Raises the Online Validated event. (Inherited from Online Control.)
Protected method | Online OnValidating | Raises the Online Validating event. (Inherited from Online Control.)
Protected method | Online OnVisibleChanged | (Inherited from Online ScrollableControl.)
Public method | Online PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Online Control.)
Public method | Online PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Online Control.)
Public method | Online PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Online Control.)
Public method | Online PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Online Control.)
Public method | Online PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Online Control.)
Public method | Online PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Online Control.)
Protected method | Online ProcessCmdKey | Processes a command key. (Inherited from Online Control.)
Protected method | Online ProcessDialogChar | Processes a dialog character. (Inherited from Online Control.)
Protected method | Online ProcessDialogKey | Processes a dialog key. (Inherited from Online Control.)
Protected method | Online ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Online Control.)
Protected method | Online ProcessKeyMessage | Processes a keyboard message. (Inherited from Online Control.)
Protected method | Online ProcessKeyPreview | Previews a keyboard message. (Inherited from Online Control.)
Protected method | Online ProcessMnemonic | Processes a mnemonic character. (Inherited from Online Control.)
Protected method | Online RaiseDragEvent | Raises the appropriate drag event. (Inherited from Online Control.)
Protected method | Online RaiseKeyEvent | Raises the appropriate key event. (Inherited from Online Control.)
Protected method | Online RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Online Control.)
Protected method | Online RaisePaintEvent | Raises the appropriate paint event. (Inherited from Online Control.)
Protected method | Online RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Online Control.)
Public method | Online RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Online Control.)
Public method | Online RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Online Control.)
Public method | Online Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Online Control.)
Public method | Online ResetBackColor | Resets the Online BackColor property to its default value. (Inherited from Online Control.)
Public method | Online ResetBindings | Causes a control bound to the Online BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Online Control.)
Public method | Online ResetCursor | Resets the Online Cursor property to its default value. (Inherited from Online Control.)
Public method | Online ResetFont | Resets the Online Font property to its default value. (Inherited from Online Control.)
Public method | Online ResetForeColor | Resets the Online ForeColor property to its default value. (Inherited from Online Control.)
Public method | Online ResetImeMode | Resets the Online ImeMode property to its default value. (Inherited from Online Control.)
Protected method | Online ResetMouseEventArgs | Resets the control to handle the Online MouseLeave event. (Inherited from Online Control.)
Public method | Online ResetRightToLeft | Resets the Online RightToLeft property to its default value. (Inherited from Online Control.)
Public method | Online ResetText | Resets the Online Text property to its default value. (Inherited from Online Control.)
Public method | Online ResumeLayout | Resumes usual layout logic. (Inherited from Online Control.)
Public method | Online ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Online Control.)
Protected method | Online RtlTranslateAlignment(HorizontalAlignment) | Converts the specified Online HorizontalAlignment to the appropriate Online HorizontalAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateAlignment(LeftRightAlignment) | Converts the specified Online LeftRightAlignment to the appropriate Online LeftRightAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateAlignment(ContentAlignment) | Converts the specified Online ContentAlignment to the appropriate Online ContentAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateContent | Converts the specified Online ContentAlignment to the appropriate Online ContentAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateHorizontal | Converts the specified Online HorizontalAlignment to the appropriate Online HorizontalAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateLeftRight | Converts the specified Online LeftRightAlignment to the appropriate Online LeftRightAlignment to support right-to-left text. (Inherited from Online Control.)
Public method | Online Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Online Control.)
Public method | Online Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Online Control.)
Public method | Online Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Online Control.)
Protected method | Online ScaleControl | (Inherited from Online ScrollableControl.)
Protected method | Online ScaleCore | (Inherited from Online ScrollableControl.)
Public method | Online ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from Online ScrollableControl.)
Protected method | Online ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from Online ScrollableControl.)
Public method | Online Select | Activates the control. (Inherited from Online Control.)
Protected method | Online Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Online Control.)
Public method | Online SelectNextControl | Activates the next control. (Inherited from Online Control.)
Public method | Online SendToBack | Sends the control to the back of the z-order. (Inherited from Online Control.)
Public method | Online SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from Online ScrollableControl.)
Protected method | Online SetAutoSizeMode | Sets a value indicating how a control will behave when its Online AutoSize property is enabled. (Inherited from Online Control.)
Public method | Online SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Online Control.)
Public method | Online SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Online Control.)
Protected method | Online SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Online Control.)
Protected method | Online SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Online Control.)
Protected method | Online SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from Online ScrollableControl.)
Protected method | Online SetScrollState | Sets the specified scroll state flag. (Inherited from Online ScrollableControl.)
Public method | SetSelectionRange | Establishes the selection range with only one graphical update.
Protected method | Online SetStyle | Sets a specified Online ControlStyles flag to either true or false. (Inherited from Online Control.)
Protected method | Online SetTopLevel | Sets the control as the top-level control. (Inherited from Online Control.)
Public method | SetViewRange | Sets the value of ViewStart and ViewEnd properties triggering only one repaint process
Protected method | Online SetVisibleCore | Sets the control to the specified visible state. (Inherited from Online Control.)
Public method | Online Show | Displays the control to the user. (Inherited from Online Control.)
Protected method | Online SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Online Control.)
Public method | Online SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Online Control.)
Public method | Online ToString | Returns a Online String containing the name of the Online Component, if any. This method should not be overridden. (Inherited from Online Component.)
Public method | Online Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Online Control.)
Protected method | Online UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Online Control.)
Protected method | Online UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Online Control.)
Protected method | Online UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Online Control.)
Protected method | Online UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Online Control.)
Protected method | Online UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Online Control.)
Public method | ViewIntersects(CalendarItem) | Returns a value indicating if the view range intersect the date range of the specified item
Public method | ViewIntersects(DateTime, DateTime) | Returns a value indicating if the view range intersects the specified date range.
Protected method | Online WndProc | (Inherited from Online ScrollableControl.)
Back to Top
Properties
 | Name | Description
Public property | Online AccessibilityObject | Gets the Online AccessibleObject assigned to the control. (Inherited from Online Control.)
Public property | Online AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Online Control.)
Public property | Online AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Online Control.)
Public property | Online AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Online Control.)
Public property | Online AccessibleRole | Gets or sets the accessible role of the control (Inherited from Online Control.)
Public property | Online AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Online Control.)
Public property | AllowItemEdit | Gets or sets a value indicating if the user can edit the item using the mouse or keyboard
Public property | AllowItemResize | Gets or sets a value indicating if calendar allows user to resize the calendar.
Public property | AllowNew | Gets or sets a value indicating if the control let's the user create new items.
Public property | Online Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Online Control.)
Public property | Online AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from Online ScrollableControl.)
Public property | Online AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from Online ScrollableControl.)
Public property | Online AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from Online ScrollableControl.)
Public property | Online AutoScrollOffset | Gets or sets where this control is scrolled to in Online ScrollControlIntoView(Control). (Inherited from Online Control.)
Public property | Online AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from Online ScrollableControl.)
Public property | Online AutoSize | This property is not relevant for this class. (Inherited from Online Control.)
Public property | Online BackColor | Gets or sets the background color for the control. (Inherited from Online Control.)
Public property | Online BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Online Control.)
Public property | Online BackgroundImageLayout | Gets or sets the background image layout as defined in the Online ImageLayout enumeration. (Inherited from Online Control.)
Public property | Online BindingContext | Gets or sets the Online BindingContext for the control. (Inherited from Online Control.)
Public property | Online Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Online Control.)
Public property | Online Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Online Control.)
Public property | CalendarItemFont | Gets or sets the calendar item font.
Public property | CalendarTimeFormat | Gets or sets the time format.
Protected property | Online CanEnableIme | Gets a value indicating whether the Online ImeMode property can be set to an active value, to enable IME support. (Inherited from Online Control.)
Public property | Online CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Online Control.)
Protected property | Online CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Online Control.)
Public property | Online CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Online Control.)
Public property | Online Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Online Control.)
Public property | Online CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Online Control.)
Public property | Online ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Online Control.)
Public property | Online ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Online Control.)
Public property | Online CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Online Control.)
Public property | Online Container | Gets the Online IContainer that contains the Online Component. (Inherited from Online Component.)
Public property | Online ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Online Control.)
Public property | Online ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Online Control.)
Public property | Online ContextMenuStrip | Gets or sets the Online ContextMenuStrip associated with this control. (Inherited from Online Control.)
Public property | Online Controls | Gets the collection of controls contained within the control. (Inherited from Online Control.)
Public property | Online Created | Gets a value indicating whether the control has been created. (Inherited from Online Control.)
Protected property | Online CreateParams | (Inherited from Online ScrollableControl.)
Public property | Online Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Online Control.)
Public property | Online DataBindings | Gets the data bindings for the control. (Inherited from Online Control.)
Public property | Days | Gets the days visible on the ccurrent view
Public property | DaysBodyRectangle | Gets the union of day body rectangles
Public property | DaysMode | Gets the mode in which days are drawn.
Protected property | Online DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Online Control.)
Protected property | Online DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Online Control.)
Protected property | Online DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Online Control.)
Protected property | Online DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Online Control.)
Protected property | Online DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Online Control.)
Protected property | Online DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Online Control.)
Protected property | Online DefaultSize | Gets the default size of the control. (Inherited from Online Control.)
Protected property | Online DesignMode | Gets a value that indicates whether the Online Component is currently in design mode. (Inherited from Online Component.)
Public property | Online DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from Online ScrollableControl.)
Public property | Online Disposing | Gets a value indicating whether the base Online Control class is in the process of disposing. (Inherited from Online Control.)
Public property | Online Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Online Control.)
Public property | Online DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from Online ScrollableControl.)
Protected property | Online DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Online Control.)
Public property | EditMode | Gets if the calendar is currently in edit mode of some item
Public property | EditModeItem | Gets the item being edited (if any)
Public property | Online Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Online Control.)
Protected property | Online Events | Gets the list of event handlers that are attached to this Online Component. (Inherited from Online Component.)
Public property | FirstDayOfWeek | Gets or sets the first day of weeks
Public property | Online Focused | Gets a value indicating whether the control has input focus. (Inherited from Online Control.)
Public property | Online Font | Gets or sets the font of the text displayed by the control. (Inherited from Online Control.)
Protected property | Online FontHeight | Gets or sets the height of the font of the control. (Inherited from Online Control.)
Public property | Online ForeColor | Gets or sets the foreground color of the control. (Inherited from Online Control.)
Public property | Online Handle | Gets the window handle that the control is bound to. (Inherited from Online Control.)
Public property | Online HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Online Control.)
Public property | Online Height | Gets or sets the height of the control. (Inherited from Online Control.)
Public property | HighlightRanges | Gets or sets the time ranges that should be highlighted as work-time. This ranges are week based.
Public property | Online HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from Online ScrollableControl.)
Protected property | Online HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from Online ScrollableControl.)
Public property | Online ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Online Control.)
Protected property | Online ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Online Control.)
Public property | Online InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Online Control.)
Public property | Online IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Online Control.)
Public property | Online IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Online Control.)
Public property | Online IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Online Control.)
Public property | Online IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Online Control.)
Public property | Items | Gets the collection of items currently on the view.
Public property | ItemsDateFormat | Gets or sets the format in which time is shown in the items, when applicable
Public property | ItemsTimeFormat | Gets or sets the format in which time is shown in the items, when applicable
Public property | Online LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Online Control.)
Public property | Online Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Online Control.)
Public property | Online Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Online Control.)
Public property | Online Margin | Gets or sets the space between controls. (Inherited from Online Control.)
Public property | MaximumFullDays | Gets or sets the maximum full days shown on the view. After this amount of days, they will be shown as short days.
Public property | Online MaximumSize | Gets or sets the size that is the upper limit that Online GetPreferredSize(Size) can specify. (Inherited from Online Control.)
Public property | MaximumViewDays | Gets or sets the maximum amount of days supported by the view. Value must be multiple of 7
Public property | Online MinimumSize | Gets or sets the size that is the lower limit that Online GetPreferredSize(Size) can specify. (Inherited from Online Control.)
Public property | Online Name | Gets or sets the name of the control. (Inherited from Online Control.)
Public property | Online Padding | Gets or sets padding within the control. (Inherited from Online Control.)
Public property | Online Parent | Gets or sets the parent container of the control. (Inherited from Online Control.)
Public property | Online PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Online Control.)
Public property | Online ProductName | Gets the product name of the assembly containing the control. (Inherited from Online Control.)
Public property | Online ProductVersion | Gets the version of the assembly containing the control. (Inherited from Online Control.)
Public property | Online RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Online Control.)
Public property | Online Region | Gets or sets the window region associated with the control. (Inherited from Online Control.)
Public property | Renderer | Gets or sets the CalendarRenderer of the Calendar
Protected property | Online RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Online Control.)
Protected property | Online ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Online Control.)
Public property | Online Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Online Control.)
Public property | Online RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Online Control.)
Protected property | Online ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Online Control.)
Public property | Scrollbars | Gets or sets the scrollbars.
Public property | SelectedElementEnd | Gets the last selected element
Public property | SelectedElementStart | Gets the first selected element
Public property | SelectionEnd | Gets or sets the end date-time of the view's selection.
Public property | SelectionStart | Gets or sets the start date-time of the view's selection.
Protected property | Online ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Online Control.)
Protected property | Online ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Online Control.)
Public property | Online Site | Gets or sets the site of the control. (Inherited from Online Control.)
Public property | Online Size | Gets or sets the height and width of the control. (Inherited from Online Control.)
Public property | State | Gets or sets the state of the calendar
Public property | Online TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Online Control.)
Public property | Online TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Online Control.)
Public property | Online Tag | Gets or sets the object that contains data about the control. (Inherited from Online Control.)
Public property | Online Text | Gets or sets the text associated with this control. (Inherited from Online Control.)
Public property | TimeScale | Gets or sets the CalendarTimeScale for visualization.
Public property | TimeUnitsOffset | Gets or sets the offset of scrolled units
Public property | Online Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Online Control.)
Public property | Online TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Online Form that the control is contained in. (Inherited from Online Control.)
Public property | Online UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Online Control.)
Public property | Online VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from Online ScrollableControl.)
Public property | ViewEnd | Gets or sets the end date-time of the current view.
Public property | ViewStart | Gets or sets the start date-time of the current view.
Public property | Online Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Online Control.)
Protected property | Online VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from Online ScrollableControl.)
Public property | Weeks | Gets the weeks currently visible on the calendar, if DaysMode is Short
Public property | Online Width | Gets or sets the width of the control. (Inherited from Online Control.)
Public property | Online WindowTarget | This property is not relevant for this class. (Inherited from Online Control.)
Back to Top
Events
 | Name | Description
Public event | Online AutoSizeChanged | This event is not relevant for this class. (Inherited from Online Control.)
Public event | Online BackColorChanged | Occurs when the value of the Online BackColor property changes. (Inherited from Online Control.)
Public event | Online BackgroundImageChanged | Occurs when the value of the Online BackgroundImage property changes. (Inherited from Online Control.)
Public event | Online BackgroundImageLayoutChanged | Occurs when the Online BackgroundImageLayout property changes. (Inherited from Online Control.)
Public event | Online BindingContextChanged | Occurs when the value of the Online BindingContext property changes. (Inherited from Online Control.)
Public event | Online CausesValidationChanged | Occurs when the value of the Online CausesValidation property changes. (Inherited from Online Control.)
Public event | Online ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Online Control.)
Public event | Online Click | Occurs when the control is clicked. (Inherited from Online Control.)
Public event | Online ClientSizeChanged | Occurs when the value of the Online ClientSize property changes. (Inherited from Online Control.)
Public event | Online ContextMenuChanged | Occurs when the value of the Online ContextMenu property changes. (Inherited from Online Control.)
Public event | Online ContextMenuStripChanged | Occurs when the value of the Online ContextMenuStrip property changes. (Inherited from Online Control.)
Public event | Online ControlAdded | Occurs when a new control is added to the Online Control ControlCollection. (Inherited from Online Control.)
Public event | Online ControlRemoved | Occurs when a control is removed from the Online Control ControlCollection. (Inherited from Online Control.)
Public event | Online CursorChanged | Occurs when the value of the Online Cursor property changes. (Inherited from Online Control.)
Public event | DayHeaderClick | Occurs when a day header is clicked
Public event | Online Disposed | Occurs when the component is disposed by a call to the Online Dispose method. (Inherited from Online Component.)
Public event | Online DockChanged | Occurs when the value of the Online Dock property changes. (Inherited from Online Control.)
Public event | Online DoubleClick | Occurs when the control is double-clicked. (Inherited from Online Control.)
Public event | Online DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Online Control.)
Public event | Online DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Online Control.)
Public event | Online DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Online Control.)
Public event | Online DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Online Control.)
Public event | Online EnabledChanged | Occurs when the Online Enabled property value has changed. (Inherited from Online Control.)
Public event | Online Enter | Occurs when the control is entered. (Inherited from Online Control.)
Public event | Online FontChanged | Occurs when the Online Font property value changes. (Inherited from Online Control.)
Public event | Online ForeColorChanged | Occurs when the Online ForeColor property value changes. (Inherited from Online Control.)
Public event | Online GiveFeedback | Occurs during a drag operation. (Inherited from Online Control.)
Public event | Online GotFocus | Occurs when the control receives focus. (Inherited from Online Control.)
Public event | Online HandleCreated | Occurs when a handle is created for the control. (Inherited from Online Control.)
Public event | Online HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Online Control.)
Public event | Online HelpRequested | Occurs when the user requests help for a control. (Inherited from Online Control.)
Public event | Online ImeModeChanged | Occurs when the Online ImeMode property has changed. (Inherited from Online Control.)
Public event | Online Invalidated | Occurs when a control's display requires redrawing. (Inherited from Online Control.)
Public event | ItemClick | Occurs when an item is clicked
Public event | ItemCreated | Occurs when an item has been created.
Public event | ItemCreating | Occurs when an item is about to be created.
Public event | ItemDatesChanged | Occurs when an item time range has changed
Public event | ItemDeleted | Occurs when an item has been deleted
Public event | ItemDeleting | Occurs before an item is deleted
Public event | ItemDoubleClick | Occurs when an item is double-clicked
Public event | ItemMouseHover | Occurs when the mouse is moved over an item
Public event | ItemSelected | Occurs when an item is selected
Public event | ItemsPositioned | Occurs after the items are positioned
Public event | ItemTextEdited | Occurs when an item text is edited
Public event | ItemTextEditing | Occurs when an item text is about to be edited
Public event | Online KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Online Control.)
Public event | Online KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Online Control.)
Public event | Online KeyUp | Occurs when a key is released while the control has focus. (Inherited from Online Control.)
Public event | Online Layout | Occurs when a control should reposition its child controls. (Inherited from Online Control.)
Public event | Online Leave | Occurs when the input focus leaves the control. (Inherited from Online Control.)
Public event | LoadItems | Occurs when items are load into view
Public event | Online LocationChanged | Occurs when the Online Location property value has changed. (Inherited from Online Control.)
Public event | Online LostFocus | Occurs when the control loses focus. (Inherited from Online Control.)
Public event | Online MarginChanged | Occurs when the control's margin changes. (Inherited from Online Control.)
Public event | Online MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Online Control.)
Public event | Online MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Online Control.)
Public event | Online MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Online Control.)
Public event | Online MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Online Control.)
Public event | Online MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Online Control.)
Public event | Online MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Online Control.)
Public event | Online MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Online Control.)
Public event | Online MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Online Control.)
Public event | Online MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Online Control.)
Public event | Online MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Online Control.)
Public event | Online Move | Occurs when the control is moved. (Inherited from Online Control.)
Public event | Online PaddingChanged | Occurs when the control's padding changes. (Inherited from Online Control.)
Public event | Online Paint | Occurs when the control is redrawn. (Inherited from Online Control.)
Public event | Online ParentChanged | Occurs when the Online Parent property value changes. (Inherited from Online Control.)
Public event | Online PreviewKeyDown | Occurs before the Online KeyDown event when a key is pressed while focus is on this control. (Inherited from Online Control.)
Public event | Online QueryAccessibilityHelp | Occurs when Online AccessibleObject is providing help to accessibility applications. (Inherited from Online Control.)
Public event | Online QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Online Control.)
Public event | Online RegionChanged | Occurs when the value of the Online Region property changes. (Inherited from Online Control.)
Public event | Online Resize | Occurs when the control is resized. (Inherited from Online Control.)
Public event | Online RightToLeftChanged | Occurs when the Online RightToLeft property value changes. (Inherited from Online Control.)
Public event | Online Scroll | Occurs when the user or code scrolls through the client area. (Inherited from Online ScrollableControl.)
Public event | Online SizeChanged | Occurs when the Online Size property value changes. (Inherited from Online Control.)
Public event | Online StyleChanged | Occurs when the control style changes. (Inherited from Online Control.)
Public event | Online SystemColorsChanged | Occurs when the system colors change. (Inherited from Online Control.)
Public event | Online TabIndexChanged | Occurs when the Online TabIndex property value changes. (Inherited from Online Control.)
Public event | Online TabStopChanged | Occurs when the Online TabStop property value changes. (Inherited from Online Control.)
Public event | Online TextChanged | Occurs when the Online Text property value changes. (Inherited from Online Control.)
Public event | Online Validated | Occurs when the control is finished validating. (Inherited from Online Control.)
Public event | Online Validating | Occurs when the control is validating. (Inherited from Online Control.)
Public event | Online VisibleChanged | Occurs when the Online Visible property value changes. (Inherited from Online Control.)
Back to Top
See Also
Calendar Class


Calendar Constructor

Calendar Constructor A Sandcastle Documented Class Library
Creates a new Calendar control

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New
Public Sub New
public Calendar()
public Calendar()
public:
Calendar()
public:
Calendar()
See Also
Calendar Class
Calendar Members


Calendar Methods

Calendar Methods A Sandcastle Documented Class Library
The Calendar type exposes the following members.
Methods
 | Name | Description
Protected method | Online AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified Online AccessibleEvents for the specified child control. (Inherited from Online Control.)
Protected method | Online AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified Online AccessibleEvents for the specified child control . (Inherited from Online Control.)
Public method | ActivateEditMode | Activates the edit mode on the first selected item
Public method | ActivateEditMode(CalendarItem) | Activates the edit mode on the specified item
Protected method | Online AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Online ScrollableControl.)
Public method | Online BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Online Control.)
Public method | Online BeginInvoke(Delegate, Object ) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Online Control.)
Public method | Online BringToFront | Brings the control to the front of the z-order. (Inherited from Online Control.)
Public method | Online Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Online Control.)
Protected method | Online CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Online Control.)
Public method | Online CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Online Control.)
Protected method | Online CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Online Control.)
Public method | Online CreateGraphics | Creates the Online Graphics for the control. (Inherited from Online Control.)
Protected method | Online CreateHandle | Creates a handle for the control. (Inherited from Online Control.)
Public method | CreateItemOnSelection | Creates a new item on the current selection. If there's no selection, this will be ignored.
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
 | DateIntersects | Returns a value indicating if two date ranges intersect.
Protected method | Online DefWndProc | Sends the specified message to the default window procedure. (Inherited from Online Control.)
Protected method | Online DestroyHandle | Destroys the handle associated with the control. (Inherited from Online Control.)
Public method | Online Dispose | Releases all resources used by the Online Component. (Inherited from Online Component.)
Protected method | Online Dispose(Boolean) | Releases the unmanaged resources used by the Online Control and its child controls and optionally releases the managed resources. (Inherited from Online Control.)
Public method | Online DoDragDrop | Begins a drag-and-drop operation. (Inherited from Online Control.)
Public method | Online DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Online Control.)
Public method | Online EndInvoke | Retrieves the return value of the asynchronous operation represented by the Online IAsyncResult passed. (Inherited from Online Control.)
Public method | EnsureVisible | Ensures the scrolling shows the specified time unit. It doesn't affect View date ranges.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Releases unmanaged resources and performs other cleanup operations before the Online Component is reclaimed by garbage collection. (Inherited from Online Component.)
Public method | FinalizeEditMode | Finalizes editing the EditModeItem.
Public method | FindDay | Finds the CalendarDay for the specified date, if in the view.
Public method | Online FindForm | Retrieves the form that the control is on. (Inherited from Online Control.)
Public method | Online Focus | Sets input focus to the control. (Inherited from Online Control.)
Protected method | Online GetAccessibilityObjectById | Retrieves the specified Online AccessibleObject. (Inherited from Online Control.)
Protected method | Online GetAutoSizeMode | Retrieves a value indicating how a control will behave when its Online AutoSize property is enabled. (Inherited from Online Control.)
Public method | Online GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Online Control.)
Public method | Online GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Online Control.)
Public method | Online GetContainerControl | Returns the next Online ContainerControl up the control's chain of parent controls. (Inherited from Online Control.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Online Control.)
Public method | Online GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Online Control.)
Protected method | Online GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Online Control.)
Protected method | Online GetScrollState | Determines whether the specified flag has been set. (Inherited from Online ScrollableControl.)
Public method | GetSelectedItems | Gets the items that are currently selected
Protected method | Online GetService | Returns an object that represents a service provided by the Online Component or by its Online Container. (Inherited from Online Component.)
Protected method | Online GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Online Control.)
Public method | GetTimeUnit | Gets the time unit that starts with the specified date
Protected method | Online GetTopLevel | Determines if the control is a top-level control. (Inherited from Online Control.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online Hide | Conceals the control from the user. (Inherited from Online Control.)
Public method | HitTest(Point) | Searches for the first hitted ICalendarSelectableElement
Public method | HitTest(Point, Boolean) | Searches for the first hitted ICalendarSelectableElement
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online InitLayout | Called after the control has been added to another container. (Inherited from Online Control.)
Public method | Online Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Online Control.)
Public method | Online Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Online Control.)
Public method | Invalidate(CalendarDay) | Invalidates the bounds of the specified day
Public method | Invalidate(CalendarItem) | Invalidates the area of the specified item
Public method | Invalidate(CalendarTimeScaleUnit) | Ivalidates the bounds of the specified unit
Public method | Online Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Online Control.)
Public method | Online Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Online Control.)
Public method | Online Invoke(Delegate, Object ) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Online Control.)
Protected method | Online InvokeGotFocus | Raises the Online GotFocus event for the specified control. (Inherited from Online Control.)
Protected method | Online InvokeLostFocus | Raises the Online LostFocus event for the specified control. (Inherited from Online Control.)
Protected method | Online InvokeOnClick | Raises the Online Click event for the specified control. (Inherited from Online Control.)
Protected method | Online InvokePaint | Raises the Online Paint event for the specified control. (Inherited from Online Control.)
Protected method | Online InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Online Control.)
Protected method | Online IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Online Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Overrides Online Control IsInputKey(Keys).)
Public method | ItemAt | Returns the item hitted at the specified location. Null if no item hitted.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online NotifyInvalidate | Raises the Online Invalidated event with a specified region of the control to invalidate. (Inherited from Online Control.)
Protected method | Online OnAutoSizeChanged | Raises the Online AutoSizeChanged event. (Inherited from Online Control.)
Protected method | Online OnBackColorChanged | Raises the Online BackColorChanged event. (Inherited from Online Control.)
Protected method | Online OnBackgroundImageChanged | Raises the Online BackgroundImageChanged event. (Inherited from Online Control.)
Protected method | Online OnBackgroundImageLayoutChanged | Raises the Online BackgroundImageLayoutChanged event. (Inherited from Online Control.)
Protected method | Online OnBindingContextChanged | Raises the Online BindingContextChanged event. (Inherited from Online Control.)
Protected method | Online OnCausesValidationChanged | Raises the Online CausesValidationChanged event. (Inherited from Online Control.)
Protected method | Online OnChangeUICues | Raises the Online ChangeUICues event. (Inherited from Online Control.)
Protected method | OnClick | Raises the Online Click event. (Overrides Online Control OnClick(EventArgs).)
Protected method | Online OnClientSizeChanged | Raises the Online ClientSizeChanged event. (Inherited from Online Control.)
Protected method | Online OnContextMenuChanged | Raises the Online ContextMenuChanged event. (Inherited from Online Control.)
Protected method | Online OnContextMenuStripChanged | Raises the Online ContextMenuStripChanged event. (Inherited from Online Control.)
Protected method | Online OnControlAdded | Raises the Online ControlAdded event. (Inherited from Online Control.)
Protected method | Online OnControlRemoved | Raises the Online ControlRemoved event. (Inherited from Online Control.)
Protected method | OnCreateControl | Raises the Online CreateControl method. (Overrides Online Control OnCreateControl .)
Protected method | Online OnCursorChanged | Raises the Online CursorChanged event. (Inherited from Online Control.)
Protected method | OnDayHeaderClick | Raises the [E:DayHeaderClick] event.
Protected method | Online OnDockChanged | Raises the Online DockChanged event. (Inherited from Online Control.)
Protected method | OnDoubleClick | Raises the Online DoubleClick event. (Overrides Online Control OnDoubleClick(EventArgs).)
Protected method | Online OnDragDrop | Raises the Online DragDrop event. (Inherited from Online Control.)
Protected method | Online OnDragEnter | Raises the Online DragEnter event. (Inherited from Online Control.)
Protected method | Online OnDragLeave | Raises the Online DragLeave event. (Inherited from Online Control.)
Protected method | Online OnDragOver | Raises the Online DragOver event. (Inherited from Online Control.)
Protected method | Online OnEnabledChanged | Raises the Online EnabledChanged event. (Inherited from Online Control.)
Protected method | Online OnEnter | Raises the Online Enter event. (Inherited from Online Control.)
Protected method | Online OnFontChanged | Raises the Online FontChanged event. (Inherited from Online Control.)
Protected method | Online OnForeColorChanged | Raises the Online ForeColorChanged event. (Inherited from Online Control.)
Protected method | Online OnGiveFeedback | Raises the Online GiveFeedback event. (Inherited from Online Control.)
Protected method | Online OnGotFocus | Raises the Online GotFocus event. (Inherited from Online Control.)
Protected method | Online OnHandleCreated | Raises the Online HandleCreated event. (Inherited from Online Control.)
Protected method | Online OnHandleDestroyed | Raises the Online HandleDestroyed event. (Inherited from Online Control.)
Protected method | Online OnHelpRequested | Raises the Online HelpRequested event. (Inherited from Online Control.)
Protected method | Online OnImeModeChanged | Raises the Online ImeModeChanged event. (Inherited from Online Control.)
Protected method | Online OnInvalidated | Raises the Online Invalidated event. (Inherited from Online Control.)
Protected method | OnItemClick | Raises the [E:ItemClick] event.
Protected method | OnItemCreated | Raises the [E:ItemCreated] event.
Protected method | OnItemCreating | Raises the [E:ItemCreating] event.
Protected method | OnItemDatesChanged | Raises the [E:ItemDatesChanged] event.
Protected method | OnItemDeleted | Raises the [E:ItemDeleted] event.
Protected method | OnItemDeleting | Raises the [E:ItemDeleting] event.
Protected method | OnItemDoubleClick | Raises the [E:ItemDoubleClick] event.
Protected method | OnItemEdited | Raises the [E:ItemEdited] event.
Protected method | OnItemEditing | Raises the [E:ItemEditing] event.
Protected method | OnItemMouseHover | Raises the [E:ItemMouseHover] event.
Protected method | OnItemSelected | Raises the [E:ItemSelected] event.
Protected method | OnItemsPositioned | Raises the [E:ItemsPositioned] event.
Protected method | OnKeyDown | Raises the Online KeyDown event. (Overrides Online Control OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the Online KeyPress event. (Overrides Online Control OnKeyPress(KeyPressEventArgs).)
Protected method | Online OnKeyUp | Raises the Online KeyUp event. (Inherited from Online Control.)
Protected method | Online OnLayout | (Inherited from Online ScrollableControl.)
Protected method | Online OnLeave | Raises the Online Leave event. (Inherited from Online Control.)
Protected method | OnLoadItems | Raises the [E:LoadItems] event.
Protected method | Online OnLocationChanged | Raises the Online LocationChanged event. (Inherited from Online Control.)
Protected method | Online OnLostFocus | Raises the Online LostFocus event. (Inherited from Online Control.)
Protected method | Online OnMarginChanged | Raises the Online MarginChanged event. (Inherited from Online Control.)
Protected method | Online OnMouseCaptureChanged | Raises the Online MouseCaptureChanged event. (Inherited from Online Control.)
Protected method | Online OnMouseClick | Raises the Online MouseClick event. (Inherited from Online Control.)
Protected method | OnMouseDoubleClick | Raises the Online MouseDoubleClick event. (Overrides Online Control OnMouseDoubleClick(MouseEventArgs).)
Protected method | OnMouseDown | Raises the Online MouseDown event. (Overrides Online Control OnMouseDown(MouseEventArgs).)
Protected method | Online OnMouseEnter | Raises the Online MouseEnter event. (Inherited from Online Control.)
Protected method | Online OnMouseHover | Raises the Online MouseHover event. (Inherited from Online Control.)
Protected method | Online OnMouseLeave | Raises the Online MouseLeave event. (Inherited from Online Control.)
Protected method | OnMouseMove | Raises the Online MouseMove event. (Overrides Online Control OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the Online MouseUp event. (Overrides Online Control OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the Online MouseWheel event. (Overrides Online ScrollableControl OnMouseWheel(MouseEventArgs).)
Protected method | Online OnMove | Raises the Online Move event. (Inherited from Online Control.)
Protected method | Online OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Online Control.)
Protected method | Online OnPaddingChanged | Raises the Online PaddingChanged event. (Inherited from Online ScrollableControl.)
Protected method | OnPaint | Raises the Online Paint event. (Overrides Online Control OnPaint(PaintEventArgs).)
Protected method | Online OnPaintBackground | Paints the background of the control. (Inherited from Online ScrollableControl.)
Protected method | Online OnParentBackColorChanged | Raises the Online BackColorChanged event when the Online BackColor property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentBackgroundImageChanged | Raises the Online BackgroundImageChanged event when the Online BackgroundImage property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentBindingContextChanged | Raises the Online BindingContextChanged event when the Online BindingContext property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentChanged | Raises the Online ParentChanged event. (Inherited from Online Control.)
Protected method | Online OnParentCursorChanged | Raises the Online CursorChanged event. (Inherited from Online Control.)
Protected method | Online OnParentEnabledChanged | Raises the Online EnabledChanged event when the Online Enabled property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentFontChanged | Raises the Online FontChanged event when the Online Font property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentForeColorChanged | Raises the Online ForeColorChanged event when the Online ForeColor property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentRightToLeftChanged | Raises the Online RightToLeftChanged event when the Online RightToLeft property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentVisibleChanged | Raises the Online VisibleChanged event when the Online Visible property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnPreviewKeyDown | Raises the Online PreviewKeyDown event. (Inherited from Online Control.)
Protected method | Online OnPrint | Raises the Online Paint event. (Inherited from Online Control.)
Protected method | Online OnQueryContinueDrag | Raises the Online QueryContinueDrag event. (Inherited from Online Control.)
Protected method | Online OnRegionChanged | Raises the Online RegionChanged event. (Inherited from Online Control.)
Protected method | OnResize | Raises the Online Resize event. (Overrides Online Control OnResize(EventArgs).)
Protected method | Online OnRightToLeftChanged | (Inherited from Online ScrollableControl.)
Protected method | Online OnScroll | Raises the Online Scroll event. (Inherited from Online ScrollableControl.)
Protected method | Online OnSizeChanged | Raises the Online SizeChanged event. (Inherited from Online Control.)
Protected method | Online OnStyleChanged | Raises the Online StyleChanged event. (Inherited from Online Control.)
Protected method | Online OnSystemColorsChanged | Raises the Online SystemColorsChanged event. (Inherited from Online Control.)
Protected method | Online OnTabIndexChanged | Raises the Online TabIndexChanged event. (Inherited from Online Control.)
Protected method | Online OnTabStopChanged | Raises the Online TabStopChanged event. (Inherited from Online Control.)
Protected method | Online OnTextChanged | Raises the Online TextChanged event. (Inherited from Online Control.)
Protected method | Online OnValidated | Raises the Online Validated event. (Inherited from Online Control.)
Protected method | Online OnValidating | Raises the Online Validating event. (Inherited from Online Control.)
Protected method | Online OnVisibleChanged | (Inherited from Online ScrollableControl.)
Public method | Online PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Online Control.)
Public method | Online PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Online Control.)
Public method | Online PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Online Control.)
Public method | Online PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Online Control.)
Public method | Online PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Online Control.)
Public method | Online PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Online Control.)
Protected method | Online ProcessCmdKey | Processes a command key. (Inherited from Online Control.)
Protected method | Online ProcessDialogChar | Processes a dialog character. (Inherited from Online Control.)
Protected method | Online ProcessDialogKey | Processes a dialog key. (Inherited from Online Control.)
Protected method | Online ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Online Control.)
Protected method | Online ProcessKeyMessage | Processes a keyboard message. (Inherited from Online Control.)
Protected method | Online ProcessKeyPreview | Previews a keyboard message. (Inherited from Online Control.)
Protected method | Online ProcessMnemonic | Processes a mnemonic character. (Inherited from Online Control.)
Protected method | Online RaiseDragEvent | Raises the appropriate drag event. (Inherited from Online Control.)
Protected method | Online RaiseKeyEvent | Raises the appropriate key event. (Inherited from Online Control.)
Protected method | Online RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Online Control.)
Protected method | Online RaisePaintEvent | Raises the appropriate paint event. (Inherited from Online Control.)
Protected method | Online RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Online Control.)
Public method | Online RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Online Control.)
Public method | Online RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Online Control.)
Public method | Online Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Online Control.)
Public method | Online ResetBackColor | Resets the Online BackColor property to its default value. (Inherited from Online Control.)
Public method | Online ResetBindings | Causes a control bound to the Online BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Online Control.)
Public method | Online ResetCursor | Resets the Online Cursor property to its default value. (Inherited from Online Control.)
Public method | Online ResetFont | Resets the Online Font property to its default value. (Inherited from Online Control.)
Public method | Online ResetForeColor | Resets the Online ForeColor property to its default value. (Inherited from Online Control.)
Public method | Online ResetImeMode | Resets the Online ImeMode property to its default value. (Inherited from Online Control.)
Protected method | Online ResetMouseEventArgs | Resets the control to handle the Online MouseLeave event. (Inherited from Online Control.)
Public method | Online ResetRightToLeft | Resets the Online RightToLeft property to its default value. (Inherited from Online Control.)
Public method | Online ResetText | Resets the Online Text property to its default value. (Inherited from Online Control.)
Public method | Online ResumeLayout | Resumes usual layout logic. (Inherited from Online Control.)
Public method | Online ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Online Control.)
Protected method | Online RtlTranslateAlignment(HorizontalAlignment) | Converts the specified Online HorizontalAlignment to the appropriate Online HorizontalAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateAlignment(LeftRightAlignment) | Converts the specified Online LeftRightAlignment to the appropriate Online LeftRightAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateAlignment(ContentAlignment) | Converts the specified Online ContentAlignment to the appropriate Online ContentAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateContent | Converts the specified Online ContentAlignment to the appropriate Online ContentAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateHorizontal | Converts the specified Online HorizontalAlignment to the appropriate Online HorizontalAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateLeftRight | Converts the specified Online LeftRightAlignment to the appropriate Online LeftRightAlignment to support right-to-left text. (Inherited from Online Control.)
Public method | Online Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Online Control.)
Public method | Online Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Online Control.)
Public method | Online Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Online Control.)
Protected method | Online ScaleControl | (Inherited from Online ScrollableControl.)
Protected method | Online ScaleCore | (Inherited from Online ScrollableControl.)
Public method | Online ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from Online ScrollableControl.)
Protected method | Online ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from Online ScrollableControl.)
Public method | Online Select | Activates the control. (Inherited from Online Control.)
Protected method | Online Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Online Control.)
Public method | Online SelectNextControl | Activates the next control. (Inherited from Online Control.)
Public method | Online SendToBack | Sends the control to the back of the z-order. (Inherited from Online Control.)
Public method | Online SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from Online ScrollableControl.)
Protected method | Online SetAutoSizeMode | Sets a value indicating how a control will behave when its Online AutoSize property is enabled. (Inherited from Online Control.)
Public method | Online SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Online Control.)
Public method | Online SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Online Control.)
Protected method | Online SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Online Control.)
Protected method | Online SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Online Control.)
Protected method | Online SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from Online ScrollableControl.)
Protected method | Online SetScrollState | Sets the specified scroll state flag. (Inherited from Online ScrollableControl.)
Public method | SetSelectionRange | Establishes the selection range with only one graphical update.
Protected method | Online SetStyle | Sets a specified Online ControlStyles flag to either true or false. (Inherited from Online Control.)
Protected method | Online SetTopLevel | Sets the control as the top-level control. (Inherited from Online Control.)
Public method | SetViewRange | Sets the value of ViewStart and ViewEnd properties triggering only one repaint process
Protected method | Online SetVisibleCore | Sets the control to the specified visible state. (Inherited from Online Control.)
Public method | Online Show | Displays the control to the user. (Inherited from Online Control.)
Protected method | Online SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Online Control.)
Public method | Online SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Online Control.)
Public method | Online ToString | Returns a Online String containing the name of the Online Component, if any. This method should not be overridden. (Inherited from Online Component.)
Public method | Online Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Online Control.)
Protected method | Online UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Online Control.)
Protected method | Online UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Online Control.)
Protected method | Online UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Online Control.)
Protected method | Online UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Online Control.)
Protected method | Online UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Online Control.)
Public method | ViewIntersects(CalendarItem) | Returns a value indicating if the view range intersect the date range of the specified item
Public method | ViewIntersects(DateTime, DateTime) | Returns a value indicating if the view range intersects the specified date range.
Protected method | Online WndProc | (Inherited from Online ScrollableControl.)
Back to Top
See Also
Calendar Class


ActivateEditMode Method

Calendar ActivateEditMode Method A Sandcastle Documented Class Library
Send Feedback
Overload List
 | Name | Description
Public method | ActivateEditMode | Activates the edit mode on the first selected item
Public method | ActivateEditMode(CalendarItem) | Activates the edit mode on the specified item
Back to Top
See Also
Calendar Class
Calendar Members


ActivateEditMode Method

Calendar ActivateEditMode Method A Sandcastle Documented Class Library
Send Feedback
Activates the edit mode on the first selected item

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub ActivateEditMode
Public Sub ActivateEditMode
public void ActivateEditMode()
public void ActivateEditMode()
public:
void ActivateEditMode()
public:
void ActivateEditMode()
See Also
Calendar Class
Calendar Members
ActivateEditMode Overload


ActivateEditMode Method (CalendarItem)

Calendar ActivateEditMode Method (CalendarItem) A Sandcastle Documented Class Library
Send Feedback
Activates the edit mode on the specified item

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub ActivateEditMode ( _
    item As CalendarItem _
)
Public Sub ActivateEditMode ( _
    item As CalendarItem _
)
public void ActivateEditMode(
    CalendarItem item
)
public void ActivateEditMode(
    CalendarItem item
)
public:
void ActivateEditMode(
    CalendarItem^ item
)
public:
void ActivateEditMode(
    CalendarItem^ item
)
Parameters
item
Type: WindowsFormsCalendar CalendarItem
The item.
See Also
Calendar Class
Calendar Members
ActivateEditMode Overload


CreateItemOnSelection Method

Calendar CreateItemOnSelection Method A Sandcastle Documented Class Library
Send Feedback
Creates a new item on the current selection. If there's no selection, this will be ignored.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub CreateItemOnSelection ( _
    itemText As String, _
    editMode As Boolean _
)
Public Sub CreateItemOnSelection ( _
    itemText As String, _
    editMode As Boolean _
)
public void CreateItemOnSelection(
    string itemText,
    bool editMode
)
public void CreateItemOnSelection(
    string itemText,
    bool editMode
)
public:
void CreateItemOnSelection(
    String^ itemText,
    bool editMode
)
public:
void CreateItemOnSelection(
    String^ itemText,
    bool editMode
)
Parameters
itemText
Type:   Online System String
Text of the item
editMode
Type:   Online System Boolean
If true activates the edit mode so user can edit the text of the item.
See Also
Calendar Class
Calendar Members


DateIntersects Method

Calendar DateIntersects Method A Sandcastle Documented Class Library
Send Feedback
Returns a value indicating if two date ranges intersect.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Shared Function DateIntersects ( _
    startA As DateTime, _
    endA As DateTime, _
    startB As DateTime, _
    endB As DateTime _
) As Boolean
Public Shared Function DateIntersects ( _
    startA As DateTime, _
    endA As DateTime, _
    startB As DateTime, _
    endB As DateTime _
) As Boolean
public static bool DateIntersects(
    DateTime startA,
    DateTime endA,
    DateTime startB,
    DateTime endB
)
public static bool DateIntersects(
    DateTime startA,
    DateTime endA,
    DateTime startB,
    DateTime endB
)
public:
static bool DateIntersects(
    DateTime startA,
    DateTime endA,
    DateTime startB,
    DateTime endB
)
public:
static bool DateIntersects(
    DateTime startA,
    DateTime endA,
    DateTime startB,
    DateTime endB
)
Parameters
startA
Type:   Online System DateTime
The start A.
endA
Type:   Online System DateTime
The end A.
startB
Type:   Online System DateTime
The start B.
endB
Type:   Online System DateTime
The end B.
Return Value
[Missing <returns> documentation for "M:WindowsFormsCalendar.Calendar.DateIntersects(System.DateTime,System.DateTime,System.DateTime,System.DateTime)"]
See Also
Calendar Class
Calendar Members


EnsureVisible Method

Calendar EnsureVisible Method A Sandcastle Documented Class Library
Send Feedback
Ensures the scrolling shows the specified time unit. It doesn't affect View date ranges.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub EnsureVisible ( _
    unit As CalendarTimeScaleUnit _
)
Public Sub EnsureVisible ( _
    unit As CalendarTimeScaleUnit _
)
public void EnsureVisible(
    CalendarTimeScaleUnit unit
)
public void EnsureVisible(
    CalendarTimeScaleUnit unit
)
public:
void EnsureVisible(
    CalendarTimeScaleUnit^ unit
)
public:
void EnsureVisible(
    CalendarTimeScaleUnit^ unit
)
Parameters
unit
Type: WindowsFormsCalendar CalendarTimeScaleUnit
Unit to ensure visibility
See Also
Calendar Class
Calendar Members


FinalizeEditMode Method

Calendar FinalizeEditMode Method A Sandcastle Documented Class Library
Send Feedback
Finalizes editing the EditModeItem.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub FinalizeEditMode ( _
    cancel As Boolean _
)
Public Sub FinalizeEditMode ( _
    cancel As Boolean _
)
public void FinalizeEditMode(
    bool cancel
)
public void FinalizeEditMode(
    bool cancel
)
public:
void FinalizeEditMode(
    bool cancel
)
public:
void FinalizeEditMode(
    bool cancel
)
Parameters
cancel
Type:   Online System Boolean
Value indicating if edition of item should be canceled.
See Also
Calendar Class
Calendar Members


FindDay Method

Calendar FindDay Method A Sandcastle Documented Class Library
Send Feedback
Finds the CalendarDay for the specified date, if in the view.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Function FindDay ( _
    d As DateTime _
) As CalendarDay
Public Function FindDay ( _
    d As DateTime _
) As CalendarDay
public CalendarDay FindDay(
    DateTime d
)
public CalendarDay FindDay(
    DateTime d
)
public:
CalendarDay^ FindDay(
    DateTime d
)
public:
CalendarDay^ FindDay(
    DateTime d
)
Parameters
d
Type:   Online System DateTime
Date to find day
Return Value
CalendarDay object that matches the date, null if day was not found.
See Also
Calendar Class
Calendar Members


GetSelectedItems Method

Calendar GetSelectedItems Method A Sandcastle Documented Class Library
Send Feedback
Gets the items that are currently selected

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Function GetSelectedItems As IEnumerable(Of CalendarItem)
Public Function GetSelectedItems As IEnumerable(Of CalendarItem)
public IEnumerable<CalendarItem> GetSelectedItems()
public IEnumerable<CalendarItem> GetSelectedItems()
public:
IEnumerable<CalendarItem^>^ GetSelectedItems()
public:
IEnumerable<CalendarItem^>^ GetSelectedItems()
Return Value
[Missing <returns> documentation for "M:WindowsFormsCalendar.Calendar.GetSelectedItems"]
See Also
Calendar Class
Calendar Members


GetTimeUnit Method

Calendar GetTimeUnit Method A Sandcastle Documented Class Library
Send Feedback
Gets the time unit that starts with the specified date

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Function GetTimeUnit ( _
    d As DateTime _
) As CalendarTimeScaleUnit
Public Function GetTimeUnit ( _
    d As DateTime _
) As CalendarTimeScaleUnit
public CalendarTimeScaleUnit GetTimeUnit(
    DateTime d
)
public CalendarTimeScaleUnit GetTimeUnit(
    DateTime d
)
public:
CalendarTimeScaleUnit^ GetTimeUnit(
    DateTime d
)
public:
CalendarTimeScaleUnit^ GetTimeUnit(
    DateTime d
)
Parameters
d
Type:   Online System DateTime
The d.
Return Value

            Matching time unit. null If out of range.

See Also
Calendar Class
Calendar Members


HitTest Method

Calendar HitTest Method A Sandcastle Documented Class Library
Send Feedback
Overload List
 | Name | Description
Public method | HitTest(Point) | Searches for the first hitted ICalendarSelectableElement
Public method | HitTest(Point, Boolean) | Searches for the first hitted ICalendarSelectableElement
Back to Top
See Also
Calendar Class
Calendar Members


HitTest Method (Point)

Calendar HitTest Method (Point) A Sandcastle Documented Class Library
Send Feedback
Searches for the first hitted ICalendarSelectableElement

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Function HitTest ( _
    p As Point _
) As ICalendarSelectableElement
Public Function HitTest ( _
    p As Point _
) As ICalendarSelectableElement
public ICalendarSelectableElement HitTest(
    Point p
)
public ICalendarSelectableElement HitTest(
    Point p
)
public:
ICalendarSelectableElement^ HitTest(
    Point p
)
public:
ICalendarSelectableElement^ HitTest(
    Point p
)
Parameters
p
Type:   Online System.Drawing Point
Point to check for hit test
Return Value
[Missing <returns> documentation for "M:WindowsFormsCalendar.Calendar.HitTest(System.Drawing.Point)"]
See Also
Calendar Class
Calendar Members
HitTest Overload


HitTest Method (Point, Boolean)

Calendar HitTest Method (Point, Boolean) A Sandcastle Documented Class Library
Send Feedback
Searches for the first hitted ICalendarSelectableElement

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Function HitTest ( _
    p As Point, _
    ignoreItems As Boolean _
) As ICalendarSelectableElement
Public Function HitTest ( _
    p As Point, _
    ignoreItems As Boolean _
) As ICalendarSelectableElement
public ICalendarSelectableElement HitTest(
    Point p,
    bool ignoreItems
)
public ICalendarSelectableElement HitTest(
    Point p,
    bool ignoreItems
)
public:
ICalendarSelectableElement^ HitTest(
    Point p,
    bool ignoreItems
)
public:
ICalendarSelectableElement^ HitTest(
    Point p,
    bool ignoreItems
)
Parameters
p
Type:   Online System.Drawing Point
Point to check for hit test
ignoreItems
Type:   Online System Boolean
if set to true [ignore items].
Return Value
[Missing <returns> documentation for "M:WindowsFormsCalendar.Calendar.HitTest(System.Drawing.Point,System.Boolean)"]
See Also
Calendar Class
Calendar Members
HitTest Overload


Invalidate Method

Calendar Invalidate Method A Sandcastle Documented Class Library
Send Feedback
Overload List
 | Name | Description
Public method | Online Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Online Control.)
Public method | Online Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Online Control.)
Public method | Invalidate(CalendarDay) | Invalidates the bounds of the specified day
Public method | Invalidate(CalendarItem) | Invalidates the area of the specified item
Public method | Invalidate(CalendarTimeScaleUnit) | Ivalidates the bounds of the specified unit
Public method | Online Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Online Control.)
Back to Top
See Also
Calendar Class
Calendar Members


Invalidate Method (CalendarDay)

Calendar Invalidate Method (CalendarDay) A Sandcastle Documented Class Library
Send Feedback
Invalidates the bounds of the specified day

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub Invalidate ( _
    day As CalendarDay _
)
Public Sub Invalidate ( _
    day As CalendarDay _
)
public void Invalidate(
    CalendarDay day
)
public void Invalidate(
    CalendarDay day
)
public:
void Invalidate(
    CalendarDay^ day
)
public:
void Invalidate(
    CalendarDay^ day
)
Parameters
day
Type: WindowsFormsCalendar CalendarDay
The day.
See Also
Calendar Class
Calendar Members
Invalidate Overload


Invalidate Method (CalendarItem)

Calendar Invalidate Method (CalendarItem) A Sandcastle Documented Class Library
Send Feedback
Invalidates the area of the specified item

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub Invalidate ( _
    item As CalendarItem _
)
Public Sub Invalidate ( _
    item As CalendarItem _
)
public void Invalidate(
    CalendarItem item
)
public void Invalidate(
    CalendarItem item
)
public:
void Invalidate(
    CalendarItem^ item
)
public:
void Invalidate(
    CalendarItem^ item
)
Parameters
item
Type: WindowsFormsCalendar CalendarItem
The item.
See Also
Calendar Class
Calendar Members
Invalidate Overload


Invalidate Method (CalendarTimeScaleUnit)

Calendar Invalidate Method (CalendarTimeScaleUnit) A Sandcastle Documented Class Library
Send Feedback
Ivalidates the bounds of the specified unit

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub Invalidate ( _
    unit As CalendarTimeScaleUnit _
)
Public Sub Invalidate ( _
    unit As CalendarTimeScaleUnit _
)
public void Invalidate(
    CalendarTimeScaleUnit unit
)
public void Invalidate(
    CalendarTimeScaleUnit unit
)
public:
void Invalidate(
    CalendarTimeScaleUnit^ unit
)
public:
void Invalidate(
    CalendarTimeScaleUnit^ unit
)
Parameters
unit
Type: WindowsFormsCalendar CalendarTimeScaleUnit
The unit.
See Also
Calendar Class
Calendar Members
Invalidate Overload


IsInputKey Method

Calendar IsInputKey Method A Sandcastle Documented Class Library
Send Feedback
Determines whether the specified key is a regular input key or a special key that requires preprocessing.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overrides Function IsInputKey ( _
    keyData As Keys _
) As Boolean
Protected Overrides Function IsInputKey ( _
    keyData As Keys _
) As Boolean
protected override bool IsInputKey(
    Keys keyData
)
protected override bool IsInputKey(
    Keys keyData
)
protected:
virtual bool IsInputKey(
    Keys keyData
) override
protected:
virtual bool IsInputKey(
    Keys keyData
) override
Parameters
keyData
Type:   Online System.Windows.Forms Keys
One of the   Online Keys values.
Return Value

            true if the specified key is a regular input key; otherwise, false.

See Also
Calendar Class
Calendar Members


ItemAt Method

Calendar ItemAt Method A Sandcastle Documented Class Library
Returns the item hitted at the specified location. Null if no item hitted.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Function ItemAt ( _
    p As Point _
) As CalendarItem
Public Function ItemAt ( _
    p As Point _
) As CalendarItem
public CalendarItem ItemAt(
    Point p
)
public CalendarItem ItemAt(
    Point p
)
public:
CalendarItem^ ItemAt(
    Point p
)
public:
CalendarItem^ ItemAt(
    Point p
)
Parameters
p
Type:   Online System.Drawing Point
Location to serach for items
Return Value
Hitted item at the location. Null if no item hitted.
See Also
Calendar Class
Calendar Members


OnClick Method

Calendar OnClick Method A Sandcastle Documented Class Library
Send Feedback
Raises the Online Click event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overrides Sub OnClick ( _
    e As EventArgs _
)
Protected Overrides Sub OnClick ( _
    e As EventArgs _
)
protected override void OnClick(
    EventArgs e
)
protected override void OnClick(
    EventArgs e
)
protected:
virtual void OnClick(
    EventArgs^ e
) override
protected:
virtual void OnClick(
    EventArgs^ e
) override
Parameters
e
Type:   Online System EventArgs
An   Online EventArgs that contains the event data.
See Also
Calendar Class
Calendar Members


OnCreateControl Method

Calendar OnCreateControl Method A Sandcastle Documented Class Library
Send Feedback
Raises the Online CreateControl method.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overrides Sub OnCreateControl
Protected Overrides Sub OnCreateControl
protected override void OnCreateControl()
protected override void OnCreateControl()
protected:
virtual void OnCreateControl() override
protected:
virtual void OnCreateControl() override
See Also
Calendar Class
Calendar Members


OnDayHeaderClick Method

Calendar OnDayHeaderClick Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:DayHeaderClick] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overridable Sub OnDayHeaderClick ( _
    e As CalendarDayEventArgs _
)
Protected Overridable Sub OnDayHeaderClick ( _
    e As CalendarDayEventArgs _
)
protected virtual void OnDayHeaderClick(
    CalendarDayEventArgs e
)
protected virtual void OnDayHeaderClick(
    CalendarDayEventArgs e
)
protected:
virtual void OnDayHeaderClick(
    CalendarDayEventArgs^ e
)
protected:
virtual void OnDayHeaderClick(
    CalendarDayEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarDayEventArgs
The CalendarDayEventArgs instance containing the event data.
See Also
Calendar Class
Calendar Members


OnDoubleClick Method

Calendar OnDoubleClick Method A Sandcastle Documented Class Library
Send Feedback
Raises the Online DoubleClick event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overrides Sub OnDoubleClick ( _
    e As EventArgs _
)
Protected Overrides Sub OnDoubleClick ( _
    e As EventArgs _
)
protected override void OnDoubleClick(
    EventArgs e
)
protected override void OnDoubleClick(
    EventArgs e
)
protected:
virtual void OnDoubleClick(
    EventArgs^ e
) override
protected:
virtual void OnDoubleClick(
    EventArgs^ e
) override
Parameters
e
Type:   Online System EventArgs
An   Online EventArgs that contains the event data.
See Also
Calendar Class
Calendar Members


OnItemClick Method

Calendar OnItemClick Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:ItemClick] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overridable Sub OnItemClick ( _
    e As CalendarItemEventArgs _
)
Protected Overridable Sub OnItemClick ( _
    e As CalendarItemEventArgs _
)
protected virtual void OnItemClick(
    CalendarItemEventArgs e
)
protected virtual void OnItemClick(
    CalendarItemEventArgs e
)
protected:
virtual void OnItemClick(
    CalendarItemEventArgs^ e
)
protected:
virtual void OnItemClick(
    CalendarItemEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarItemEventArgs
The CalendarItemEventArgs instance containing the event data.
See Also
Calendar Class
Calendar Members


OnItemCreated Method

Calendar OnItemCreated Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:ItemCreated] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overridable Sub OnItemCreated ( _
    e As CalendarItemCancelEventArgs _
)
Protected Overridable Sub OnItemCreated ( _
    e As CalendarItemCancelEventArgs _
)
protected virtual void OnItemCreated(
    CalendarItemCancelEventArgs e
)
protected virtual void OnItemCreated(
    CalendarItemCancelEventArgs e
)
protected:
virtual void OnItemCreated(
    CalendarItemCancelEventArgs^ e
)
protected:
virtual void OnItemCreated(
    CalendarItemCancelEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarItemCancelEventArgs
The CalendarItemCancelEventArgs instance containing the event data.
See Also
Calendar Class
Calendar Members


OnItemCreating Method

Calendar OnItemCreating Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:ItemCreating] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overridable Sub OnItemCreating ( _
    e As CalendarItemCancelEventArgs _
)
Protected Overridable Sub OnItemCreating ( _
    e As CalendarItemCancelEventArgs _
)
protected virtual void OnItemCreating(
    CalendarItemCancelEventArgs e
)
protected virtual void OnItemCreating(
    CalendarItemCancelEventArgs e
)
protected:
virtual void OnItemCreating(
    CalendarItemCancelEventArgs^ e
)
protected:
virtual void OnItemCreating(
    CalendarItemCancelEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarItemCancelEventArgs
The CalendarItemCancelEventArgs instance containing the event data.
See Also
Calendar Class
Calendar Members


OnItemDatesChanged Method

Calendar OnItemDatesChanged Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:ItemDatesChanged] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overridable Sub OnItemDatesChanged ( _
    e As CalendarItemEventArgs _
)
Protected Overridable Sub OnItemDatesChanged ( _
    e As CalendarItemEventArgs _
)
protected virtual void OnItemDatesChanged(
    CalendarItemEventArgs e
)
protected virtual void OnItemDatesChanged(
    CalendarItemEventArgs e
)
protected:
virtual void OnItemDatesChanged(
    CalendarItemEventArgs^ e
)
protected:
virtual void OnItemDatesChanged(
    CalendarItemEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarItemEventArgs
The CalendarItemEventArgs instance containing the event data.
See Also
Calendar Class
Calendar Members


OnItemDeleted Method

Calendar OnItemDeleted Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:ItemDeleted] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overridable Sub OnItemDeleted ( _
    e As CalendarItemEventArgs _
)
Protected Overridable Sub OnItemDeleted ( _
    e As CalendarItemEventArgs _
)
protected virtual void OnItemDeleted(
    CalendarItemEventArgs e
)
protected virtual void OnItemDeleted(
    CalendarItemEventArgs e
)
protected:
virtual void OnItemDeleted(
    CalendarItemEventArgs^ e
)
protected:
virtual void OnItemDeleted(
    CalendarItemEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarItemEventArgs
The CalendarItemEventArgs instance containing the event data.
See Also
Calendar Class
Calendar Members


OnItemDeleting Method

Calendar OnItemDeleting Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:ItemDeleting] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overridable Sub OnItemDeleting ( _
    e As CalendarItemCancelEventArgs _
)
Protected Overridable Sub OnItemDeleting ( _
    e As CalendarItemCancelEventArgs _
)
protected virtual void OnItemDeleting(
    CalendarItemCancelEventArgs e
)
protected virtual void OnItemDeleting(
    CalendarItemCancelEventArgs e
)
protected:
virtual void OnItemDeleting(
    CalendarItemCancelEventArgs^ e
)
protected:
virtual void OnItemDeleting(
    CalendarItemCancelEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarItemCancelEventArgs
The CalendarItemCancelEventArgs instance containing the event data.
See Also
Calendar Class
Calendar Members


OnItemDoubleClick Method

Calendar OnItemDoubleClick Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:ItemDoubleClick] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overridable Sub OnItemDoubleClick ( _
    e As CalendarItemEventArgs _
)
Protected Overridable Sub OnItemDoubleClick ( _
    e As CalendarItemEventArgs _
)
protected virtual void OnItemDoubleClick(
    CalendarItemEventArgs e
)
protected virtual void OnItemDoubleClick(
    CalendarItemEventArgs e
)
protected:
virtual void OnItemDoubleClick(
    CalendarItemEventArgs^ e
)
protected:
virtual void OnItemDoubleClick(
    CalendarItemEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarItemEventArgs
The CalendarItemEventArgs instance containing the event data.
See Also
Calendar Class
Calendar Members


OnItemEdited Method

Calendar OnItemEdited Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:ItemEdited] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overridable Sub OnItemEdited ( _
    e As CalendarItemCancelEventArgs _
)
Protected Overridable Sub OnItemEdited ( _
    e As CalendarItemCancelEventArgs _
)
protected virtual void OnItemEdited(
    CalendarItemCancelEventArgs e
)
protected virtual void OnItemEdited(
    CalendarItemCancelEventArgs e
)
protected:
virtual void OnItemEdited(
    CalendarItemCancelEventArgs^ e
)
protected:
virtual void OnItemEdited(
    CalendarItemCancelEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarItemCancelEventArgs
The CalendarItemCancelEventArgs instance containing the event data.
See Also
Calendar Class
Calendar Members


OnItemEditing Method

Calendar OnItemEditing Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:ItemEditing] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overridable Sub OnItemEditing ( _
    e As CalendarItemCancelEventArgs _
)
Protected Overridable Sub OnItemEditing ( _
    e As CalendarItemCancelEventArgs _
)
protected virtual void OnItemEditing(
    CalendarItemCancelEventArgs e
)
protected virtual void OnItemEditing(
    CalendarItemCancelEventArgs e
)
protected:
virtual void OnItemEditing(
    CalendarItemCancelEventArgs^ e
)
protected:
virtual void OnItemEditing(
    CalendarItemCancelEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarItemCancelEventArgs
The CalendarItemCancelEventArgs instance containing the event data.
See Also
Calendar Class
Calendar Members


OnItemMouseHover Method

Calendar OnItemMouseHover Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:ItemMouseHover] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overridable Sub OnItemMouseHover ( _
    e As CalendarItemEventArgs _
)
Protected Overridable Sub OnItemMouseHover ( _
    e As CalendarItemEventArgs _
)
protected virtual void OnItemMouseHover(
    CalendarItemEventArgs e
)
protected virtual void OnItemMouseHover(
    CalendarItemEventArgs e
)
protected:
virtual void OnItemMouseHover(
    CalendarItemEventArgs^ e
)
protected:
virtual void OnItemMouseHover(
    CalendarItemEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarItemEventArgs
The CalendarItemEventArgs instance containing the event data.
See Also
Calendar Class
Calendar Members


OnItemSelected Method

Calendar OnItemSelected Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:ItemSelected] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overridable Sub OnItemSelected ( _
    e As CalendarItemEventArgs _
)
Protected Overridable Sub OnItemSelected ( _
    e As CalendarItemEventArgs _
)
protected virtual void OnItemSelected(
    CalendarItemEventArgs e
)
protected virtual void OnItemSelected(
    CalendarItemEventArgs e
)
protected:
virtual void OnItemSelected(
    CalendarItemEventArgs^ e
)
protected:
virtual void OnItemSelected(
    CalendarItemEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarItemEventArgs
The CalendarItemEventArgs instance containing the event data.
See Also
Calendar Class
Calendar Members


OnItemsPositioned Method

Calendar OnItemsPositioned Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:ItemsPositioned] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overridable Sub OnItemsPositioned ( _
    e As EventArgs _
)
Protected Overridable Sub OnItemsPositioned ( _
    e As EventArgs _
)
protected virtual void OnItemsPositioned(
    EventArgs e
)
protected virtual void OnItemsPositioned(
    EventArgs e
)
protected:
virtual void OnItemsPositioned(
    EventArgs^ e
)
protected:
virtual void OnItemsPositioned(
    EventArgs^ e
)
Parameters
e
Type:   Online System EventArgs
The   Online EventArgs instance containing the event data.
See Also
Calendar Class
Calendar Members


OnKeyDown Method

Calendar OnKeyDown Method A Sandcastle Documented Class Library
Send Feedback
Raises the Online KeyDown event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
protected override void OnKeyDown(
    KeyEventArgs e
)
protected override void OnKeyDown(
    KeyEventArgs e
)
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override
Parameters
e
Type:   Online System.Windows.Forms KeyEventArgs
A   Online KeyEventArgs that contains the event data.
See Also
Calendar Class
Calendar Members


OnKeyPress Method

Calendar OnKeyPress Method A Sandcastle Documented Class Library
Send Feedback
Raises the Online KeyPress event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overrides Sub OnKeyPress ( _
    e As KeyPressEventArgs _
)
Protected Overrides Sub OnKeyPress ( _
    e As KeyPressEventArgs _
)
protected override void OnKeyPress(
    KeyPressEventArgs e
)
protected override void OnKeyPress(
    KeyPressEventArgs e
)
protected:
virtual void OnKeyPress(
    KeyPressEventArgs^ e
) override
protected:
virtual void OnKeyPress(
    KeyPressEventArgs^ e
) override
Parameters
e
Type:   Online System.Windows.Forms KeyPressEventArgs
A   Online KeyPressEventArgs that contains the event data.
See Also
Calendar Class
Calendar Members


OnLoadItems Method

Calendar OnLoadItems Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:LoadItems] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overridable Sub OnLoadItems ( _
    e As CalendarLoadEventArgs _
)
Protected Overridable Sub OnLoadItems ( _
    e As CalendarLoadEventArgs _
)
protected virtual void OnLoadItems(
    CalendarLoadEventArgs e
)
protected virtual void OnLoadItems(
    CalendarLoadEventArgs e
)
protected:
virtual void OnLoadItems(
    CalendarLoadEventArgs^ e
)
protected:
virtual void OnLoadItems(
    CalendarLoadEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarLoadEventArgs
The CalendarLoadEventArgs instance containing the event data.
See Also
Calendar Class
Calendar Members


OnMouseDoubleClick Method

Calendar OnMouseDoubleClick Method A Sandcastle Documented Class Library
Send Feedback
Raises the Online MouseDoubleClick event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overrides Sub OnMouseDoubleClick ( _
    e As MouseEventArgs _
)
Protected Overrides Sub OnMouseDoubleClick ( _
    e As MouseEventArgs _
)
protected override void OnMouseDoubleClick(
    MouseEventArgs e
)
protected override void OnMouseDoubleClick(
    MouseEventArgs e
)
protected:
virtual void OnMouseDoubleClick(
    MouseEventArgs^ e
) override
protected:
virtual void OnMouseDoubleClick(
    MouseEventArgs^ e
) override
Parameters
e
Type:   Online System.Windows.Forms MouseEventArgs
An   Online MouseEventArgs that contains the event data.
See Also
Calendar Class
Calendar Members


OnMouseDown Method

Calendar OnMouseDown Method A Sandcastle Documented Class Library
Send Feedback
Raises the Online MouseDown event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
protected override void OnMouseDown(
    MouseEventArgs e
)
protected override void OnMouseDown(
    MouseEventArgs e
)
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override
Parameters
e
Type:   Online System.Windows.Forms MouseEventArgs
A   Online MouseEventArgs that contains the event data.
See Also
Calendar Class
Calendar Members


OnMouseMove Method

Calendar OnMouseMove Method A Sandcastle Documented Class Library
Send Feedback
Raises the Online MouseMove event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
protected override void OnMouseMove(
    MouseEventArgs e
)
protected override void OnMouseMove(
    MouseEventArgs e
)
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override
Parameters
e
Type:   Online System.Windows.Forms MouseEventArgs
A   Online MouseEventArgs that contains the event data.
See Also
Calendar Class
Calendar Members


OnMouseUp Method

Calendar OnMouseUp Method A Sandcastle Documented Class Library
Send Feedback
Raises the Online MouseUp event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Protected Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
protected override void OnMouseUp(
    MouseEventArgs e
)
protected override void OnMouseUp(
    MouseEventArgs e
)
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override
Parameters
e
Type:   Online System.Windows.Forms MouseEventArgs
A   Online MouseEventArgs that contains the event data.
See Also
Calendar Class
Calendar Members


OnMouseWheel Method

Calendar OnMouseWheel Method A Sandcastle Documented Class Library
Send Feedback
Raises the Online MouseWheel event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overrides Sub OnMouseWheel ( _
    e As MouseEventArgs _
)
Protected Overrides Sub OnMouseWheel ( _
    e As MouseEventArgs _
)
protected override void OnMouseWheel(
    MouseEventArgs e
)
protected override void OnMouseWheel(
    MouseEventArgs e
)
protected:
virtual void OnMouseWheel(
    MouseEventArgs^ e
) override
protected:
virtual void OnMouseWheel(
    MouseEventArgs^ e
) override
Parameters
e
Type:   Online System.Windows.Forms MouseEventArgs
A   Online MouseEventArgs that contains the event data.
See Also
Calendar Class
Calendar Members


OnPaint Method

Calendar OnPaint Method A Sandcastle Documented Class Library
Send Feedback
Raises the Online Paint event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
protected override void OnPaint(
    PaintEventArgs e
)
protected override void OnPaint(
    PaintEventArgs e
)
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override
Parameters
e
Type:   Online System.Windows.Forms PaintEventArgs
A   Online PaintEventArgs that contains the event data.
See Also
Calendar Class
Calendar Members


OnResize Method

Calendar OnResize Method A Sandcastle Documented Class Library
Send Feedback
Raises the Online Resize event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overrides Sub OnResize ( _
    e As EventArgs _
)
Protected Overrides Sub OnResize ( _
    e As EventArgs _
)
protected override void OnResize(
    EventArgs e
)
protected override void OnResize(
    EventArgs e
)
protected:
virtual void OnResize(
    EventArgs^ e
) override
protected:
virtual void OnResize(
    EventArgs^ e
) override
Parameters
e
Type:   Online System EventArgs
An   Online EventArgs that contains the event data.
See Also
Calendar Class
Calendar Members


SetSelectionRange Method

Calendar SetSelectionRange Method A Sandcastle Documented Class Library
Send Feedback
Establishes the selection range with only one graphical update.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub SetSelectionRange ( _
    selectionStart As ICalendarSelectableElement, _
    selectionEnd As ICalendarSelectableElement _
)
Public Sub SetSelectionRange ( _
    selectionStart As ICalendarSelectableElement, _
    selectionEnd As ICalendarSelectableElement _
)
public void SetSelectionRange(
    ICalendarSelectableElement selectionStart,
    ICalendarSelectableElement selectionEnd
)
public void SetSelectionRange(
    ICalendarSelectableElement selectionStart,
    ICalendarSelectableElement selectionEnd
)
public:
void SetSelectionRange(
    ICalendarSelectableElement^ selectionStart,
    ICalendarSelectableElement^ selectionEnd
)
public:
void SetSelectionRange(
    ICalendarSelectableElement^ selectionStart,
    ICalendarSelectableElement^ selectionEnd
)
Parameters
selectionStart
Type: WindowsFormsCalendar ICalendarSelectableElement
Fisrt selected element
selectionEnd
Type: WindowsFormsCalendar ICalendarSelectableElement
Last selection element
See Also
Calendar Class
Calendar Members


SetViewRange Method

Calendar SetViewRange Method A Sandcastle Documented Class Library
Send Feedback
Sets the value of ViewStart and ViewEnd properties triggering only one repaint process

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub SetViewRange ( _
    dateStart As DateTime, _
    dateEnd As DateTime _
)
Public Sub SetViewRange ( _
    dateStart As DateTime, _
    dateEnd As DateTime _
)
public void SetViewRange(
    DateTime dateStart,
    DateTime dateEnd
)
public void SetViewRange(
    DateTime dateStart,
    DateTime dateEnd
)
public:
void SetViewRange(
    DateTime dateStart,
    DateTime dateEnd
)
public:
void SetViewRange(
    DateTime dateStart,
    DateTime dateEnd
)
Parameters
dateStart
Type:   Online System DateTime
Start date of view
dateEnd
Type:   Online System DateTime
End date of view
See Also
Calendar Class
Calendar Members


ViewIntersects Method

Calendar ViewIntersects Method A Sandcastle Documented Class Library
Send Feedback
Overload List
 | Name | Description
Public method | ViewIntersects(CalendarItem) | Returns a value indicating if the view range intersect the date range of the specified item
Public method | ViewIntersects(DateTime, DateTime) | Returns a value indicating if the view range intersects the specified date range.
Back to Top
See Also
Calendar Class
Calendar Members


ViewIntersects Method (CalendarItem)

Calendar ViewIntersects Method (CalendarItem) A Sandcastle Documented Class Library
Send Feedback
Returns a value indicating if the view range intersect the date range of the specified item

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Function ViewIntersects ( _
    item As CalendarItem _
) As Boolean
Public Function ViewIntersects ( _
    item As CalendarItem _
) As Boolean
public bool ViewIntersects(
    CalendarItem item
)
public bool ViewIntersects(
    CalendarItem item
)
public:
bool ViewIntersects(
    CalendarItem^ item
)
public:
bool ViewIntersects(
    CalendarItem^ item
)
Parameters
item
Type: WindowsFormsCalendar CalendarItem
The item.
Return Value
[Missing <returns> documentation for "M:WindowsFormsCalendar.Calendar.ViewIntersects(WindowsFormsCalendar.CalendarItem)"]
See Also
Calendar Class
Calendar Members
ViewIntersects Overload


ViewIntersects Method (DateTime, DateTime)

Calendar ViewIntersects Method (DateTime, DateTime) A Sandcastle Documented Class Library
Send Feedback
Returns a value indicating if the view range intersects the specified date range.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Function ViewIntersects ( _
    startDate As DateTime, _
    endDate As DateTime _
) As Boolean
Public Function ViewIntersects ( _
    startDate As DateTime, _
    endDate As DateTime _
) As Boolean
public bool ViewIntersects(
    DateTime startDate,
    DateTime endDate
)
public bool ViewIntersects(
    DateTime startDate,
    DateTime endDate
)
public:
bool ViewIntersects(
    DateTime startDate,
    DateTime endDate
)
public:
bool ViewIntersects(
    DateTime startDate,
    DateTime endDate
)
Parameters
startDate
Type:   Online System DateTime
The start date.
endDate
Type:   Online System DateTime
The end date.
Return Value
[Missing <returns> documentation for "M:WindowsFormsCalendar.Calendar.ViewIntersects(System.DateTime,System.DateTime)"]
See Also
Calendar Class
Calendar Members
ViewIntersects Overload


Calendar Properties

Calendar Properties A Sandcastle Documented Class Library
The Calendar type exposes the following members.
Properties
 | Name | Description
Public property | Online AccessibilityObject | Gets the Online AccessibleObject assigned to the control. (Inherited from Online Control.)
Public property | Online AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Online Control.)
Public property | Online AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Online Control.)
Public property | Online AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Online Control.)
Public property | Online AccessibleRole | Gets or sets the accessible role of the control (Inherited from Online Control.)
Public property | Online AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Online Control.)
Public property | AllowItemEdit | Gets or sets a value indicating if the user can edit the item using the mouse or keyboard
Public property | AllowItemResize | Gets or sets a value indicating if calendar allows user to resize the calendar.
Public property | AllowNew | Gets or sets a value indicating if the control let's the user create new items.
Public property | Online Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Online Control.)
Public property | Online AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from Online ScrollableControl.)
Public property | Online AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from Online ScrollableControl.)
Public property | Online AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from Online ScrollableControl.)
Public property | Online AutoScrollOffset | Gets or sets where this control is scrolled to in Online ScrollControlIntoView(Control). (Inherited from Online Control.)
Public property | Online AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from Online ScrollableControl.)
Public property | Online AutoSize | This property is not relevant for this class. (Inherited from Online Control.)
Public property | Online BackColor | Gets or sets the background color for the control. (Inherited from Online Control.)
Public property | Online BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Online Control.)
Public property | Online BackgroundImageLayout | Gets or sets the background image layout as defined in the Online ImageLayout enumeration. (Inherited from Online Control.)
Public property | Online BindingContext | Gets or sets the Online BindingContext for the control. (Inherited from Online Control.)
Public property | Online Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Online Control.)
Public property | Online Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Online Control.)
Public property | CalendarItemFont | Gets or sets the calendar item font.
Public property | CalendarTimeFormat | Gets or sets the time format.
Protected property | Online CanEnableIme | Gets a value indicating whether the Online ImeMode property can be set to an active value, to enable IME support. (Inherited from Online Control.)
Public property | Online CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Online Control.)
Protected property | Online CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Online Control.)
Public property | Online CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Online Control.)
Public property | Online Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Online Control.)
Public property | Online CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Online Control.)
Public property | Online ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Online Control.)
Public property | Online ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Online Control.)
Public property | Online CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Online Control.)
Public property | Online Container | Gets the Online IContainer that contains the Online Component. (Inherited from Online Component.)
Public property | Online ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Online Control.)
Public property | Online ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Online Control.)
Public property | Online ContextMenuStrip | Gets or sets the Online ContextMenuStrip associated with this control. (Inherited from Online Control.)
Public property | Online Controls | Gets the collection of controls contained within the control. (Inherited from Online Control.)
Public property | Online Created | Gets a value indicating whether the control has been created. (Inherited from Online Control.)
Protected property | Online CreateParams | (Inherited from Online ScrollableControl.)
Public property | Online Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Online Control.)
Public property | Online DataBindings | Gets the data bindings for the control. (Inherited from Online Control.)
Public property | Days | Gets the days visible on the ccurrent view
Public property | DaysBodyRectangle | Gets the union of day body rectangles
Public property | DaysMode | Gets the mode in which days are drawn.
Protected property | Online DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Online Control.)
Protected property | Online DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Online Control.)
Protected property | Online DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Online Control.)
Protected property | Online DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Online Control.)
Protected property | Online DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Online Control.)
Protected property | Online DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Online Control.)
Protected property | Online DefaultSize | Gets the default size of the control. (Inherited from Online Control.)
Protected property | Online DesignMode | Gets a value that indicates whether the Online Component is currently in design mode. (Inherited from Online Component.)
Public property | Online DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from Online ScrollableControl.)
Public property | Online Disposing | Gets a value indicating whether the base Online Control class is in the process of disposing. (Inherited from Online Control.)
Public property | Online Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Online Control.)
Public property | Online DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from Online ScrollableControl.)
Protected property | Online DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Online Control.)
Public property | EditMode | Gets if the calendar is currently in edit mode of some item
Public property | EditModeItem | Gets the item being edited (if any)
Public property | Online Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Online Control.)
Protected property | Online Events | Gets the list of event handlers that are attached to this Online Component. (Inherited from Online Component.)
Public property | FirstDayOfWeek | Gets or sets the first day of weeks
Public property | Online Focused | Gets a value indicating whether the control has input focus. (Inherited from Online Control.)
Public property | Online Font | Gets or sets the font of the text displayed by the control. (Inherited from Online Control.)
Protected property | Online FontHeight | Gets or sets the height of the font of the control. (Inherited from Online Control.)
Public property | Online ForeColor | Gets or sets the foreground color of the control. (Inherited from Online Control.)
Public property | Online Handle | Gets the window handle that the control is bound to. (Inherited from Online Control.)
Public property | Online HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Online Control.)
Public property | Online Height | Gets or sets the height of the control. (Inherited from Online Control.)
Public property | HighlightRanges | Gets or sets the time ranges that should be highlighted as work-time. This ranges are week based.
Public property | Online HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from Online ScrollableControl.)
Protected property | Online HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from Online ScrollableControl.)
Public property | Online ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Online Control.)
Protected property | Online ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Online Control.)
Public property | Online InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Online Control.)
Public property | Online IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Online Control.)
Public property | Online IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Online Control.)
Public property | Online IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Online Control.)
Public property | Online IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Online Control.)
Public property | Items | Gets the collection of items currently on the view.
Public property | ItemsDateFormat | Gets or sets the format in which time is shown in the items, when applicable
Public property | ItemsTimeFormat | Gets or sets the format in which time is shown in the items, when applicable
Public property | Online LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Online Control.)
Public property | Online Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Online Control.)
Public property | Online Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Online Control.)
Public property | Online Margin | Gets or sets the space between controls. (Inherited from Online Control.)
Public property | MaximumFullDays | Gets or sets the maximum full days shown on the view. After this amount of days, they will be shown as short days.
Public property | Online MaximumSize | Gets or sets the size that is the upper limit that Online GetPreferredSize(Size) can specify. (Inherited from Online Control.)
Public property | MaximumViewDays | Gets or sets the maximum amount of days supported by the view. Value must be multiple of 7
Public property | Online MinimumSize | Gets or sets the size that is the lower limit that Online GetPreferredSize(Size) can specify. (Inherited from Online Control.)
Public property | Online Name | Gets or sets the name of the control. (Inherited from Online Control.)
Public property | Online Padding | Gets or sets padding within the control. (Inherited from Online Control.)
Public property | Online Parent | Gets or sets the parent container of the control. (Inherited from Online Control.)
Public property | Online PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Online Control.)
Public property | Online ProductName | Gets the product name of the assembly containing the control. (Inherited from Online Control.)
Public property | Online ProductVersion | Gets the version of the assembly containing the control. (Inherited from Online Control.)
Public property | Online RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Online Control.)
Public property | Online Region | Gets or sets the window region associated with the control. (Inherited from Online Control.)
Public property | Renderer | Gets or sets the CalendarRenderer of the Calendar
Protected property | Online RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Online Control.)
Protected property | Online ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Online Control.)
Public property | Online Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Online Control.)
Public property | Online RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Online Control.)
Protected property | Online ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Online Control.)
Public property | Scrollbars | Gets or sets the scrollbars.
Public property | SelectedElementEnd | Gets the last selected element
Public property | SelectedElementStart | Gets the first selected element
Public property | SelectionEnd | Gets or sets the end date-time of the view's selection.
Public property | SelectionStart | Gets or sets the start date-time of the view's selection.
Protected property | Online ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Online Control.)
Protected property | Online ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Online Control.)
Public property | Online Site | Gets or sets the site of the control. (Inherited from Online Control.)
Public property | Online Size | Gets or sets the height and width of the control. (Inherited from Online Control.)
Public property | State | Gets or sets the state of the calendar
Public property | Online TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Online Control.)
Public property | Online TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Online Control.)
Public property | Online Tag | Gets or sets the object that contains data about the control. (Inherited from Online Control.)
Public property | Online Text | Gets or sets the text associated with this control. (Inherited from Online Control.)
Public property | TimeScale | Gets or sets the CalendarTimeScale for visualization.
Public property | TimeUnitsOffset | Gets or sets the offset of scrolled units
Public property | Online Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Online Control.)
Public property | Online TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Online Form that the control is contained in. (Inherited from Online Control.)
Public property | Online UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Online Control.)
Public property | Online VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from Online ScrollableControl.)
Public property | ViewEnd | Gets or sets the end date-time of the current view.
Public property | ViewStart | Gets or sets the start date-time of the current view.
Public property | Online Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Online Control.)
Protected property | Online VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from Online ScrollableControl.)
Public property | Weeks | Gets the weeks currently visible on the calendar, if DaysMode is Short
Public property | Online Width | Gets or sets the width of the control. (Inherited from Online Control.)
Public property | Online WindowTarget | This property is not relevant for this class. (Inherited from Online Control.)
Back to Top
See Also
Calendar Class


AllowItemEdit Property

Calendar AllowItemEdit Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets a value indicating if the user can edit the item using the mouse or keyboard

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property AllowItemEdit As Boolean
    Get
    Set
Public Property AllowItemEdit As Boolean
    Get
    Set
public bool AllowItemEdit { get; set; }
public bool AllowItemEdit { get; set; }
public:
property bool AllowItemEdit {
    bool get ();
    void set (bool value);
}
public:
property bool AllowItemEdit {
    bool get ();
    void set (bool value);
}
See Also
Calendar Class
Calendar Members


AllowItemResize Property

Calendar AllowItemResize Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets a value indicating if calendar allows user to resize the calendar.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property AllowItemResize As Boolean
    Get
    Set
Public Property AllowItemResize As Boolean
    Get
    Set
public bool AllowItemResize { get; set; }
public bool AllowItemResize { get; set; }
public:
property bool AllowItemResize {
    bool get ();
    void set (bool value);
}
public:
property bool AllowItemResize {
    bool get ();
    void set (bool value);
}
See Also
Calendar Class
Calendar Members


AllowNew Property

Calendar AllowNew Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets a value indicating if the control let's the user create new items.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property AllowNew As Boolean
    Get
    Set
Public Property AllowNew As Boolean
    Get
    Set
public bool AllowNew { get; set; }
public bool AllowNew { get; set; }
public:
property bool AllowNew {
    bool get ();
    void set (bool value);
}
public:
property bool AllowNew {
    bool get ();
    void set (bool value);
}
See Also
Calendar Class
Calendar Members


CalendarItemFont Property

Calendar CalendarItemFont Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the calendar item font.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property CalendarItemFont As Font
    Get
    Set
Public Property CalendarItemFont As Font
    Get
    Set
public Font CalendarItemFont { get; set; }
public Font CalendarItemFont { get; set; }
public:
property Font^ CalendarItemFont {
    Font^ get ();
    void set (Font^ value);
}
public:
property Font^ CalendarItemFont {
    Font^ get ();
    void set (Font^ value);
}
Field Value

            The calendar item font.

See Also
Calendar Class
Calendar Members


CalendarTimeFormat Property

Calendar CalendarTimeFormat Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the time format.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property CalendarTimeFormat As CalendarTimeFormat
    Get
    Set
Public Property CalendarTimeFormat As CalendarTimeFormat
    Get
    Set
public CalendarTimeFormat CalendarTimeFormat { get; set; }
public CalendarTimeFormat CalendarTimeFormat { get; set; }
public:
property CalendarTimeFormat CalendarTimeFormat {
    CalendarTimeFormat get ();
    void set (CalendarTimeFormat value);
}
public:
property CalendarTimeFormat CalendarTimeFormat {
    CalendarTimeFormat get ();
    void set (CalendarTimeFormat value);
}
Field Value

            The time format.

See Also
Calendar Class
Calendar Members


Days Property

Calendar Days Property A Sandcastle Documented Class Library
Gets the days visible on the ccurrent view

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Days As CalendarDay()
    Get
Public ReadOnly Property Days As CalendarDay()
    Get
public CalendarDay[] Days { get; }
public CalendarDay[] Days { get; }
public:
property array<CalendarDay^>^ Days {
    array<CalendarDay^>^ get ();
}
public:
property array<CalendarDay^>^ Days {
    array<CalendarDay^>^ get ();
}
See Also
Calendar Class
Calendar Members


DaysBodyRectangle Property

Calendar DaysBodyRectangle Property A Sandcastle Documented Class Library
Send Feedback
Gets the union of day body rectangles

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property DaysBodyRectangle As Rectangle
    Get
Public ReadOnly Property DaysBodyRectangle As Rectangle
    Get
public Rectangle DaysBodyRectangle { get; }
public Rectangle DaysBodyRectangle { get; }
public:
property Rectangle DaysBodyRectangle {
    Rectangle get ();
}
public:
property Rectangle DaysBodyRectangle {
    Rectangle get ();
}
See Also
Calendar Class
Calendar Members


DaysMode Property

Calendar DaysMode Property A Sandcastle Documented Class Library
Send Feedback
Gets the mode in which days are drawn.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property DaysMode As CalendarDaysMode
    Get
Public ReadOnly Property DaysMode As CalendarDaysMode
    Get
public CalendarDaysMode DaysMode { get; }
public CalendarDaysMode DaysMode { get; }
public:
property CalendarDaysMode DaysMode {
    CalendarDaysMode get ();
}
public:
property CalendarDaysMode DaysMode {
    CalendarDaysMode get ();
}
See Also
Calendar Class
Calendar Members


EditMode Property

Calendar EditMode Property A Sandcastle Documented Class Library
Send Feedback
Gets if the calendar is currently in edit mode of some item

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property EditMode As Boolean
    Get
Public ReadOnly Property EditMode As Boolean
    Get
public bool EditMode { get; }
public bool EditMode { get; }
public:
property bool EditMode {
    bool get ();
}
public:
property bool EditMode {
    bool get ();
}
See Also
Calendar Class
Calendar Members


EditModeItem Property

Calendar EditModeItem Property A Sandcastle Documented Class Library
Send Feedback
Gets the item being edited (if any)

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property EditModeItem As CalendarItem
    Get
Public ReadOnly Property EditModeItem As CalendarItem
    Get
public CalendarItem EditModeItem { get; }
public CalendarItem EditModeItem { get; }
public:
property CalendarItem^ EditModeItem {
    CalendarItem^ get ();
}
public:
property CalendarItem^ EditModeItem {
    CalendarItem^ get ();
}
See Also
Calendar Class
Calendar Members


FirstDayOfWeek Property

Calendar FirstDayOfWeek Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the first day of weeks

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property FirstDayOfWeek As DayOfWeek
    Get
    Set
Public Property FirstDayOfWeek As DayOfWeek
    Get
    Set
public DayOfWeek FirstDayOfWeek { get; set; }
public DayOfWeek FirstDayOfWeek { get; set; }
public:
property DayOfWeek FirstDayOfWeek {
    DayOfWeek get ();
    void set (DayOfWeek value);
}
public:
property DayOfWeek FirstDayOfWeek {
    DayOfWeek get ();
    void set (DayOfWeek value);
}
See Also
Calendar Class
Calendar Members


HighlightRanges Property

Calendar HighlightRanges Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the time ranges that should be highlighted as work-time. This ranges are week based.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property HighlightRanges As CalendarHighlightRange()
    Get
    Set
Public Property HighlightRanges As CalendarHighlightRange()
    Get
    Set
public CalendarHighlightRange[] HighlightRanges { get; set; }
public CalendarHighlightRange[] HighlightRanges { get; set; }
public:
property array<CalendarHighlightRange^>^ HighlightRanges {
    array<CalendarHighlightRange^>^ get ();
    void set (array<CalendarHighlightRange^>^ value);
}
public:
property array<CalendarHighlightRange^>^ HighlightRanges {
    array<CalendarHighlightRange^>^ get ();
    void set (array<CalendarHighlightRange^>^ value);
}
See Also
Calendar Class
Calendar Members


Items Property

Calendar Items Property A Sandcastle Documented Class Library
Send Feedback
Gets the collection of items currently on the view.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Items As CalendarItemCollection
    Get
Public ReadOnly Property Items As CalendarItemCollection
    Get
public CalendarItemCollection Items { get; }
public CalendarItemCollection Items { get; }
public:
property CalendarItemCollection^ Items {
    CalendarItemCollection^ get ();
}
public:
property CalendarItemCollection^ Items {
    CalendarItemCollection^ get ();
}
Remarks

            This collection changes every time the view is changed

See Also
Calendar Class
Calendar Members


ItemsDateFormat Property

Calendar ItemsDateFormat Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the format in which time is shown in the items, when applicable

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property ItemsDateFormat As String
    Get
    Set
Public Property ItemsDateFormat As String
    Get
    Set
public string ItemsDateFormat { get; set; }
public string ItemsDateFormat { get; set; }
public:
property String^ ItemsDateFormat {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ItemsDateFormat {
    String^ get ();
    void set (String^ value);
}
See Also
Calendar Class
Calendar Members


ItemsTimeFormat Property

Calendar ItemsTimeFormat Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the format in which time is shown in the items, when applicable

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property ItemsTimeFormat As String
    Get
    Set
Public Property ItemsTimeFormat As String
    Get
    Set
public string ItemsTimeFormat { get; set; }
public string ItemsTimeFormat { get; set; }
public:
property String^ ItemsTimeFormat {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ItemsTimeFormat {
    String^ get ();
    void set (String^ value);
}
See Also
Calendar Class
Calendar Members


MaximumFullDays Property

Calendar MaximumFullDays Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the maximum full days shown on the view. After this amount of days, they will be shown as short days.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property MaximumFullDays As Integer
    Get
    Set
Public Property MaximumFullDays As Integer
    Get
    Set
public int MaximumFullDays { get; set; }
public int MaximumFullDays { get; set; }
public:
property int MaximumFullDays {
    int get ();
    void set (int value);
}
public:
property int MaximumFullDays {
    int get ();
    void set (int value);
}
See Also
Calendar Class
Calendar Members


MaximumViewDays Property

Calendar MaximumViewDays Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the maximum amount of days supported by the view. Value must be multiple of 7

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property MaximumViewDays As Integer
    Get
    Set
Public Property MaximumViewDays As Integer
    Get
    Set
public int MaximumViewDays { get; set; }
public int MaximumViewDays { get; set; }
public:
property int MaximumViewDays {
    int get ();
    void set (int value);
}
public:
property int MaximumViewDays {
    int get ();
    void set (int value);
}
See Also
Calendar Class
Calendar Members


Renderer Property

Calendar Renderer Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the CalendarRenderer of the Calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property Renderer As CalendarRenderer
    Get
    Set
Public Property Renderer As CalendarRenderer
    Get
    Set
public CalendarRenderer Renderer { get; set; }
public CalendarRenderer Renderer { get; set; }
public:
property CalendarRenderer^ Renderer {
    CalendarRenderer^ get ();
    void set (CalendarRenderer^ value);
}
public:
property CalendarRenderer^ Renderer {
    CalendarRenderer^ get ();
    void set (CalendarRenderer^ value);
}
See Also
Calendar Class
Calendar Members


Scrollbars Property

Calendar Scrollbars Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the scrollbars.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property Scrollbars As CalendarScrollBars
    Get
    Set
Public Property Scrollbars As CalendarScrollBars
    Get
    Set
public CalendarScrollBars Scrollbars { get; set; }
public CalendarScrollBars Scrollbars { get; set; }
public:
property CalendarScrollBars Scrollbars {
    CalendarScrollBars get ();
    void set (CalendarScrollBars value);
}
public:
property CalendarScrollBars Scrollbars {
    CalendarScrollBars get ();
    void set (CalendarScrollBars value);
}
Field Value

            The scrollbars.

See Also
Calendar Class
Calendar Members


SelectedElementEnd Property

Calendar SelectedElementEnd Property A Sandcastle Documented Class Library
Send Feedback
Gets the last selected element

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property SelectedElementEnd As ICalendarSelectableElement
    Get
    Set
Public Property SelectedElementEnd As ICalendarSelectableElement
    Get
    Set
public ICalendarSelectableElement SelectedElementEnd { get; set; }
public ICalendarSelectableElement SelectedElementEnd { get; set; }
public:
property ICalendarSelectableElement^ SelectedElementEnd {
    ICalendarSelectableElement^ get ();
    void set (ICalendarSelectableElement^ value);
}
public:
property ICalendarSelectableElement^ SelectedElementEnd {
    ICalendarSelectableElement^ get ();
    void set (ICalendarSelectableElement^ value);
}
See Also
Calendar Class
Calendar Members


SelectedElementStart Property

Calendar SelectedElementStart Property A Sandcastle Documented Class Library
Send Feedback
Gets the first selected element

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property SelectedElementStart As ICalendarSelectableElement
    Get
    Set
Public Property SelectedElementStart As ICalendarSelectableElement
    Get
    Set
public ICalendarSelectableElement SelectedElementStart { get; set; }
public ICalendarSelectableElement SelectedElementStart { get; set; }
public:
property ICalendarSelectableElement^ SelectedElementStart {
    ICalendarSelectableElement^ get ();
    void set (ICalendarSelectableElement^ value);
}
public:
property ICalendarSelectableElement^ SelectedElementStart {
    ICalendarSelectableElement^ get ();
    void set (ICalendarSelectableElement^ value);
}
See Also
Calendar Class
Calendar Members


SelectionEnd Property

Calendar SelectionEnd Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the end date-time of the view's selection.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property SelectionEnd As DateTime
    Get
    Set
Public Property SelectionEnd As DateTime
    Get
    Set
public DateTime SelectionEnd { get; set; }
public DateTime SelectionEnd { get; set; }
public:
property DateTime SelectionEnd {
    DateTime get ();
    void set (DateTime value);
}
public:
property DateTime SelectionEnd {
    DateTime get ();
    void set (DateTime value);
}
See Also
Calendar Class
Calendar Members


SelectionStart Property

Calendar SelectionStart Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the start date-time of the view's selection.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property SelectionStart As DateTime
    Get
    Set
Public Property SelectionStart As DateTime
    Get
    Set
public DateTime SelectionStart { get; set; }
public DateTime SelectionStart { get; set; }
public:
property DateTime SelectionStart {
    DateTime get ();
    void set (DateTime value);
}
public:
property DateTime SelectionStart {
    DateTime get ();
    void set (DateTime value);
}
See Also
Calendar Class
Calendar Members


State Property

Calendar State Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the state of the calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property State As CalendarState
    Get
Public ReadOnly Property State As CalendarState
    Get
public CalendarState State { get; }
public CalendarState State { get; }
public:
property CalendarState State {
    CalendarState get ();
}
public:
property CalendarState State {
    CalendarState get ();
}
See Also
Calendar Class
Calendar Members


TimeScale Property

Calendar TimeScale Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the CalendarTimeScale for visualization.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property TimeScale As CalendarTimeScale
    Get
    Set
Public Property TimeScale As CalendarTimeScale
    Get
    Set
public CalendarTimeScale TimeScale { get; set; }
public CalendarTimeScale TimeScale { get; set; }
public:
property CalendarTimeScale TimeScale {
    CalendarTimeScale get ();
    void set (CalendarTimeScale value);
}
public:
property CalendarTimeScale TimeScale {
    CalendarTimeScale get ();
    void set (CalendarTimeScale value);
}
See Also
Calendar Class
Calendar Members


TimeUnitsOffset Property

Calendar TimeUnitsOffset Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the offset of scrolled units

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property TimeUnitsOffset As Integer
    Get
    Set
Public Property TimeUnitsOffset As Integer
    Get
    Set
public int TimeUnitsOffset { get; set; }
public int TimeUnitsOffset { get; set; }
public:
property int TimeUnitsOffset {
    int get ();
    void set (int value);
}
public:
property int TimeUnitsOffset {
    int get ();
    void set (int value);
}
See Also
Calendar Class
Calendar Members


ViewEnd Property

Calendar ViewEnd Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the end date-time of the current view.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property ViewEnd As DateTime
    Get
    Set
Public Property ViewEnd As DateTime
    Get
    Set
public DateTime ViewEnd { get; set; }
public DateTime ViewEnd { get; set; }
public:
property DateTime ViewEnd {
    DateTime get ();
    void set (DateTime value);
}
public:
property DateTime ViewEnd {
    DateTime get ();
    void set (DateTime value);
}
See Also
Calendar Class
Calendar Members


ViewStart Property

Calendar ViewStart Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the start date-time of the current view.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property ViewStart As DateTime
    Get
    Set
Public Property ViewStart As DateTime
    Get
    Set
public DateTime ViewStart { get; set; }
public DateTime ViewStart { get; set; }
public:
property DateTime ViewStart {
    DateTime get ();
    void set (DateTime value);
}
public:
property DateTime ViewStart {
    DateTime get ();
    void set (DateTime value);
}
See Also
Calendar Class
Calendar Members


Weeks Property

Calendar Weeks Property A Sandcastle Documented Class Library
Send Feedback
Gets the weeks currently visible on the calendar, if DaysMode is Short

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Weeks As CalendarWeek()
    Get
Public ReadOnly Property Weeks As CalendarWeek()
    Get
public CalendarWeek[] Weeks { get; }
public CalendarWeek[] Weeks { get; }
public:
property array<CalendarWeek^>^ Weeks {
    array<CalendarWeek^>^ get ();
}
public:
property array<CalendarWeek^>^ Weeks {
    array<CalendarWeek^>^ get ();
}
See Also
Calendar Class
Calendar Members


Calendar Events

Calendar Events A Sandcastle Documented Class Library
The Calendar type exposes the following members.
Events
 | Name | Description
Public event | Online AutoSizeChanged | This event is not relevant for this class. (Inherited from Online Control.)
Public event | Online BackColorChanged | Occurs when the value of the Online BackColor property changes. (Inherited from Online Control.)
Public event | Online BackgroundImageChanged | Occurs when the value of the Online BackgroundImage property changes. (Inherited from Online Control.)
Public event | Online BackgroundImageLayoutChanged | Occurs when the Online BackgroundImageLayout property changes. (Inherited from Online Control.)
Public event | Online BindingContextChanged | Occurs when the value of the Online BindingContext property changes. (Inherited from Online Control.)
Public event | Online CausesValidationChanged | Occurs when the value of the Online CausesValidation property changes. (Inherited from Online Control.)
Public event | Online ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Online Control.)
Public event | Online Click | Occurs when the control is clicked. (Inherited from Online Control.)
Public event | Online ClientSizeChanged | Occurs when the value of the Online ClientSize property changes. (Inherited from Online Control.)
Public event | Online ContextMenuChanged | Occurs when the value of the Online ContextMenu property changes. (Inherited from Online Control.)
Public event | Online ContextMenuStripChanged | Occurs when the value of the Online ContextMenuStrip property changes. (Inherited from Online Control.)
Public event | Online ControlAdded | Occurs when a new control is added to the Online Control ControlCollection. (Inherited from Online Control.)
Public event | Online ControlRemoved | Occurs when a control is removed from the Online Control ControlCollection. (Inherited from Online Control.)
Public event | Online CursorChanged | Occurs when the value of the Online Cursor property changes. (Inherited from Online Control.)
Public event | DayHeaderClick | Occurs when a day header is clicked
Public event | Online Disposed | Occurs when the component is disposed by a call to the Online Dispose method. (Inherited from Online Component.)
Public event | Online DockChanged | Occurs when the value of the Online Dock property changes. (Inherited from Online Control.)
Public event | Online DoubleClick | Occurs when the control is double-clicked. (Inherited from Online Control.)
Public event | Online DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Online Control.)
Public event | Online DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Online Control.)
Public event | Online DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Online Control.)
Public event | Online DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Online Control.)
Public event | Online EnabledChanged | Occurs when the Online Enabled property value has changed. (Inherited from Online Control.)
Public event | Online Enter | Occurs when the control is entered. (Inherited from Online Control.)
Public event | Online FontChanged | Occurs when the Online Font property value changes. (Inherited from Online Control.)
Public event | Online ForeColorChanged | Occurs when the Online ForeColor property value changes. (Inherited from Online Control.)
Public event | Online GiveFeedback | Occurs during a drag operation. (Inherited from Online Control.)
Public event | Online GotFocus | Occurs when the control receives focus. (Inherited from Online Control.)
Public event | Online HandleCreated | Occurs when a handle is created for the control. (Inherited from Online Control.)
Public event | Online HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Online Control.)
Public event | Online HelpRequested | Occurs when the user requests help for a control. (Inherited from Online Control.)
Public event | Online ImeModeChanged | Occurs when the Online ImeMode property has changed. (Inherited from Online Control.)
Public event | Online Invalidated | Occurs when a control's display requires redrawing. (Inherited from Online Control.)
Public event | ItemClick | Occurs when an item is clicked
Public event | ItemCreated | Occurs when an item has been created.
Public event | ItemCreating | Occurs when an item is about to be created.
Public event | ItemDatesChanged | Occurs when an item time range has changed
Public event | ItemDeleted | Occurs when an item has been deleted
Public event | ItemDeleting | Occurs before an item is deleted
Public event | ItemDoubleClick | Occurs when an item is double-clicked
Public event | ItemMouseHover | Occurs when the mouse is moved over an item
Public event | ItemSelected | Occurs when an item is selected
Public event | ItemsPositioned | Occurs after the items are positioned
Public event | ItemTextEdited | Occurs when an item text is edited
Public event | ItemTextEditing | Occurs when an item text is about to be edited
Public event | Online KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Online Control.)
Public event | Online KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Online Control.)
Public event | Online KeyUp | Occurs when a key is released while the control has focus. (Inherited from Online Control.)
Public event | Online Layout | Occurs when a control should reposition its child controls. (Inherited from Online Control.)
Public event | Online Leave | Occurs when the input focus leaves the control. (Inherited from Online Control.)
Public event | LoadItems | Occurs when items are load into view
Public event | Online LocationChanged | Occurs when the Online Location property value has changed. (Inherited from Online Control.)
Public event | Online LostFocus | Occurs when the control loses focus. (Inherited from Online Control.)
Public event | Online MarginChanged | Occurs when the control's margin changes. (Inherited from Online Control.)
Public event | Online MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Online Control.)
Public event | Online MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Online Control.)
Public event | Online MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Online Control.)
Public event | Online MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Online Control.)
Public event | Online MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Online Control.)
Public event | Online MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Online Control.)
Public event | Online MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Online Control.)
Public event | Online MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Online Control.)
Public event | Online MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Online Control.)
Public event | Online MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Online Control.)
Public event | Online Move | Occurs when the control is moved. (Inherited from Online Control.)
Public event | Online PaddingChanged | Occurs when the control's padding changes. (Inherited from Online Control.)
Public event | Online Paint | Occurs when the control is redrawn. (Inherited from Online Control.)
Public event | Online ParentChanged | Occurs when the Online Parent property value changes. (Inherited from Online Control.)
Public event | Online PreviewKeyDown | Occurs before the Online KeyDown event when a key is pressed while focus is on this control. (Inherited from Online Control.)
Public event | Online QueryAccessibilityHelp | Occurs when Online AccessibleObject is providing help to accessibility applications. (Inherited from Online Control.)
Public event | Online QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Online Control.)
Public event | Online RegionChanged | Occurs when the value of the Online Region property changes. (Inherited from Online Control.)
Public event | Online Resize | Occurs when the control is resized. (Inherited from Online Control.)
Public event | Online RightToLeftChanged | Occurs when the Online RightToLeft property value changes. (Inherited from Online Control.)
Public event | Online Scroll | Occurs when the user or code scrolls through the client area. (Inherited from Online ScrollableControl.)
Public event | Online SizeChanged | Occurs when the Online Size property value changes. (Inherited from Online Control.)
Public event | Online StyleChanged | Occurs when the control style changes. (Inherited from Online Control.)
Public event | Online SystemColorsChanged | Occurs when the system colors change. (Inherited from Online Control.)
Public event | Online TabIndexChanged | Occurs when the Online TabIndex property value changes. (Inherited from Online Control.)
Public event | Online TabStopChanged | Occurs when the Online TabStop property value changes. (Inherited from Online Control.)
Public event | Online TextChanged | Occurs when the Online Text property value changes. (Inherited from Online Control.)
Public event | Online Validated | Occurs when the control is finished validating. (Inherited from Online Control.)
Public event | Online Validating | Occurs when the control is validating. (Inherited from Online Control.)
Public event | Online VisibleChanged | Occurs when the Online Visible property value changes. (Inherited from Online Control.)
Back to Top
See Also
Calendar Class


DayHeaderClick Event

Calendar DayHeaderClick Event A Sandcastle Documented Class Library
Send Feedback
Occurs when a day header is clicked

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Event DayHeaderClick As Calendar..::..CalendarDayEventHandler
Public Event DayHeaderClick As Calendar..::..CalendarDayEventHandler
public event Calendar..::..CalendarDayEventHandler DayHeaderClick
public event Calendar..::..CalendarDayEventHandler DayHeaderClick
public:
 event Calendar..::..CalendarDayEventHandler^ DayHeaderClick {
    void add (Calendar..::..CalendarDayEventHandler^ value);
    void remove (Calendar..::..CalendarDayEventHandler^ value);
}
public:
 event Calendar..::..CalendarDayEventHandler^ DayHeaderClick {
    void add (Calendar..::..CalendarDayEventHandler^ value);
    void remove (Calendar..::..CalendarDayEventHandler^ value);
}
See Also
Calendar Class
Calendar Members


ItemClick Event

Calendar ItemClick Event A Sandcastle Documented Class Library
Send Feedback
Occurs when an item is clicked

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Event ItemClick As Calendar..::..CalendarItemEventHandler
Public Event ItemClick As Calendar..::..CalendarItemEventHandler
public event Calendar..::..CalendarItemEventHandler ItemClick
public event Calendar..::..CalendarItemEventHandler ItemClick
public:
 event Calendar..::..CalendarItemEventHandler^ ItemClick {
    void add (Calendar..::..CalendarItemEventHandler^ value);
    void remove (Calendar..::..CalendarItemEventHandler^ value);
}
public:
 event Calendar..::..CalendarItemEventHandler^ ItemClick {
    void add (Calendar..::..CalendarItemEventHandler^ value);
    void remove (Calendar..::..CalendarItemEventHandler^ value);
}
See Also
Calendar Class
Calendar Members


ItemCreated Event

Calendar ItemCreated Event A Sandcastle Documented Class Library
Send Feedback
Occurs when an item has been created.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Event ItemCreated As Calendar..::..CalendarItemCancelEventHandler
Public Event ItemCreated As Calendar..::..CalendarItemCancelEventHandler
public event Calendar..::..CalendarItemCancelEventHandler ItemCreated
public event Calendar..::..CalendarItemCancelEventHandler ItemCreated
public:
 event Calendar..::..CalendarItemCancelEventHandler^ ItemCreated {
    void add (Calendar..::..CalendarItemCancelEventHandler^ value);
    void remove (Calendar..::..CalendarItemCancelEventHandler^ value);
}
public:
 event Calendar..::..CalendarItemCancelEventHandler^ ItemCreated {
    void add (Calendar..::..CalendarItemCancelEventHandler^ value);
    void remove (Calendar..::..CalendarItemCancelEventHandler^ value);
}
See Also
Calendar Class
Calendar Members


ItemCreating Event

Calendar ItemCreating Event A Sandcastle Documented Class Library
Send Feedback
Occurs when an item is about to be created.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Event ItemCreating As Calendar..::..CalendarItemCancelEventHandler
Public Event ItemCreating As Calendar..::..CalendarItemCancelEventHandler
public event Calendar..::..CalendarItemCancelEventHandler ItemCreating
public event Calendar..::..CalendarItemCancelEventHandler ItemCreating
public:
 event Calendar..::..CalendarItemCancelEventHandler^ ItemCreating {
    void add (Calendar..::..CalendarItemCancelEventHandler^ value);
    void remove (Calendar..::..CalendarItemCancelEventHandler^ value);
}
public:
 event Calendar..::..CalendarItemCancelEventHandler^ ItemCreating {
    void add (Calendar..::..CalendarItemCancelEventHandler^ value);
    void remove (Calendar..::..CalendarItemCancelEventHandler^ value);
}
Remarks

            Event can be cancelled

See Also
Calendar Class
Calendar Members


ItemDatesChanged Event

Calendar ItemDatesChanged Event A Sandcastle Documented Class Library
Send Feedback
Occurs when an item time range has changed

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Event ItemDatesChanged As Calendar..::..CalendarItemEventHandler
Public Event ItemDatesChanged As Calendar..::..CalendarItemEventHandler
public event Calendar..::..CalendarItemEventHandler ItemDatesChanged
public event Calendar..::..CalendarItemEventHandler ItemDatesChanged
public:
 event Calendar..::..CalendarItemEventHandler^ ItemDatesChanged {
    void add (Calendar..::..CalendarItemEventHandler^ value);
    void remove (Calendar..::..CalendarItemEventHandler^ value);
}
public:
 event Calendar..::..CalendarItemEventHandler^ ItemDatesChanged {
    void add (Calendar..::..CalendarItemEventHandler^ value);
    void remove (Calendar..::..CalendarItemEventHandler^ value);
}
See Also
Calendar Class
Calendar Members


ItemDeleted Event

Calendar ItemDeleted Event A Sandcastle Documented Class Library
Send Feedback
Occurs when an item has been deleted

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Event ItemDeleted As Calendar..::..CalendarItemEventHandler
Public Event ItemDeleted As Calendar..::..CalendarItemEventHandler
public event Calendar..::..CalendarItemEventHandler ItemDeleted
public event Calendar..::..CalendarItemEventHandler ItemDeleted
public:
 event Calendar..::..CalendarItemEventHandler^ ItemDeleted {
    void add (Calendar..::..CalendarItemEventHandler^ value);
    void remove (Calendar..::..CalendarItemEventHandler^ value);
}
public:
 event Calendar..::..CalendarItemEventHandler^ ItemDeleted {
    void add (Calendar..::..CalendarItemEventHandler^ value);
    void remove (Calendar..::..CalendarItemEventHandler^ value);
}
See Also
Calendar Class
Calendar Members


ItemDeleting Event

Calendar ItemDeleting Event A Sandcastle Documented Class Library
Send Feedback
Occurs before an item is deleted

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Event ItemDeleting As Calendar..::..CalendarItemCancelEventHandler
Public Event ItemDeleting As Calendar..::..CalendarItemCancelEventHandler
public event Calendar..::..CalendarItemCancelEventHandler ItemDeleting
public event Calendar..::..CalendarItemCancelEventHandler ItemDeleting
public:
 event Calendar..::..CalendarItemCancelEventHandler^ ItemDeleting {
    void add (Calendar..::..CalendarItemCancelEventHandler^ value);
    void remove (Calendar..::..CalendarItemCancelEventHandler^ value);
}
public:
 event Calendar..::..CalendarItemCancelEventHandler^ ItemDeleting {
    void add (Calendar..::..CalendarItemCancelEventHandler^ value);
    void remove (Calendar..::..CalendarItemCancelEventHandler^ value);
}
See Also
Calendar Class
Calendar Members


ItemDoubleClick Event

Calendar ItemDoubleClick Event A Sandcastle Documented Class Library
Send Feedback
Occurs when an item is double-clicked

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Event ItemDoubleClick As Calendar..::..CalendarItemEventHandler
Public Event ItemDoubleClick As Calendar..::..CalendarItemEventHandler
public event Calendar..::..CalendarItemEventHandler ItemDoubleClick
public event Calendar..::..CalendarItemEventHandler ItemDoubleClick
public:
 event Calendar..::..CalendarItemEventHandler^ ItemDoubleClick {
    void add (Calendar..::..CalendarItemEventHandler^ value);
    void remove (Calendar..::..CalendarItemEventHandler^ value);
}
public:
 event Calendar..::..CalendarItemEventHandler^ ItemDoubleClick {
    void add (Calendar..::..CalendarItemEventHandler^ value);
    void remove (Calendar..::..CalendarItemEventHandler^ value);
}
See Also
Calendar Class
Calendar Members


ItemMouseHover Event

Calendar ItemMouseHover Event A Sandcastle Documented Class Library
Send Feedback
Occurs when the mouse is moved over an item

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Event ItemMouseHover As Calendar..::..CalendarItemEventHandler
Public Event ItemMouseHover As Calendar..::..CalendarItemEventHandler
public event Calendar..::..CalendarItemEventHandler ItemMouseHover
public event Calendar..::..CalendarItemEventHandler ItemMouseHover
public:
 event Calendar..::..CalendarItemEventHandler^ ItemMouseHover {
    void add (Calendar..::..CalendarItemEventHandler^ value);
    void remove (Calendar..::..CalendarItemEventHandler^ value);
}
public:
 event Calendar..::..CalendarItemEventHandler^ ItemMouseHover {
    void add (Calendar..::..CalendarItemEventHandler^ value);
    void remove (Calendar..::..CalendarItemEventHandler^ value);
}
See Also
Calendar Class
Calendar Members


ItemSelected Event

Calendar ItemSelected Event A Sandcastle Documented Class Library
Send Feedback
Occurs when an item is selected

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Event ItemSelected As Calendar..::..CalendarItemEventHandler
Public Event ItemSelected As Calendar..::..CalendarItemEventHandler
public event Calendar..::..CalendarItemEventHandler ItemSelected
public event Calendar..::..CalendarItemEventHandler ItemSelected
public:
 event Calendar..::..CalendarItemEventHandler^ ItemSelected {
    void add (Calendar..::..CalendarItemEventHandler^ value);
    void remove (Calendar..::..CalendarItemEventHandler^ value);
}
public:
 event Calendar..::..CalendarItemEventHandler^ ItemSelected {
    void add (Calendar..::..CalendarItemEventHandler^ value);
    void remove (Calendar..::..CalendarItemEventHandler^ value);
}
See Also
Calendar Class
Calendar Members


ItemsPositioned Event

Calendar ItemsPositioned Event A Sandcastle Documented Class Library
Send Feedback
Occurs after the items are positioned

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Event ItemsPositioned As EventHandler
Public Event ItemsPositioned As EventHandler
public event EventHandler ItemsPositioned
public event EventHandler ItemsPositioned
public:
 event EventHandler^ ItemsPositioned {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ ItemsPositioned {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
Remarks

            Items bounds can be altered using the SetBounds(Rectangle) method.

See Also
Calendar Class
Calendar Members


ItemTextEdited Event

Calendar ItemTextEdited Event A Sandcastle Documented Class Library
Send Feedback
Occurs when an item text is edited

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Event ItemTextEdited As Calendar..::..CalendarItemCancelEventHandler
Public Event ItemTextEdited As Calendar..::..CalendarItemCancelEventHandler
public event Calendar..::..CalendarItemCancelEventHandler ItemTextEdited
public event Calendar..::..CalendarItemCancelEventHandler ItemTextEdited
public:
 event Calendar..::..CalendarItemCancelEventHandler^ ItemTextEdited {
    void add (Calendar..::..CalendarItemCancelEventHandler^ value);
    void remove (Calendar..::..CalendarItemCancelEventHandler^ value);
}
public:
 event Calendar..::..CalendarItemCancelEventHandler^ ItemTextEdited {
    void add (Calendar..::..CalendarItemCancelEventHandler^ value);
    void remove (Calendar..::..CalendarItemCancelEventHandler^ value);
}
See Also
Calendar Class
Calendar Members


ItemTextEditing Event

Calendar ItemTextEditing Event A Sandcastle Documented Class Library
Send Feedback
Occurs when an item text is about to be edited

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Event ItemTextEditing As Calendar..::..CalendarItemCancelEventHandler
Public Event ItemTextEditing As Calendar..::..CalendarItemCancelEventHandler
public event Calendar..::..CalendarItemCancelEventHandler ItemTextEditing
public event Calendar..::..CalendarItemCancelEventHandler ItemTextEditing
public:
 event Calendar..::..CalendarItemCancelEventHandler^ ItemTextEditing {
    void add (Calendar..::..CalendarItemCancelEventHandler^ value);
    void remove (Calendar..::..CalendarItemCancelEventHandler^ value);
}
public:
 event Calendar..::..CalendarItemCancelEventHandler^ ItemTextEditing {
    void add (Calendar..::..CalendarItemCancelEventHandler^ value);
    void remove (Calendar..::..CalendarItemCancelEventHandler^ value);
}
See Also
Calendar Class
Calendar Members


LoadItems Event

Calendar LoadItems Event A Sandcastle Documented Class Library
Send Feedback
Occurs when items are load into view

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Event LoadItems As Calendar..::..CalendarLoadEventHandler
Public Event LoadItems As Calendar..::..CalendarLoadEventHandler
public event Calendar..::..CalendarLoadEventHandler LoadItems
public event Calendar..::..CalendarLoadEventHandler LoadItems
public:
 event Calendar..::..CalendarLoadEventHandler^ LoadItems {
    void add (Calendar..::..CalendarLoadEventHandler^ value);
    void remove (Calendar..::..CalendarLoadEventHandler^ value);
}
public:
 event Calendar..::..CalendarLoadEventHandler^ LoadItems {
    void add (Calendar..::..CalendarLoadEventHandler^ value);
    void remove (Calendar..::..CalendarLoadEventHandler^ value);
}
See Also
Calendar Class
Calendar Members


Calendar.CalendarDayEventHandler Delegate

Calendar CalendarDayEventHandler Delegate A Sandcastle Documented Class Library
Send Feedback
Delegate that supports CalendarDay-related events

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Delegate Sub CalendarDayEventHandler ( _
    sender As Object, _
    e As CalendarDayEventArgs _
)
Public Delegate Sub CalendarDayEventHandler ( _
    sender As Object, _
    e As CalendarDayEventArgs _
)
public delegate void CalendarDayEventHandler(
    Object sender,
    CalendarDayEventArgs e
)
public delegate void CalendarDayEventHandler(
    Object sender,
    CalendarDayEventArgs e
)
public delegate void CalendarDayEventHandler(
    Object^ sender,
    CalendarDayEventArgs^ e
)
public delegate void CalendarDayEventHandler(
    Object^ sender,
    CalendarDayEventArgs^ e
)
Parameters
sender
Type:   Online System Object
e
Type: WindowsFormsCalendar CalendarDayEventArgs
See Also


Calendar.CalendarItemCancelEventHandler Delegate

Calendar CalendarItemCancelEventHandler Delegate A Sandcastle Documented Class Library
Send Feedback
Delegate that supports cancelable item-related events

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Delegate Sub CalendarItemCancelEventHandler ( _
    sender As Object, _
    e As CalendarItemCancelEventArgs _
)
Public Delegate Sub CalendarItemCancelEventHandler ( _
    sender As Object, _
    e As CalendarItemCancelEventArgs _
)
public delegate void CalendarItemCancelEventHandler(
    Object sender,
    CalendarItemCancelEventArgs e
)
public delegate void CalendarItemCancelEventHandler(
    Object sender,
    CalendarItemCancelEventArgs e
)
public delegate void CalendarItemCancelEventHandler(
    Object^ sender,
    CalendarItemCancelEventArgs^ e
)
public delegate void CalendarItemCancelEventHandler(
    Object^ sender,
    CalendarItemCancelEventArgs^ e
)
Parameters
sender
Type:   Online System Object
e
Type: WindowsFormsCalendar CalendarItemCancelEventArgs
See Also


Calendar.CalendarItemEventHandler Delegate

Calendar CalendarItemEventHandler Delegate A Sandcastle Documented Class Library
Send Feedback
Delegate that supports item-related events

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Delegate Sub CalendarItemEventHandler ( _
    sender As Object, _
    e As CalendarItemEventArgs _
)
Public Delegate Sub CalendarItemEventHandler ( _
    sender As Object, _
    e As CalendarItemEventArgs _
)
public delegate void CalendarItemEventHandler(
    Object sender,
    CalendarItemEventArgs e
)
public delegate void CalendarItemEventHandler(
    Object sender,
    CalendarItemEventArgs e
)
public delegate void CalendarItemEventHandler(
    Object^ sender,
    CalendarItemEventArgs^ e
)
public delegate void CalendarItemEventHandler(
    Object^ sender,
    CalendarItemEventArgs^ e
)
Parameters
sender
Type:   Online System Object
e
Type: WindowsFormsCalendar CalendarItemEventArgs
See Also


Calendar.CalendarLoadEventHandler Delegate

Calendar CalendarLoadEventHandler Delegate A Sandcastle Documented Class Library
Send Feedback
Delegate that supports LoadItems event

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Delegate Sub CalendarLoadEventHandler ( _
    sender As Object, _
    e As CalendarLoadEventArgs _
)
Public Delegate Sub CalendarLoadEventHandler ( _
    sender As Object, _
    e As CalendarLoadEventArgs _
)
public delegate void CalendarLoadEventHandler(
    Object sender,
    CalendarLoadEventArgs e
)
public delegate void CalendarLoadEventHandler(
    Object sender,
    CalendarLoadEventArgs e
)
public delegate void CalendarLoadEventHandler(
    Object^ sender,
    CalendarLoadEventArgs^ e
)
public delegate void CalendarLoadEventHandler(
    Object^ sender,
    CalendarLoadEventArgs^ e
)
Parameters
sender
Type:   Online System Object
Sender of the event
e
Type: WindowsFormsCalendar CalendarLoadEventArgs
Event Data
See Also


CalendarColorTable Class

CalendarColorTable Class A Sandcastle Documented Class Library
Send Feedback
Provides color information of calendar graphical elements
Inheritance Hierarchy
Online System Object
WindowsFormsCalendar CalendarColorTable

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class CalendarColorTable
Public Class CalendarColorTable
public class CalendarColorTable
public class CalendarColorTable
public ref class CalendarColorTable
public ref class CalendarColorTable
See Also
CalendarColorTable Members


CalendarColorTable Members

CalendarColorTable Members A Sandcastle Documented Class Library
Send Feedback

The CalendarColorTable type exposes the following members.
Constructors
 | Name | Description
Public method | CalendarColorTable | Initializes a new instance of the CalendarColorTable class
Back to Top
Methods
 | Name | Description
 | Combine | Returns the result of combining the specified colors
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | FromHex | Converts the hex formatted color to a Online Color
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Public field | Background | Background color of calendar
Public field | DayBackgroundEven | Background color of days in even months
Public field | DayBackgroundOdd | Background color of days in odd months
Public field | DayBackgroundSelected | Background color of selected days
Public field | DayBorder | Border of
Public field | DayHeaderBackground | Background color of day headers.
Public field | DayHeaderSecondaryText | Color of secondary text in headers
Public field | DayHeaderText | Color of text of day headers
Public field | DayOverflowBackground | Background color of the overflow indicators
Public field | DayOverflowBorder | Border color of the overflow indicators
Public field | DayOverflowSelectedBackground | Background color of selected overflow indicators
Public field | DayTopBackground | Background color of day tops.
Public field | DayTopBorder | Color of border of the top part of the days
Public field | DayTopSelectedBackground | Background color of selected day tops.
Public field | DayTopSelectedBorder | Color of border of the top parth of the days when selected
Public field | ItemBackground | Background color of items
Public field | ItemBorder | Color of items borders
Public field | ItemSecondaryText | Color of secondary text on items (Dates and times)
Public field | ItemSelectedBackground | Background color of selected items
Public field | ItemSelectedBorder | Color of items selected border
Public field | ItemSelectedText | Forecolor of selected items
Public field | ItemShadow | Color of items shadow
Public field | ItemText | Forecolor of items
Public field | TimeScaleHours | Color of text representing hours on the timescale
Public field | TimeScaleLine | Color of lines in timescale
Public field | TimeScaleMinutes | Color of text representing minutes on the timescale
Public field | TimeUnitBackground | Background color of time units
Public field | TimeUnitBorderDark | Color of dark border of time units
Public field | TimeUnitBorderLight | Color of light border of time units
Public field | TimeUnitHighlightedBackground | Background color of highlighted time units
Public field | TimeUnitSelectedBackground | Background color of selected time units
Public field | TodayBorder | Border color of today day
Public field | TodayTopBackground | Background color of today's DayTop
Public field | WeekDayName | Forecolor of day names
Public field | WeekHeaderBackground | Background color of week headers
Public field | WeekHeaderBorder | Border color of week headers
Public field | WeekHeaderText | Forecolor of week headers
Back to Top
See Also
CalendarColorTable Class


CalendarColorTable Constructor

CalendarColorTable Constructor A Sandcastle Documented Class Library
Send Feedback
Initializes a new instance of the CalendarColorTable class

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New
Public Sub New
public CalendarColorTable()
public CalendarColorTable()
public:
CalendarColorTable()
public:
CalendarColorTable()
See Also
CalendarColorTable Class
CalendarColorTable Members


CalendarColorTable Fields

CalendarColorTable Fields A Sandcastle Documented Class Library
Send Feedback
The CalendarColorTable type exposes the following members.
Fields
 | Name | Description
Public field | Background | Background color of calendar
Public field | DayBackgroundEven | Background color of days in even months
Public field | DayBackgroundOdd | Background color of days in odd months
Public field | DayBackgroundSelected | Background color of selected days
Public field | DayBorder | Border of
Public field | DayHeaderBackground | Background color of day headers.
Public field | DayHeaderSecondaryText | Color of secondary text in headers
Public field | DayHeaderText | Color of text of day headers
Public field | DayOverflowBackground | Background color of the overflow indicators
Public field | DayOverflowBorder | Border color of the overflow indicators
Public field | DayOverflowSelectedBackground | Background color of selected overflow indicators
Public field | DayTopBackground | Background color of day tops.
Public field | DayTopBorder | Color of border of the top part of the days
Public field | DayTopSelectedBackground | Background color of selected day tops.
Public field | DayTopSelectedBorder | Color of border of the top parth of the days when selected
Public field | ItemBackground | Background color of items
Public field | ItemBorder | Color of items borders
Public field | ItemSecondaryText | Color of secondary text on items (Dates and times)
Public field | ItemSelectedBackground | Background color of selected items
Public field | ItemSelectedBorder | Color of items selected border
Public field | ItemSelectedText | Forecolor of selected items
Public field | ItemShadow | Color of items shadow
Public field | ItemText | Forecolor of items
Public field | TimeScaleHours | Color of text representing hours on the timescale
Public field | TimeScaleLine | Color of lines in timescale
Public field | TimeScaleMinutes | Color of text representing minutes on the timescale
Public field | TimeUnitBackground | Background color of time units
Public field | TimeUnitBorderDark | Color of dark border of time units
Public field | TimeUnitBorderLight | Color of light border of time units
Public field | TimeUnitHighlightedBackground | Background color of highlighted time units
Public field | TimeUnitSelectedBackground | Background color of selected time units
Public field | TodayBorder | Border color of today day
Public field | TodayTopBackground | Background color of today's DayTop
Public field | WeekDayName | Forecolor of day names
Public field | WeekHeaderBackground | Background color of week headers
Public field | WeekHeaderBorder | Border color of week headers
Public field | WeekHeaderText | Forecolor of week headers
Back to Top
See Also
CalendarColorTable Class


Background Field

CalendarColorTable Background Field A Sandcastle Documented Class Library
Send Feedback
Background color of calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Background As Color
Public Background As Color
public Color Background
public Color Background
public:
Color Background
public:
Color Background
See Also
CalendarColorTable Class
CalendarColorTable Members


DayBackgroundEven Field

CalendarColorTable DayBackgroundEven Field A Sandcastle Documented Class Library
Send Feedback
Background color of days in even months

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public DayBackgroundEven As Color
Public DayBackgroundEven As Color
public Color DayBackgroundEven
public Color DayBackgroundEven
public:
Color DayBackgroundEven
public:
Color DayBackgroundEven
See Also
CalendarColorTable Class
CalendarColorTable Members


DayBackgroundOdd Field

CalendarColorTable DayBackgroundOdd Field A Sandcastle Documented Class Library
Send Feedback
Background color of days in odd months

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public DayBackgroundOdd As Color
Public DayBackgroundOdd As Color
public Color DayBackgroundOdd
public Color DayBackgroundOdd
public:
Color DayBackgroundOdd
public:
Color DayBackgroundOdd
See Also
CalendarColorTable Class
CalendarColorTable Members


DayBackgroundSelected Field

CalendarColorTable DayBackgroundSelected Field A Sandcastle Documented Class Library
Send Feedback
Background color of selected days

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public DayBackgroundSelected As Color
Public DayBackgroundSelected As Color
public Color DayBackgroundSelected
public Color DayBackgroundSelected
public:
Color DayBackgroundSelected
public:
Color DayBackgroundSelected
See Also
CalendarColorTable Class
CalendarColorTable Members


DayBorder Field

CalendarColorTable DayBorder Field A Sandcastle Documented Class Library
Send Feedback
Border of

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public DayBorder As Color
Public DayBorder As Color
public Color DayBorder
public Color DayBorder
public:
Color DayBorder
public:
Color DayBorder
See Also
CalendarColorTable Class
CalendarColorTable Members


DayHeaderBackground Field

CalendarColorTable DayHeaderBackground Field A Sandcastle Documented Class Library
Send Feedback
Background color of day headers.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public DayHeaderBackground As Color
Public DayHeaderBackground As Color
public Color DayHeaderBackground
public Color DayHeaderBackground
public:
Color DayHeaderBackground
public:
Color DayHeaderBackground
See Also
CalendarColorTable Class
CalendarColorTable Members


DayHeaderSecondaryText Field

CalendarColorTable DayHeaderSecondaryText Field A Sandcastle Documented Class Library
Send Feedback
Color of secondary text in headers

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public DayHeaderSecondaryText As Color
Public DayHeaderSecondaryText As Color
public Color DayHeaderSecondaryText
public Color DayHeaderSecondaryText
public:
Color DayHeaderSecondaryText
public:
Color DayHeaderSecondaryText
See Also
CalendarColorTable Class
CalendarColorTable Members


DayHeaderText Field

CalendarColorTable DayHeaderText Field A Sandcastle Documented Class Library
Send Feedback
Color of text of day headers

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public DayHeaderText As Color
Public DayHeaderText As Color
public Color DayHeaderText
public Color DayHeaderText
public:
Color DayHeaderText
public:
Color DayHeaderText
See Also
CalendarColorTable Class
CalendarColorTable Members


DayOverflowBackground Field

CalendarColorTable DayOverflowBackground Field A Sandcastle Documented Class Library
Send Feedback
Background color of the overflow indicators

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public DayOverflowBackground As Color
Public DayOverflowBackground As Color
public Color DayOverflowBackground
public Color DayOverflowBackground
public:
Color DayOverflowBackground
public:
Color DayOverflowBackground
See Also
CalendarColorTable Class
CalendarColorTable Members


DayOverflowBorder Field

CalendarColorTable DayOverflowBorder Field A Sandcastle Documented Class Library
Send Feedback
Border color of the overflow indicators

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public DayOverflowBorder As Color
Public DayOverflowBorder As Color
public Color DayOverflowBorder
public Color DayOverflowBorder
public:
Color DayOverflowBorder
public:
Color DayOverflowBorder
See Also
CalendarColorTable Class
CalendarColorTable Members


DayOverflowSelectedBackground Field

CalendarColorTable DayOverflowSelectedBackground Field A Sandcastle Documented Class Library
Send Feedback
Background color of selected overflow indicators

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public DayOverflowSelectedBackground As Color
Public DayOverflowSelectedBackground As Color
public Color DayOverflowSelectedBackground
public Color DayOverflowSelectedBackground
public:
Color DayOverflowSelectedBackground
public:
Color DayOverflowSelectedBackground
See Also
CalendarColorTable Class
CalendarColorTable Members


DayTopBackground Field

CalendarColorTable DayTopBackground Field A Sandcastle Documented Class Library
Send Feedback
Background color of day tops.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public DayTopBackground As Color
Public DayTopBackground As Color
public Color DayTopBackground
public Color DayTopBackground
public:
Color DayTopBackground
public:
Color DayTopBackground
Remarks

            The DayTop is the zone of the calendar where items that lasts all or more are placed.

See Also
CalendarColorTable Class
CalendarColorTable Members


DayTopBorder Field

CalendarColorTable DayTopBorder Field A Sandcastle Documented Class Library
Send Feedback
Color of border of the top part of the days

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public DayTopBorder As Color
Public DayTopBorder As Color
public Color DayTopBorder
public Color DayTopBorder
public:
Color DayTopBorder
public:
Color DayTopBorder
Remarks

            The DayTop is the zone of the calendar where items that lasts all or more are placed.

See Also
CalendarColorTable Class
CalendarColorTable Members


DayTopSelectedBackground Field

CalendarColorTable DayTopSelectedBackground Field A Sandcastle Documented Class Library
Send Feedback
Background color of selected day tops.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public DayTopSelectedBackground As Color
Public DayTopSelectedBackground As Color
public Color DayTopSelectedBackground
public Color DayTopSelectedBackground
public:
Color DayTopSelectedBackground
public:
Color DayTopSelectedBackground
Remarks

            The DayTop is the zone of the calendar where items that lasts all or more are placed.

See Also
CalendarColorTable Class
CalendarColorTable Members


DayTopSelectedBorder Field

CalendarColorTable DayTopSelectedBorder Field A Sandcastle Documented Class Library
Send Feedback
Color of border of the top parth of the days when selected

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public DayTopSelectedBorder As Color
Public DayTopSelectedBorder As Color
public Color DayTopSelectedBorder
public Color DayTopSelectedBorder
public:
Color DayTopSelectedBorder
public:
Color DayTopSelectedBorder
Remarks

            The DayTop is the zone of the calendar where items that lasts all or more are placed.

See Also
CalendarColorTable Class
CalendarColorTable Members


ItemBackground Field

CalendarColorTable ItemBackground Field A Sandcastle Documented Class Library
Send Feedback
Background color of items

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ItemBackground As Color
Public ItemBackground As Color
public Color ItemBackground
public Color ItemBackground
public:
Color ItemBackground
public:
Color ItemBackground
See Also
CalendarColorTable Class
CalendarColorTable Members


ItemBorder Field

CalendarColorTable ItemBorder Field A Sandcastle Documented Class Library
Send Feedback
Color of items borders

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ItemBorder As Color
Public ItemBorder As Color
public Color ItemBorder
public Color ItemBorder
public:
Color ItemBorder
public:
Color ItemBorder
See Also
CalendarColorTable Class
CalendarColorTable Members


ItemSecondaryText Field

CalendarColorTable ItemSecondaryText Field A Sandcastle Documented Class Library
Send Feedback
Color of secondary text on items (Dates and times)

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ItemSecondaryText As Color
Public ItemSecondaryText As Color
public Color ItemSecondaryText
public Color ItemSecondaryText
public:
Color ItemSecondaryText
public:
Color ItemSecondaryText
See Also
CalendarColorTable Class
CalendarColorTable Members


ItemSelectedBackground Field

CalendarColorTable ItemSelectedBackground Field A Sandcastle Documented Class Library
Send Feedback
Background color of selected items

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ItemSelectedBackground As Color
Public ItemSelectedBackground As Color
public Color ItemSelectedBackground
public Color ItemSelectedBackground
public:
Color ItemSelectedBackground
public:
Color ItemSelectedBackground
See Also
CalendarColorTable Class
CalendarColorTable Members


ItemSelectedBorder Field

CalendarColorTable ItemSelectedBorder Field A Sandcastle Documented Class Library
Send Feedback
Color of items selected border

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ItemSelectedBorder As Color
Public ItemSelectedBorder As Color
public Color ItemSelectedBorder
public Color ItemSelectedBorder
public:
Color ItemSelectedBorder
public:
Color ItemSelectedBorder
See Also
CalendarColorTable Class
CalendarColorTable Members


ItemSelectedText Field

CalendarColorTable ItemSelectedText Field A Sandcastle Documented Class Library
Send Feedback
Forecolor of selected items

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ItemSelectedText As Color
Public ItemSelectedText As Color
public Color ItemSelectedText
public Color ItemSelectedText
public:
Color ItemSelectedText
public:
Color ItemSelectedText
See Also
CalendarColorTable Class
CalendarColorTable Members


ItemShadow Field

CalendarColorTable ItemShadow Field A Sandcastle Documented Class Library
Send Feedback
Color of items shadow

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ItemShadow As Color
Public ItemShadow As Color
public Color ItemShadow
public Color ItemShadow
public:
Color ItemShadow
public:
Color ItemShadow
See Also
CalendarColorTable Class
CalendarColorTable Members


ItemText Field

CalendarColorTable ItemText Field A Sandcastle Documented Class Library
Send Feedback
Forecolor of items

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ItemText As Color
Public ItemText As Color
public Color ItemText
public Color ItemText
public:
Color ItemText
public:
Color ItemText
See Also
CalendarColorTable Class
CalendarColorTable Members


TimeScaleHours Field

CalendarColorTable TimeScaleHours Field A Sandcastle Documented Class Library
Send Feedback
Color of text representing hours on the timescale

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public TimeScaleHours As Color
Public TimeScaleHours As Color
public Color TimeScaleHours
public Color TimeScaleHours
public:
Color TimeScaleHours
public:
Color TimeScaleHours
See Also
CalendarColorTable Class
CalendarColorTable Members


TimeScaleLine Field

CalendarColorTable TimeScaleLine Field A Sandcastle Documented Class Library
Send Feedback
Color of lines in timescale

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public TimeScaleLine As Color
Public TimeScaleLine As Color
public Color TimeScaleLine
public Color TimeScaleLine
public:
Color TimeScaleLine
public:
Color TimeScaleLine
See Also
CalendarColorTable Class
CalendarColorTable Members


TimeScaleMinutes Field

CalendarColorTable TimeScaleMinutes Field A Sandcastle Documented Class Library
Send Feedback
Color of text representing minutes on the timescale

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public TimeScaleMinutes As Color
Public TimeScaleMinutes As Color
public Color TimeScaleMinutes
public Color TimeScaleMinutes
public:
Color TimeScaleMinutes
public:
Color TimeScaleMinutes
See Also
CalendarColorTable Class
CalendarColorTable Members


TimeUnitBackground Field

CalendarColorTable TimeUnitBackground Field A Sandcastle Documented Class Library
Send Feedback
Background color of time units

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public TimeUnitBackground As Color
Public TimeUnitBackground As Color
public Color TimeUnitBackground
public Color TimeUnitBackground
public:
Color TimeUnitBackground
public:
Color TimeUnitBackground
See Also
CalendarColorTable Class
CalendarColorTable Members


TimeUnitBorderDark Field

CalendarColorTable TimeUnitBorderDark Field A Sandcastle Documented Class Library
Send Feedback
Color of dark border of time units

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public TimeUnitBorderDark As Color
Public TimeUnitBorderDark As Color
public Color TimeUnitBorderDark
public Color TimeUnitBorderDark
public:
Color TimeUnitBorderDark
public:
Color TimeUnitBorderDark
See Also
CalendarColorTable Class
CalendarColorTable Members


TimeUnitBorderLight Field

CalendarColorTable TimeUnitBorderLight Field A Sandcastle Documented Class Library
Send Feedback
Color of light border of time units

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public TimeUnitBorderLight As Color
Public TimeUnitBorderLight As Color
public Color TimeUnitBorderLight
public Color TimeUnitBorderLight
public:
Color TimeUnitBorderLight
public:
Color TimeUnitBorderLight
See Also
CalendarColorTable Class
CalendarColorTable Members


TimeUnitHighlightedBackground Field

CalendarColorTable TimeUnitHighlightedBackground Field A Sandcastle Documented Class Library
Send Feedback
Background color of highlighted time units

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public TimeUnitHighlightedBackground As Color
Public TimeUnitHighlightedBackground As Color
public Color TimeUnitHighlightedBackground
public Color TimeUnitHighlightedBackground
public:
Color TimeUnitHighlightedBackground
public:
Color TimeUnitHighlightedBackground
See Also
CalendarColorTable Class
CalendarColorTable Members


TimeUnitSelectedBackground Field

CalendarColorTable TimeUnitSelectedBackground Field A Sandcastle Documented Class Library
Send Feedback
Background color of selected time units

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public TimeUnitSelectedBackground As Color
Public TimeUnitSelectedBackground As Color
public Color TimeUnitSelectedBackground
public Color TimeUnitSelectedBackground
public:
Color TimeUnitSelectedBackground
public:
Color TimeUnitSelectedBackground
See Also
CalendarColorTable Class
CalendarColorTable Members


TodayBorder Field

CalendarColorTable TodayBorder Field A Sandcastle Documented Class Library
Send Feedback
Border color of today day

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public TodayBorder As Color
Public TodayBorder As Color
public Color TodayBorder
public Color TodayBorder
public:
Color TodayBorder
public:
Color TodayBorder
See Also
CalendarColorTable Class
CalendarColorTable Members


TodayTopBackground Field

CalendarColorTable TodayTopBackground Field A Sandcastle Documented Class Library
Send Feedback
Background color of today's DayTop

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public TodayTopBackground As Color
Public TodayTopBackground As Color
public Color TodayTopBackground
public Color TodayTopBackground
public:
Color TodayTopBackground
public:
Color TodayTopBackground
See Also
CalendarColorTable Class
CalendarColorTable Members


WeekDayName Field

CalendarColorTable WeekDayName Field A Sandcastle Documented Class Library
Send Feedback
Forecolor of day names

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public WeekDayName As Color
Public WeekDayName As Color
public Color WeekDayName
public Color WeekDayName
public:
Color WeekDayName
public:
Color WeekDayName
See Also
CalendarColorTable Class
CalendarColorTable Members


WeekHeaderBackground Field

CalendarColorTable WeekHeaderBackground Field A Sandcastle Documented Class Library
Send Feedback
Background color of week headers

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public WeekHeaderBackground As Color
Public WeekHeaderBackground As Color
public Color WeekHeaderBackground
public Color WeekHeaderBackground
public:
Color WeekHeaderBackground
public:
Color WeekHeaderBackground
See Also
CalendarColorTable Class
CalendarColorTable Members


WeekHeaderBorder Field

CalendarColorTable WeekHeaderBorder Field A Sandcastle Documented Class Library
Send Feedback
Border color of week headers

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public WeekHeaderBorder As Color
Public WeekHeaderBorder As Color
public Color WeekHeaderBorder
public Color WeekHeaderBorder
public:
Color WeekHeaderBorder
public:
Color WeekHeaderBorder
See Also
CalendarColorTable Class
CalendarColorTable Members


WeekHeaderText Field

CalendarColorTable WeekHeaderText Field A Sandcastle Documented Class Library
Send Feedback
Forecolor of week headers

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public WeekHeaderText As Color
Public WeekHeaderText As Color
public Color WeekHeaderText
public Color WeekHeaderText
public:
Color WeekHeaderText
public:
Color WeekHeaderText
See Also
CalendarColorTable Class
CalendarColorTable Members


CalendarColorTable Methods

CalendarColorTable Methods A Sandcastle Documented Class Library
Send Feedback
The CalendarColorTable type exposes the following members.
Methods
 | Name | Description
 | Combine | Returns the result of combining the specified colors
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | FromHex | Converts the hex formatted color to a Online Color
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CalendarColorTable Class


Combine Method

CalendarColorTable Combine Method A Sandcastle Documented Class Library
Send Feedback
Returns the result of combining the specified colors

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Shared Function Combine ( _
    c1 As Color, _
    c2 As Color _
) As Color
Public Shared Function Combine ( _
    c1 As Color, _
    c2 As Color _
) As Color
public static Color Combine(
    Color c1,
    Color c2
)
public static Color Combine(
    Color c1,
    Color c2
)
public:
static Color Combine(
    Color c1,
    Color c2
)
public:
static Color Combine(
    Color c1,
    Color c2
)
Parameters
c1
Type:   Online System.Drawing Color
First color to combine
c2
Type:   Online System.Drawing Color
Second olor to combine
Return Value
Average of both colors
See Also
CalendarColorTable Class
CalendarColorTable Members


FromHex Method

CalendarColorTable FromHex Method A Sandcastle Documented Class Library
Send Feedback
Converts the hex formatted color to a Online Color

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Shared Function FromHex ( _
    hex As String _
) As Color
Public Shared Function FromHex ( _
    hex As String _
) As Color
public static Color FromHex(
    string hex
)
public static Color FromHex(
    string hex
)
public:
static Color FromHex(
    String^ hex
)
public:
static Color FromHex(
    String^ hex
)
Parameters
hex
Type:   Online System String
[Missing <param name="hex"/> documentation for "M:WindowsFormsCalendar.CalendarColorTable.FromHex(System.String)"]
Return Value
[Missing <returns> documentation for "M:WindowsFormsCalendar.CalendarColorTable.FromHex(System.String)"]
See Also
CalendarColorTable Class
CalendarColorTable Members


CalendarDay Class

CalendarDay Class A Sandcastle Documented Class Library
Represents a day present on the Calendar control's view.
Inheritance Hierarchy
Online System Object
WindowsFormsCalendar CalendarSelectableElement
WindowsFormsCalendar CalendarDay

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class CalendarDay _
    Inherits CalendarSelectableElement
Public Class CalendarDay _
    Inherits CalendarSelectableElement
public class CalendarDay : CalendarSelectableElement
public class CalendarDay : CalendarSelectableElement
public ref class CalendarDay : public CalendarSelectableElement
public ref class CalendarDay : public CalendarSelectableElement
See Also
CalendarDay Members


CalendarDay Members

CalendarDay Members A Sandcastle Documented Class Library

The CalendarDay type exposes the following members.
Methods
 | Name | Description
Public method | CompareTo | Compares this element with other using date as comparer (Inherited from CalendarSelectableElement.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Returns a Online String that represents this instance. (Overrides Online Object ToString .)
Back to Top
Properties
 | Name | Description
Public property | BodyBounds | Gets the bounds of the body of the day (where time-based CalendarItems are placed)
Public property | Bounds | Gets the Bounds of the element on the Calendar window (Inherited from CalendarSelectableElement.)
Public property | Calendar | Gets the Calendar this element belongs to (Inherited from CalendarSelectableElement.)
Public property | Date | Gets the date this day represents (Overrides CalendarSelectableElement Date.)
Public property | DayTop | Gets the DayTop of the day, the place where multi-day and all-day items are placed
Public property | HeaderBounds | Gets the bounds of the header of the day
Public property | Index | Gets the index of this day on the calendar
Public property | OverflowEnd | Gets a value indicating if the day contains items not shown through the end of the day
Public property | OverflowEndBounds | Gets the bounds of the OverflowEnd indicator
Public property | OverflowEndSelected | Gets a value indicating if the OverflowEnd indicator is currently selected
Public property | OverflowStart | /// Gets a value indicating if the day contains items not shown through the start of the day
Public property | OverflowStartBounds | Gets the bounds of the OverflowStart indicator
Public property | OverflowStartSelected | Gets a value indicating if the OverflowStart indicator is currently selected
Public property | Selected | Gets a value indicating if the element is currently selected (Inherited from CalendarSelectableElement.)
Public property | SpecifiedOnView | Gets a value indicating if the day is specified on the view (See remarks).
Public property | TimeUnits | Gets the time units contained on the day
Back to Top
See Also
CalendarDay Class


CalendarDay Methods

CalendarDay Methods A Sandcastle Documented Class Library
The CalendarDay type exposes the following members.
Methods
 | Name | Description
Public method | CompareTo | Compares this element with other using date as comparer (Inherited from CalendarSelectableElement.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Returns a Online String that represents this instance. (Overrides Online Object ToString .)
Back to Top
See Also
CalendarDay Class


ToString Method

CalendarDay ToString Method A Sandcastle Documented Class Library
Send Feedback
Returns a Online String that represents this instance.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public override string ToString()
public override string ToString()
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
Return Value

            A   Online String that represents this instance.

See Also
CalendarDay Class
CalendarDay Members


CalendarDay Properties

CalendarDay Properties A Sandcastle Documented Class Library
The CalendarDay type exposes the following members.
Properties
 | Name | Description
Public property | BodyBounds | Gets the bounds of the body of the day (where time-based CalendarItems are placed)
Public property | Bounds | Gets the Bounds of the element on the Calendar window (Inherited from CalendarSelectableElement.)
Public property | Calendar | Gets the Calendar this element belongs to (Inherited from CalendarSelectableElement.)
Public property | Date | Gets the date this day represents (Overrides CalendarSelectableElement Date.)
Public property | DayTop | Gets the DayTop of the day, the place where multi-day and all-day items are placed
Public property | HeaderBounds | Gets the bounds of the header of the day
Public property | Index | Gets the index of this day on the calendar
Public property | OverflowEnd | Gets a value indicating if the day contains items not shown through the end of the day
Public property | OverflowEndBounds | Gets the bounds of the OverflowEnd indicator
Public property | OverflowEndSelected | Gets a value indicating if the OverflowEnd indicator is currently selected
Public property | OverflowStart | /// Gets a value indicating if the day contains items not shown through the start of the day
Public property | OverflowStartBounds | Gets the bounds of the OverflowStart indicator
Public property | OverflowStartSelected | Gets a value indicating if the OverflowStart indicator is currently selected
Public property | Selected | Gets a value indicating if the element is currently selected (Inherited from CalendarSelectableElement.)
Public property | SpecifiedOnView | Gets a value indicating if the day is specified on the view (See remarks).
Public property | TimeUnits | Gets the time units contained on the day
Back to Top
See Also
CalendarDay Class


BodyBounds Property

CalendarDay BodyBounds Property A Sandcastle Documented Class Library
Send Feedback
Gets the bounds of the body of the day (where time-based CalendarItems are placed)

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property BodyBounds As Rectangle
    Get
Public ReadOnly Property BodyBounds As Rectangle
    Get
public Rectangle BodyBounds { get; }
public Rectangle BodyBounds { get; }
public:
property Rectangle BodyBounds {
    Rectangle get ();
}
public:
property Rectangle BodyBounds {
    Rectangle get ();
}
See Also
CalendarDay Class
CalendarDay Members


Date Property

CalendarDay Date Property A Sandcastle Documented Class Library
Send Feedback
Gets the date this day represents

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides ReadOnly Property Date As DateTime
    Get
Public Overrides ReadOnly Property Date As DateTime
    Get
public override DateTime Date { get; }
public override DateTime Date { get; }
public:
virtual property DateTime Date {
    DateTime get () override;
}
public:
virtual property DateTime Date {
    DateTime get () override;
}
Implements
ICalendarSelectableElement Date
See Also
CalendarDay Class
CalendarDay Members


DayTop Property

CalendarDay DayTop Property A Sandcastle Documented Class Library
Send Feedback
Gets the DayTop of the day, the place where multi-day and all-day items are placed

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property DayTop As CalendarDayTop
    Get
Public ReadOnly Property DayTop As CalendarDayTop
    Get
public CalendarDayTop DayTop { get; }
public CalendarDayTop DayTop { get; }
public:
property CalendarDayTop^ DayTop {
    CalendarDayTop^ get ();
}
public:
property CalendarDayTop^ DayTop {
    CalendarDayTop^ get ();
}
See Also
CalendarDay Class
CalendarDay Members


HeaderBounds Property

CalendarDay HeaderBounds Property A Sandcastle Documented Class Library
Send Feedback
Gets the bounds of the header of the day

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property HeaderBounds As Rectangle
    Get
Public ReadOnly Property HeaderBounds As Rectangle
    Get
public Rectangle HeaderBounds { get; }
public Rectangle HeaderBounds { get; }
public:
property Rectangle HeaderBounds {
    Rectangle get ();
}
public:
property Rectangle HeaderBounds {
    Rectangle get ();
}
See Also
CalendarDay Class
CalendarDay Members


Index Property

CalendarDay Index Property A Sandcastle Documented Class Library
Send Feedback
Gets the index of this day on the calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Index As Integer
    Get
Public ReadOnly Property Index As Integer
    Get
public int Index { get; }
public int Index { get; }
public:
property int Index {
    int get ();
}
public:
property int Index {
    int get ();
}
See Also
CalendarDay Class
CalendarDay Members


OverflowEnd Property

CalendarDay OverflowEnd Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if the day contains items not shown through the end of the day

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property OverflowEnd As Boolean
    Get
Public ReadOnly Property OverflowEnd As Boolean
    Get
public bool OverflowEnd { get; }
public bool OverflowEnd { get; }
public:
property bool OverflowEnd {
    bool get ();
}
public:
property bool OverflowEnd {
    bool get ();
}
See Also
CalendarDay Class
CalendarDay Members


OverflowEndBounds Property

CalendarDay OverflowEndBounds Property A Sandcastle Documented Class Library
Send Feedback
Gets the bounds of the OverflowEnd indicator

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable ReadOnly Property OverflowEndBounds As Rectangle
    Get
Public Overridable ReadOnly Property OverflowEndBounds As Rectangle
    Get
public virtual Rectangle OverflowEndBounds { get; }
public virtual Rectangle OverflowEndBounds { get; }
public:
virtual property Rectangle OverflowEndBounds {
    Rectangle get ();
}
public:
virtual property Rectangle OverflowEndBounds {
    Rectangle get ();
}
See Also
CalendarDay Class
CalendarDay Members


OverflowEndSelected Property

CalendarDay OverflowEndSelected Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if the OverflowEnd indicator is currently selected

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property OverflowEndSelected As Boolean
    Get
Public ReadOnly Property OverflowEndSelected As Boolean
    Get
public bool OverflowEndSelected { get; }
public bool OverflowEndSelected { get; }
public:
property bool OverflowEndSelected {
    bool get ();
}
public:
property bool OverflowEndSelected {
    bool get ();
}
Remarks

            This value set to true when user hovers the mouse on the OverflowStartBounds area

See Also
CalendarDay Class
CalendarDay Members


OverflowStart Property

CalendarDay OverflowStart Property A Sandcastle Documented Class Library
Send Feedback
///
Gets a value indicating if the day contains items not shown through the start of the day

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property OverflowStart As Boolean
    Get
Public ReadOnly Property OverflowStart As Boolean
    Get
public bool OverflowStart { get; }
public bool OverflowStart { get; }
public:
property bool OverflowStart {
    bool get ();
}
public:
property bool OverflowStart {
    bool get ();
}
See Also
CalendarDay Class
CalendarDay Members


OverflowStartBounds Property

CalendarDay OverflowStartBounds Property A Sandcastle Documented Class Library
Send Feedback
Gets the bounds of the OverflowStart indicator

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable ReadOnly Property OverflowStartBounds As Rectangle
    Get
Public Overridable ReadOnly Property OverflowStartBounds As Rectangle
    Get
public virtual Rectangle OverflowStartBounds { get; }
public virtual Rectangle OverflowStartBounds { get; }
public:
virtual property Rectangle OverflowStartBounds {
    Rectangle get ();
}
public:
virtual property Rectangle OverflowStartBounds {
    Rectangle get ();
}
See Also
CalendarDay Class
CalendarDay Members


OverflowStartSelected Property

CalendarDay OverflowStartSelected Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if the OverflowStart indicator is currently selected

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property OverflowStartSelected As Boolean
    Get
Public ReadOnly Property OverflowStartSelected As Boolean
    Get
public bool OverflowStartSelected { get; }
public bool OverflowStartSelected { get; }
public:
property bool OverflowStartSelected {
    bool get ();
}
public:
property bool OverflowStartSelected {
    bool get ();
}
Remarks

            This value set to true when user hovers the mouse on the OverflowStartBounds area

See Also
CalendarDay Class
CalendarDay Members


SpecifiedOnView Property

CalendarDay SpecifiedOnView Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if the day is specified on the view (See remarks).

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property SpecifiedOnView As Boolean
    Get
Public ReadOnly Property SpecifiedOnView As Boolean
    Get
public bool SpecifiedOnView { get; }
public bool SpecifiedOnView { get; }
public:
property bool SpecifiedOnView {
    bool get ();
}
public:
property bool SpecifiedOnView {
    bool get ();
}
Remarks

            A day may not be specified on the view, but still present to make up a square calendar.
            This days should be drawn in a way that indicates it's necessary but unrequested presence.

See Also
CalendarDay Class
CalendarDay Members


TimeUnits Property

CalendarDay TimeUnits Property A Sandcastle Documented Class Library
Send Feedback
Gets the time units contained on the day

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property TimeUnits As CalendarTimeScaleUnit()
    Get
Public ReadOnly Property TimeUnits As CalendarTimeScaleUnit()
    Get
public CalendarTimeScaleUnit[] TimeUnits { get; }
public CalendarTimeScaleUnit[] TimeUnits { get; }
public:
property array<CalendarTimeScaleUnit^>^ TimeUnits {
    array<CalendarTimeScaleUnit^>^ get ();
}
public:
property array<CalendarTimeScaleUnit^>^ TimeUnits {
    array<CalendarTimeScaleUnit^>^ get ();
}
See Also
CalendarDay Class
CalendarDay Members


CalendarDayEventArgs Class

CalendarDayEventArgs Class A Sandcastle Documented Class Library
Send Feedback
Event data with a CalendarDay element
Inheritance Hierarchy
Online System Object
Online System EventArgs
WindowsFormsCalendar CalendarDayEventArgs

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class CalendarDayEventArgs _
    Inherits EventArgs
Public Class CalendarDayEventArgs _
    Inherits EventArgs
public class CalendarDayEventArgs : EventArgs
public class CalendarDayEventArgs : EventArgs
public ref class CalendarDayEventArgs : public EventArgs
public ref class CalendarDayEventArgs : public EventArgs
See Also
CalendarDayEventArgs Members


CalendarDayEventArgs Members

CalendarDayEventArgs Members A Sandcastle Documented Class Library
Send Feedback

The CalendarDayEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | CalendarDayEventArgs | Creates a new event with the specified day
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | CalendarDay | Gets the day related to the event
Back to Top
See Also
CalendarDayEventArgs Class


CalendarDayEventArgs Constructor

CalendarDayEventArgs Constructor A Sandcastle Documented Class Library
Send Feedback
Creates a new event with the specified day

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    day As CalendarDay _
)
Public Sub New ( _
    day As CalendarDay _
)
public CalendarDayEventArgs(
    CalendarDay day
)
public CalendarDayEventArgs(
    CalendarDay day
)
public:
CalendarDayEventArgs(
    CalendarDay^ day
)
public:
CalendarDayEventArgs(
    CalendarDay^ day
)
Parameters
day
Type: WindowsFormsCalendar CalendarDay
Day of the event
See Also
CalendarDayEventArgs Class
CalendarDayEventArgs Members


CalendarDayEventArgs Methods

CalendarDayEventArgs Methods A Sandcastle Documented Class Library
Send Feedback
The CalendarDayEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CalendarDayEventArgs Class


CalendarDayEventArgs Properties

CalendarDayEventArgs Properties A Sandcastle Documented Class Library
Send Feedback
The CalendarDayEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | CalendarDay | Gets the day related to the event
Back to Top
See Also
CalendarDayEventArgs Class


CalendarDay Property

CalendarDayEventArgs CalendarDay Property A Sandcastle Documented Class Library
Send Feedback
Gets the day related to the event

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property CalendarDay As CalendarDay
    Get
Public ReadOnly Property CalendarDay As CalendarDay
    Get
public CalendarDay CalendarDay { get; }
public CalendarDay CalendarDay { get; }
public:
property CalendarDay^ CalendarDay {
    CalendarDay^ get ();
}
public:
property CalendarDay^ CalendarDay {
    CalendarDay^ get ();
}
See Also
CalendarDayEventArgs Class
CalendarDayEventArgs Members


CalendarDaysMode Enumeration

CalendarDaysMode Enumeration A Sandcastle Documented Class Library
Send Feedback
Enumerates the possible modes of the days visualization on the Calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Enumeration CalendarDaysMode
Public Enumeration CalendarDaysMode
public enum CalendarDaysMode
public enum CalendarDaysMode
public enum class CalendarDaysMode
public enum class CalendarDaysMode
Members
Member name | Value | Description
Short | 0 | A short version of the day is visible without time scale.
Expanded | 1 | The day is fully visible with time scale.
See Also


CalendarDayTop Class

CalendarDayTop Class A Sandcastle Documented Class Library
Represents the top area of a day, where multiday and all day items are stored
Inheritance Hierarchy
Online System Object
WindowsFormsCalendar CalendarSelectableElement
WindowsFormsCalendar CalendarDayTop

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class CalendarDayTop _
    Inherits CalendarSelectableElement
Public Class CalendarDayTop _
    Inherits CalendarSelectableElement
public class CalendarDayTop : CalendarSelectableElement
public class CalendarDayTop : CalendarSelectableElement
public ref class CalendarDayTop : public CalendarSelectableElement
public ref class CalendarDayTop : public CalendarSelectableElement
See Also
CalendarDayTop Members


CalendarDayTop Members

CalendarDayTop Members A Sandcastle Documented Class Library

The CalendarDayTop type exposes the following members.
Constructors
 | Name | Description
Public method | CalendarDayTop | Creates a new DayTop for the specified day
Back to Top
Methods
 | Name | Description
Public method | CompareTo | Compares this element with other using date as comparer (Inherited from CalendarSelectableElement.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Bounds | Gets the Bounds of the element on the Calendar window (Inherited from CalendarSelectableElement.)
Public property | Calendar | Gets the Calendar this element belongs to (Inherited from CalendarSelectableElement.)
Public property | Date | Gets the date. (Overrides CalendarSelectableElement Date.)
Public property | Day | Gets the Day of this DayTop
Public property | PassingItems | Gets the list of items passing on this daytop
Public property | Selected | Gets a value indicating if the element is currently selected (Inherited from CalendarSelectableElement.)
Back to Top
See Also
CalendarDayTop Class


CalendarDayTop Constructor

CalendarDayTop Constructor A Sandcastle Documented Class Library
Send Feedback
Creates a new DayTop for the specified day

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    day As CalendarDay _
)
Public Sub New ( _
    day As CalendarDay _
)
public CalendarDayTop(
    CalendarDay day
)
public CalendarDayTop(
    CalendarDay day
)
public:
CalendarDayTop(
    CalendarDay^ day
)
public:
CalendarDayTop(
    CalendarDay^ day
)
Parameters
day
Type: WindowsFormsCalendar CalendarDay
[Missing <param name="day"/> documentation for "M:WindowsFormsCalendar.CalendarDayTop.#ctor(WindowsFormsCalendar.CalendarDay)"]
See Also
CalendarDayTop Class
CalendarDayTop Members


CalendarDayTop Methods

CalendarDayTop Methods A Sandcastle Documented Class Library
The CalendarDayTop type exposes the following members.
Methods
 | Name | Description
Public method | CompareTo | Compares this element with other using date as comparer (Inherited from CalendarSelectableElement.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CalendarDayTop Class


CalendarDayTop Properties

CalendarDayTop Properties A Sandcastle Documented Class Library
Send Feedback
The CalendarDayTop type exposes the following members.
Properties
 | Name | Description
Public property | Bounds | Gets the Bounds of the element on the Calendar window (Inherited from CalendarSelectableElement.)
Public property | Calendar | Gets the Calendar this element belongs to (Inherited from CalendarSelectableElement.)
Public property | Date | Gets the date. (Overrides CalendarSelectableElement Date.)
Public property | Day | Gets the Day of this DayTop
Public property | PassingItems | Gets the list of items passing on this daytop
Public property | Selected | Gets a value indicating if the element is currently selected (Inherited from CalendarSelectableElement.)
Back to Top
See Also
CalendarDayTop Class


Date Property

CalendarDayTop Date Property A Sandcastle Documented Class Library
Send Feedback
Gets the date.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides ReadOnly Property Date As DateTime
    Get
Public Overrides ReadOnly Property Date As DateTime
    Get
public override DateTime Date { get; }
public override DateTime Date { get; }
public:
virtual property DateTime Date {
    DateTime get () override;
}
public:
virtual property DateTime Date {
    DateTime get () override;
}
Implements
ICalendarSelectableElement Date
See Also
CalendarDayTop Class
CalendarDayTop Members


Day Property

CalendarDayTop Day Property A Sandcastle Documented Class Library
Send Feedback
Gets the Day of this DayTop

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Day As CalendarDay
    Get
Public ReadOnly Property Day As CalendarDay
    Get
public CalendarDay Day { get; }
public CalendarDay Day { get; }
public:
property CalendarDay^ Day {
    CalendarDay^ get ();
}
public:
property CalendarDay^ Day {
    CalendarDay^ get ();
}
See Also
CalendarDayTop Class
CalendarDayTop Members


PassingItems Property

CalendarDayTop PassingItems Property A Sandcastle Documented Class Library
Send Feedback
Gets the list of items passing on this daytop

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property PassingItems As List(Of CalendarItem)
    Get
Public ReadOnly Property PassingItems As List(Of CalendarItem)
    Get
public List<CalendarItem> PassingItems { get; }
public List<CalendarItem> PassingItems { get; }
public:
property List<CalendarItem^>^ PassingItems {
    List<CalendarItem^>^ get ();
}
public:
property List<CalendarItem^>^ PassingItems {
    List<CalendarItem^>^ get ();
}
See Also
CalendarDayTop Class
CalendarDayTop Members


CalendarHighlightRange Class

CalendarHighlightRange Class A Sandcastle Documented Class Library
Send Feedback
Represents a range of time that is highlighted as work-time
Inheritance Hierarchy
Online System Object
WindowsFormsCalendar CalendarHighlightRange

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class CalendarHighlightRange
Public Class CalendarHighlightRange
public class CalendarHighlightRange
public class CalendarHighlightRange
public ref class CalendarHighlightRange
public ref class CalendarHighlightRange
See Also
CalendarHighlightRange Members


CalendarHighlightRange Members

CalendarHighlightRange Members A Sandcastle Documented Class Library
Send Feedback

The CalendarHighlightRange type exposes the following members.
Constructors
 | Name | Description
Public method | CalendarHighlightRange | Initializes a new instance of the CalendarHighlightRange class.
Public method | CalendarHighlightRange(DayOfWeek, TimeSpan, TimeSpan) | Initializes a new instance of the CalendarHighlightRange class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Calendar | Gets the calendar that this range is assigned to. (If any)
Public property | DayOfWeek | Gets or sets the day of the week for this range
Public property | EndTime | Gets or sets the end time of the range
Public property | StartTime | Gets or sets the start time of the range
Back to Top
See Also
CalendarHighlightRange Class


CalendarHighlightRange Constructor

CalendarHighlightRange Constructor A Sandcastle Documented Class Library
Send Feedback
Overload List
 | Name | Description
Public method | CalendarHighlightRange | Initializes a new instance of the CalendarHighlightRange class.
Public method | CalendarHighlightRange(DayOfWeek, TimeSpan, TimeSpan) | Initializes a new instance of the CalendarHighlightRange class.
Back to Top
See Also
CalendarHighlightRange Class
CalendarHighlightRange Members


CalendarHighlightRange Constructor

CalendarHighlightRange Constructor A Sandcastle Documented Class Library
Send Feedback
Initializes a new instance of the CalendarHighlightRange class.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New
Public Sub New
public CalendarHighlightRange()
public CalendarHighlightRange()
public:
CalendarHighlightRange()
public:
CalendarHighlightRange()
See Also
CalendarHighlightRange Class
CalendarHighlightRange Members
CalendarHighlightRange Overload


CalendarHighlightRange Constructor (DayOfWeek, TimeSpan, TimeSpan)

CalendarHighlightRange Constructor (DayOfWeek, TimeSpan, TimeSpan) A Sandcastle Documented Class Library
Send Feedback
Initializes a new instance of the CalendarHighlightRange class.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    day As DayOfWeek, _
    startTime As TimeSpan, _
    endTime As TimeSpan _
)
Public Sub New ( _
    day As DayOfWeek, _
    startTime As TimeSpan, _
    endTime As TimeSpan _
)
public CalendarHighlightRange(
    DayOfWeek day,
    TimeSpan startTime,
    TimeSpan endTime
)
public CalendarHighlightRange(
    DayOfWeek day,
    TimeSpan startTime,
    TimeSpan endTime
)
public:
CalendarHighlightRange(
    DayOfWeek day,
    TimeSpan startTime,
    TimeSpan endTime
)
public:
CalendarHighlightRange(
    DayOfWeek day,
    TimeSpan startTime,
    TimeSpan endTime
)
Parameters
day
Type:   Online System DayOfWeek
The day.
startTime
Type:   Online System TimeSpan
The start time.
endTime
Type:   Online System TimeSpan
The end time.
See Also
CalendarHighlightRange Class
CalendarHighlightRange Members
CalendarHighlightRange Overload


CalendarHighlightRange Methods

CalendarHighlightRange Methods A Sandcastle Documented Class Library
Send Feedback
The CalendarHighlightRange type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CalendarHighlightRange Class


CalendarHighlightRange Properties

CalendarHighlightRange Properties A Sandcastle Documented Class Library
Send Feedback
The CalendarHighlightRange type exposes the following members.
Properties
 | Name | Description
Public property | Calendar | Gets the calendar that this range is assigned to. (If any)
Public property | DayOfWeek | Gets or sets the day of the week for this range
Public property | EndTime | Gets or sets the end time of the range
Public property | StartTime | Gets or sets the start time of the range
Back to Top
See Also
CalendarHighlightRange Class


Calendar Property

CalendarHighlightRange Calendar Property A Sandcastle Documented Class Library
Send Feedback
Gets the calendar that this range is assigned to. (If any)

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Calendar As Calendar
    Get
Public ReadOnly Property Calendar As Calendar
    Get
public Calendar Calendar { get; }
public Calendar Calendar { get; }
public:
property Calendar^ Calendar {
    Calendar^ get ();
}
public:
property Calendar^ Calendar {
    Calendar^ get ();
}
See Also
CalendarHighlightRange Class
CalendarHighlightRange Members


DayOfWeek Property

CalendarHighlightRange DayOfWeek Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the day of the week for this range

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property DayOfWeek As DayOfWeek
    Get
    Set
Public Property DayOfWeek As DayOfWeek
    Get
    Set
public DayOfWeek DayOfWeek { get; set; }
public DayOfWeek DayOfWeek { get; set; }
public:
property DayOfWeek DayOfWeek {
    DayOfWeek get ();
    void set (DayOfWeek value);
}
public:
property DayOfWeek DayOfWeek {
    DayOfWeek get ();
    void set (DayOfWeek value);
}
See Also
CalendarHighlightRange Class
CalendarHighlightRange Members


EndTime Property

CalendarHighlightRange EndTime Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the end time of the range

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property EndTime As TimeSpan
    Get
    Set
Public Property EndTime As TimeSpan
    Get
    Set
public TimeSpan EndTime { get; set; }
public TimeSpan EndTime { get; set; }
public:
property TimeSpan EndTime {
    TimeSpan get ();
    void set (TimeSpan value);
}
public:
property TimeSpan EndTime {
    TimeSpan get ();
    void set (TimeSpan value);
}
See Also
CalendarHighlightRange Class
CalendarHighlightRange Members


StartTime Property

CalendarHighlightRange StartTime Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the start time of the range

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property StartTime As TimeSpan
    Get
    Set
Public Property StartTime As TimeSpan
    Get
    Set
public TimeSpan StartTime { get; set; }
public TimeSpan StartTime { get; set; }
public:
property TimeSpan StartTime {
    TimeSpan get ();
    void set (TimeSpan value);
}
public:
property TimeSpan StartTime {
    TimeSpan get ();
    void set (TimeSpan value);
}
See Also
CalendarHighlightRange Class
CalendarHighlightRange Members


CalendarItem Class

CalendarItem Class A Sandcastle Documented Class Library
Represents an item of the calendar with a date and timespan
Inheritance Hierarchy
Online System Object
WindowsFormsCalendar CalendarSelectableElement
WindowsFormsCalendar CalendarItem

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class CalendarItem _
    Inherits CalendarSelectableElement
Public Class CalendarItem _
    Inherits CalendarSelectableElement
public class CalendarItem : CalendarSelectableElement
public class CalendarItem : CalendarSelectableElement
public ref class CalendarItem : public CalendarSelectableElement
public ref class CalendarItem : public CalendarSelectableElement
Remarks
CalendarItem provides a graphical representation of tasks within a date range.
See Also
CalendarItem Members


CalendarItem Members

CalendarItem Members A Sandcastle Documented Class Library

The CalendarItem type exposes the following members.
Constructors
 | Name | Description
Public method | CalendarItem(Calendar) | Initializes a new instance of the CalendarItem class.
Public method | CalendarItem(Calendar, DateTime, DateTime, String) | Initializes a new instance of the CalendarItem class.
Public method | CalendarItem(Calendar, DateTime, TimeSpan, String) | Initializes a new instance of the CalendarItem class.
Back to Top
Methods
 | Name | Description
Public method | ApplyColor | Applies color to background, border, and forecolor, from the specified color.
Public method | CompareTo | Compares this element with other using date as comparer (Inherited from CalendarSelectableElement.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAllBounds | Gets all the bounds related to the item.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IntersectsWith | Indicates if the time of the item intersects with the provided time
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RemoveColors | Removes all specific coloring for the item.
Public method | ResizeEndDateZone | Gets a value indicating if the specified point is in a resize zone of EndDate
Public method | ResizeStartDateZone | Gets a value indicating if the specified point is in a resize zone of StartDate
Public method | SetBounds | Sets the bounds of the item
Public method | ToString | Returns a Online String that represents this instance. (Overrides Online Object ToString .)
Back to Top
Properties
 | Name | Description
Public property | AditionalBounds | Gets or sets an array of rectangles containing bounds additional to Bounds property.
Public property | BackgroundColor | Gets or sets the a background color for the object. If Color.Empty, renderer default's will be used.
Public property | BackgroundColorLighter | Gets or sets the lighter background color of the item
Public property | BorderColor | Gets or sets the bordercolor of the item. If Color.Empty, renderer default's will be used.
Public property | Bounds | Gets the Bounds of the element on the Calendar window (Inherited from CalendarSelectableElement.)
Public property | Calendar | Gets the Calendar this element belongs to (Inherited from CalendarSelectableElement.)
Public property | Date | Gets the StartDate of the item. Implemented (Overrides CalendarSelectableElement Date.)
Public property | DayEnd | Gets the day on the Calendar where this item ends
Public property | DayStart | Gets the day on the Calendar where this item starts
Public property | Duration | Gets the duration of the item
Public property | EndDate | Gets or sets the end time of the item
Public property | EndDateText | Gets the text of the end date
Public property | Font | Gets or sets the font.
Public property | ForeColor | Gets or sets the forecolor of the item. If Color.Empty, renderer default's will be used.
Public property | Image | Gets or sets an image for the item
Public property | ImageAlign | Gets or sets the alignment of the image relative to the text
Public property | IsDragging | Gets a value indicating if the item is being dragged
Public property | IsEditing | Gets a value indicating if the item is currently being edited by the user
Public property | IsOnDayTop | Gets a value indicating if the item goes on the DayTop area of the CalendarDay
Public property | IsOnView | Gets a value indicating if the item is currently on view.
Public property | IsOnViewDateRange | Gets a value indicating if the item is on the range specified by ViewStart and ViewEnd
Public property | IsOpenEnd | Gets a value indicating if the item's EndDate is aftter the ViewEnd date.
Public property | IsOpenStart | Gets a value indicating if the item's StartDate is before the ViewStart date.
Public property | IsResizingEndDate | Gets a value indicating if item is being resized by the EndDate
Public property | IsResizingStartDate | Gets a value indicating if item is being resized by the StartDate
Public property | Locked | Gets a value indicating if this item is locked.
Public property | MinuteEndTop | Gets the top correspoinding to the ending minute
Public property | MinuteStartTop | Gets the top corresponding to the starting minute
Public property | Pattern | Gets or sets the pattern style to use in the background of item.
Public property | PatternColor | Gets or sets the pattern's color
Public property | Selected | Gets a value indicating if the element is currently selected (Inherited from CalendarSelectableElement.)
Public property | ShowEndTime | Gets a value indicating if the item should show the time of the EndDate
Public property | ShowStartTime | Gets a value indicating if the item should show the time of the StartDate
Public property | StartDate | Gets or sets the start time of the item
Public property | StartDateText | Gets the text of the start date
Public property | Tag | Gets or sets a tag object for the item
Public property | Text | Gets or sets the text of the item
Back to Top
See Also
CalendarItem Class


CalendarItem Constructor

CalendarItem Constructor A Sandcastle Documented Class Library
Send Feedback
Overload List
 | Name | Description
Public method | CalendarItem(Calendar) | Initializes a new instance of the CalendarItem class.
Public method | CalendarItem(Calendar, DateTime, DateTime, String) | Initializes a new instance of the CalendarItem class.
Public method | CalendarItem(Calendar, DateTime, TimeSpan, String) | Initializes a new instance of the CalendarItem class.
Back to Top
See Also
CalendarItem Class
CalendarItem Members


CalendarItem Constructor (Calendar)

CalendarItem Constructor (Calendar) A Sandcastle Documented Class Library
Send Feedback
Initializes a new instance of the CalendarItem class.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    calendar As Calendar _
)
Public Sub New ( _
    calendar As Calendar _
)
public CalendarItem(
    Calendar calendar
)
public CalendarItem(
    Calendar calendar
)
public:
CalendarItem(
    Calendar^ calendar
)
public:
CalendarItem(
    Calendar^ calendar
)
Parameters
calendar
Type: WindowsFormsCalendar Calendar
[Missing <param name="calendar"/> documentation for "M:WindowsFormsCalendar.CalendarItem.#ctor(WindowsFormsCalendar.Calendar)"]
See Also
CalendarItem Class
CalendarItem Members
CalendarItem Overload


CalendarItem Constructor (Calendar, DateTime, DateTime, String)

CalendarItem Constructor (Calendar, DateTime, DateTime, String) A Sandcastle Documented Class Library
Send Feedback
Initializes a new instance of the CalendarItem class.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    calendar As Calendar, _
    startDate As DateTime, _
    endDate As DateTime, _
    text As String _
)
Public Sub New ( _
    calendar As Calendar, _
    startDate As DateTime, _
    endDate As DateTime, _
    text As String _
)
public CalendarItem(
    Calendar calendar,
    DateTime startDate,
    DateTime endDate,
    string text
)
public CalendarItem(
    Calendar calendar,
    DateTime startDate,
    DateTime endDate,
    string text
)
public:
CalendarItem(
    Calendar^ calendar,
    DateTime startDate,
    DateTime endDate,
    String^ text
)
public:
CalendarItem(
    Calendar^ calendar,
    DateTime startDate,
    DateTime endDate,
    String^ text
)
Parameters
calendar
Type: WindowsFormsCalendar Calendar
The calendar.
startDate
Type:   Online System DateTime
The start date.
endDate
Type:   Online System DateTime
The end date.
text
Type:   Online System String
The text.
See Also
CalendarItem Class
CalendarItem Members
CalendarItem Overload


CalendarItem Constructor (Calendar, DateTime, TimeSpan, String)

CalendarItem Constructor (Calendar, DateTime, TimeSpan, String) A Sandcastle Documented Class Library
Send Feedback
Initializes a new instance of the CalendarItem class.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    calendar As Calendar, _
    startDate As DateTime, _
    duration As TimeSpan, _
    text As String _
)
Public Sub New ( _
    calendar As Calendar, _
    startDate As DateTime, _
    duration As TimeSpan, _
    text As String _
)
public CalendarItem(
    Calendar calendar,
    DateTime startDate,
    TimeSpan duration,
    string text
)
public CalendarItem(
    Calendar calendar,
    DateTime startDate,
    TimeSpan duration,
    string text
)
public:
CalendarItem(
    Calendar^ calendar,
    DateTime startDate,
    TimeSpan duration,
    String^ text
)
public:
CalendarItem(
    Calendar^ calendar,
    DateTime startDate,
    TimeSpan duration,
    String^ text
)
Parameters
calendar
Type: WindowsFormsCalendar Calendar
The calendar.
startDate
Type:   Online System DateTime
The start date.
duration
Type:   Online System TimeSpan
The duration.
text
Type:   Online System String
The text.
See Also
CalendarItem Class
CalendarItem Members
CalendarItem Overload


CalendarItem Methods

CalendarItem Methods A Sandcastle Documented Class Library
The CalendarItem type exposes the following members.
Methods
 | Name | Description
Public method | ApplyColor | Applies color to background, border, and forecolor, from the specified color.
Public method | CompareTo | Compares this element with other using date as comparer (Inherited from CalendarSelectableElement.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAllBounds | Gets all the bounds related to the item.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IntersectsWith | Indicates if the time of the item intersects with the provided time
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RemoveColors | Removes all specific coloring for the item.
Public method | ResizeEndDateZone | Gets a value indicating if the specified point is in a resize zone of EndDate
Public method | ResizeStartDateZone | Gets a value indicating if the specified point is in a resize zone of StartDate
Public method | SetBounds | Sets the bounds of the item
Public method | ToString | Returns a Online String that represents this instance. (Overrides Online Object ToString .)
Back to Top
See Also
CalendarItem Class


ApplyColor Method

CalendarItem ApplyColor Method A Sandcastle Documented Class Library
Send Feedback
Applies color to background, border, and forecolor, from the specified color.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub ApplyColor ( _
    color As Color _
)
Public Sub ApplyColor ( _
    color As Color _
)
public void ApplyColor(
    Color color
)
public void ApplyColor(
    Color color
)
public:
void ApplyColor(
    Color color
)
public:
void ApplyColor(
    Color color
)
Parameters
color
Type:   Online System.Drawing Color
The color.
See Also
CalendarItem Class
CalendarItem Members


GetAllBounds Method

CalendarItem GetAllBounds Method A Sandcastle Documented Class Library
Send Feedback
Gets all the bounds related to the item.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Function GetAllBounds As IEnumerable(Of Rectangle)
Public Function GetAllBounds As IEnumerable(Of Rectangle)
public IEnumerable<Rectangle> GetAllBounds()
public IEnumerable<Rectangle> GetAllBounds()
public:
IEnumerable<Rectangle>^ GetAllBounds()
public:
IEnumerable<Rectangle>^ GetAllBounds()
Return Value
[Missing <returns> documentation for "M:WindowsFormsCalendar.CalendarItem.GetAllBounds"]
Remarks

            Items that are broken on two or more weeks may have more than one rectangle bounds.

See Also
CalendarItem Class
CalendarItem Members


IntersectsWith Method

CalendarItem IntersectsWith Method A Sandcastle Documented Class Library
Send Feedback
Indicates if the time of the item intersects with the provided time

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Function IntersectsWith ( _
    startTime As TimeSpan, _
    endTime As TimeSpan _
) As Boolean
Public Function IntersectsWith ( _
    startTime As TimeSpan, _
    endTime As TimeSpan _
) As Boolean
public bool IntersectsWith(
    TimeSpan startTime,
    TimeSpan endTime
)
public bool IntersectsWith(
    TimeSpan startTime,
    TimeSpan endTime
)
public:
bool IntersectsWith(
    TimeSpan startTime,
    TimeSpan endTime
)
public:
bool IntersectsWith(
    TimeSpan startTime,
    TimeSpan endTime
)
Parameters
startTime
Type:   Online System TimeSpan
The start time.
endTime
Type:   Online System TimeSpan
The end time.
Return Value
[Missing <returns> documentation for "M:WindowsFormsCalendar.CalendarItem.IntersectsWith(System.TimeSpan,System.TimeSpan)"]
See Also
CalendarItem Class
CalendarItem Members


RemoveColors Method

CalendarItem RemoveColors Method A Sandcastle Documented Class Library
Send Feedback
Removes all specific coloring for the item.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub RemoveColors
Public Sub RemoveColors
public void RemoveColors()
public void RemoveColors()
public:
void RemoveColors()
public:
void RemoveColors()
See Also
CalendarItem Class
CalendarItem Members


ResizeEndDateZone Method

CalendarItem ResizeEndDateZone Method A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if the specified point is in a resize zone of EndDate

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Function ResizeEndDateZone ( _
    point As Point _
) As Boolean
Public Function ResizeEndDateZone ( _
    point As Point _
) As Boolean
public bool ResizeEndDateZone(
    Point point
)
public bool ResizeEndDateZone(
    Point point
)
public:
bool ResizeEndDateZone(
    Point point
)
public:
bool ResizeEndDateZone(
    Point point
)
Parameters
point
Type:   Online System.Drawing Point
The point.
Return Value
[Missing <returns> documentation for "M:WindowsFormsCalendar.CalendarItem.ResizeEndDateZone(System.Drawing.Point)"]
See Also
CalendarItem Class
CalendarItem Members


ResizeStartDateZone Method

CalendarItem ResizeStartDateZone Method A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if the specified point is in a resize zone of StartDate

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Function ResizeStartDateZone ( _
    point As Point _
) As Boolean
Public Function ResizeStartDateZone ( _
    point As Point _
) As Boolean
public bool ResizeStartDateZone(
    Point point
)
public bool ResizeStartDateZone(
    Point point
)
public:
bool ResizeStartDateZone(
    Point point
)
public:
bool ResizeStartDateZone(
    Point point
)
Parameters
point
Type:   Online System.Drawing Point
The point.
Return Value
[Missing <returns> documentation for "M:WindowsFormsCalendar.CalendarItem.ResizeStartDateZone(System.Drawing.Point)"]
See Also
CalendarItem Class
CalendarItem Members


SetBounds Method

CalendarItem SetBounds Method A Sandcastle Documented Class Library
Send Feedback
Sets the bounds of the item

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub SetBounds ( _
    rectangle As Rectangle _
)
Public Sub SetBounds ( _
    rectangle As Rectangle _
)
public void SetBounds(
    Rectangle rectangle
)
public void SetBounds(
    Rectangle rectangle
)
public:
void SetBounds(
    Rectangle rectangle
)
public:
void SetBounds(
    Rectangle rectangle
)
Parameters
rectangle
Type:   Online System.Drawing Rectangle
The rectangle.
See Also
CalendarItem Class
CalendarItem Members


ToString Method

CalendarItem ToString Method A Sandcastle Documented Class Library
Send Feedback
Returns a Online String that represents this instance.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public override string ToString()
public override string ToString()
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
Return Value

            A   Online String that represents this instance.

See Also
CalendarItem Class
CalendarItem Members


CalendarItem Properties

CalendarItem Properties A Sandcastle Documented Class Library
Send Feedback
The CalendarItem type exposes the following members.
Properties
 | Name | Description
Public property | AditionalBounds | Gets or sets an array of rectangles containing bounds additional to Bounds property.
Public property | BackgroundColor | Gets or sets the a background color for the object. If Color.Empty, renderer default's will be used.
Public property | BackgroundColorLighter | Gets or sets the lighter background color of the item
Public property | BorderColor | Gets or sets the bordercolor of the item. If Color.Empty, renderer default's will be used.
Public property | Bounds | Gets the Bounds of the element on the Calendar window (Inherited from CalendarSelectableElement.)
Public property | Calendar | Gets the Calendar this element belongs to (Inherited from CalendarSelectableElement.)
Public property | Date | Gets the StartDate of the item. Implemented (Overrides CalendarSelectableElement Date.)
Public property | DayEnd | Gets the day on the Calendar where this item ends
Public property | DayStart | Gets the day on the Calendar where this item starts
Public property | Duration | Gets the duration of the item
Public property | EndDate | Gets or sets the end time of the item
Public property | EndDateText | Gets the text of the end date
Public property | Font | Gets or sets the font.
Public property | ForeColor | Gets or sets the forecolor of the item. If Color.Empty, renderer default's will be used.
Public property | Image | Gets or sets an image for the item
Public property | ImageAlign | Gets or sets the alignment of the image relative to the text
Public property | IsDragging | Gets a value indicating if the item is being dragged
Public property | IsEditing | Gets a value indicating if the item is currently being edited by the user
Public property | IsOnDayTop | Gets a value indicating if the item goes on the DayTop area of the CalendarDay
Public property | IsOnView | Gets a value indicating if the item is currently on view.
Public property | IsOnViewDateRange | Gets a value indicating if the item is on the range specified by ViewStart and ViewEnd
Public property | IsOpenEnd | Gets a value indicating if the item's EndDate is aftter the ViewEnd date.
Public property | IsOpenStart | Gets a value indicating if the item's StartDate is before the ViewStart date.
Public property | IsResizingEndDate | Gets a value indicating if item is being resized by the EndDate
Public property | IsResizingStartDate | Gets a value indicating if item is being resized by the StartDate
Public property | Locked | Gets a value indicating if this item is locked.
Public property | MinuteEndTop | Gets the top correspoinding to the ending minute
Public property | MinuteStartTop | Gets the top corresponding to the starting minute
Public property | Pattern | Gets or sets the pattern style to use in the background of item.
Public property | PatternColor | Gets or sets the pattern's color
Public property | Selected | Gets a value indicating if the element is currently selected (Inherited from CalendarSelectableElement.)
Public property | ShowEndTime | Gets a value indicating if the item should show the time of the EndDate
Public property | ShowStartTime | Gets a value indicating if the item should show the time of the StartDate
Public property | StartDate | Gets or sets the start time of the item
Public property | StartDateText | Gets the text of the start date
Public property | Tag | Gets or sets a tag object for the item
Public property | Text | Gets or sets the text of the item
Back to Top
See Also
CalendarItem Class


AditionalBounds Property

CalendarItem AditionalBounds Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets an array of rectangles containing bounds additional to Bounds property.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Property AditionalBounds As Rectangle()
    Get
    Set
Public Overridable Property AditionalBounds As Rectangle()
    Get
    Set
public virtual Rectangle[] AditionalBounds { get; set; }
public virtual Rectangle[] AditionalBounds { get; set; }
public:
virtual property array<Rectangle>^ AditionalBounds {
    array<Rectangle>^ get ();
    void set (array<Rectangle>^ value);
}
public:
virtual property array<Rectangle>^ AditionalBounds {
    array<Rectangle>^ get ();
    void set (array<Rectangle>^ value);
}
Remarks

            Items may contain additional bounds because of several graphical occourences, mostly when Calendar in
            Short mode, due to the duration of the item; e.g. when an all day item lasts several weeks,
            one rectangle for week must be drawn to indicate the presence of the item.

See Also
CalendarItem Class
CalendarItem Members


BackgroundColor Property

CalendarItem BackgroundColor Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the a background color for the object. If Color.Empty, renderer default's will be used.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property BackgroundColor As Color
    Get
    Set
Public Property BackgroundColor As Color
    Get
    Set
public Color BackgroundColor { get; set; }
public Color BackgroundColor { get; set; }
public:
property Color BackgroundColor {
    Color get ();
    void set (Color value);
}
public:
property Color BackgroundColor {
    Color get ();
    void set (Color value);
}
See Also
CalendarItem Class
CalendarItem Members


BackgroundColorLighter Property

CalendarItem BackgroundColorLighter Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the lighter background color of the item

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property BackgroundColorLighter As Color
    Get
    Set
Public Property BackgroundColorLighter As Color
    Get
    Set
public Color BackgroundColorLighter { get; set; }
public Color BackgroundColorLighter { get; set; }
public:
property Color BackgroundColorLighter {
    Color get ();
    void set (Color value);
}
public:
property Color BackgroundColorLighter {
    Color get ();
    void set (Color value);
}
See Also
CalendarItem Class
CalendarItem Members


BorderColor Property

CalendarItem BorderColor Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the bordercolor of the item. If Color.Empty, renderer default's will be used.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property BorderColor As Color
    Get
    Set
Public Property BorderColor As Color
    Get
    Set
public Color BorderColor { get; set; }
public Color BorderColor { get; set; }
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
See Also
CalendarItem Class
CalendarItem Members


Date Property

CalendarItem Date Property A Sandcastle Documented Class Library
Send Feedback
Gets the StartDate of the item. Implemented

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides ReadOnly Property Date As DateTime
    Get
Public Overrides ReadOnly Property Date As DateTime
    Get
public override DateTime Date { get; }
public override DateTime Date { get; }
public:
virtual property DateTime Date {
    DateTime get () override;
}
public:
virtual property DateTime Date {
    DateTime get () override;
}
Implements
ICalendarSelectableElement Date
See Also
CalendarItem Class
CalendarItem Members


DayEnd Property

CalendarItem DayEnd Property A Sandcastle Documented Class Library
Send Feedback
Gets the day on the Calendar where this item ends

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property DayEnd As CalendarDay
    Get
Public ReadOnly Property DayEnd As CalendarDay
    Get
public CalendarDay DayEnd { get; }
public CalendarDay DayEnd { get; }
public:
property CalendarDay^ DayEnd {
    CalendarDay^ get ();
}
public:
property CalendarDay^ DayEnd {
    CalendarDay^ get ();
}
Remarks

            This day is not necesarily the day corresponding to the day on EndDate,
            since this date can be out of the range of the current view.

If Item is not on view date range this property will return null.
See Also
CalendarItem Class
CalendarItem Members


DayStart Property

CalendarItem DayStart Property A Sandcastle Documented Class Library
Send Feedback
Gets the day on the Calendar where this item starts

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property DayStart As CalendarDay
    Get
Public ReadOnly Property DayStart As CalendarDay
    Get
public CalendarDay DayStart { get; }
public CalendarDay DayStart { get; }
public:
property CalendarDay^ DayStart {
    CalendarDay^ get ();
}
public:
property CalendarDay^ DayStart {
    CalendarDay^ get ();
}
Remarks

            This day is not necesarily the day corresponding to the day on StartDate,
            since start date can be out of the range of the current view.

If Item is not on view date range this property will return null.
See Also
CalendarItem Class
CalendarItem Members


Duration Property

CalendarItem Duration Property A Sandcastle Documented Class Library
Send Feedback
Gets the duration of the item

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Duration As TimeSpan
    Get
Public ReadOnly Property Duration As TimeSpan
    Get
public TimeSpan Duration { get; }
public TimeSpan Duration { get; }
public:
property TimeSpan Duration {
    TimeSpan get ();
}
public:
property TimeSpan Duration {
    TimeSpan get ();
}
See Also
CalendarItem Class
CalendarItem Members


EndDate Property

CalendarItem EndDate Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the end time of the item

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property EndDate As DateTime
    Get
    Set
Public Property EndDate As DateTime
    Get
    Set
public DateTime EndDate { get; set; }
public DateTime EndDate { get; set; }
public:
property DateTime EndDate {
    DateTime get ();
    void set (DateTime value);
}
public:
property DateTime EndDate {
    DateTime get ();
    void set (DateTime value);
}
See Also
CalendarItem Class
CalendarItem Members


EndDateText Property

CalendarItem EndDateText Property A Sandcastle Documented Class Library
Send Feedback
Gets the text of the end date

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable ReadOnly Property EndDateText As String
    Get
Public Overridable ReadOnly Property EndDateText As String
    Get
public virtual string EndDateText { get; }
public virtual string EndDateText { get; }
public:
virtual property String^ EndDateText {
    String^ get ();
}
public:
virtual property String^ EndDateText {
    String^ get ();
}
See Also
CalendarItem Class
CalendarItem Members


Font Property

CalendarItem Font Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the font.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property Font As Font
    Get
    Set
Public Property Font As Font
    Get
    Set
public Font Font { get; set; }
public Font Font { get; set; }
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
Field Value

            The font.

See Also
CalendarItem Class
CalendarItem Members


ForeColor Property

CalendarItem ForeColor Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the forecolor of the item. If Color.Empty, renderer default's will be used.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property ForeColor As Color
    Get
    Set
Public Property ForeColor As Color
    Get
    Set
public Color ForeColor { get; set; }
public Color ForeColor { get; set; }
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
See Also
CalendarItem Class
CalendarItem Members


Image Property

CalendarItem Image Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets an image for the item

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property Image As Image
    Get
    Set
Public Property Image As Image
    Get
    Set
public Image Image { get; set; }
public Image Image { get; set; }
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}
See Also
CalendarItem Class
CalendarItem Members


ImageAlign Property

CalendarItem ImageAlign Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the alignment of the image relative to the text

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property ImageAlign As CalendarItemImageAlign
    Get
    Set
Public Property ImageAlign As CalendarItemImageAlign
    Get
    Set
public CalendarItemImageAlign ImageAlign { get; set; }
public CalendarItemImageAlign ImageAlign { get; set; }
public:
property CalendarItemImageAlign ImageAlign {
    CalendarItemImageAlign get ();
    void set (CalendarItemImageAlign value);
}
public:
property CalendarItemImageAlign ImageAlign {
    CalendarItemImageAlign get ();
    void set (CalendarItemImageAlign value);
}
See Also
CalendarItem Class
CalendarItem Members


IsDragging Property

CalendarItem IsDragging Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if the item is being dragged

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property IsDragging As Boolean
    Get
Public ReadOnly Property IsDragging As Boolean
    Get
public bool IsDragging { get; }
public bool IsDragging { get; }
public:
property bool IsDragging {
    bool get ();
}
public:
property bool IsDragging {
    bool get ();
}
See Also
CalendarItem Class
CalendarItem Members


IsEditing Property

CalendarItem IsEditing Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if the item is currently being edited by the user

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property IsEditing As Boolean
    Get
Public ReadOnly Property IsEditing As Boolean
    Get
public bool IsEditing { get; }
public bool IsEditing { get; }
public:
property bool IsEditing {
    bool get ();
}
public:
property bool IsEditing {
    bool get ();
}
See Also
CalendarItem Class
CalendarItem Members


IsOnDayTop Property

CalendarItem IsOnDayTop Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if the item goes on the DayTop area of the CalendarDay

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property IsOnDayTop As Boolean
    Get
Public ReadOnly Property IsOnDayTop As Boolean
    Get
public bool IsOnDayTop { get; }
public bool IsOnDayTop { get; }
public:
property bool IsOnDayTop {
    bool get ();
}
public:
property bool IsOnDayTop {
    bool get ();
}
See Also
CalendarItem Class
CalendarItem Members


IsOnView Property

CalendarItem IsOnView Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if the item is currently on view.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property IsOnView As Boolean
    Get
Public ReadOnly Property IsOnView As Boolean
    Get
public bool IsOnView { get; }
public bool IsOnView { get; }
public:
property bool IsOnView {
    bool get ();
}
public:
property bool IsOnView {
    bool get ();
}
Remarks

            The item may not be on view because of scrolling

See Also
CalendarItem Class
CalendarItem Members


IsOnViewDateRange Property

CalendarItem IsOnViewDateRange Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if the item is on the range specified by ViewStart and ViewEnd

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property IsOnViewDateRange As Boolean
    Get
Public ReadOnly Property IsOnViewDateRange As Boolean
    Get
public bool IsOnViewDateRange { get; }
public bool IsOnViewDateRange { get; }
public:
property bool IsOnViewDateRange {
    bool get ();
}
public:
property bool IsOnViewDateRange {
    bool get ();
}
See Also
CalendarItem Class
CalendarItem Members


IsOpenEnd Property

CalendarItem IsOpenEnd Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if the item's EndDate is aftter the ViewEnd date.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property IsOpenEnd As Boolean
    Get
Public ReadOnly Property IsOpenEnd As Boolean
    Get
public bool IsOpenEnd { get; }
public bool IsOpenEnd { get; }
public:
property bool IsOpenEnd {
    bool get ();
}
public:
property bool IsOpenEnd {
    bool get ();
}
See Also
CalendarItem Class
CalendarItem Members


IsOpenStart Property

CalendarItem IsOpenStart Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if the item's StartDate is before the ViewStart date.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property IsOpenStart As Boolean
    Get
Public ReadOnly Property IsOpenStart As Boolean
    Get
public bool IsOpenStart { get; }
public bool IsOpenStart { get; }
public:
property bool IsOpenStart {
    bool get ();
}
public:
property bool IsOpenStart {
    bool get ();
}
See Also
CalendarItem Class
CalendarItem Members


IsResizingEndDate Property

CalendarItem IsResizingEndDate Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if item is being resized by the EndDate

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property IsResizingEndDate As Boolean
    Get
Public ReadOnly Property IsResizingEndDate As Boolean
    Get
public bool IsResizingEndDate { get; }
public bool IsResizingEndDate { get; }
public:
property bool IsResizingEndDate {
    bool get ();
}
public:
property bool IsResizingEndDate {
    bool get ();
}
See Also
CalendarItem Class
CalendarItem Members


IsResizingStartDate Property

CalendarItem IsResizingStartDate Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if item is being resized by the StartDate

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property IsResizingStartDate As Boolean
    Get
Public ReadOnly Property IsResizingStartDate As Boolean
    Get
public bool IsResizingStartDate { get; }
public bool IsResizingStartDate { get; }
public:
property bool IsResizingStartDate {
    bool get ();
}
public:
property bool IsResizingStartDate {
    bool get ();
}
See Also
CalendarItem Class
CalendarItem Members


Locked Property

CalendarItem Locked Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if this item is locked.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property Locked As Boolean
    Get
    Set
Public Property Locked As Boolean
    Get
    Set
public bool Locked { get; set; }
public bool Locked { get; set; }
public:
property bool Locked {
    bool get ();
    void set (bool value);
}
public:
property bool Locked {
    bool get ();
    void set (bool value);
}
Remarks

            When an item is locked, the user can't drag it or change it's text

See Also
CalendarItem Class
CalendarItem Members


MinuteEndTop Property

CalendarItem MinuteEndTop Property A Sandcastle Documented Class Library
Send Feedback
Gets the top correspoinding to the ending minute

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property MinuteEndTop As Integer
    Get
Public ReadOnly Property MinuteEndTop As Integer
    Get
public int MinuteEndTop { get; }
public int MinuteEndTop { get; }
public:
property int MinuteEndTop {
    int get ();
}
public:
property int MinuteEndTop {
    int get ();
}
See Also
CalendarItem Class
CalendarItem Members


MinuteStartTop Property

CalendarItem MinuteStartTop Property A Sandcastle Documented Class Library
Send Feedback
Gets the top corresponding to the starting minute

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property MinuteStartTop As Integer
    Get
Public ReadOnly Property MinuteStartTop As Integer
    Get
public int MinuteStartTop { get; }
public int MinuteStartTop { get; }
public:
property int MinuteStartTop {
    int get ();
}
public:
property int MinuteStartTop {
    int get ();
}
See Also
CalendarItem Class
CalendarItem Members


Pattern Property

CalendarItem Pattern Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the pattern style to use in the background of item.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property Pattern As HatchStyle
    Get
    Set
Public Property Pattern As HatchStyle
    Get
    Set
public HatchStyle Pattern { get; set; }
public HatchStyle Pattern { get; set; }
public:
property HatchStyle Pattern {
    HatchStyle get ();
    void set (HatchStyle value);
}
public:
property HatchStyle Pattern {
    HatchStyle get ();
    void set (HatchStyle value);
}
See Also
CalendarItem Class
CalendarItem Members


PatternColor Property

CalendarItem PatternColor Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the pattern's color

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property PatternColor As Color
    Get
    Set
Public Property PatternColor As Color
    Get
    Set
public Color PatternColor { get; set; }
public Color PatternColor { get; set; }
public:
property Color PatternColor {
    Color get ();
    void set (Color value);
}
public:
property Color PatternColor {
    Color get ();
    void set (Color value);
}
See Also
CalendarItem Class
CalendarItem Members


ShowEndTime Property

CalendarItem ShowEndTime Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if the item should show the time of the EndDate

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable ReadOnly Property ShowEndTime As Boolean
    Get
Public Overridable ReadOnly Property ShowEndTime As Boolean
    Get
public virtual bool ShowEndTime { get; }
public virtual bool ShowEndTime { get; }
public:
virtual property bool ShowEndTime {
    bool get ();
}
public:
virtual property bool ShowEndTime {
    bool get ();
}
See Also
CalendarItem Class
CalendarItem Members


ShowStartTime Property

CalendarItem ShowStartTime Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if the item should show the time of the StartDate

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property ShowStartTime As Boolean
    Get
Public ReadOnly Property ShowStartTime As Boolean
    Get
public bool ShowStartTime { get; }
public bool ShowStartTime { get; }
public:
property bool ShowStartTime {
    bool get ();
}
public:
property bool ShowStartTime {
    bool get ();
}
See Also
CalendarItem Class
CalendarItem Members


StartDate Property

CalendarItem StartDate Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the start time of the item

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Property StartDate As DateTime
    Get
    Set
Public Overridable Property StartDate As DateTime
    Get
    Set
public virtual DateTime StartDate { get; set; }
public virtual DateTime StartDate { get; set; }
public:
virtual property DateTime StartDate {
    DateTime get ();
    void set (DateTime value);
}
public:
virtual property DateTime StartDate {
    DateTime get ();
    void set (DateTime value);
}
See Also
CalendarItem Class
CalendarItem Members


StartDateText Property

CalendarItem StartDateText Property A Sandcastle Documented Class Library
Send Feedback
Gets the text of the start date

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable ReadOnly Property StartDateText As String
    Get
Public Overridable ReadOnly Property StartDateText As String
    Get
public virtual string StartDateText { get; }
public virtual string StartDateText { get; }
public:
virtual property String^ StartDateText {
    String^ get ();
}
public:
virtual property String^ StartDateText {
    String^ get ();
}
See Also
CalendarItem Class
CalendarItem Members


Tag Property

CalendarItem Tag Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets a tag object for the item

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property Tag As Object
    Get
    Set
Public Property Tag As Object
    Get
    Set
public Object Tag { get; set; }
public Object Tag { get; set; }
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}
See Also
CalendarItem Class
CalendarItem Members


Text Property

CalendarItem Text Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the text of the item

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Property Text As String
    Get
    Set
Public Overridable Property Text As String
    Get
    Set
public virtual string Text { get; set; }
public virtual string Text { get; set; }
public:
virtual property String^ Text {
    String^ get ();
    void set (String^ value);
}
public:
virtual property String^ Text {
    String^ get ();
    void set (String^ value);
}
See Also
CalendarItem Class
CalendarItem Members


CalendarItemCancelEventArgs Class

CalendarItemCancelEventArgs Class A Sandcastle Documented Class Library
Send Feedback
Event arguments for calendar cancel item event
Inheritance Hierarchy
Online System Object
Online System EventArgs
Online System.ComponentModel CancelEventArgs
WindowsFormsCalendar CalendarItemCancelEventArgs

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class CalendarItemCancelEventArgs _
    Inherits CancelEventArgs
Public Class CalendarItemCancelEventArgs _
    Inherits CancelEventArgs
public class CalendarItemCancelEventArgs : CancelEventArgs
public class CalendarItemCancelEventArgs : CancelEventArgs
public ref class CalendarItemCancelEventArgs : public CancelEventArgs
public ref class CalendarItemCancelEventArgs : public CancelEventArgs
See Also
CalendarItemCancelEventArgs Members


CalendarItemCancelEventArgs Members

CalendarItemCancelEventArgs Members A Sandcastle Documented Class Library
Send Feedback

The CalendarItemCancelEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | CalendarItemCancelEventArgs | Creates a new CalendarItemEventArgs
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Online Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from Online CancelEventArgs.)
Public property | Item | Gets the CalendarItem related to the event
Back to Top
See Also
CalendarItemCancelEventArgs Class


CalendarItemCancelEventArgs Constructor

CalendarItemCancelEventArgs Constructor A Sandcastle Documented Class Library
Send Feedback
Creates a new CalendarItemEventArgs

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    item As CalendarItem _
)
Public Sub New ( _
    item As CalendarItem _
)
public CalendarItemCancelEventArgs(
    CalendarItem item
)
public CalendarItemCancelEventArgs(
    CalendarItem item
)
public:
CalendarItemCancelEventArgs(
    CalendarItem^ item
)
public:
CalendarItemCancelEventArgs(
    CalendarItem^ item
)
Parameters
item
Type: WindowsFormsCalendar CalendarItem
Related Item
See Also
CalendarItemCancelEventArgs Class
CalendarItemCancelEventArgs Members


CalendarItemCancelEventArgs Methods

CalendarItemCancelEventArgs Methods A Sandcastle Documented Class Library
Send Feedback
The CalendarItemCancelEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CalendarItemCancelEventArgs Class


CalendarItemCancelEventArgs Properties

CalendarItemCancelEventArgs Properties A Sandcastle Documented Class Library
Send Feedback
The CalendarItemCancelEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Online Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from Online CancelEventArgs.)
Public property | Item | Gets the CalendarItem related to the event
Back to Top
See Also
CalendarItemCancelEventArgs Class


Item Property

CalendarItemCancelEventArgs Item Property A Sandcastle Documented Class Library
Send Feedback
Gets the CalendarItem related to the event

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Item As CalendarItem
    Get
Public ReadOnly Property Item As CalendarItem
    Get
public CalendarItem Item { get; }
public CalendarItem Item { get; }
public:
property CalendarItem^ Item {
    CalendarItem^ get ();
}
public:
property CalendarItem^ Item {
    CalendarItem^ get ();
}
See Also
CalendarItemCancelEventArgs Class
CalendarItemCancelEventArgs Members


CalendarItemCollection Class

CalendarItemCollection Class A Sandcastle Documented Class Library
Send Feedback
A collection of calendar items
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic List CalendarItem
WindowsFormsCalendar CalendarItemCollection

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class CalendarItemCollection _
    Inherits List(Of CalendarItem)
Public Class CalendarItemCollection _
    Inherits List(Of CalendarItem)
public class CalendarItemCollection : List<CalendarItem>
public class CalendarItemCollection : List<CalendarItem>
public ref class CalendarItemCollection : public List<CalendarItem^>
public ref class CalendarItemCollection : public List<CalendarItem^>
See Also
CalendarItemCollection Members


CalendarItemCollection Members

CalendarItemCollection Members A Sandcastle Documented Class Library
Send Feedback

The CalendarItemCollection type exposes the following members.
Methods
 | Name | Description
Public method | Add | Adds an item to the end of the list
Public method | AddRange | Adds the items of the specified collection to the end of the list.
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List CalendarItem .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List CalendarItem .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List CalendarItem .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List CalendarItem .)
Public method | Clear | Removes all elements from the collection.
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List CalendarItem .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List CalendarItem .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List CalendarItem .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List CalendarItem .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List CalendarItem .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List CalendarItem .)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List CalendarItem .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List CalendarItem .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List CalendarItem .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List CalendarItem .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List CalendarItem .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List CalendarItem .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List CalendarItem .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List CalendarItem .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List CalendarItem .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List CalendarItem .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List CalendarItem .)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List CalendarItem .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List CalendarItem .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List CalendarItem .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List CalendarItem .)
Public method | Insert | Inserts an item into the collection at the specified index.
Public method | InsertRange | Inserts the items of a collection into this collection at the specified index.
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List CalendarItem .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List CalendarItem .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List CalendarItem .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove | Removes the first occurrence of a specific object from the collection.
Public method | RemoveAll | Removes the all the items that match the conditions defined by the specified predicate.
Public method | RemoveAt | Removes the item at the specified index of the collection
Public method | RemoveRange | Removes a range of elements from the collection
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List CalendarItem .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List CalendarItem .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List CalendarItem .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List CalendarItem .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List CalendarItem .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List CalendarItem .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List CalendarItem .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List CalendarItem .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List CalendarItem .)
Back to Top
Properties
 | Name | Description
Public property | Calendar | Gets the calendar.
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List CalendarItem .)
Public property | Online Count | Gets the number of elements actually contained in the Online List T . (Inherited from Online List CalendarItem .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List CalendarItem .)
Back to Top
See Also
CalendarItemCollection Class


CalendarItemCollection Methods

CalendarItemCollection Methods A Sandcastle Documented Class Library
Send Feedback
The CalendarItemCollection type exposes the following members.
Methods
 | Name | Description
Public method | Add | Adds an item to the end of the list
Public method | AddRange | Adds the items of the specified collection to the end of the list.
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List CalendarItem .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List CalendarItem .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List CalendarItem .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List CalendarItem .)
Public method | Clear | Removes all elements from the collection.
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List CalendarItem .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List CalendarItem .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List CalendarItem .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List CalendarItem .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List CalendarItem .)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List CalendarItem .)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List CalendarItem .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List CalendarItem .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List CalendarItem .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List CalendarItem .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List CalendarItem .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List CalendarItem .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List CalendarItem .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List CalendarItem .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List CalendarItem .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List CalendarItem .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List CalendarItem .)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List CalendarItem .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List CalendarItem .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List CalendarItem .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List CalendarItem .)
Public method | Insert | Inserts an item into the collection at the specified index.
Public method | InsertRange | Inserts the items of a collection into this collection at the specified index.
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List CalendarItem .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List CalendarItem .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List CalendarItem .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove | Removes the first occurrence of a specific object from the collection.
Public method | RemoveAll | Removes the all the items that match the conditions defined by the specified predicate.
Public method | RemoveAt | Removes the item at the specified index of the collection
Public method | RemoveRange | Removes a range of elements from the collection
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List CalendarItem .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List CalendarItem .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List CalendarItem .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List CalendarItem .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List CalendarItem .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List CalendarItem .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List CalendarItem .)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List CalendarItem .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List CalendarItem .)
Back to Top
See Also
CalendarItemCollection Class


Add Method

CalendarItemCollection Add Method A Sandcastle Documented Class Library
Send Feedback
Adds an item to the end of the list

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub Add ( _
    item As CalendarItem _
)
Public Sub Add ( _
    item As CalendarItem _
)
public void Add(
    CalendarItem item
)
public void Add(
    CalendarItem item
)
public:
void Add(
    CalendarItem^ item
)
public:
void Add(
    CalendarItem^ item
)
Parameters
item
Type: WindowsFormsCalendar CalendarItem
The object to be added to the end of the collection. The value can be null for reference types.
See Also
CalendarItemCollection Class
CalendarItemCollection Members


AddRange Method

CalendarItemCollection AddRange Method A Sandcastle Documented Class Library
Send Feedback
Adds the items of the specified collection to the end of the list.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub AddRange ( _
    items As IEnumerable(Of CalendarItem) _
)
Public Sub AddRange ( _
    items As IEnumerable(Of CalendarItem) _
)
public void AddRange(
    IEnumerable<CalendarItem> items
)
public void AddRange(
    IEnumerable<CalendarItem> items
)
public:
void AddRange(
    IEnumerable<CalendarItem^>^ items
)
public:
void AddRange(
    IEnumerable<CalendarItem^>^ items
)
Parameters
items
Type:   Online System.Collections.Generic IEnumerable  CalendarItem
The items whose elements should be added to the end of the collection. The collection itself cannont be null, but it can contain elements that are null.
See Also
CalendarItemCollection Class
CalendarItemCollection Members


Clear Method

CalendarItemCollection Clear Method A Sandcastle Documented Class Library
Send Feedback
Removes all elements from the collection.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub Clear
Public Sub Clear
public void Clear()
public void Clear()
public:
void Clear()
public:
void Clear()
See Also
CalendarItemCollection Class
CalendarItemCollection Members


Insert Method

CalendarItemCollection Insert Method A Sandcastle Documented Class Library
Send Feedback
Inserts an item into the collection at the specified index.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub Insert ( _
    index As Integer, _
    item As CalendarItem _
)
Public Sub Insert ( _
    index As Integer, _
    item As CalendarItem _
)
public void Insert(
    int index,
    CalendarItem item
)
public void Insert(
    int index,
    CalendarItem item
)
public:
void Insert(
    int index,
    CalendarItem^ item
)
public:
void Insert(
    int index,
    CalendarItem^ item
)
Parameters
index
Type:   Online System Int32
The zero-based index at which item should be inserted.
item
Type: WindowsFormsCalendar CalendarItem
The object to insert. The value can be null for reference types.
See Also
CalendarItemCollection Class
CalendarItemCollection Members


InsertRange Method

CalendarItemCollection InsertRange Method A Sandcastle Documented Class Library
Send Feedback
Inserts the items of a collection into this collection at the specified index.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub InsertRange ( _
    index As Integer, _
    items As IEnumerable(Of CalendarItem) _
)
Public Sub InsertRange ( _
    index As Integer, _
    items As IEnumerable(Of CalendarItem) _
)
public void InsertRange(
    int index,
    IEnumerable<CalendarItem> items
)
public void InsertRange(
    int index,
    IEnumerable<CalendarItem> items
)
public:
void InsertRange(
    int index,
    IEnumerable<CalendarItem^>^ items
)
public:
void InsertRange(
    int index,
    IEnumerable<CalendarItem^>^ items
)
Parameters
index
Type:   Online System Int32
The zero-based index at which the new elements should be inserted.
items
Type:   Online System.Collections.Generic IEnumerable  CalendarItem
[Missing <param name="items"/> documentation for "M:WindowsFormsCalendar.CalendarItemCollection.InsertRange(System.Int32,System.Collections.Generic.IEnumerable{WindowsFormsCalendar.CalendarItem})"]
See Also
CalendarItemCollection Class
CalendarItemCollection Members


Remove Method

CalendarItemCollection Remove Method A Sandcastle Documented Class Library
Send Feedback
Removes the first occurrence of a specific object from the collection.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Function Remove ( _
    item As CalendarItem _
) As Boolean
Public Function Remove ( _
    item As CalendarItem _
) As Boolean
public bool Remove(
    CalendarItem item
)
public bool Remove(
    CalendarItem item
)
public:
bool Remove(
    CalendarItem^ item
)
public:
bool Remove(
    CalendarItem^ item
)
Parameters
item
Type: WindowsFormsCalendar CalendarItem
The item to remove from the collection. The value can be null for reference types.
Return Value
true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the collection.
See Also
CalendarItemCollection Class
CalendarItemCollection Members


RemoveAll Method

CalendarItemCollection RemoveAll Method A Sandcastle Documented Class Library
Send Feedback
Removes the all the items that match the conditions defined by the specified predicate.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Function RemoveAll ( _
    match As Predicate(Of CalendarItem) _
) As Integer
Public Function RemoveAll ( _
    match As Predicate(Of CalendarItem) _
) As Integer
public int RemoveAll(
    Predicate<CalendarItem> match
)
public int RemoveAll(
    Predicate<CalendarItem> match
)
public:
int RemoveAll(
    Predicate<CalendarItem^>^ match
)
public:
int RemoveAll(
    Predicate<CalendarItem^>^ match
)
Parameters
match
Type:   Online System Predicate  CalendarItem
The Predicate delegate that defines the conditions of the items to remove.
Return Value
The number of items removed from the collection.
See Also
CalendarItemCollection Class
CalendarItemCollection Members


RemoveAt Method

CalendarItemCollection RemoveAt Method A Sandcastle Documented Class Library
Send Feedback
Removes the item at the specified index of the collection

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub RemoveAt ( _
    index As Integer _
)
Public Sub RemoveAt ( _
    index As Integer _
)
public void RemoveAt(
    int index
)
public void RemoveAt(
    int index
)
public:
void RemoveAt(
    int index
)
public:
void RemoveAt(
    int index
)
Parameters
index
Type:   Online System Int32
The zero-based index of the item to remove.
Exceptions
Exception | Condition
Online System ArgumentOutOfRangeException | index is less than 0. -or- index is equal to or greater than Online Count.
See Also
CalendarItemCollection Class
CalendarItemCollection Members


RemoveRange Method

CalendarItemCollection RemoveRange Method A Sandcastle Documented Class Library
Send Feedback
Removes a range of elements from the collection

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub RemoveRange ( _
    index As Integer, _
    count As Integer _
)
Public Sub RemoveRange ( _
    index As Integer, _
    count As Integer _
)
public void RemoveRange(
    int index,
    int count
)
public void RemoveRange(
    int index,
    int count
)
public:
void RemoveRange(
    int index,
    int count
)
public:
void RemoveRange(
    int index,
    int count
)
Parameters
index
Type:   Online System Int32
The zero-based starting index of the range of items to remove.
count
Type:   Online System Int32
The number of items to remove
See Also
CalendarItemCollection Class
CalendarItemCollection Members


CalendarItemCollection Properties

CalendarItemCollection Properties A Sandcastle Documented Class Library
Send Feedback
The CalendarItemCollection type exposes the following members.
Properties
 | Name | Description
Public property | Calendar | Gets the calendar.
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List CalendarItem .)
Public property | Online Count | Gets the number of elements actually contained in the Online List T . (Inherited from Online List CalendarItem .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List CalendarItem .)
Back to Top
See Also
CalendarItemCollection Class


Calendar Property

CalendarItemCollection Calendar Property A Sandcastle Documented Class Library
Send Feedback
Gets the calendar.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Calendar As Calendar
    Get
Public ReadOnly Property Calendar As Calendar
    Get
public Calendar Calendar { get; }
public Calendar Calendar { get; }
public:
property Calendar^ Calendar {
    Calendar^ get ();
}
public:
property Calendar^ Calendar {
    Calendar^ get ();
}
See Also
CalendarItemCollection Class
CalendarItemCollection Members


CalendarItemEventArgs Class

CalendarItemEventArgs Class A Sandcastle Documented Class Library
Send Feedback
Event arguments for the calendar item events.
Inheritance Hierarchy
Online System Object
Online System EventArgs
WindowsFormsCalendar CalendarItemEventArgs

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class CalendarItemEventArgs _
    Inherits EventArgs
Public Class CalendarItemEventArgs _
    Inherits EventArgs
public class CalendarItemEventArgs : EventArgs
public class CalendarItemEventArgs : EventArgs
public ref class CalendarItemEventArgs : public EventArgs
public ref class CalendarItemEventArgs : public EventArgs
See Also
CalendarItemEventArgs Members


CalendarItemEventArgs Members

CalendarItemEventArgs Members A Sandcastle Documented Class Library
Send Feedback

The CalendarItemEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | CalendarItemEventArgs | Creates a new CalendarItemEventArgs
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Item | Gets the CalendarItem related to the event
Back to Top
See Also
CalendarItemEventArgs Class


CalendarItemEventArgs Constructor

CalendarItemEventArgs Constructor A Sandcastle Documented Class Library
Send Feedback
Creates a new CalendarItemEventArgs

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    item As CalendarItem _
)
Public Sub New ( _
    item As CalendarItem _
)
public CalendarItemEventArgs(
    CalendarItem item
)
public CalendarItemEventArgs(
    CalendarItem item
)
public:
CalendarItemEventArgs(
    CalendarItem^ item
)
public:
CalendarItemEventArgs(
    CalendarItem^ item
)
Parameters
item
Type: WindowsFormsCalendar CalendarItem
Related Item
See Also
CalendarItemEventArgs Class
CalendarItemEventArgs Members


CalendarItemEventArgs Methods

CalendarItemEventArgs Methods A Sandcastle Documented Class Library
Send Feedback
The CalendarItemEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CalendarItemEventArgs Class


CalendarItemEventArgs Properties

CalendarItemEventArgs Properties A Sandcastle Documented Class Library
Send Feedback
The CalendarItemEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Item | Gets the CalendarItem related to the event
Back to Top
See Also
CalendarItemEventArgs Class


Item Property

CalendarItemEventArgs Item Property A Sandcastle Documented Class Library
Send Feedback
Gets the CalendarItem related to the event

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Item As CalendarItem
    Get
Public ReadOnly Property Item As CalendarItem
    Get
public CalendarItem Item { get; }
public CalendarItem Item { get; }
public:
property CalendarItem^ Item {
    CalendarItem^ get ();
}
public:
property CalendarItem^ Item {
    CalendarItem^ get ();
}
See Also
CalendarItemEventArgs Class
CalendarItemEventArgs Members


CalendarItemImageAlign Enumeration

CalendarItemImageAlign Enumeration A Sandcastle Documented Class Library
Send Feedback
Possible alignment for CalendarItem images

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Enumeration CalendarItemImageAlign
Public Enumeration CalendarItemImageAlign
public enum CalendarItemImageAlign
public enum CalendarItemImageAlign
public enum class CalendarItemImageAlign
public enum class CalendarItemImageAlign
Members
Member name | Value | Description
North | 0 | Image is drawn at north of text
South | 1 | Image is drawn at south of text
East | 2 | Image is drawn at east of text
West | 3 | Image is drawn at west of text
See Also


CalendarLoadEventArgs Class

CalendarLoadEventArgs Class A Sandcastle Documented Class Library
Send Feedback
Holds data of a Calendar Loading Items of certain date range
Inheritance Hierarchy
Online System Object
Online System EventArgs
WindowsFormsCalendar CalendarLoadEventArgs

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class CalendarLoadEventArgs _
    Inherits EventArgs
Public Class CalendarLoadEventArgs _
    Inherits EventArgs
public class CalendarLoadEventArgs : EventArgs
public class CalendarLoadEventArgs : EventArgs
public ref class CalendarLoadEventArgs : public EventArgs
public ref class CalendarLoadEventArgs : public EventArgs
See Also
CalendarLoadEventArgs Members


CalendarLoadEventArgs Members

CalendarLoadEventArgs Members A Sandcastle Documented Class Library
Send Feedback

The CalendarLoadEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | CalendarLoadEventArgs | Initializes a new instance of the CalendarLoadEventArgs class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Calendar | Gets the calendar that originated the event
Public property | DateEnd | Gets the end date of the load
Public property | DateStart | Gets the start date of the load
Back to Top
See Also
CalendarLoadEventArgs Class


CalendarLoadEventArgs Constructor

CalendarLoadEventArgs Constructor A Sandcastle Documented Class Library
Send Feedback
Initializes a new instance of the CalendarLoadEventArgs class.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    calendar As Calendar, _
    dateStart As DateTime, _
    dateEnd As DateTime _
)
Public Sub New ( _
    calendar As Calendar, _
    dateStart As DateTime, _
    dateEnd As DateTime _
)
public CalendarLoadEventArgs(
    Calendar calendar,
    DateTime dateStart,
    DateTime dateEnd
)
public CalendarLoadEventArgs(
    Calendar calendar,
    DateTime dateStart,
    DateTime dateEnd
)
public:
CalendarLoadEventArgs(
    Calendar^ calendar,
    DateTime dateStart,
    DateTime dateEnd
)
public:
CalendarLoadEventArgs(
    Calendar^ calendar,
    DateTime dateStart,
    DateTime dateEnd
)
Parameters
calendar
Type: WindowsFormsCalendar Calendar
The calendar.
dateStart
Type:   Online System DateTime
The date start.
dateEnd
Type:   Online System DateTime
The date end.
See Also
CalendarLoadEventArgs Class
CalendarLoadEventArgs Members


CalendarLoadEventArgs Methods

CalendarLoadEventArgs Methods A Sandcastle Documented Class Library
Send Feedback
The CalendarLoadEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CalendarLoadEventArgs Class


CalendarLoadEventArgs Properties

CalendarLoadEventArgs Properties A Sandcastle Documented Class Library
Send Feedback
The CalendarLoadEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Calendar | Gets the calendar that originated the event
Public property | DateEnd | Gets the end date of the load
Public property | DateStart | Gets the start date of the load
Back to Top
See Also
CalendarLoadEventArgs Class


Calendar Property

CalendarLoadEventArgs Calendar Property A Sandcastle Documented Class Library
Send Feedback
Gets the calendar that originated the event

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Calendar As Calendar
    Get
Public ReadOnly Property Calendar As Calendar
    Get
public Calendar Calendar { get; }
public Calendar Calendar { get; }
public:
property Calendar^ Calendar {
    Calendar^ get ();
}
public:
property Calendar^ Calendar {
    Calendar^ get ();
}
See Also
CalendarLoadEventArgs Class
CalendarLoadEventArgs Members


DateEnd Property

CalendarLoadEventArgs DateEnd Property A Sandcastle Documented Class Library
Send Feedback
Gets the end date of the load

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property DateEnd As DateTime
    Get
Public ReadOnly Property DateEnd As DateTime
    Get
public DateTime DateEnd { get; }
public DateTime DateEnd { get; }
public:
property DateTime DateEnd {
    DateTime get ();
}
public:
property DateTime DateEnd {
    DateTime get ();
}
See Also
CalendarLoadEventArgs Class
CalendarLoadEventArgs Members


DateStart Property

CalendarLoadEventArgs DateStart Property A Sandcastle Documented Class Library
Send Feedback
Gets the start date of the load

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property DateStart As DateTime
    Get
    Set
Public Property DateStart As DateTime
    Get
    Set
public DateTime DateStart { get; set; }
public DateTime DateStart { get; set; }
public:
property DateTime DateStart {
    DateTime get ();
    void set (DateTime value);
}
public:
property DateTime DateStart {
    DateTime get ();
    void set (DateTime value);
}
See Also
CalendarLoadEventArgs Class
CalendarLoadEventArgs Members


CalendarProfessionalRenderer Class

CalendarProfessionalRenderer Class A Sandcastle Documented Class Library
Send Feedback
Renders the professional calendar control
Inheritance Hierarchy
Online System Object
WindowsFormsCalendar CalendarRenderer
WindowsFormsCalendar CalendarSystemRenderer
WindowsFormsCalendar CalendarProfessionalRenderer

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class CalendarProfessionalRenderer _
    Inherits CalendarSystemRenderer
Public Class CalendarProfessionalRenderer _
    Inherits CalendarSystemRenderer
public class CalendarProfessionalRenderer : CalendarSystemRenderer
public class CalendarProfessionalRenderer : CalendarSystemRenderer
public ref class CalendarProfessionalRenderer : public CalendarSystemRenderer
public ref class CalendarProfessionalRenderer : public CalendarSystemRenderer
See Also
CalendarProfessionalRenderer Members


CalendarProfessionalRenderer Members

CalendarProfessionalRenderer Members A Sandcastle Documented Class Library
Send Feedback

The CalendarProfessionalRenderer type exposes the following members.
Constructors
 | Name | Description
Public method | CalendarProfessionalRenderer | Initializes a new instance of the CalendarProfessionalRenderer class.
Back to Top
Methods
 | Name | Description
Protected method | DrawStandarBoxText | Draws text using the information of the CalendarRendererBoxEventArgs (Inherited from CalendarRenderer.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetTimeY | Gets the exact Y coordinate that corresponds to the specified time. This only works when in Expanded mode. (Inherited from CalendarRenderer.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | GlossyRect | Glossies the rect.
 | GradientRect | Gradients the rect.
Public method | ItemBorder | Draws the specified rectangle with item border roundnesss (Inherited from CalendarRenderer.)
Public method | ItemFill | Fills the specified rectangle with item border roundness (Inherited from CalendarRenderer.)
Public method | ItemPattern | Items the pattern. (Inherited from CalendarRenderer.)
Public method | ItemRectangle | Creates a rectangle with item roundess (Inherited from CalendarRenderer.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OnDrawBackground | Paints the background of the calendar (Inherited from CalendarSystemRenderer.)
Public method | OnDrawDay | Paints the specified day on the calendar (Inherited from CalendarSystemRenderer.)
Public method | OnDrawDayBorder | Paints the border of the specified day (Inherited from CalendarSystemRenderer.)
Public method | OnDrawDayHeaderBackground | Raises the [E:DrawDayHeaderBackground] event. (Overrides CalendarSystemRenderer OnDrawDayHeaderBackground(CalendarRendererDayEventArgs).)
Public method | OnDrawDayHeaderText | Paints the header of the specified day (Inherited from CalendarRenderer.)
Public method | OnDrawDayNameHeader | Raises the [E:DrawDayNameHeader] event. (Inherited from CalendarSystemRenderer.)
Public method | OnDrawDayNameHeaders | Raises the [E:DrawDayNameHeaders] event. (Inherited from CalendarRenderer.)
Public method | OnDrawDayOverflowEnd | Draws the overflow to end of specified day (Inherited from CalendarSystemRenderer.)
Public method | OnDrawDayOverflowStart | Draws the overflow to start of specified day (Inherited from CalendarRenderer.)
Public method | OnDrawDays | Paints the days on the current calendar view (Inherited from CalendarRenderer.)
Public method | OnDrawDayTimeUnit | Draws a time unit of a day (Inherited from CalendarSystemRenderer.)
Public method | OnDrawDayTimeUnits | Raises the [E:DrawDayTimeUnits] event. (Inherited from CalendarRenderer.)
Public method | OnDrawDayTop | Draws the all day items area (Inherited from CalendarSystemRenderer.)
Public method | OnDrawItem | Draws an item of the calendar (Inherited from CalendarRenderer.)
Public method | OnDrawItemBackground | Draws the background of the specified item (Inherited from CalendarSystemRenderer.)
Public method | OnDrawItemBorder | Raises the [E:DrawItemBorder] event. (Overrides CalendarSystemRenderer OnDrawItemBorder(CalendarRendererItemBoundsEventArgs).)
Public method | OnDrawItemContent | Draws the strings of an item. Strings inlude StartTime, EndTime and Text (Inherited from CalendarRenderer.)
Public method | OnDrawItemEndTime | Draws the end time of the item if applicable (Inherited from CalendarSystemRenderer.)
Public method | OnDrawItemImage | Draws the image of an item (Inherited from CalendarRenderer.)
Public method | OnDrawItemPattern | Raises the [E:DrawItemPattern] event. (Inherited from CalendarRenderer.)
Public method | OnDrawItems | Draws the items of the calendar (Inherited from CalendarRenderer.)
Public method | OnDrawItemShadow | Draws the shadow of the specified item (Inherited from CalendarSystemRenderer.)
Public method | OnDrawItemStartTime | Draws the starttime of the item if applicable (Inherited from CalendarSystemRenderer.)
Public method | OnDrawItemText | Draws the text of an item (Inherited from CalendarSystemRenderer.)
Public method | OnDrawOverflows | Draws the overflows of days (Inherited from CalendarRenderer.)
Public method | OnDrawTimeScale | Paints the timescale of the calendar (Inherited from CalendarSystemRenderer.)
Public method | OnDrawTimeScaleHour | Paints an hour of a timescale unit (Inherited from CalendarSystemRenderer.)
Public method | OnDrawTimeScaleMinutes | Paints minutes of a timescale unit (Inherited from CalendarSystemRenderer.)
Public method | OnDrawWeekHeader | Raises the [E:DrawWeekHeader] event. (Inherited from CalendarSystemRenderer.)
Public method | OnDrawWeekHeaders | Raises the [E:DrawWeekHeaders] event. (Inherited from CalendarSystemRenderer.)
Public method | OnInitialize | Initializes the Calendar (Overrides CalendarRenderer OnInitialize(CalendarRendererEventArgs).)
Public method | PerformItemsLayout | Updates the bounds of CalendarItems (Inherited from CalendarRenderer.)
Public method | PerformLayout | Peform layout of elements and items of the calendar (Inherited from CalendarRenderer.)
Public method | PerformLayout(Boolean) | Updates the bounds of graphical elements. Optionally calls PerformItemsLayout to update bounds of items. (Inherited from CalendarRenderer.)
Protected method | SetDayHeaderHeight | Sets the value of the DayHeaderHeight property (Inherited from CalendarRenderer.)
Protected method | SetDayNameHeadersHeight | Sets the value of the DayNameHeadersHeight property (Inherited from CalendarRenderer.)
Protected method | SetDayTopHeight | Sets the value of the DayTopHeight property (Inherited from CalendarRenderer.)
Protected method | SetTimeScaleUnitHeight | Sets the value of the TimeScaleUnitHeight property (Inherited from CalendarRenderer.)
Protected method | SetTimeScaleWidth | Sets the value of the TimeScaleWidth property (Inherited from CalendarRenderer.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Fields
 | Name | Description
Public field | HeaderA | HeaderA
Public field | HeaderB | HeaderB
Public field | HeaderC | HeaderC
Public field | HeaderD | HeaderD
Public field | TodayA | TodayA
Public field | TodayB | TodayB
Public field | TodayC | TodayC
Public field | TodayD | TodayD
Back to Top
Properties
 | Name | Description
Public property | Calendar | Gets the Calendar this renderer belongs to (Inherited from CalendarRenderer.)
Public property | ColorTable | Gets or sets the CalendarColorTable for this renderer (Inherited from CalendarSystemRenderer.)
Public property | DayHeaderHeight | Gets the height of the header of days (Inherited from CalendarRenderer.)
Public property | DayNameHeaderColumns | Gets the bounds for day name headers (Inherited from CalendarRenderer.)
Public property | DayNameHeadersHeight | Gets the height of the day name headers (Inherited from CalendarRenderer.)
Public property | DayNameHeadersVisible | Gets a value indicating if the day names headers are visible (e.g. Monday, Tuesday, Wednesday ...) (Inherited from CalendarRenderer.)
Public property | DayTopHeight | Gets the current height of the all day items area (Inherited from CalendarRenderer.)
Public property | DayTopItemsPadding | Gets or sets the padding of the items that goes on the top part of the days, when in Expanded (Inherited from CalendarRenderer.)
Public property | DayTopMinHeight | Gets the minimum height for day tops (Inherited from CalendarRenderer.)
Public property | ItemInvalidateMargin | Gets or sets the extra margin for invalidating and redrawing items (Inherited from CalendarRenderer.)
Public property | ItemRoundness | Gets or sets the roundness of the item (Inherited from CalendarRenderer.)
Public property | ItemShadowPadding | Gets or sets the amount of pixels that the item's shadow is dropped (Inherited from CalendarRenderer.)
Public property | ItemsPadding | Gets or sets the padding of items on expanded mode (Inherited from CalendarRenderer.)
Public property | ItemTextMargin | Gets the margin of the text in the items (Inherited from CalendarRenderer.)
Public property | SelectedItemBorder | Gets or sets the size of the border of selected items (Inherited from CalendarSystemRenderer.)
Public property | StandardItemHeight | Gets the height of items on day tops (Inherited from CalendarRenderer.)
Public property | TimeScaleBounds | Gets or sets the bounds of the timescale (Inherited from CalendarRenderer.)
Public property | TimeScaleUnitHeight | Gets the height of the time scale unit. (Inherited from CalendarRenderer.)
Public property | TimeScaleVisible | Gets a value indicating whether [time scale visible]. (Inherited from CalendarRenderer.)
Public property | TimeScaleWidth | Gets the width of the timescale (Inherited from CalendarRenderer.)
Public property | WeekHeaderWidth | Gets the width of the week header. (Inherited from CalendarRenderer.)
Back to Top
See Also
CalendarProfessionalRenderer Class


CalendarProfessionalRenderer Constructor

CalendarProfessionalRenderer Constructor A Sandcastle Documented Class Library
Send Feedback
Initializes a new instance of the CalendarProfessionalRenderer class.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    c As Calendar _
)
Public Sub New ( _
    c As Calendar _
)
public CalendarProfessionalRenderer(
    Calendar c
)
public CalendarProfessionalRenderer(
    Calendar c
)
public:
CalendarProfessionalRenderer(
    Calendar^ c
)
public:
CalendarProfessionalRenderer(
    Calendar^ c
)
Parameters
c
Type: WindowsFormsCalendar Calendar
The c.
See Also
CalendarProfessionalRenderer Class
CalendarProfessionalRenderer Members


CalendarProfessionalRenderer Fields

CalendarProfessionalRenderer Fields A Sandcastle Documented Class Library
Send Feedback
The CalendarProfessionalRenderer type exposes the following members.
Fields
 | Name | Description
Public field | HeaderA | HeaderA
Public field | HeaderB | HeaderB
Public field | HeaderC | HeaderC
Public field | HeaderD | HeaderD
Public field | TodayA | TodayA
Public field | TodayB | TodayB
Public field | TodayC | TodayC
Public field | TodayD | TodayD
Back to Top
See Also
CalendarProfessionalRenderer Class


HeaderA Field

CalendarProfessionalRenderer HeaderA Field A Sandcastle Documented Class Library
Send Feedback
HeaderA

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public HeaderA As Color
Public HeaderA As Color
public Color HeaderA
public Color HeaderA
public:
Color HeaderA
public:
Color HeaderA
See Also
CalendarProfessionalRenderer Class
CalendarProfessionalRenderer Members


HeaderB Field

CalendarProfessionalRenderer HeaderB Field A Sandcastle Documented Class Library
Send Feedback
HeaderB

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public HeaderB As Color
Public HeaderB As Color
public Color HeaderB
public Color HeaderB
public:
Color HeaderB
public:
Color HeaderB
See Also
CalendarProfessionalRenderer Class
CalendarProfessionalRenderer Members


HeaderC Field

CalendarProfessionalRenderer HeaderC Field A Sandcastle Documented Class Library
Send Feedback
HeaderC

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public HeaderC As Color
Public HeaderC As Color
public Color HeaderC
public Color HeaderC
public:
Color HeaderC
public:
Color HeaderC
See Also
CalendarProfessionalRenderer Class
CalendarProfessionalRenderer Members


HeaderD Field

CalendarProfessionalRenderer HeaderD Field A Sandcastle Documented Class Library
Send Feedback
HeaderD

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public HeaderD As Color
Public HeaderD As Color
public Color HeaderD
public Color HeaderD
public:
Color HeaderD
public:
Color HeaderD
See Also
CalendarProfessionalRenderer Class
CalendarProfessionalRenderer Members


TodayA Field

CalendarProfessionalRenderer TodayA Field A Sandcastle Documented Class Library
Send Feedback
TodayA

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public TodayA As Color
Public TodayA As Color
public Color TodayA
public Color TodayA
public:
Color TodayA
public:
Color TodayA
See Also
CalendarProfessionalRenderer Class
CalendarProfessionalRenderer Members


TodayB Field

CalendarProfessionalRenderer TodayB Field A Sandcastle Documented Class Library
Send Feedback
TodayB

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public TodayB As Color
Public TodayB As Color
public Color TodayB
public Color TodayB
public:
Color TodayB
public:
Color TodayB
See Also
CalendarProfessionalRenderer Class
CalendarProfessionalRenderer Members


TodayC Field

CalendarProfessionalRenderer TodayC Field A Sandcastle Documented Class Library
Send Feedback
TodayC

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public TodayC As Color
Public TodayC As Color
public Color TodayC
public Color TodayC
public:
Color TodayC
public:
Color TodayC
See Also
CalendarProfessionalRenderer Class
CalendarProfessionalRenderer Members


TodayD Field

CalendarProfessionalRenderer TodayD Field A Sandcastle Documented Class Library
Send Feedback
TodayD

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public TodayD As Color
Public TodayD As Color
public Color TodayD
public Color TodayD
public:
Color TodayD
public:
Color TodayD
See Also
CalendarProfessionalRenderer Class
CalendarProfessionalRenderer Members


CalendarProfessionalRenderer Methods

CalendarProfessionalRenderer Methods A Sandcastle Documented Class Library
Send Feedback
The CalendarProfessionalRenderer type exposes the following members.
Methods
 | Name | Description
Protected method | DrawStandarBoxText | Draws text using the information of the CalendarRendererBoxEventArgs (Inherited from CalendarRenderer.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetTimeY | Gets the exact Y coordinate that corresponds to the specified time. This only works when in Expanded mode. (Inherited from CalendarRenderer.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | GlossyRect | Glossies the rect.
 | GradientRect | Gradients the rect.
Public method | ItemBorder | Draws the specified rectangle with item border roundnesss (Inherited from CalendarRenderer.)
Public method | ItemFill | Fills the specified rectangle with item border roundness (Inherited from CalendarRenderer.)
Public method | ItemPattern | Items the pattern. (Inherited from CalendarRenderer.)
Public method | ItemRectangle | Creates a rectangle with item roundess (Inherited from CalendarRenderer.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OnDrawBackground | Paints the background of the calendar (Inherited from CalendarSystemRenderer.)
Public method | OnDrawDay | Paints the specified day on the calendar (Inherited from CalendarSystemRenderer.)
Public method | OnDrawDayBorder | Paints the border of the specified day (Inherited from CalendarSystemRenderer.)
Public method | OnDrawDayHeaderBackground | Raises the [E:DrawDayHeaderBackground] event. (Overrides CalendarSystemRenderer OnDrawDayHeaderBackground(CalendarRendererDayEventArgs).)
Public method | OnDrawDayHeaderText | Paints the header of the specified day (Inherited from CalendarRenderer.)
Public method | OnDrawDayNameHeader | Raises the [E:DrawDayNameHeader] event. (Inherited from CalendarSystemRenderer.)
Public method | OnDrawDayNameHeaders | Raises the [E:DrawDayNameHeaders] event. (Inherited from CalendarRenderer.)
Public method | OnDrawDayOverflowEnd | Draws the overflow to end of specified day (Inherited from CalendarSystemRenderer.)
Public method | OnDrawDayOverflowStart | Draws the overflow to start of specified day (Inherited from CalendarRenderer.)
Public method | OnDrawDays | Paints the days on the current calendar view (Inherited from CalendarRenderer.)
Public method | OnDrawDayTimeUnit | Draws a time unit of a day (Inherited from CalendarSystemRenderer.)
Public method | OnDrawDayTimeUnits | Raises the [E:DrawDayTimeUnits] event. (Inherited from CalendarRenderer.)
Public method | OnDrawDayTop | Draws the all day items area (Inherited from CalendarSystemRenderer.)
Public method | OnDrawItem | Draws an item of the calendar (Inherited from CalendarRenderer.)
Public method | OnDrawItemBackground | Draws the background of the specified item (Inherited from CalendarSystemRenderer.)
Public method | OnDrawItemBorder | Raises the [E:DrawItemBorder] event. (Overrides CalendarSystemRenderer OnDrawItemBorder(CalendarRendererItemBoundsEventArgs).)
Public method | OnDrawItemContent | Draws the strings of an item. Strings inlude StartTime, EndTime and Text (Inherited from CalendarRenderer.)
Public method | OnDrawItemEndTime | Draws the end time of the item if applicable (Inherited from CalendarSystemRenderer.)
Public method | OnDrawItemImage | Draws the image of an item (Inherited from CalendarRenderer.)
Public method | OnDrawItemPattern | Raises the [E:DrawItemPattern] event. (Inherited from CalendarRenderer.)
Public method | OnDrawItems | Draws the items of the calendar (Inherited from CalendarRenderer.)
Public method | OnDrawItemShadow | Draws the shadow of the specified item (Inherited from CalendarSystemRenderer.)
Public method | OnDrawItemStartTime | Draws the starttime of the item if applicable (Inherited from CalendarSystemRenderer.)
Public method | OnDrawItemText | Draws the text of an item (Inherited from CalendarSystemRenderer.)
Public method | OnDrawOverflows | Draws the overflows of days (Inherited from CalendarRenderer.)
Public method | OnDrawTimeScale | Paints the timescale of the calendar (Inherited from CalendarSystemRenderer.)
Public method | OnDrawTimeScaleHour | Paints an hour of a timescale unit (Inherited from CalendarSystemRenderer.)
Public method | OnDrawTimeScaleMinutes | Paints minutes of a timescale unit (Inherited from CalendarSystemRenderer.)
Public method | OnDrawWeekHeader | Raises the [E:DrawWeekHeader] event. (Inherited from CalendarSystemRenderer.)
Public method | OnDrawWeekHeaders | Raises the [E:DrawWeekHeaders] event. (Inherited from CalendarSystemRenderer.)
Public method | OnInitialize | Initializes the Calendar (Overrides CalendarRenderer OnInitialize(CalendarRendererEventArgs).)
Public method | PerformItemsLayout | Updates the bounds of CalendarItems (Inherited from CalendarRenderer.)
Public method | PerformLayout | Peform layout of elements and items of the calendar (Inherited from CalendarRenderer.)
Public method | PerformLayout(Boolean) | Updates the bounds of graphical elements. Optionally calls PerformItemsLayout to update bounds of items. (Inherited from CalendarRenderer.)
Protected method | SetDayHeaderHeight | Sets the value of the DayHeaderHeight property (Inherited from CalendarRenderer.)
Protected method | SetDayNameHeadersHeight | Sets the value of the DayNameHeadersHeight property (Inherited from CalendarRenderer.)
Protected method | SetDayTopHeight | Sets the value of the DayTopHeight property (Inherited from CalendarRenderer.)
Protected method | SetTimeScaleUnitHeight | Sets the value of the TimeScaleUnitHeight property (Inherited from CalendarRenderer.)
Protected method | SetTimeScaleWidth | Sets the value of the TimeScaleWidth property (Inherited from CalendarRenderer.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CalendarProfessionalRenderer Class


GlossyRect Method

CalendarProfessionalRenderer GlossyRect Method A Sandcastle Documented Class Library
Send Feedback
Glossies the rect.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Shared Sub GlossyRect ( _
    g As Graphics, _
    bounds As Rectangle, _
    a As Color, _
    b As Color, _
    c As Color, _
    d As Color _
)
Public Shared Sub GlossyRect ( _
    g As Graphics, _
    bounds As Rectangle, _
    a As Color, _
    b As Color, _
    c As Color, _
    d As Color _
)
public static void GlossyRect(
    Graphics g,
    Rectangle bounds,
    Color a,
    Color b,
    Color c,
    Color d
)
public static void GlossyRect(
    Graphics g,
    Rectangle bounds,
    Color a,
    Color b,
    Color c,
    Color d
)
public:
static void GlossyRect(
    Graphics^ g,
    Rectangle bounds,
    Color a,
    Color b,
    Color c,
    Color d
)
public:
static void GlossyRect(
    Graphics^ g,
    Rectangle bounds,
    Color a,
    Color b,
    Color c,
    Color d
)
Parameters
g
Type:   Online System.Drawing Graphics
The g.
bounds
Type:   Online System.Drawing Rectangle
The bounds.
a
Type:   Online System.Drawing Color
A.
b
Type:   Online System.Drawing Color
The b.
c
Type:   Online System.Drawing Color
The c.
d
Type:   Online System.Drawing Color
The d.
See Also
CalendarProfessionalRenderer Class
CalendarProfessionalRenderer Members


GradientRect Method

CalendarProfessionalRenderer GradientRect Method A Sandcastle Documented Class Library
Send Feedback
Gradients the rect.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Shared Sub GradientRect ( _
    g As Graphics, _
    bounds As Rectangle, _
    a As Color, _
    b As Color _
)
Public Shared Sub GradientRect ( _
    g As Graphics, _
    bounds As Rectangle, _
    a As Color, _
    b As Color _
)
public static void GradientRect(
    Graphics g,
    Rectangle bounds,
    Color a,
    Color b
)
public static void GradientRect(
    Graphics g,
    Rectangle bounds,
    Color a,
    Color b
)
public:
static void GradientRect(
    Graphics^ g,
    Rectangle bounds,
    Color a,
    Color b
)
public:
static void GradientRect(
    Graphics^ g,
    Rectangle bounds,
    Color a,
    Color b
)
Parameters
g
Type:   Online System.Drawing Graphics
The g.
bounds
Type:   Online System.Drawing Rectangle
The bounds.
a
Type:   Online System.Drawing Color
A.
b
Type:   Online System.Drawing Color
The b.
See Also
CalendarProfessionalRenderer Class
CalendarProfessionalRenderer Members


OnDrawDayHeaderBackground Method

CalendarProfessionalRenderer OnDrawDayHeaderBackground Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:DrawDayHeaderBackground] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Sub OnDrawDayHeaderBackground ( _
    e As CalendarRendererDayEventArgs _
)
Public Overrides Sub OnDrawDayHeaderBackground ( _
    e As CalendarRendererDayEventArgs _
)
public override void OnDrawDayHeaderBackground(
    CalendarRendererDayEventArgs e
)
public override void OnDrawDayHeaderBackground(
    CalendarRendererDayEventArgs e
)
public:
virtual void OnDrawDayHeaderBackground(
    CalendarRendererDayEventArgs^ e
) override
public:
virtual void OnDrawDayHeaderBackground(
    CalendarRendererDayEventArgs^ e
) override
Parameters
e
Type: WindowsFormsCalendar CalendarRendererDayEventArgs
The CalendarRendererDayEventArgs instance containing the event data.
See Also
CalendarProfessionalRenderer Class
CalendarProfessionalRenderer Members


OnDrawItemBorder Method

CalendarProfessionalRenderer OnDrawItemBorder Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:DrawItemBorder] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Sub OnDrawItemBorder ( _
    e As CalendarRendererItemBoundsEventArgs _
)
Public Overrides Sub OnDrawItemBorder ( _
    e As CalendarRendererItemBoundsEventArgs _
)
public override void OnDrawItemBorder(
    CalendarRendererItemBoundsEventArgs e
)
public override void OnDrawItemBorder(
    CalendarRendererItemBoundsEventArgs e
)
public:
virtual void OnDrawItemBorder(
    CalendarRendererItemBoundsEventArgs^ e
) override
public:
virtual void OnDrawItemBorder(
    CalendarRendererItemBoundsEventArgs^ e
) override
Parameters
e
Type: WindowsFormsCalendar CalendarRendererItemBoundsEventArgs
The CalendarRendererItemBoundsEventArgs instance containing the event data.
See Also
CalendarProfessionalRenderer Class
CalendarProfessionalRenderer Members


OnInitialize Method

CalendarProfessionalRenderer OnInitialize Method A Sandcastle Documented Class Library
Send Feedback
Initializes the Calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Sub OnInitialize ( _
    e As CalendarRendererEventArgs _
)
Public Overrides Sub OnInitialize ( _
    e As CalendarRendererEventArgs _
)
public override void OnInitialize(
    CalendarRendererEventArgs e
)
public override void OnInitialize(
    CalendarRendererEventArgs e
)
public:
virtual void OnInitialize(
    CalendarRendererEventArgs^ e
) override
public:
virtual void OnInitialize(
    CalendarRendererEventArgs^ e
) override
Parameters
e
Type: WindowsFormsCalendar CalendarRendererEventArgs
[Missing <param name="e"/> documentation for "M:WindowsFormsCalendar.CalendarProfessionalRenderer.OnInitialize(WindowsFormsCalendar.CalendarRendererEventArgs)"]
See Also
CalendarProfessionalRenderer Class
CalendarProfessionalRenderer Members


CalendarProfessionalRenderer Properties

CalendarProfessionalRenderer Properties A Sandcastle Documented Class Library
Send Feedback
The CalendarProfessionalRenderer type exposes the following members.
Properties
 | Name | Description
Public property | Calendar | Gets the Calendar this renderer belongs to (Inherited from CalendarRenderer.)
Public property | ColorTable | Gets or sets the CalendarColorTable for this renderer (Inherited from CalendarSystemRenderer.)
Public property | DayHeaderHeight | Gets the height of the header of days (Inherited from CalendarRenderer.)
Public property | DayNameHeaderColumns | Gets the bounds for day name headers (Inherited from CalendarRenderer.)
Public property | DayNameHeadersHeight | Gets the height of the day name headers (Inherited from CalendarRenderer.)
Public property | DayNameHeadersVisible | Gets a value indicating if the day names headers are visible (e.g. Monday, Tuesday, Wednesday ...) (Inherited from CalendarRenderer.)
Public property | DayTopHeight | Gets the current height of the all day items area (Inherited from CalendarRenderer.)
Public property | DayTopItemsPadding | Gets or sets the padding of the items that goes on the top part of the days, when in Expanded (Inherited from CalendarRenderer.)
Public property | DayTopMinHeight | Gets the minimum height for day tops (Inherited from CalendarRenderer.)
Public property | ItemInvalidateMargin | Gets or sets the extra margin for invalidating and redrawing items (Inherited from CalendarRenderer.)
Public property | ItemRoundness | Gets or sets the roundness of the item (Inherited from CalendarRenderer.)
Public property | ItemShadowPadding | Gets or sets the amount of pixels that the item's shadow is dropped (Inherited from CalendarRenderer.)
Public property | ItemsPadding | Gets or sets the padding of items on expanded mode (Inherited from CalendarRenderer.)
Public property | ItemTextMargin | Gets the margin of the text in the items (Inherited from CalendarRenderer.)
Public property | SelectedItemBorder | Gets or sets the size of the border of selected items (Inherited from CalendarSystemRenderer.)
Public property | StandardItemHeight | Gets the height of items on day tops (Inherited from CalendarRenderer.)
Public property | TimeScaleBounds | Gets or sets the bounds of the timescale (Inherited from CalendarRenderer.)
Public property | TimeScaleUnitHeight | Gets the height of the time scale unit. (Inherited from CalendarRenderer.)
Public property | TimeScaleVisible | Gets a value indicating whether [time scale visible]. (Inherited from CalendarRenderer.)
Public property | TimeScaleWidth | Gets the width of the timescale (Inherited from CalendarRenderer.)
Public property | WeekHeaderWidth | Gets the width of the week header. (Inherited from CalendarRenderer.)
Back to Top
See Also
CalendarProfessionalRenderer Class


CalendarRenderer Class

CalendarRenderer Class A Sandcastle Documented Class Library
Base class that renders visual elements of Calendar control
Inheritance Hierarchy
Online System Object
WindowsFormsCalendar CalendarRenderer
WindowsFormsCalendar CalendarSystemRenderer

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class CalendarRenderer
Public Class CalendarRenderer
public class CalendarRenderer
public class CalendarRenderer
public ref class CalendarRenderer
public ref class CalendarRenderer
See Also
CalendarRenderer Members


CalendarRenderer Members

CalendarRenderer Members A Sandcastle Documented Class Library
Send Feedback

The CalendarRenderer type exposes the following members.
Constructors
 | Name | Description
Public method | CalendarRenderer | Creates a new renderer for the specified calendar
Back to Top
Methods
 | Name | Description
Protected method | DrawStandarBoxText | Draws text using the information of the CalendarRendererBoxEventArgs
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetTimeY | Gets the exact Y coordinate that corresponds to the specified time. This only works when in Expanded mode.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | ItemBorder | Draws the specified rectangle with item border roundnesss
Public method | ItemFill | Fills the specified rectangle with item border roundness
Public method | ItemPattern | Items the pattern.
Public method | ItemRectangle | Creates a rectangle with item roundess
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OnDrawBackground | Paints the background of the calendar
Public method | OnDrawDay | Paints the specified day on the calendar
Public method | OnDrawDayBorder | Paints the border of the specified day
Public method | OnDrawDayHeaderBackground | Paints the background of the specified day's header
Public method | OnDrawDayHeaderText | Paints the header of the specified day
Public method | OnDrawDayNameHeader | Raises the [E:DrawDayNameHeader] event.
Public method | OnDrawDayNameHeaders | Raises the [E:DrawDayNameHeaders] event.
Public method | OnDrawDayOverflowEnd | Draws the overflow to end of specified day
Public method | OnDrawDayOverflowStart | Draws the overflow to start of specified day
Public method | OnDrawDays | Paints the days on the current calendar view
Public method | OnDrawDayTimeUnit | Draws a time unit of a day
Public method | OnDrawDayTimeUnits | Raises the [E:DrawDayTimeUnits] event.
Public method | OnDrawDayTop | Draws the all day items area
Public method | OnDrawItem | Draws an item of the calendar
Public method | OnDrawItemBackground | Draws the background of the specified item
Public method | OnDrawItemBorder | Draws the border of the specified item
Public method | OnDrawItemContent | Draws the strings of an item. Strings inlude StartTime, EndTime and Text
Public method | OnDrawItemEndTime | Draws the end time of the item if applicable
Public method | OnDrawItemImage | Draws the image of an item
Public method | OnDrawItemPattern | Raises the [E:DrawItemPattern] event.
Public method | OnDrawItems | Draws the items of the calendar
Public method | OnDrawItemShadow | Draws the shadow of the specified item
Public method | OnDrawItemStartTime | Draws the starttime of the item if applicable
Public method | OnDrawItemText | Draws the text of an item
Public method | OnDrawOverflows | Draws the overflows of days
Public method | OnDrawTimeScale | Paints the timescale of the calendar
Public method | OnDrawTimeScaleHour | Paints an hour of a timescale unit
Public method | OnDrawTimeScaleMinutes | Paints minutes of a timescale unit
Public method | OnDrawWeekHeader | Raises the [E:DrawWeekHeader] event.
Public method | OnDrawWeekHeaders | Raises the [E:DrawWeekHeaders] event.
Public method | OnInitialize | Initializes the Calendar
Public method | PerformItemsLayout | Updates the bounds of CalendarItems
Public method | PerformLayout | Peform layout of elements and items of the calendar
Public method | PerformLayout(Boolean) | Updates the bounds of graphical elements. Optionally calls PerformItemsLayout to update bounds of items.
 | RoundRectangle(Rectangle, Int32) | Creates a rectangle with rounded corners
 | RoundRectangle(Rectangle, Int32, Corners) | Creates a rectangle with the specified corners rounded
Protected method | SetDayHeaderHeight | Sets the value of the DayHeaderHeight property
Protected method | SetDayNameHeadersHeight | Sets the value of the DayNameHeadersHeight property
Protected method | SetDayTopHeight | Sets the value of the DayTopHeight property
Protected method | SetTimeScaleUnitHeight | Sets the value of the TimeScaleUnitHeight property
Protected method | SetTimeScaleWidth | Sets the value of the TimeScaleWidth property
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Calendar | Gets the Calendar this renderer belongs to
Public property | DayHeaderHeight | Gets the height of the header of days
Public property | DayNameHeaderColumns | Gets the bounds for day name headers
Public property | DayNameHeadersHeight | Gets the height of the day name headers
Public property | DayNameHeadersVisible | Gets a value indicating if the day names headers are visible (e.g. Monday, Tuesday, Wednesday ...)
Public property | DayTopHeight | Gets the current height of the all day items area
Public property | DayTopItemsPadding | Gets or sets the padding of the items that goes on the top part of the days, when in Expanded
Public property | DayTopMinHeight | Gets the minimum height for day tops
Public property | ItemInvalidateMargin | Gets or sets the extra margin for invalidating and redrawing items
Public property | ItemRoundness | Gets or sets the roundness of the item
Public property | ItemShadowPadding | Gets or sets the amount of pixels that the item's shadow is dropped
Public property | ItemsPadding | Gets or sets the padding of items on expanded mode
Public property | ItemTextMargin | Gets the margin of the text in the items
Public property | StandardItemHeight | Gets the height of items on day tops
Public property | TimeScaleBounds | Gets or sets the bounds of the timescale
Public property | TimeScaleUnitHeight | Gets the height of the time scale unit.
Public property | TimeScaleVisible | Gets a value indicating whether [time scale visible].
Public property | TimeScaleWidth | Gets the width of the timescale
Public property | WeekHeaderWidth | Gets the width of the week header.
Back to Top
See Also
CalendarRenderer Class


CalendarRenderer Constructor

CalendarRenderer Constructor A Sandcastle Documented Class Library
Send Feedback
Creates a new renderer for the specified calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    calendar As Calendar _
)
Public Sub New ( _
    calendar As Calendar _
)
public CalendarRenderer(
    Calendar calendar
)
public CalendarRenderer(
    Calendar calendar
)
public:
CalendarRenderer(
    Calendar^ calendar
)
public:
CalendarRenderer(
    Calendar^ calendar
)
Parameters
calendar
Type: WindowsFormsCalendar Calendar
[Missing <param name="calendar"/> documentation for "M:WindowsFormsCalendar.CalendarRenderer.#ctor(WindowsFormsCalendar.Calendar)"]
See Also
CalendarRenderer Class
CalendarRenderer Members


CalendarRenderer Methods

CalendarRenderer Methods A Sandcastle Documented Class Library
Send Feedback
The CalendarRenderer type exposes the following members.
Methods
 | Name | Description
Protected method | DrawStandarBoxText | Draws text using the information of the CalendarRendererBoxEventArgs
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetTimeY | Gets the exact Y coordinate that corresponds to the specified time. This only works when in Expanded mode.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | ItemBorder | Draws the specified rectangle with item border roundnesss
Public method | ItemFill | Fills the specified rectangle with item border roundness
Public method | ItemPattern | Items the pattern.
Public method | ItemRectangle | Creates a rectangle with item roundess
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OnDrawBackground | Paints the background of the calendar
Public method | OnDrawDay | Paints the specified day on the calendar
Public method | OnDrawDayBorder | Paints the border of the specified day
Public method | OnDrawDayHeaderBackground | Paints the background of the specified day's header
Public method | OnDrawDayHeaderText | Paints the header of the specified day
Public method | OnDrawDayNameHeader | Raises the [E:DrawDayNameHeader] event.
Public method | OnDrawDayNameHeaders | Raises the [E:DrawDayNameHeaders] event.
Public method | OnDrawDayOverflowEnd | Draws the overflow to end of specified day
Public method | OnDrawDayOverflowStart | Draws the overflow to start of specified day
Public method | OnDrawDays | Paints the days on the current calendar view
Public method | OnDrawDayTimeUnit | Draws a time unit of a day
Public method | OnDrawDayTimeUnits | Raises the [E:DrawDayTimeUnits] event.
Public method | OnDrawDayTop | Draws the all day items area
Public method | OnDrawItem | Draws an item of the calendar
Public method | OnDrawItemBackground | Draws the background of the specified item
Public method | OnDrawItemBorder | Draws the border of the specified item
Public method | OnDrawItemContent | Draws the strings of an item. Strings inlude StartTime, EndTime and Text
Public method | OnDrawItemEndTime | Draws the end time of the item if applicable
Public method | OnDrawItemImage | Draws the image of an item
Public method | OnDrawItemPattern | Raises the [E:DrawItemPattern] event.
Public method | OnDrawItems | Draws the items of the calendar
Public method | OnDrawItemShadow | Draws the shadow of the specified item
Public method | OnDrawItemStartTime | Draws the starttime of the item if applicable
Public method | OnDrawItemText | Draws the text of an item
Public method | OnDrawOverflows | Draws the overflows of days
Public method | OnDrawTimeScale | Paints the timescale of the calendar
Public method | OnDrawTimeScaleHour | Paints an hour of a timescale unit
Public method | OnDrawTimeScaleMinutes | Paints minutes of a timescale unit
Public method | OnDrawWeekHeader | Raises the [E:DrawWeekHeader] event.
Public method | OnDrawWeekHeaders | Raises the [E:DrawWeekHeaders] event.
Public method | OnInitialize | Initializes the Calendar
Public method | PerformItemsLayout | Updates the bounds of CalendarItems
Public method | PerformLayout | Peform layout of elements and items of the calendar
Public method | PerformLayout(Boolean) | Updates the bounds of graphical elements. Optionally calls PerformItemsLayout to update bounds of items.
 | RoundRectangle(Rectangle, Int32) | Creates a rectangle with rounded corners
 | RoundRectangle(Rectangle, Int32, Corners) | Creates a rectangle with the specified corners rounded
Protected method | SetDayHeaderHeight | Sets the value of the DayHeaderHeight property
Protected method | SetDayNameHeadersHeight | Sets the value of the DayNameHeadersHeight property
Protected method | SetDayTopHeight | Sets the value of the DayTopHeight property
Protected method | SetTimeScaleUnitHeight | Sets the value of the TimeScaleUnitHeight property
Protected method | SetTimeScaleWidth | Sets the value of the TimeScaleWidth property
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CalendarRenderer Class


DrawStandarBoxText Method

CalendarRenderer DrawStandarBoxText Method A Sandcastle Documented Class Library
Send Feedback
Draws text using the information of the CalendarRendererBoxEventArgs

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overridable Sub DrawStandarBoxText ( _
    e As CalendarRendererBoxEventArgs _
)
Protected Overridable Sub DrawStandarBoxText ( _
    e As CalendarRendererBoxEventArgs _
)
protected virtual void DrawStandarBoxText(
    CalendarRendererBoxEventArgs e
)
protected virtual void DrawStandarBoxText(
    CalendarRendererBoxEventArgs e
)
protected:
virtual void DrawStandarBoxText(
    CalendarRendererBoxEventArgs^ e
)
protected:
virtual void DrawStandarBoxText(
    CalendarRendererBoxEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererBoxEventArgs
[Missing <param name="e"/> documentation for "M:WindowsFormsCalendar.CalendarRenderer.DrawStandarBoxText(WindowsFormsCalendar.CalendarRendererBoxEventArgs)"]
See Also
CalendarRenderer Class
CalendarRenderer Members


GetTimeY Method

CalendarRenderer GetTimeY Method A Sandcastle Documented Class Library
Send Feedback
Gets the exact Y coordinate that corresponds to the specified time. This only works when in Expanded mode.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Function GetTimeY ( _
    time As TimeSpan _
) As Integer
Public Function GetTimeY ( _
    time As TimeSpan _
) As Integer
public int GetTimeY(
    TimeSpan time
)
public int GetTimeY(
    TimeSpan time
)
public:
int GetTimeY(
    TimeSpan time
)
public:
int GetTimeY(
    TimeSpan time
)
Parameters
time
Type:   Online System TimeSpan
Time of day to get Y coordinate
Return Value

            Y coordinate corresponding to the specified
time
Exceptions
Exception | Condition
Online System InvalidOperationException | When calendar is not in Expaned mode.
See Also
CalendarRenderer Class
CalendarRenderer Members


ItemBorder Method

CalendarRenderer ItemBorder Method A Sandcastle Documented Class Library
Send Feedback
Draws the specified rectangle with item border roundnesss

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub ItemBorder ( _
    e As CalendarRendererItemBoundsEventArgs, _
    bounds As Rectangle, _
    color As Color, _
    width As Single _
)
Public Sub ItemBorder ( _
    e As CalendarRendererItemBoundsEventArgs, _
    bounds As Rectangle, _
    color As Color, _
    width As Single _
)
public void ItemBorder(
    CalendarRendererItemBoundsEventArgs e,
    Rectangle bounds,
    Color color,
    float width
)
public void ItemBorder(
    CalendarRendererItemBoundsEventArgs e,
    Rectangle bounds,
    Color color,
    float width
)
public:
void ItemBorder(
    CalendarRendererItemBoundsEventArgs^ e,
    Rectangle bounds,
    Color color,
    float width
)
public:
void ItemBorder(
    CalendarRendererItemBoundsEventArgs^ e,
    Rectangle bounds,
    Color color,
    float width
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererItemBoundsEventArgs
The CalendarRendererItemBoundsEventArgs instance containing the event data.
bounds
Type:   Online System.Drawing Rectangle
The bounds.
color
Type:   Online System.Drawing Color
The color.
width
Type:   Online System Single
The width.
See Also
CalendarRenderer Class
CalendarRenderer Members


ItemFill Method

CalendarRenderer ItemFill Method A Sandcastle Documented Class Library
Send Feedback
Fills the specified rectangle with item border roundness

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub ItemFill ( _
    e As CalendarRendererItemBoundsEventArgs, _
    bounds As Rectangle, _
    north As Color, _
    south As Color _
)
Public Sub ItemFill ( _
    e As CalendarRendererItemBoundsEventArgs, _
    bounds As Rectangle, _
    north As Color, _
    south As Color _
)
public void ItemFill(
    CalendarRendererItemBoundsEventArgs e,
    Rectangle bounds,
    Color north,
    Color south
)
public void ItemFill(
    CalendarRendererItemBoundsEventArgs e,
    Rectangle bounds,
    Color north,
    Color south
)
public:
void ItemFill(
    CalendarRendererItemBoundsEventArgs^ e,
    Rectangle bounds,
    Color north,
    Color south
)
public:
void ItemFill(
    CalendarRendererItemBoundsEventArgs^ e,
    Rectangle bounds,
    Color north,
    Color south
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererItemBoundsEventArgs
The CalendarRendererItemBoundsEventArgs instance containing the event data.
bounds
Type:   Online System.Drawing Rectangle
The bounds.
north
Type:   Online System.Drawing Color
The north.
south
Type:   Online System.Drawing Color
The south.
See Also
CalendarRenderer Class
CalendarRenderer Members


ItemPattern Method

CalendarRenderer ItemPattern Method A Sandcastle Documented Class Library
Send Feedback
Items the pattern.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub ItemPattern ( _
    e As CalendarRendererItemBoundsEventArgs, _
    bounds As Rectangle, _
    patternColor As Color _
)
Public Sub ItemPattern ( _
    e As CalendarRendererItemBoundsEventArgs, _
    bounds As Rectangle, _
    patternColor As Color _
)
public void ItemPattern(
    CalendarRendererItemBoundsEventArgs e,
    Rectangle bounds,
    Color patternColor
)
public void ItemPattern(
    CalendarRendererItemBoundsEventArgs e,
    Rectangle bounds,
    Color patternColor
)
public:
void ItemPattern(
    CalendarRendererItemBoundsEventArgs^ e,
    Rectangle bounds,
    Color patternColor
)
public:
void ItemPattern(
    CalendarRendererItemBoundsEventArgs^ e,
    Rectangle bounds,
    Color patternColor
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererItemBoundsEventArgs
The CalendarRendererItemBoundsEventArgs instance containing the event data.
bounds
Type:   Online System.Drawing Rectangle
The bounds.
patternColor
Type:   Online System.Drawing Color
Color of the pattern.
See Also
CalendarRenderer Class
CalendarRenderer Members


ItemRectangle Method

CalendarRenderer ItemRectangle Method A Sandcastle Documented Class Library
Send Feedback
Creates a rectangle with item roundess

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Function ItemRectangle ( _
    evtData As CalendarRendererItemBoundsEventArgs, _
    bounds As Rectangle _
) As GraphicsPath
Public Function ItemRectangle ( _
    evtData As CalendarRendererItemBoundsEventArgs, _
    bounds As Rectangle _
) As GraphicsPath
public GraphicsPath ItemRectangle(
    CalendarRendererItemBoundsEventArgs evtData,
    Rectangle bounds
)
public GraphicsPath ItemRectangle(
    CalendarRendererItemBoundsEventArgs evtData,
    Rectangle bounds
)
public:
GraphicsPath^ ItemRectangle(
    CalendarRendererItemBoundsEventArgs^ evtData,
    Rectangle bounds
)
public:
GraphicsPath^ ItemRectangle(
    CalendarRendererItemBoundsEventArgs^ evtData,
    Rectangle bounds
)
Parameters
evtData
Type: WindowsFormsCalendar CalendarRendererItemBoundsEventArgs
The instance containing the event data.
bounds
Type:   Online System.Drawing Rectangle
The bounds.
Return Value
[Missing <returns> documentation for "M:WindowsFormsCalendar.CalendarRenderer.ItemRectangle(WindowsFormsCalendar.CalendarRendererItemBoundsEventArgs,System.Drawing.Rectangle)"]
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawBackground Method

CalendarRenderer OnDrawBackground Method A Sandcastle Documented Class Library
Send Feedback
Paints the background of the calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawBackground ( _
    e As CalendarRendererEventArgs _
)
Public Overridable Sub OnDrawBackground ( _
    e As CalendarRendererEventArgs _
)
public virtual void OnDrawBackground(
    CalendarRendererEventArgs e
)
public virtual void OnDrawBackground(
    CalendarRendererEventArgs e
)
public:
virtual void OnDrawBackground(
    CalendarRendererEventArgs^ e
)
public:
virtual void OnDrawBackground(
    CalendarRendererEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererEventArgs
Paint info
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawDay Method

CalendarRenderer OnDrawDay Method A Sandcastle Documented Class Library
Send Feedback
Paints the specified day on the calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawDay ( _
    e As CalendarRendererDayEventArgs _
)
Public Overridable Sub OnDrawDay ( _
    e As CalendarRendererDayEventArgs _
)
public virtual void OnDrawDay(
    CalendarRendererDayEventArgs e
)
public virtual void OnDrawDay(
    CalendarRendererDayEventArgs e
)
public:
virtual void OnDrawDay(
    CalendarRendererDayEventArgs^ e
)
public:
virtual void OnDrawDay(
    CalendarRendererDayEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererDayEventArgs
Paint info
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawDayBorder Method

CalendarRenderer OnDrawDayBorder Method A Sandcastle Documented Class Library
Send Feedback
Paints the border of the specified day

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawDayBorder ( _
    e As CalendarRendererDayEventArgs _
)
Public Overridable Sub OnDrawDayBorder ( _
    e As CalendarRendererDayEventArgs _
)
public virtual void OnDrawDayBorder(
    CalendarRendererDayEventArgs e
)
public virtual void OnDrawDayBorder(
    CalendarRendererDayEventArgs e
)
public:
virtual void OnDrawDayBorder(
    CalendarRendererDayEventArgs^ e
)
public:
virtual void OnDrawDayBorder(
    CalendarRendererDayEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererDayEventArgs
[Missing <param name="e"/> documentation for "M:WindowsFormsCalendar.CalendarRenderer.OnDrawDayBorder(WindowsFormsCalendar.CalendarRendererDayEventArgs)"]
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawDayHeaderBackground Method

CalendarRenderer OnDrawDayHeaderBackground Method A Sandcastle Documented Class Library
Send Feedback
Paints the background of the specified day's header

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawDayHeaderBackground ( _
    e As CalendarRendererDayEventArgs _
)
Public Overridable Sub OnDrawDayHeaderBackground ( _
    e As CalendarRendererDayEventArgs _
)
public virtual void OnDrawDayHeaderBackground(
    CalendarRendererDayEventArgs e
)
public virtual void OnDrawDayHeaderBackground(
    CalendarRendererDayEventArgs e
)
public:
virtual void OnDrawDayHeaderBackground(
    CalendarRendererDayEventArgs^ e
)
public:
virtual void OnDrawDayHeaderBackground(
    CalendarRendererDayEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererDayEventArgs
[Missing <param name="e"/> documentation for "M:WindowsFormsCalendar.CalendarRenderer.OnDrawDayHeaderBackground(WindowsFormsCalendar.CalendarRendererDayEventArgs)"]
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawDayHeaderText Method

CalendarRenderer OnDrawDayHeaderText Method A Sandcastle Documented Class Library
Send Feedback
Paints the header of the specified day

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawDayHeaderText ( _
    e As CalendarRendererBoxEventArgs _
)
Public Overridable Sub OnDrawDayHeaderText ( _
    e As CalendarRendererBoxEventArgs _
)
public virtual void OnDrawDayHeaderText(
    CalendarRendererBoxEventArgs e
)
public virtual void OnDrawDayHeaderText(
    CalendarRendererBoxEventArgs e
)
public:
virtual void OnDrawDayHeaderText(
    CalendarRendererBoxEventArgs^ e
)
public:
virtual void OnDrawDayHeaderText(
    CalendarRendererBoxEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererBoxEventArgs
Paint info
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawDayNameHeader Method

CalendarRenderer OnDrawDayNameHeader Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:DrawDayNameHeader] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawDayNameHeader ( _
    e As CalendarRendererBoxEventArgs _
)
Public Overridable Sub OnDrawDayNameHeader ( _
    e As CalendarRendererBoxEventArgs _
)
public virtual void OnDrawDayNameHeader(
    CalendarRendererBoxEventArgs e
)
public virtual void OnDrawDayNameHeader(
    CalendarRendererBoxEventArgs e
)
public:
virtual void OnDrawDayNameHeader(
    CalendarRendererBoxEventArgs^ e
)
public:
virtual void OnDrawDayNameHeader(
    CalendarRendererBoxEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererBoxEventArgs
The CalendarRendererBoxEventArgs instance containing the event data.
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawDayNameHeaders Method

CalendarRenderer OnDrawDayNameHeaders Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:DrawDayNameHeaders] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawDayNameHeaders ( _
    e As CalendarRendererEventArgs _
)
Public Overridable Sub OnDrawDayNameHeaders ( _
    e As CalendarRendererEventArgs _
)
public virtual void OnDrawDayNameHeaders(
    CalendarRendererEventArgs e
)
public virtual void OnDrawDayNameHeaders(
    CalendarRendererEventArgs e
)
public:
virtual void OnDrawDayNameHeaders(
    CalendarRendererEventArgs^ e
)
public:
virtual void OnDrawDayNameHeaders(
    CalendarRendererEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererEventArgs
The CalendarRendererEventArgs instance containing the event data.
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawDayOverflowEnd Method

CalendarRenderer OnDrawDayOverflowEnd Method A Sandcastle Documented Class Library
Send Feedback
Draws the overflow to end of specified day

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawDayOverflowEnd ( _
    e As CalendarRendererDayEventArgs _
)
Public Overridable Sub OnDrawDayOverflowEnd ( _
    e As CalendarRendererDayEventArgs _
)
public virtual void OnDrawDayOverflowEnd(
    CalendarRendererDayEventArgs e
)
public virtual void OnDrawDayOverflowEnd(
    CalendarRendererDayEventArgs e
)
public:
virtual void OnDrawDayOverflowEnd(
    CalendarRendererDayEventArgs^ e
)
public:
virtual void OnDrawDayOverflowEnd(
    CalendarRendererDayEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererDayEventArgs
[Missing <param name="e"/> documentation for "M:WindowsFormsCalendar.CalendarRenderer.OnDrawDayOverflowEnd(WindowsFormsCalendar.CalendarRendererDayEventArgs)"]
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawDayOverflowStart Method

CalendarRenderer OnDrawDayOverflowStart Method A Sandcastle Documented Class Library
Send Feedback
Draws the overflow to start of specified day

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawDayOverflowStart ( _
    e As CalendarRendererDayEventArgs _
)
Public Overridable Sub OnDrawDayOverflowStart ( _
    e As CalendarRendererDayEventArgs _
)
public virtual void OnDrawDayOverflowStart(
    CalendarRendererDayEventArgs e
)
public virtual void OnDrawDayOverflowStart(
    CalendarRendererDayEventArgs e
)
public:
virtual void OnDrawDayOverflowStart(
    CalendarRendererDayEventArgs^ e
)
public:
virtual void OnDrawDayOverflowStart(
    CalendarRendererDayEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererDayEventArgs
Event data
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawDays Method

CalendarRenderer OnDrawDays Method A Sandcastle Documented Class Library
Send Feedback
Paints the days on the current calendar view

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawDays ( _
    e As CalendarRendererEventArgs _
)
Public Overridable Sub OnDrawDays ( _
    e As CalendarRendererEventArgs _
)
public virtual void OnDrawDays(
    CalendarRendererEventArgs e
)
public virtual void OnDrawDays(
    CalendarRendererEventArgs e
)
public:
virtual void OnDrawDays(
    CalendarRendererEventArgs^ e
)
public:
virtual void OnDrawDays(
    CalendarRendererEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererEventArgs
Paint Info
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawDayTimeUnit Method

CalendarRenderer OnDrawDayTimeUnit Method A Sandcastle Documented Class Library
Send Feedback
Draws a time unit of a day

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawDayTimeUnit ( _
    e As CalendarRendererTimeUnitEventArgs _
)
Public Overridable Sub OnDrawDayTimeUnit ( _
    e As CalendarRendererTimeUnitEventArgs _
)
public virtual void OnDrawDayTimeUnit(
    CalendarRendererTimeUnitEventArgs e
)
public virtual void OnDrawDayTimeUnit(
    CalendarRendererTimeUnitEventArgs e
)
public:
virtual void OnDrawDayTimeUnit(
    CalendarRendererTimeUnitEventArgs^ e
)
public:
virtual void OnDrawDayTimeUnit(
    CalendarRendererTimeUnitEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererTimeUnitEventArgs
[Missing <param name="e"/> documentation for "M:WindowsFormsCalendar.CalendarRenderer.OnDrawDayTimeUnit(WindowsFormsCalendar.CalendarRendererTimeUnitEventArgs)"]
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawDayTimeUnits Method

CalendarRenderer OnDrawDayTimeUnits Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:DrawDayTimeUnits] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawDayTimeUnits ( _
    e As CalendarRendererDayEventArgs _
)
Public Overridable Sub OnDrawDayTimeUnits ( _
    e As CalendarRendererDayEventArgs _
)
public virtual void OnDrawDayTimeUnits(
    CalendarRendererDayEventArgs e
)
public virtual void OnDrawDayTimeUnits(
    CalendarRendererDayEventArgs e
)
public:
virtual void OnDrawDayTimeUnits(
    CalendarRendererDayEventArgs^ e
)
public:
virtual void OnDrawDayTimeUnits(
    CalendarRendererDayEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererDayEventArgs
The CalendarRendererDayEventArgs instance containing the event data.
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawDayTop Method

CalendarRenderer OnDrawDayTop Method A Sandcastle Documented Class Library
Send Feedback
Draws the all day items area

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawDayTop ( _
    e As CalendarRendererDayEventArgs _
)
Public Overridable Sub OnDrawDayTop ( _
    e As CalendarRendererDayEventArgs _
)
public virtual void OnDrawDayTop(
    CalendarRendererDayEventArgs e
)
public virtual void OnDrawDayTop(
    CalendarRendererDayEventArgs e
)
public:
virtual void OnDrawDayTop(
    CalendarRendererDayEventArgs^ e
)
public:
virtual void OnDrawDayTop(
    CalendarRendererDayEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererDayEventArgs
Paint Info
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawItem Method

CalendarRenderer OnDrawItem Method A Sandcastle Documented Class Library
Send Feedback
Draws an item of the calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawItem ( _
    e As CalendarRendererItemEventArgs _
)
Public Overridable Sub OnDrawItem ( _
    e As CalendarRendererItemEventArgs _
)
public virtual void OnDrawItem(
    CalendarRendererItemEventArgs e
)
public virtual void OnDrawItem(
    CalendarRendererItemEventArgs e
)
public:
virtual void OnDrawItem(
    CalendarRendererItemEventArgs^ e
)
public:
virtual void OnDrawItem(
    CalendarRendererItemEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererItemEventArgs
Event Info
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawItemBackground Method

CalendarRenderer OnDrawItemBackground Method A Sandcastle Documented Class Library
Send Feedback
Draws the background of the specified item

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawItemBackground ( _
    e As CalendarRendererItemBoundsEventArgs _
)
Public Overridable Sub OnDrawItemBackground ( _
    e As CalendarRendererItemBoundsEventArgs _
)
public virtual void OnDrawItemBackground(
    CalendarRendererItemBoundsEventArgs e
)
public virtual void OnDrawItemBackground(
    CalendarRendererItemBoundsEventArgs e
)
public:
virtual void OnDrawItemBackground(
    CalendarRendererItemBoundsEventArgs^ e
)
public:
virtual void OnDrawItemBackground(
    CalendarRendererItemBoundsEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererItemBoundsEventArgs
Event Info
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawItemBorder Method

CalendarRenderer OnDrawItemBorder Method A Sandcastle Documented Class Library
Send Feedback
Draws the border of the specified item

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawItemBorder ( _
    e As CalendarRendererItemBoundsEventArgs _
)
Public Overridable Sub OnDrawItemBorder ( _
    e As CalendarRendererItemBoundsEventArgs _
)
public virtual void OnDrawItemBorder(
    CalendarRendererItemBoundsEventArgs e
)
public virtual void OnDrawItemBorder(
    CalendarRendererItemBoundsEventArgs e
)
public:
virtual void OnDrawItemBorder(
    CalendarRendererItemBoundsEventArgs^ e
)
public:
virtual void OnDrawItemBorder(
    CalendarRendererItemBoundsEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererItemBoundsEventArgs
Event Info
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawItemContent Method

CalendarRenderer OnDrawItemContent Method A Sandcastle Documented Class Library
Send Feedback
Draws the strings of an item. Strings inlude StartTime, EndTime and Text

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawItemContent ( _
    e As CalendarRendererItemBoundsEventArgs _
)
Public Overridable Sub OnDrawItemContent ( _
    e As CalendarRendererItemBoundsEventArgs _
)
public virtual void OnDrawItemContent(
    CalendarRendererItemBoundsEventArgs e
)
public virtual void OnDrawItemContent(
    CalendarRendererItemBoundsEventArgs e
)
public:
virtual void OnDrawItemContent(
    CalendarRendererItemBoundsEventArgs^ e
)
public:
virtual void OnDrawItemContent(
    CalendarRendererItemBoundsEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererItemBoundsEventArgs
Event Info
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawItemEndTime Method

CalendarRenderer OnDrawItemEndTime Method A Sandcastle Documented Class Library
Send Feedback
Draws the end time of the item if applicable

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawItemEndTime ( _
    e As CalendarRendererBoxEventArgs _
)
Public Overridable Sub OnDrawItemEndTime ( _
    e As CalendarRendererBoxEventArgs _
)
public virtual void OnDrawItemEndTime(
    CalendarRendererBoxEventArgs e
)
public virtual void OnDrawItemEndTime(
    CalendarRendererBoxEventArgs e
)
public:
virtual void OnDrawItemEndTime(
    CalendarRendererBoxEventArgs^ e
)
public:
virtual void OnDrawItemEndTime(
    CalendarRendererBoxEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererBoxEventArgs
Event data
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawItemImage Method

CalendarRenderer OnDrawItemImage Method A Sandcastle Documented Class Library
Send Feedback
Draws the image of an item

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawItemImage ( _
    e As CalendarRendererItemBoundsEventArgs _
)
Public Overridable Sub OnDrawItemImage ( _
    e As CalendarRendererItemBoundsEventArgs _
)
public virtual void OnDrawItemImage(
    CalendarRendererItemBoundsEventArgs e
)
public virtual void OnDrawItemImage(
    CalendarRendererItemBoundsEventArgs e
)
public:
virtual void OnDrawItemImage(
    CalendarRendererItemBoundsEventArgs^ e
)
public:
virtual void OnDrawItemImage(
    CalendarRendererItemBoundsEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererItemBoundsEventArgs
[Missing <param name="e"/> documentation for "M:WindowsFormsCalendar.CalendarRenderer.OnDrawItemImage(WindowsFormsCalendar.CalendarRendererItemBoundsEventArgs)"]
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawItemPattern Method

CalendarRenderer OnDrawItemPattern Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:DrawItemPattern] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawItemPattern ( _
    e As CalendarRendererItemBoundsEventArgs _
)
Public Overridable Sub OnDrawItemPattern ( _
    e As CalendarRendererItemBoundsEventArgs _
)
public virtual void OnDrawItemPattern(
    CalendarRendererItemBoundsEventArgs e
)
public virtual void OnDrawItemPattern(
    CalendarRendererItemBoundsEventArgs e
)
public:
virtual void OnDrawItemPattern(
    CalendarRendererItemBoundsEventArgs^ e
)
public:
virtual void OnDrawItemPattern(
    CalendarRendererItemBoundsEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererItemBoundsEventArgs
The CalendarRendererItemBoundsEventArgs instance containing the event data.
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawItems Method

CalendarRenderer OnDrawItems Method A Sandcastle Documented Class Library
Send Feedback
Draws the items of the calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawItems ( _
    e As CalendarRendererEventArgs _
)
Public Overridable Sub OnDrawItems ( _
    e As CalendarRendererEventArgs _
)
public virtual void OnDrawItems(
    CalendarRendererEventArgs e
)
public virtual void OnDrawItems(
    CalendarRendererEventArgs e
)
public:
virtual void OnDrawItems(
    CalendarRendererEventArgs^ e
)
public:
virtual void OnDrawItems(
    CalendarRendererEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererEventArgs
Event info
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawItemShadow Method

CalendarRenderer OnDrawItemShadow Method A Sandcastle Documented Class Library
Send Feedback
Draws the shadow of the specified item

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawItemShadow ( _
    e As CalendarRendererItemBoundsEventArgs _
)
Public Overridable Sub OnDrawItemShadow ( _
    e As CalendarRendererItemBoundsEventArgs _
)
public virtual void OnDrawItemShadow(
    CalendarRendererItemBoundsEventArgs e
)
public virtual void OnDrawItemShadow(
    CalendarRendererItemBoundsEventArgs e
)
public:
virtual void OnDrawItemShadow(
    CalendarRendererItemBoundsEventArgs^ e
)
public:
virtual void OnDrawItemShadow(
    CalendarRendererItemBoundsEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererItemBoundsEventArgs
[Missing <param name="e"/> documentation for "M:WindowsFormsCalendar.CalendarRenderer.OnDrawItemShadow(WindowsFormsCalendar.CalendarRendererItemBoundsEventArgs)"]
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawItemStartTime Method

CalendarRenderer OnDrawItemStartTime Method A Sandcastle Documented Class Library
Send Feedback
Draws the starttime of the item if applicable

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawItemStartTime ( _
    e As CalendarRendererBoxEventArgs _
)
Public Overridable Sub OnDrawItemStartTime ( _
    e As CalendarRendererBoxEventArgs _
)
public virtual void OnDrawItemStartTime(
    CalendarRendererBoxEventArgs e
)
public virtual void OnDrawItemStartTime(
    CalendarRendererBoxEventArgs e
)
public:
virtual void OnDrawItemStartTime(
    CalendarRendererBoxEventArgs^ e
)
public:
virtual void OnDrawItemStartTime(
    CalendarRendererBoxEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererBoxEventArgs
Event data
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawItemText Method

CalendarRenderer OnDrawItemText Method A Sandcastle Documented Class Library
Send Feedback
Draws the text of an item

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawItemText ( _
    e As CalendarRendererBoxEventArgs _
)
Public Overridable Sub OnDrawItemText ( _
    e As CalendarRendererBoxEventArgs _
)
public virtual void OnDrawItemText(
    CalendarRendererBoxEventArgs e
)
public virtual void OnDrawItemText(
    CalendarRendererBoxEventArgs e
)
public:
virtual void OnDrawItemText(
    CalendarRendererBoxEventArgs^ e
)
public:
virtual void OnDrawItemText(
    CalendarRendererBoxEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererBoxEventArgs
[Missing <param name="e"/> documentation for "M:WindowsFormsCalendar.CalendarRenderer.OnDrawItemText(WindowsFormsCalendar.CalendarRendererBoxEventArgs)"]
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawOverflows Method

CalendarRenderer OnDrawOverflows Method A Sandcastle Documented Class Library
Send Feedback
Draws the overflows of days

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawOverflows ( _
    e As CalendarRendererEventArgs _
)
Public Overridable Sub OnDrawOverflows ( _
    e As CalendarRendererEventArgs _
)
public virtual void OnDrawOverflows(
    CalendarRendererEventArgs e
)
public virtual void OnDrawOverflows(
    CalendarRendererEventArgs e
)
public:
virtual void OnDrawOverflows(
    CalendarRendererEventArgs^ e
)
public:
virtual void OnDrawOverflows(
    CalendarRendererEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererEventArgs
[Missing <param name="e"/> documentation for "M:WindowsFormsCalendar.CalendarRenderer.OnDrawOverflows(WindowsFormsCalendar.CalendarRendererEventArgs)"]
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawTimeScale Method

CalendarRenderer OnDrawTimeScale Method A Sandcastle Documented Class Library
Send Feedback
Paints the timescale of the calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawTimeScale ( _
    e As CalendarRendererEventArgs _
)
Public Overridable Sub OnDrawTimeScale ( _
    e As CalendarRendererEventArgs _
)
public virtual void OnDrawTimeScale(
    CalendarRendererEventArgs e
)
public virtual void OnDrawTimeScale(
    CalendarRendererEventArgs e
)
public:
virtual void OnDrawTimeScale(
    CalendarRendererEventArgs^ e
)
public:
virtual void OnDrawTimeScale(
    CalendarRendererEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererEventArgs
Paint info
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawTimeScaleHour Method

CalendarRenderer OnDrawTimeScaleHour Method A Sandcastle Documented Class Library
Send Feedback
Paints an hour of a timescale unit

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawTimeScaleHour ( _
    e As CalendarRendererBoxEventArgs _
)
Public Overridable Sub OnDrawTimeScaleHour ( _
    e As CalendarRendererBoxEventArgs _
)
public virtual void OnDrawTimeScaleHour(
    CalendarRendererBoxEventArgs e
)
public virtual void OnDrawTimeScaleHour(
    CalendarRendererBoxEventArgs e
)
public:
virtual void OnDrawTimeScaleHour(
    CalendarRendererBoxEventArgs^ e
)
public:
virtual void OnDrawTimeScaleHour(
    CalendarRendererBoxEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererBoxEventArgs
Paint Info
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawTimeScaleMinutes Method

CalendarRenderer OnDrawTimeScaleMinutes Method A Sandcastle Documented Class Library
Send Feedback
Paints minutes of a timescale unit

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawTimeScaleMinutes ( _
    e As CalendarRendererBoxEventArgs _
)
Public Overridable Sub OnDrawTimeScaleMinutes ( _
    e As CalendarRendererBoxEventArgs _
)
public virtual void OnDrawTimeScaleMinutes(
    CalendarRendererBoxEventArgs e
)
public virtual void OnDrawTimeScaleMinutes(
    CalendarRendererBoxEventArgs e
)
public:
virtual void OnDrawTimeScaleMinutes(
    CalendarRendererBoxEventArgs^ e
)
public:
virtual void OnDrawTimeScaleMinutes(
    CalendarRendererBoxEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererBoxEventArgs
Paint Info
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawWeekHeader Method

CalendarRenderer OnDrawWeekHeader Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:DrawWeekHeader] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawWeekHeader ( _
    e As CalendarRendererBoxEventArgs _
)
Public Overridable Sub OnDrawWeekHeader ( _
    e As CalendarRendererBoxEventArgs _
)
public virtual void OnDrawWeekHeader(
    CalendarRendererBoxEventArgs e
)
public virtual void OnDrawWeekHeader(
    CalendarRendererBoxEventArgs e
)
public:
virtual void OnDrawWeekHeader(
    CalendarRendererBoxEventArgs^ e
)
public:
virtual void OnDrawWeekHeader(
    CalendarRendererBoxEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererBoxEventArgs
The CalendarRendererBoxEventArgs instance containing the event data.
See Also
CalendarRenderer Class
CalendarRenderer Members


OnDrawWeekHeaders Method

CalendarRenderer OnDrawWeekHeaders Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:DrawWeekHeaders] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnDrawWeekHeaders ( _
    e As CalendarRendererEventArgs _
)
Public Overridable Sub OnDrawWeekHeaders ( _
    e As CalendarRendererEventArgs _
)
public virtual void OnDrawWeekHeaders(
    CalendarRendererEventArgs e
)
public virtual void OnDrawWeekHeaders(
    CalendarRendererEventArgs e
)
public:
virtual void OnDrawWeekHeaders(
    CalendarRendererEventArgs^ e
)
public:
virtual void OnDrawWeekHeaders(
    CalendarRendererEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererEventArgs
The CalendarRendererEventArgs instance containing the event data.
See Also
CalendarRenderer Class
CalendarRenderer Members


OnInitialize Method

CalendarRenderer OnInitialize Method A Sandcastle Documented Class Library
Send Feedback
Initializes the Calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Sub OnInitialize ( _
    e As CalendarRendererEventArgs _
)
Public Overridable Sub OnInitialize ( _
    e As CalendarRendererEventArgs _
)
public virtual void OnInitialize(
    CalendarRendererEventArgs e
)
public virtual void OnInitialize(
    CalendarRendererEventArgs e
)
public:
virtual void OnInitialize(
    CalendarRendererEventArgs^ e
)
public:
virtual void OnInitialize(
    CalendarRendererEventArgs^ e
)
Parameters
e
Type: WindowsFormsCalendar CalendarRendererEventArgs
[Missing <param name="e"/> documentation for "M:WindowsFormsCalendar.CalendarRenderer.OnInitialize(WindowsFormsCalendar.CalendarRendererEventArgs)"]
See Also
CalendarRenderer Class
CalendarRenderer Members


PerformItemsLayout Method

CalendarRenderer PerformItemsLayout Method A Sandcastle Documented Class Library
Send Feedback
Updates the bounds of CalendarItems

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub PerformItemsLayout
Public Sub PerformItemsLayout
public void PerformItemsLayout()
public void PerformItemsLayout()
public:
void PerformItemsLayout()
public:
void PerformItemsLayout()
See Also
CalendarRenderer Class
CalendarRenderer Members


PerformLayout Method

CalendarRenderer PerformLayout Method A Sandcastle Documented Class Library
Send Feedback
Overload List
 | Name | Description
Public method | PerformLayout | Peform layout of elements and items of the calendar
Public method | PerformLayout(Boolean) | Updates the bounds of graphical elements. Optionally calls PerformItemsLayout to update bounds of items.
Back to Top
See Also
CalendarRenderer Class
CalendarRenderer Members


PerformLayout Method

CalendarRenderer PerformLayout Method A Sandcastle Documented Class Library
Send Feedback
Peform layout of elements and items of the calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub PerformLayout
Public Sub PerformLayout
public void PerformLayout()
public void PerformLayout()
public:
void PerformLayout()
public:
void PerformLayout()
See Also
CalendarRenderer Class
CalendarRenderer Members
PerformLayout Overload


PerformLayout Method (Boolean)

CalendarRenderer PerformLayout Method (Boolean) A Sandcastle Documented Class Library
Send Feedback
Updates the bounds of graphical elements. Optionally calls PerformItemsLayout to update bounds of items.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub PerformLayout ( _
    performItemsLayout As Boolean _
)
Public Sub PerformLayout ( _
    performItemsLayout As Boolean _
)
public void PerformLayout(
    bool performItemsLayout
)
public void PerformLayout(
    bool performItemsLayout
)
public:
void PerformLayout(
    bool performItemsLayout
)
public:
void PerformLayout(
    bool performItemsLayout
)
Parameters
performItemsLayout
Type:   Online System Boolean
[Missing <param name="performItemsLayout"/> documentation for "M:WindowsFormsCalendar.CalendarRenderer.PerformLayout(System.Boolean)"]
Remarks

            This method is called every time the Calendar control is resized.

See Also
CalendarRenderer Class
CalendarRenderer Members
PerformLayout Overload


RoundRectangle Method

CalendarRenderer RoundRectangle Method A Sandcastle Documented Class Library
Send Feedback
Overload List
Name | Description
RoundRectangle(Rectangle, Int32) | Creates a rectangle with rounded corners
RoundRectangle(Rectangle, Int32, Corners) | Creates a rectangle with the specified corners rounded
Back to Top
See Also
CalendarRenderer Class
CalendarRenderer Members


RoundRectangle Method (Rectangle, Int32)

CalendarRenderer RoundRectangle Method (Rectangle, Int32) A Sandcastle Documented Class Library
Send Feedback
Creates a rectangle with rounded corners

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Shared Function RoundRectangle ( _
    r As Rectangle, _
    radius As Integer _
) As GraphicsPath
Public Shared Function RoundRectangle ( _
    r As Rectangle, _
    radius As Integer _
) As GraphicsPath
public static GraphicsPath RoundRectangle(
    Rectangle r,
    int radius
)
public static GraphicsPath RoundRectangle(
    Rectangle r,
    int radius
)
public:
static GraphicsPath^ RoundRectangle(
    Rectangle r,
    int radius
)
public:
static GraphicsPath^ RoundRectangle(
    Rectangle r,
    int radius
)
Parameters
r
Type:   Online System.Drawing Rectangle
[Missing <param name="r"/> documentation for "M:WindowsFormsCalendar.CalendarRenderer.RoundRectangle(System.Drawing.Rectangle,System.Int32)"]
radius
Type:   Online System Int32
[Missing <param name="radius"/> documentation for "M:WindowsFormsCalendar.CalendarRenderer.RoundRectangle(System.Drawing.Rectangle,System.Int32)"]
Return Value
[Missing <returns> documentation for "M:WindowsFormsCalendar.CalendarRenderer.RoundRectangle(System.Drawing.Rectangle,System.Int32)"]
See Also
CalendarRenderer Class
CalendarRenderer Members
RoundRectangle Overload


RoundRectangle Method (Rectangle, Int32, Corners)

CalendarRenderer RoundRectangle Method (Rectangle, Int32, Corners) A Sandcastle Documented Class Library
Send Feedback
Creates a rectangle with the specified corners rounded

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Shared Function RoundRectangle ( _
    r As Rectangle, _
    radius As Integer, _
    corners As Corners _
) As GraphicsPath
Public Shared Function RoundRectangle ( _
    r As Rectangle, _
    radius As Integer, _
    corners As Corners _
) As GraphicsPath
public static GraphicsPath RoundRectangle(
    Rectangle r,
    int radius,
    Corners corners
)
public static GraphicsPath RoundRectangle(
    Rectangle r,
    int radius,
    Corners corners
)
public:
static GraphicsPath^ RoundRectangle(
    Rectangle r,
    int radius,
    Corners corners
)
public:
static GraphicsPath^ RoundRectangle(
    Rectangle r,
    int radius,
    Corners corners
)
Parameters
r
Type:   Online System.Drawing Rectangle
[Missing <param name="r"/> documentation for "M:WindowsFormsCalendar.CalendarRenderer.RoundRectangle(System.Drawing.Rectangle,System.Int32,WindowsFormsCalendar.Corners)"]
radius
Type:   Online System Int32
[Missing <param name="radius"/> documentation for "M:WindowsFormsCalendar.CalendarRenderer.RoundRectangle(System.Drawing.Rectangle,System.Int32,WindowsFormsCalendar.Corners)"]
corners
Type: WindowsFormsCalendar Corners
[Missing <param name="corners"/> documentation for "M:WindowsFormsCalendar.CalendarRenderer.RoundRectangle(System.Drawing.Rectangle,System.Int32,WindowsFormsCalendar.Corners)"]
Return Value
[Missing <returns> documentation for "M:WindowsFormsCalendar.CalendarRenderer.RoundRectangle(System.Drawing.Rectangle,System.Int32,WindowsFormsCalendar.Corners)"]
See Also
CalendarRenderer Class
CalendarRenderer Members
RoundRectangle Overload


SetDayHeaderHeight Method

CalendarRenderer SetDayHeaderHeight Method A Sandcastle Documented Class Library
Send Feedback
Sets the value of the DayHeaderHeight property

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Sub SetDayHeaderHeight ( _
    height As Integer _
)
Protected Sub SetDayHeaderHeight ( _
    height As Integer _
)
protected void SetDayHeaderHeight(
    int height
)
protected void SetDayHeaderHeight(
    int height
)
protected:
void SetDayHeaderHeight(
    int height
)
protected:
void SetDayHeaderHeight(
    int height
)
Parameters
height
Type:   Online System Int32
Height of the day header
See Also
CalendarRenderer Class
CalendarRenderer Members


SetDayNameHeadersHeight Method

CalendarRenderer SetDayNameHeadersHeight Method A Sandcastle Documented Class Library
Send Feedback
Sets the value of the DayNameHeadersHeight property

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Sub SetDayNameHeadersHeight ( _
    height As Integer _
)
Protected Sub SetDayNameHeadersHeight ( _
    height As Integer _
)
protected void SetDayNameHeadersHeight(
    int height
)
protected void SetDayNameHeadersHeight(
    int height
)
protected:
void SetDayNameHeadersHeight(
    int height
)
protected:
void SetDayNameHeadersHeight(
    int height
)
Parameters
height
Type:   Online System Int32
Height of the day name headers
See Also
CalendarRenderer Class
CalendarRenderer Members


SetDayTopHeight Method

CalendarRenderer SetDayTopHeight Method A Sandcastle Documented Class Library
Send Feedback
Sets the value of the DayTopHeight property

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Sub SetDayTopHeight ( _
    height As Integer _
)
Protected Sub SetDayTopHeight ( _
    height As Integer _
)
protected void SetDayTopHeight(
    int height
)
protected void SetDayTopHeight(
    int height
)
protected:
void SetDayTopHeight(
    int height
)
protected:
void SetDayTopHeight(
    int height
)
Parameters
height
Type:   Online System Int32
Height of all CalendarDayTop elements
See Also
CalendarRenderer Class
CalendarRenderer Members


SetTimeScaleUnitHeight Method

CalendarRenderer SetTimeScaleUnitHeight Method A Sandcastle Documented Class Library
Send Feedback
Sets the value of the TimeScaleUnitHeight property

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Sub SetTimeScaleUnitHeight ( _
    height As Integer _
)
Protected Sub SetTimeScaleUnitHeight ( _
    height As Integer _
)
protected void SetTimeScaleUnitHeight(
    int height
)
protected void SetTimeScaleUnitHeight(
    int height
)
protected:
void SetTimeScaleUnitHeight(
    int height
)
protected:
void SetTimeScaleUnitHeight(
    int height
)
Parameters
height
Type:   Online System Int32
Height of the time scale unit
See Also
CalendarRenderer Class
CalendarRenderer Members


SetTimeScaleWidth Method

CalendarRenderer SetTimeScaleWidth Method A Sandcastle Documented Class Library
Send Feedback
Sets the value of the TimeScaleWidth property

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Sub SetTimeScaleWidth ( _
    width As Integer _
)
Protected Sub SetTimeScaleWidth ( _
    width As Integer _
)
protected void SetTimeScaleWidth(
    int width
)
protected void SetTimeScaleWidth(
    int width
)
protected:
void SetTimeScaleWidth(
    int width
)
protected:
void SetTimeScaleWidth(
    int width
)
Parameters
width
Type:   Online System Int32
New width for the time scale
See Also
CalendarRenderer Class
CalendarRenderer Members


CalendarRenderer Properties

CalendarRenderer Properties A Sandcastle Documented Class Library
Send Feedback
The CalendarRenderer type exposes the following members.
Properties
 | Name | Description
Public property | Calendar | Gets the Calendar this renderer belongs to
Public property | DayHeaderHeight | Gets the height of the header of days
Public property | DayNameHeaderColumns | Gets the bounds for day name headers
Public property | DayNameHeadersHeight | Gets the height of the day name headers
Public property | DayNameHeadersVisible | Gets a value indicating if the day names headers are visible (e.g. Monday, Tuesday, Wednesday ...)
Public property | DayTopHeight | Gets the current height of the all day items area
Public property | DayTopItemsPadding | Gets or sets the padding of the items that goes on the top part of the days, when in Expanded
Public property | DayTopMinHeight | Gets the minimum height for day tops
Public property | ItemInvalidateMargin | Gets or sets the extra margin for invalidating and redrawing items
Public property | ItemRoundness | Gets or sets the roundness of the item
Public property | ItemShadowPadding | Gets or sets the amount of pixels that the item's shadow is dropped
Public property | ItemsPadding | Gets or sets the padding of items on expanded mode
Public property | ItemTextMargin | Gets the margin of the text in the items
Public property | StandardItemHeight | Gets the height of items on day tops
Public property | TimeScaleBounds | Gets or sets the bounds of the timescale
Public property | TimeScaleUnitHeight | Gets the height of the time scale unit.
Public property | TimeScaleVisible | Gets a value indicating whether [time scale visible].
Public property | TimeScaleWidth | Gets the width of the timescale
Public property | WeekHeaderWidth | Gets the width of the week header.
Back to Top
See Also
CalendarRenderer Class


Calendar Property

CalendarRenderer Calendar Property A Sandcastle Documented Class Library
Send Feedback
Gets the Calendar this renderer belongs to

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Calendar As Calendar
    Get
Public ReadOnly Property Calendar As Calendar
    Get
public Calendar Calendar { get; }
public Calendar Calendar { get; }
public:
property Calendar^ Calendar {
    Calendar^ get ();
}
public:
property Calendar^ Calendar {
    Calendar^ get ();
}
See Also
CalendarRenderer Class
CalendarRenderer Members


DayHeaderHeight Property

CalendarRenderer DayHeaderHeight Property A Sandcastle Documented Class Library
Send Feedback
Gets the height of the header of days

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable ReadOnly Property DayHeaderHeight As Integer
    Get
Public Overridable ReadOnly Property DayHeaderHeight As Integer
    Get
public virtual int DayHeaderHeight { get; }
public virtual int DayHeaderHeight { get; }
public:
virtual property int DayHeaderHeight {
    int get ();
}
public:
virtual property int DayHeaderHeight {
    int get ();
}
Field Value

            The height of the day header.

See Also
CalendarRenderer Class
CalendarRenderer Members


DayNameHeaderColumns Property

CalendarRenderer DayNameHeaderColumns Property A Sandcastle Documented Class Library
Send Feedback
Gets the bounds for day name headers

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property DayNameHeaderColumns As Rectangle()
    Get
Public ReadOnly Property DayNameHeaderColumns As Rectangle()
    Get
public Rectangle[] DayNameHeaderColumns { get; }
public Rectangle[] DayNameHeaderColumns { get; }
public:
property array<Rectangle>^ DayNameHeaderColumns {
    array<Rectangle>^ get ();
}
public:
property array<Rectangle>^ DayNameHeaderColumns {
    array<Rectangle>^ get ();
}
See Also
CalendarRenderer Class
CalendarRenderer Members


DayNameHeadersHeight Property

CalendarRenderer DayNameHeadersHeight Property A Sandcastle Documented Class Library
Send Feedback
Gets the height of the day name headers

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable ReadOnly Property DayNameHeadersHeight As Integer
    Get
Public Overridable ReadOnly Property DayNameHeadersHeight As Integer
    Get
public virtual int DayNameHeadersHeight { get; }
public virtual int DayNameHeadersHeight { get; }
public:
virtual property int DayNameHeadersHeight {
    int get ();
}
public:
virtual property int DayNameHeadersHeight {
    int get ();
}
Field Value

            The height of the day name headers.

See Also
CalendarRenderer Class
CalendarRenderer Members


DayNameHeadersVisible Property

CalendarRenderer DayNameHeadersVisible Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if the day names headers are visible (e.g. Monday, Tuesday, Wednesday ...)

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property DayNameHeadersVisible As Boolean
    Get
Public ReadOnly Property DayNameHeadersVisible As Boolean
    Get
public bool DayNameHeadersVisible { get; }
public bool DayNameHeadersVisible { get; }
public:
property bool DayNameHeadersVisible {
    bool get ();
}
public:
property bool DayNameHeadersVisible {
    bool get ();
}
Field Value
true if [day name headers visible]; otherwise, false.

See Also
CalendarRenderer Class
CalendarRenderer Members


DayTopHeight Property

CalendarRenderer DayTopHeight Property A Sandcastle Documented Class Library
Send Feedback
Gets the current height of the all day items area

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Property DayTopHeight As Integer
    Get
    Set
Public Overridable Property DayTopHeight As Integer
    Get
    Set
public virtual int DayTopHeight { get; set; }
public virtual int DayTopHeight { get; set; }
public:
virtual property int DayTopHeight {
    int get ();
    void set (int value);
}
public:
virtual property int DayTopHeight {
    int get ();
    void set (int value);
}
Field Value

            The height of the day top.

See Also
CalendarRenderer Class
CalendarRenderer Members


DayTopItemsPadding Property

CalendarRenderer DayTopItemsPadding Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the padding of the items that goes on the top part of the days, when in Expanded

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property DayTopItemsPadding As Integer
    Get
    Set
Public Property DayTopItemsPadding As Integer
    Get
    Set
public int DayTopItemsPadding { get; set; }
public int DayTopItemsPadding { get; set; }
public:
property int DayTopItemsPadding {
    int get ();
    void set (int value);
}
public:
property int DayTopItemsPadding {
    int get ();
    void set (int value);
}
Field Value

            The day top items padding.

See Also
CalendarRenderer Class
CalendarRenderer Members


DayTopMinHeight Property

CalendarRenderer DayTopMinHeight Property A Sandcastle Documented Class Library
Send Feedback
Gets the minimum height for day tops

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable ReadOnly Property DayTopMinHeight As Integer
    Get
Public Overridable ReadOnly Property DayTopMinHeight As Integer
    Get
public virtual int DayTopMinHeight { get; }
public virtual int DayTopMinHeight { get; }
public:
virtual property int DayTopMinHeight {
    int get ();
}
public:
virtual property int DayTopMinHeight {
    int get ();
}
Field Value

            The height of the day top min.

See Also
CalendarRenderer Class
CalendarRenderer Members


ItemInvalidateMargin Property

CalendarRenderer ItemInvalidateMargin Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the extra margin for invalidating and redrawing items

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property ItemInvalidateMargin As Integer
    Get
    Set
Public Property ItemInvalidateMargin As Integer
    Get
    Set
public int ItemInvalidateMargin { get; set; }
public int ItemInvalidateMargin { get; set; }
public:
property int ItemInvalidateMargin {
    int get ();
    void set (int value);
}
public:
property int ItemInvalidateMargin {
    int get ();
    void set (int value);
}
Field Value

            The item invalidate margin.

See Also
CalendarRenderer Class
CalendarRenderer Members


ItemRoundness Property

CalendarRenderer ItemRoundness Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the roundness of the item

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property ItemRoundness As Integer
    Get
    Set
Public Property ItemRoundness As Integer
    Get
    Set
public int ItemRoundness { get; set; }
public int ItemRoundness { get; set; }
public:
property int ItemRoundness {
    int get ();
    void set (int value);
}
public:
property int ItemRoundness {
    int get ();
    void set (int value);
}
Field Value

            The item roundness.

See Also
CalendarRenderer Class
CalendarRenderer Members


ItemShadowPadding Property

CalendarRenderer ItemShadowPadding Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the amount of pixels that the item's shadow is dropped

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Property ItemShadowPadding As Integer
    Get
    Set
Public Overridable Property ItemShadowPadding As Integer
    Get
    Set
public virtual int ItemShadowPadding { get; set; }
public virtual int ItemShadowPadding { get; set; }
public:
virtual property int ItemShadowPadding {
    int get ();
    void set (int value);
}
public:
virtual property int ItemShadowPadding {
    int get ();
    void set (int value);
}
Field Value

            The item shadow padding.

See Also
CalendarRenderer Class
CalendarRenderer Members


ItemsPadding Property

CalendarRenderer ItemsPadding Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the padding of items on expanded mode

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property ItemsPadding As Integer
    Get
    Set
Public Property ItemsPadding As Integer
    Get
    Set
public int ItemsPadding { get; set; }
public int ItemsPadding { get; set; }
public:
property int ItemsPadding {
    int get ();
    void set (int value);
}
public:
property int ItemsPadding {
    int get ();
    void set (int value);
}
Field Value

            The items padding.

See Also
CalendarRenderer Class
CalendarRenderer Members


ItemTextMargin Property

CalendarRenderer ItemTextMargin Property A Sandcastle Documented Class Library
Send Feedback
Gets the margin of the text in the items

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Property ItemTextMargin As Padding
    Get
    Set
Public Overridable Property ItemTextMargin As Padding
    Get
    Set
public virtual Padding ItemTextMargin { get; set; }
public virtual Padding ItemTextMargin { get; set; }
public:
virtual property Padding ItemTextMargin {
    Padding get ();
    void set (Padding value);
}
public:
virtual property Padding ItemTextMargin {
    Padding get ();
    void set (Padding value);
}
Field Value

            The item text margin.

See Also
CalendarRenderer Class
CalendarRenderer Members


StandardItemHeight Property

CalendarRenderer StandardItemHeight Property A Sandcastle Documented Class Library
Send Feedback
Gets the height of items on day tops

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable ReadOnly Property StandardItemHeight As Integer
    Get
Public Overridable ReadOnly Property StandardItemHeight As Integer
    Get
public virtual int StandardItemHeight { get; }
public virtual int StandardItemHeight { get; }
public:
virtual property int StandardItemHeight {
    int get ();
}
public:
virtual property int StandardItemHeight {
    int get ();
}
Field Value

            The height of the standard item.

See Also
CalendarRenderer Class
CalendarRenderer Members


TimeScaleBounds Property

CalendarRenderer TimeScaleBounds Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the bounds of the timescale

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property TimeScaleBounds As Rectangle
    Get
    Set
Public Property TimeScaleBounds As Rectangle
    Get
    Set
public Rectangle TimeScaleBounds { get; set; }
public Rectangle TimeScaleBounds { get; set; }
public:
property Rectangle TimeScaleBounds {
    Rectangle get ();
    void set (Rectangle value);
}
public:
property Rectangle TimeScaleBounds {
    Rectangle get ();
    void set (Rectangle value);
}
Field Value

            The time scale bounds.

See Also
CalendarRenderer Class
CalendarRenderer Members


TimeScaleUnitHeight Property

CalendarRenderer TimeScaleUnitHeight Property A Sandcastle Documented Class Library
Send Feedback
Gets the height of the time scale unit.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable ReadOnly Property TimeScaleUnitHeight As Integer
    Get
Public Overridable ReadOnly Property TimeScaleUnitHeight As Integer
    Get
public virtual int TimeScaleUnitHeight { get; }
public virtual int TimeScaleUnitHeight { get; }
public:
virtual property int TimeScaleUnitHeight {
    int get ();
}
public:
virtual property int TimeScaleUnitHeight {
    int get ();
}
Field Value

            The height of the time scale unit.

See Also
CalendarRenderer Class
CalendarRenderer Members


TimeScaleVisible Property

CalendarRenderer TimeScaleVisible Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating whether [time scale visible].

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property TimeScaleVisible As Boolean
    Get
Public ReadOnly Property TimeScaleVisible As Boolean
    Get
public bool TimeScaleVisible { get; }
public bool TimeScaleVisible { get; }
public:
property bool TimeScaleVisible {
    bool get ();
}
public:
property bool TimeScaleVisible {
    bool get ();
}
Field Value
true if [time scale visible]; otherwise, false.

See Also
CalendarRenderer Class
CalendarRenderer Members


TimeScaleWidth Property

CalendarRenderer TimeScaleWidth Property A Sandcastle Documented Class Library
Send Feedback
Gets the width of the timescale

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable ReadOnly Property TimeScaleWidth As Integer
    Get
Public Overridable ReadOnly Property TimeScaleWidth As Integer
    Get
public virtual int TimeScaleWidth { get; }
public virtual int TimeScaleWidth { get; }
public:
virtual property int TimeScaleWidth {
    int get ();
}
public:
virtual property int TimeScaleWidth {
    int get ();
}
Field Value

            The width of the time scale.

See Also
CalendarRenderer Class
CalendarRenderer Members


WeekHeaderWidth Property

CalendarRenderer WeekHeaderWidth Property A Sandcastle Documented Class Library
Send Feedback
Gets the width of the week header.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable ReadOnly Property WeekHeaderWidth As Integer
    Get
Public Overridable ReadOnly Property WeekHeaderWidth As Integer
    Get
public virtual int WeekHeaderWidth { get; }
public virtual int WeekHeaderWidth { get; }
public:
virtual property int WeekHeaderWidth {
    int get ();
}
public:
virtual property int WeekHeaderWidth {
    int get ();
}
Field Value

            The width of the week header.

See Also
CalendarRenderer Class
CalendarRenderer Members


CalendarRendererBoxEventArgs Class

CalendarRendererBoxEventArgs Class A Sandcastle Documented Class Library
Send Feedback
Contains information about something's bounds and text to draw on the calendar
Inheritance Hierarchy
Online System Object
Online System EventArgs
WindowsFormsCalendar CalendarRendererEventArgs
WindowsFormsCalendar CalendarRendererBoxEventArgs

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class CalendarRendererBoxEventArgs _
    Inherits CalendarRendererEventArgs
Public Class CalendarRendererBoxEventArgs _
    Inherits CalendarRendererEventArgs
public class CalendarRendererBoxEventArgs : CalendarRendererEventArgs
public class CalendarRendererBoxEventArgs : CalendarRendererEventArgs
public ref class CalendarRendererBoxEventArgs : public CalendarRendererEventArgs
public ref class CalendarRendererBoxEventArgs : public CalendarRendererEventArgs
See Also
CalendarRendererBoxEventArgs Members


CalendarRendererBoxEventArgs Members

CalendarRendererBoxEventArgs Members A Sandcastle Documented Class Library
Send Feedback

The CalendarRendererBoxEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | CalendarRendererBoxEventArgs(CalendarRendererEventArgs) | Initializes a new instance of the CalendarRendererBoxEventArgs class.
Public method | CalendarRendererBoxEventArgs(CalendarRendererEventArgs, Rectangle) | Initializes a new instance of the CalendarRendererBoxEventArgs class.
Public method | CalendarRendererBoxEventArgs(CalendarRendererEventArgs, Rectangle, String) | Initializes a new instance of the CalendarRendererBoxEventArgs class.
Public method | CalendarRendererBoxEventArgs(CalendarRendererEventArgs, Rectangle, String, Color) | Initializes a new instance of the CalendarRendererBoxEventArgs class.
Public method | CalendarRendererBoxEventArgs(CalendarRendererEventArgs, Rectangle, String, TextFormatFlags) | Initializes a new instance of the CalendarRendererBoxEventArgs class.
Public method | CalendarRendererBoxEventArgs(CalendarRendererEventArgs, Rectangle, String, Color, Color) | Initializes a new instance of the CalendarRendererBoxEventArgs class.
Public method | CalendarRendererBoxEventArgs(CalendarRendererEventArgs, Rectangle, String, Color, TextFormatFlags) | Initializes a new instance of the CalendarRendererBoxEventArgs class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | BackgroundColor | Gets or sets the background color of the text
Public property | Bounds | Gets or sets the bounds to draw the text
Public property | Calendar | Gets the calendar where painting (Inherited from CalendarRendererEventArgs.)
Public property | ClipRectangle | Gets the clip of the paint event (Inherited from CalendarRendererEventArgs.)
Public property | Font | Gets or sets the font of the text to be rendered
Public property | Format | Gets or sets the format to draw the text
Public property | Graphics | Gets the device where to paint (Inherited from CalendarRendererEventArgs.)
Public property | Tag | Gets or sets a tag for the event (Inherited from CalendarRendererEventArgs.)
Public property | Text | Gets or sets the text to draw
Public property | TextColor | Gets or sets the color to draw the text
Public property | TextSize | Gets the result of measuring the text
Back to Top
See Also
CalendarRendererBoxEventArgs Class


CalendarRendererBoxEventArgs Constructor

CalendarRendererBoxEventArgs Constructor A Sandcastle Documented Class Library
Send Feedback
Overload List
 | Name | Description
Public method | CalendarRendererBoxEventArgs(CalendarRendererEventArgs) | Initializes a new instance of the CalendarRendererBoxEventArgs class.
Public method | CalendarRendererBoxEventArgs(CalendarRendererEventArgs, Rectangle) | Initializes a new instance of the CalendarRendererBoxEventArgs class.
Public method | CalendarRendererBoxEventArgs(CalendarRendererEventArgs, Rectangle, String) | Initializes a new instance of the CalendarRendererBoxEventArgs class.
Public method | CalendarRendererBoxEventArgs(CalendarRendererEventArgs, Rectangle, String, Color) | Initializes a new instance of the CalendarRendererBoxEventArgs class.
Public method | CalendarRendererBoxEventArgs(CalendarRendererEventArgs, Rectangle, String, TextFormatFlags) | Initializes a new instance of the CalendarRendererBoxEventArgs class.
Public method | CalendarRendererBoxEventArgs(CalendarRendererEventArgs, Rectangle, String, Color, Color) | Initializes a new instance of the CalendarRendererBoxEventArgs class.
Public method | CalendarRendererBoxEventArgs(CalendarRendererEventArgs, Rectangle, String, Color, TextFormatFlags) | Initializes a new instance of the CalendarRendererBoxEventArgs class.
Back to Top
See Also
CalendarRendererBoxEventArgs Class
CalendarRendererBoxEventArgs Members


CalendarRendererBoxEventArgs Constructor (CalendarRendererEventArgs)

CalendarRendererBoxEventArgs Constructor (CalendarRendererEventArgs) A Sandcastle Documented Class Library
Send Feedback
Initializes a new instance of the CalendarRendererBoxEventArgs class.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    original As CalendarRendererEventArgs _
)
Public Sub New ( _
    original As CalendarRendererEventArgs _
)
public CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs original
)
public CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs original
)
public:
CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs^ original
)
public:
CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs^ original
)
Parameters
original
Type: WindowsFormsCalendar CalendarRendererEventArgs
The CalendarRendererEventArgs instance containing the event data.
See Also
CalendarRendererBoxEventArgs Class
CalendarRendererBoxEventArgs Members
CalendarRendererBoxEventArgs Overload


CalendarRendererBoxEventArgs Constructor (CalendarRendererEventArgs, Rectangle)

CalendarRendererBoxEventArgs Constructor (CalendarRendererEventArgs, Rectangle) A Sandcastle Documented Class Library
Send Feedback
Initializes a new instance of the CalendarRendererBoxEventArgs class.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    original As CalendarRendererEventArgs, _
    bounds As Rectangle _
)
Public Sub New ( _
    original As CalendarRendererEventArgs, _
    bounds As Rectangle _
)
public CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs original,
    Rectangle bounds
)
public CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs original,
    Rectangle bounds
)
public:
CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs^ original,
    Rectangle bounds
)
public:
CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs^ original,
    Rectangle bounds
)
Parameters
original
Type: WindowsFormsCalendar CalendarRendererEventArgs
The CalendarRendererEventArgs instance containing the event data.
bounds
Type:   Online System.Drawing Rectangle
The bounds.
See Also
CalendarRendererBoxEventArgs Class
CalendarRendererBoxEventArgs Members
CalendarRendererBoxEventArgs Overload


CalendarRendererBoxEventArgs Constructor (CalendarRendererEventArgs, Rectangle, String)

CalendarRendererBoxEventArgs Constructor (CalendarRendererEventArgs, Rectangle, String) A Sandcastle Documented Class Library
Send Feedback
Initializes a new instance of the CalendarRendererBoxEventArgs class.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    original As CalendarRendererEventArgs, _
    bounds As Rectangle, _
    text As String _
)
Public Sub New ( _
    original As CalendarRendererEventArgs, _
    bounds As Rectangle, _
    text As String _
)
public CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs original,
    Rectangle bounds,
    string text
)
public CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs original,
    Rectangle bounds,
    string text
)
public:
CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs^ original,
    Rectangle bounds,
    String^ text
)
public:
CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs^ original,
    Rectangle bounds,
    String^ text
)
Parameters
original
Type: WindowsFormsCalendar CalendarRendererEventArgs
The CalendarRendererEventArgs instance containing the event data.
bounds
Type:   Online System.Drawing Rectangle
The bounds.
text
Type:   Online System String
The text.
See Also
CalendarRendererBoxEventArgs Class
CalendarRendererBoxEventArgs Members
CalendarRendererBoxEventArgs Overload


CalendarRendererBoxEventArgs Constructor (CalendarRendererEventArgs, Rectangle, String, Color)

CalendarRendererBoxEventArgs Constructor (CalendarRendererEventArgs, Rectangle, String, Color) A Sandcastle Documented Class Library
Send Feedback
Initializes a new instance of the CalendarRendererBoxEventArgs class.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    original As CalendarRendererEventArgs, _
    bounds As Rectangle, _
    text As String, _
    textColor As Color _
)
Public Sub New ( _
    original As CalendarRendererEventArgs, _
    bounds As Rectangle, _
    text As String, _
    textColor As Color _
)
public CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs original,
    Rectangle bounds,
    string text,
    Color textColor
)
public CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs original,
    Rectangle bounds,
    string text,
    Color textColor
)
public:
CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs^ original,
    Rectangle bounds,
    String^ text,
    Color textColor
)
public:
CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs^ original,
    Rectangle bounds,
    String^ text,
    Color textColor
)
Parameters
original
Type: WindowsFormsCalendar CalendarRendererEventArgs
The CalendarRendererEventArgs instance containing the event data.
bounds
Type:   Online System.Drawing Rectangle
The bounds.
text
Type:   Online System String
The text.
textColor
Type:   Online System.Drawing Color
Color of the text.
See Also
CalendarRendererBoxEventArgs Class
CalendarRendererBoxEventArgs Members
CalendarRendererBoxEventArgs Overload


CalendarRendererBoxEventArgs Constructor (CalendarRendererEventArgs, Rectangle, String, TextFormatFlags)

CalendarRendererBoxEventArgs Constructor (CalendarRendererEventArgs, Rectangle, String, TextFormatFlags) A Sandcastle Documented Class Library
Send Feedback
Initializes a new instance of the CalendarRendererBoxEventArgs class.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    original As CalendarRendererEventArgs, _
    bounds As Rectangle, _
    text As String, _
    flags As TextFormatFlags _
)
Public Sub New ( _
    original As CalendarRendererEventArgs, _
    bounds As Rectangle, _
    text As String, _
    flags As TextFormatFlags _
)
public CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs original,
    Rectangle bounds,
    string text,
    TextFormatFlags flags
)
public CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs original,
    Rectangle bounds,
    string text,
    TextFormatFlags flags
)
public:
CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs^ original,
    Rectangle bounds,
    String^ text,
    TextFormatFlags flags
)
public:
CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs^ original,
    Rectangle bounds,
    String^ text,
    TextFormatFlags flags
)
Parameters
original
Type: WindowsFormsCalendar CalendarRendererEventArgs
The CalendarRendererEventArgs instance containing the event data.
bounds
Type:   Online System.Drawing Rectangle
The bounds.
text
Type:   Online System String
The text.
flags
Type:   Online System.Windows.Forms TextFormatFlags
The flags.
See Also
CalendarRendererBoxEventArgs Class
CalendarRendererBoxEventArgs Members
CalendarRendererBoxEventArgs Overload


CalendarRendererBoxEventArgs Constructor (CalendarRendererEventArgs, Rectangle, String, Color, Color)

CalendarRendererBoxEventArgs Constructor (CalendarRendererEventArgs, Rectangle, String, Color, Color) A Sandcastle Documented Class Library
Send Feedback
Initializes a new instance of the CalendarRendererBoxEventArgs class.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    original As CalendarRendererEventArgs, _
    bounds As Rectangle, _
    text As String, _
    textColor As Color, _
    backgroundColor As Color _
)
Public Sub New ( _
    original As CalendarRendererEventArgs, _
    bounds As Rectangle, _
    text As String, _
    textColor As Color, _
    backgroundColor As Color _
)
public CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs original,
    Rectangle bounds,
    string text,
    Color textColor,
    Color backgroundColor
)
public CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs original,
    Rectangle bounds,
    string text,
    Color textColor,
    Color backgroundColor
)
public:
CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs^ original,
    Rectangle bounds,
    String^ text,
    Color textColor,
    Color backgroundColor
)
public:
CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs^ original,
    Rectangle bounds,
    String^ text,
    Color textColor,
    Color backgroundColor
)
Parameters
original
Type: WindowsFormsCalendar CalendarRendererEventArgs
The CalendarRendererEventArgs instance containing the event data.
bounds
Type:   Online System.Drawing Rectangle
The bounds.
text
Type:   Online System String
The text.
textColor
Type:   Online System.Drawing Color
Color of the text.
backgroundColor
Type:   Online System.Drawing Color
Color of the background.
See Also
CalendarRendererBoxEventArgs Class
CalendarRendererBoxEventArgs Members
CalendarRendererBoxEventArgs Overload


CalendarRendererBoxEventArgs Constructor (CalendarRendererEventArgs, Rectangle, String, Color, TextFormatFlags)

CalendarRendererBoxEventArgs Constructor (CalendarRendererEventArgs, Rectangle, String, Color, TextFormatFlags) A Sandcastle Documented Class Library
Send Feedback
Initializes a new instance of the CalendarRendererBoxEventArgs class.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    original As CalendarRendererEventArgs, _
    bounds As Rectangle, _
    text As String, _
    textColor As Color, _
    flags As TextFormatFlags _
)
Public Sub New ( _
    original As CalendarRendererEventArgs, _
    bounds As Rectangle, _
    text As String, _
    textColor As Color, _
    flags As TextFormatFlags _
)
public CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs original,
    Rectangle bounds,
    string text,
    Color textColor,
    TextFormatFlags flags
)
public CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs original,
    Rectangle bounds,
    string text,
    Color textColor,
    TextFormatFlags flags
)
public:
CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs^ original,
    Rectangle bounds,
    String^ text,
    Color textColor,
    TextFormatFlags flags
)
public:
CalendarRendererBoxEventArgs(
    CalendarRendererEventArgs^ original,
    Rectangle bounds,
    String^ text,
    Color textColor,
    TextFormatFlags flags
)
Parameters
original
Type: WindowsFormsCalendar CalendarRendererEventArgs
The CalendarRendererEventArgs instance containing the event data.
bounds
Type:   Online System.Drawing Rectangle
The bounds.
text
Type:   Online System String
The text.
textColor
Type:   Online System.Drawing Color
Color of the text.
flags
Type:   Online System.Windows.Forms TextFormatFlags
The flags.
See Also
CalendarRendererBoxEventArgs Class
CalendarRendererBoxEventArgs Members
CalendarRendererBoxEventArgs Overload


CalendarRendererBoxEventArgs Methods

CalendarRendererBoxEventArgs Methods A Sandcastle Documented Class Library
Send Feedback
The CalendarRendererBoxEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CalendarRendererBoxEventArgs Class


CalendarRendererBoxEventArgs Properties

CalendarRendererBoxEventArgs Properties A Sandcastle Documented Class Library
Send Feedback
The CalendarRendererBoxEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | BackgroundColor | Gets or sets the background color of the text
Public property | Bounds | Gets or sets the bounds to draw the text
Public property | Calendar | Gets the calendar where painting (Inherited from CalendarRendererEventArgs.)
Public property | ClipRectangle | Gets the clip of the paint event (Inherited from CalendarRendererEventArgs.)
Public property | Font | Gets or sets the font of the text to be rendered
Public property | Format | Gets or sets the format to draw the text
Public property | Graphics | Gets the device where to paint (Inherited from CalendarRendererEventArgs.)
Public property | Tag | Gets or sets a tag for the event (Inherited from CalendarRendererEventArgs.)
Public property | Text | Gets or sets the text to draw
Public property | TextColor | Gets or sets the color to draw the text
Public property | TextSize | Gets the result of measuring the text
Back to Top
See Also
CalendarRendererBoxEventArgs Class


BackgroundColor Property

CalendarRendererBoxEventArgs BackgroundColor Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the background color of the text

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property BackgroundColor As Color
    Get
    Set
Public Property BackgroundColor As Color
    Get
    Set
public Color BackgroundColor { get; set; }
public Color BackgroundColor { get; set; }
public:
property Color BackgroundColor {
    Color get ();
    void set (Color value);
}
public:
property Color BackgroundColor {
    Color get ();
    void set (Color value);
}
See Also
CalendarRendererBoxEventArgs Class
CalendarRendererBoxEventArgs Members


Bounds Property

CalendarRendererBoxEventArgs Bounds Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the bounds to draw the text

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property Bounds As Rectangle
    Get
    Set
Public Property Bounds As Rectangle
    Get
    Set
public Rectangle Bounds { get; set; }
public Rectangle Bounds { get; set; }
public:
property Rectangle Bounds {
    Rectangle get ();
    void set (Rectangle value);
}
public:
property Rectangle Bounds {
    Rectangle get ();
    void set (Rectangle value);
}
See Also
CalendarRendererBoxEventArgs Class
CalendarRendererBoxEventArgs Members


Font Property

CalendarRendererBoxEventArgs Font Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the font of the text to be rendered

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property Font As Font
    Get
    Set
Public Property Font As Font
    Get
    Set
public Font Font { get; set; }
public Font Font { get; set; }
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
See Also
CalendarRendererBoxEventArgs Class
CalendarRendererBoxEventArgs Members


Format Property

CalendarRendererBoxEventArgs Format Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the format to draw the text

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property Format As TextFormatFlags
    Get
    Set
Public Property Format As TextFormatFlags
    Get
    Set
public TextFormatFlags Format { get; set; }
public TextFormatFlags Format { get; set; }
public:
property TextFormatFlags Format {
    TextFormatFlags get ();
    void set (TextFormatFlags value);
}
public:
property TextFormatFlags Format {
    TextFormatFlags get ();
    void set (TextFormatFlags value);
}
See Also
CalendarRendererBoxEventArgs Class
CalendarRendererBoxEventArgs Members


Text Property

CalendarRendererBoxEventArgs Text Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the text to draw

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property Text As String
    Get
    Set
Public Property Text As String
    Get
    Set
public string Text { get; set; }
public string Text { get; set; }
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
See Also
CalendarRendererBoxEventArgs Class
CalendarRendererBoxEventArgs Members


TextColor Property

CalendarRendererBoxEventArgs TextColor Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the color to draw the text

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property TextColor As Color
    Get
    Set
Public Property TextColor As Color
    Get
    Set
public Color TextColor { get; set; }
public Color TextColor { get; set; }
public:
property Color TextColor {
    Color get ();
    void set (Color value);
}
public:
property Color TextColor {
    Color get ();
    void set (Color value);
}
See Also
CalendarRendererBoxEventArgs Class
CalendarRendererBoxEventArgs Members


TextSize Property

CalendarRendererBoxEventArgs TextSize Property A Sandcastle Documented Class Library
Send Feedback
Gets the result of measuring the text

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property TextSize As Size
    Get
Public ReadOnly Property TextSize As Size
    Get
public Size TextSize { get; }
public Size TextSize { get; }
public:
property Size TextSize {
    Size get ();
}
public:
property Size TextSize {
    Size get ();
}
See Also
CalendarRendererBoxEventArgs Class
CalendarRendererBoxEventArgs Members


CalendarRendererDayEventArgs Class

CalendarRendererDayEventArgs Class A Sandcastle Documented Class Library
Send Feedback
Contains information about a day to draw on the calendar
Inheritance Hierarchy
Online System Object
Online System EventArgs
WindowsFormsCalendar CalendarRendererEventArgs
WindowsFormsCalendar CalendarRendererDayEventArgs

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class CalendarRendererDayEventArgs _
    Inherits CalendarRendererEventArgs
Public Class CalendarRendererDayEventArgs _
    Inherits CalendarRendererEventArgs
public class CalendarRendererDayEventArgs : CalendarRendererEventArgs
public class CalendarRendererDayEventArgs : CalendarRendererEventArgs
public ref class CalendarRendererDayEventArgs : public CalendarRendererEventArgs
public ref class CalendarRendererDayEventArgs : public CalendarRendererEventArgs
See Also
CalendarRendererDayEventArgs Members


CalendarRendererDayEventArgs Members

CalendarRendererDayEventArgs Members A Sandcastle Documented Class Library
Send Feedback

The CalendarRendererDayEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | CalendarRendererDayEventArgs | Creates a new CalendarRendererDayEventArgs object
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Calendar | Gets the calendar where painting (Inherited from CalendarRendererEventArgs.)
Public property | ClipRectangle | Gets the clip of the paint event (Inherited from CalendarRendererEventArgs.)
Public property | Day | Gets the day to paint
Public property | Graphics | Gets the device where to paint (Inherited from CalendarRendererEventArgs.)
Public property | Tag | Gets or sets a tag for the event (Inherited from CalendarRendererEventArgs.)
Back to Top
See Also
CalendarRendererDayEventArgs Class


CalendarRendererDayEventArgs Constructor

CalendarRendererDayEventArgs Constructor A Sandcastle Documented Class Library
Send Feedback
Creates a new CalendarRendererDayEventArgs object

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    original As CalendarRendererEventArgs, _
    day As CalendarDay _
)
Public Sub New ( _
    original As CalendarRendererEventArgs, _
    day As CalendarDay _
)
public CalendarRendererDayEventArgs(
    CalendarRendererEventArgs original,
    CalendarDay day
)
public CalendarRendererDayEventArgs(
    CalendarRendererEventArgs original,
    CalendarDay day
)
public:
CalendarRendererDayEventArgs(
    CalendarRendererEventArgs^ original,
    CalendarDay^ day
)
public:
CalendarRendererDayEventArgs(
    CalendarRendererEventArgs^ original,
    CalendarDay^ day
)
Parameters
original
Type: WindowsFormsCalendar CalendarRendererEventArgs
Orignal object to copy basic paramters
day
Type: WindowsFormsCalendar CalendarDay
Day to render
See Also
CalendarRendererDayEventArgs Class
CalendarRendererDayEventArgs Members


CalendarRendererDayEventArgs Methods

CalendarRendererDayEventArgs Methods A Sandcastle Documented Class Library
Send Feedback
The CalendarRendererDayEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CalendarRendererDayEventArgs Class


CalendarRendererDayEventArgs Properties

CalendarRendererDayEventArgs Properties A Sandcastle Documented Class Library
Send Feedback
The CalendarRendererDayEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Calendar | Gets the calendar where painting (Inherited from CalendarRendererEventArgs.)
Public property | ClipRectangle | Gets the clip of the paint event (Inherited from CalendarRendererEventArgs.)
Public property | Day | Gets the day to paint
Public property | Graphics | Gets the device where to paint (Inherited from CalendarRendererEventArgs.)
Public property | Tag | Gets or sets a tag for the event (Inherited from CalendarRendererEventArgs.)
Back to Top
See Also
CalendarRendererDayEventArgs Class


Day Property

CalendarRendererDayEventArgs Day Property A Sandcastle Documented Class Library
Send Feedback
Gets the day to paint

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Day As CalendarDay
    Get
Public ReadOnly Property Day As CalendarDay
    Get
public CalendarDay Day { get; }
public CalendarDay Day { get; }
public:
property CalendarDay^ Day {
    CalendarDay^ get ();
}
public:
property CalendarDay^ Day {
    CalendarDay^ get ();
}
See Also
CalendarRendererDayEventArgs Class
CalendarRendererDayEventArgs Members


CalendarRendererEventArgs Class

CalendarRendererEventArgs Class A Sandcastle Documented Class Library
Send Feedback
Contains basic information about a drawing event for CalendarRenderer
Inheritance Hierarchy
Online System Object
Online System EventArgs
WindowsFormsCalendar CalendarRendererEventArgs
WindowsFormsCalendar CalendarRendererBoxEventArgs
WindowsFormsCalendar CalendarRendererDayEventArgs
WindowsFormsCalendar CalendarRendererItemEventArgs
WindowsFormsCalendar CalendarRendererTimeUnitEventArgs

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class CalendarRendererEventArgs _
    Inherits EventArgs
Public Class CalendarRendererEventArgs _
    Inherits EventArgs
public class CalendarRendererEventArgs : EventArgs
public class CalendarRendererEventArgs : EventArgs
public ref class CalendarRendererEventArgs : public EventArgs
public ref class CalendarRendererEventArgs : public EventArgs
See Also
CalendarRendererEventArgs Members


CalendarRendererEventArgs Members

CalendarRendererEventArgs Members A Sandcastle Documented Class Library
Send Feedback

The CalendarRendererEventArgs type exposes the following members.
Constructors
 | Name | Description
Protected method | CalendarRendererEventArgs | Use it wisely just to initialize some stuff
Public method | CalendarRendererEventArgs(CalendarRendererEventArgs) | Copies the parameters from the specified CalendarRendererEventArgs
Public method | CalendarRendererEventArgs(Calendar, Graphics, Rectangle) | Creates a new CalendarRendererEventArgs
Public method | CalendarRendererEventArgs(Calendar, Graphics, Rectangle, Object) | Creates a new CalendarRendererEventArgs
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Calendar | Gets the calendar where painting
Public property | ClipRectangle | Gets the clip of the paint event
Public property | Graphics | Gets the device where to paint
Public property | Tag | Gets or sets a tag for the event
Back to Top
See Also
CalendarRendererEventArgs Class


CalendarRendererEventArgs Constructor

CalendarRendererEventArgs Constructor A Sandcastle Documented Class Library
Send Feedback
Overload List
 | Name | Description
Protected method | CalendarRendererEventArgs | Use it wisely just to initialize some stuff
Public method | CalendarRendererEventArgs(CalendarRendererEventArgs) | Copies the parameters from the specified CalendarRendererEventArgs
Public method | CalendarRendererEventArgs(Calendar, Graphics, Rectangle) | Creates a new CalendarRendererEventArgs
Public method | CalendarRendererEventArgs(Calendar, Graphics, Rectangle, Object) | Creates a new CalendarRendererEventArgs
Back to Top
See Also
CalendarRendererEventArgs Class
CalendarRendererEventArgs Members


CalendarRendererEventArgs Constructor

CalendarRendererEventArgs Constructor A Sandcastle Documented Class Library
Send Feedback
Use it wisely just to initialize some stuff

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Sub New
Protected Sub New
protected CalendarRendererEventArgs()
protected CalendarRendererEventArgs()
protected:
CalendarRendererEventArgs()
protected:
CalendarRendererEventArgs()
See Also
CalendarRendererEventArgs Class
CalendarRendererEventArgs Members
CalendarRendererEventArgs Overload


CalendarRendererEventArgs Constructor (CalendarRendererEventArgs)

CalendarRendererEventArgs Constructor (CalendarRendererEventArgs) A Sandcastle Documented Class Library
Send Feedback
Copies the parameters from the specified CalendarRendererEventArgs

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    original As CalendarRendererEventArgs _
)
Public Sub New ( _
    original As CalendarRendererEventArgs _
)
public CalendarRendererEventArgs(
    CalendarRendererEventArgs original
)
public CalendarRendererEventArgs(
    CalendarRendererEventArgs original
)
public:
CalendarRendererEventArgs(
    CalendarRendererEventArgs^ original
)
public:
CalendarRendererEventArgs(
    CalendarRendererEventArgs^ original
)
Parameters
original
Type: WindowsFormsCalendar CalendarRendererEventArgs
The CalendarRendererEventArgs instance containing the event data.
See Also
CalendarRendererEventArgs Class
CalendarRendererEventArgs Members
CalendarRendererEventArgs Overload


CalendarRendererEventArgs Constructor (Calendar, Graphics, Rectangle)

CalendarRendererEventArgs Constructor (Calendar, Graphics, Rectangle) A Sandcastle Documented Class Library
Send Feedback
Creates a new CalendarRendererEventArgs

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    calendar As Calendar, _
    graphics As Graphics, _
    clipRectangle As Rectangle _
)
Public Sub New ( _
    calendar As Calendar, _
    graphics As Graphics, _
    clipRectangle As Rectangle _
)
public CalendarRendererEventArgs(
    Calendar calendar,
    Graphics graphics,
    Rectangle clipRectangle
)
public CalendarRendererEventArgs(
    Calendar calendar,
    Graphics graphics,
    Rectangle clipRectangle
)
public:
CalendarRendererEventArgs(
    Calendar^ calendar,
    Graphics^ graphics,
    Rectangle clipRectangle
)
public:
CalendarRendererEventArgs(
    Calendar^ calendar,
    Graphics^ graphics,
    Rectangle clipRectangle
)
Parameters
calendar
Type: WindowsFormsCalendar Calendar
Calendar where painting
graphics
Type:   Online System.Drawing Graphics
The graphics.
clipRectangle
Type:   Online System.Drawing Rectangle
The clip rectangle.
See Also
CalendarRendererEventArgs Class
CalendarRendererEventArgs Members
CalendarRendererEventArgs Overload


CalendarRendererEventArgs Constructor (Calendar, Graphics, Rectangle, Object)

CalendarRendererEventArgs Constructor (Calendar, Graphics, Rectangle, Object) A Sandcastle Documented Class Library
Send Feedback
Creates a new CalendarRendererEventArgs

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    calendar As Calendar, _
    graphics As Graphics, _
    clipRectangle As Rectangle, _
    tag As Object _
)
Public Sub New ( _
    calendar As Calendar, _
    graphics As Graphics, _
    clipRectangle As Rectangle, _
    tag As Object _
)
public CalendarRendererEventArgs(
    Calendar calendar,
    Graphics graphics,
    Rectangle clipRectangle,
    Object tag
)
public CalendarRendererEventArgs(
    Calendar calendar,
    Graphics graphics,
    Rectangle clipRectangle,
    Object tag
)
public:
CalendarRendererEventArgs(
    Calendar^ calendar,
    Graphics^ graphics,
    Rectangle clipRectangle,
    Object^ tag
)
public:
CalendarRendererEventArgs(
    Calendar^ calendar,
    Graphics^ graphics,
    Rectangle clipRectangle,
    Object^ tag
)
Parameters
calendar
Type: WindowsFormsCalendar Calendar
Calendar where painting
graphics
Type:   Online System.Drawing Graphics
The graphics.
clipRectangle
Type:   Online System.Drawing Rectangle
The clip rectangle.
tag
Type:   Online System Object
The tag.
See Also
CalendarRendererEventArgs Class
CalendarRendererEventArgs Members
CalendarRendererEventArgs Overload


CalendarRendererEventArgs Methods

CalendarRendererEventArgs Methods A Sandcastle Documented Class Library
Send Feedback
The CalendarRendererEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CalendarRendererEventArgs Class


CalendarRendererEventArgs Properties

CalendarRendererEventArgs Properties A Sandcastle Documented Class Library
Send Feedback
The CalendarRendererEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Calendar | Gets the calendar where painting
Public property | ClipRectangle | Gets the clip of the paint event
Public property | Graphics | Gets the device where to paint
Public property | Tag | Gets or sets a tag for the event
Back to Top
See Also
CalendarRendererEventArgs Class


Calendar Property

CalendarRendererEventArgs Calendar Property A Sandcastle Documented Class Library
Send Feedback
Gets the calendar where painting

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Calendar As Calendar
    Get
Public ReadOnly Property Calendar As Calendar
    Get
public Calendar Calendar { get; }
public Calendar Calendar { get; }
public:
property Calendar^ Calendar {
    Calendar^ get ();
}
public:
property Calendar^ Calendar {
    Calendar^ get ();
}
See Also
CalendarRendererEventArgs Class
CalendarRendererEventArgs Members


ClipRectangle Property

CalendarRendererEventArgs ClipRectangle Property A Sandcastle Documented Class Library
Send Feedback
Gets the clip of the paint event

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property ClipRectangle As Rectangle
    Get
Public ReadOnly Property ClipRectangle As Rectangle
    Get
public Rectangle ClipRectangle { get; }
public Rectangle ClipRectangle { get; }
public:
property Rectangle ClipRectangle {
    Rectangle get ();
}
public:
property Rectangle ClipRectangle {
    Rectangle get ();
}
See Also
CalendarRendererEventArgs Class
CalendarRendererEventArgs Members


Graphics Property

CalendarRendererEventArgs Graphics Property A Sandcastle Documented Class Library
Send Feedback
Gets the device where to paint

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Graphics As Graphics
    Get
Public ReadOnly Property Graphics As Graphics
    Get
public Graphics Graphics { get; }
public Graphics Graphics { get; }
public:
property Graphics^ Graphics {
    Graphics^ get ();
}
public:
property Graphics^ Graphics {
    Graphics^ get ();
}
See Also
CalendarRendererEventArgs Class
CalendarRendererEventArgs Members


Tag Property

CalendarRendererEventArgs Tag Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets a tag for the event

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property Tag As Object
    Get
    Set
Public Property Tag As Object
    Get
    Set
public Object Tag { get; set; }
public Object Tag { get; set; }
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}
See Also
CalendarRendererEventArgs Class
CalendarRendererEventArgs Members


CalendarRendererItemBoundsEventArgs Class

CalendarRendererItemBoundsEventArgs Class A Sandcastle Documented Class Library
Send Feedback
Event arguments for calendar renter item bounds
Inheritance Hierarchy
Online System Object
Online System EventArgs
WindowsFormsCalendar CalendarRendererEventArgs
WindowsFormsCalendar CalendarRendererItemEventArgs
WindowsFormsCalendar CalendarRendererItemBoundsEventArgs

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class CalendarRendererItemBoundsEventArgs _
    Inherits CalendarRendererItemEventArgs
Public Class CalendarRendererItemBoundsEventArgs _
    Inherits CalendarRendererItemEventArgs
public class CalendarRendererItemBoundsEventArgs : CalendarRendererItemEventArgs
public class CalendarRendererItemBoundsEventArgs : CalendarRendererItemEventArgs
public ref class CalendarRendererItemBoundsEventArgs : public CalendarRendererItemEventArgs
public ref class CalendarRendererItemBoundsEventArgs : public CalendarRendererItemEventArgs
See Also
CalendarRendererItemBoundsEventArgs Members


CalendarRendererItemBoundsEventArgs Members

CalendarRendererItemBoundsEventArgs Members A Sandcastle Documented Class Library
Send Feedback

The CalendarRendererItemBoundsEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounds of the item to be rendered.
Public property | Calendar | Gets the calendar where painting (Inherited from CalendarRendererEventArgs.)
Public property | ClipRectangle | Gets the clip of the paint event (Inherited from CalendarRendererEventArgs.)
Public property | Graphics | Gets the device where to paint (Inherited from CalendarRendererEventArgs.)
Public property | IsFirst | Gets a value indicating if the bounds are the first of the item.
Public property | IsLast | Gets a value indicating if the bounds are the last of the item.
Public property | Item | Gets the Item being rendered (Inherited from CalendarRendererItemEventArgs.)
Public property | Tag | Gets or sets a tag for the event (Inherited from CalendarRendererEventArgs.)
Back to Top
See Also
CalendarRendererItemBoundsEventArgs Class


CalendarRendererItemBoundsEventArgs Methods

CalendarRendererItemBoundsEventArgs Methods A Sandcastle Documented Class Library
Send Feedback
The CalendarRendererItemBoundsEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CalendarRendererItemBoundsEventArgs Class


CalendarRendererItemBoundsEventArgs Properties

CalendarRendererItemBoundsEventArgs Properties A Sandcastle Documented Class Library
Send Feedback
The CalendarRendererItemBoundsEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Bounds | Gets the bounds of the item to be rendered.
Public property | Calendar | Gets the calendar where painting (Inherited from CalendarRendererEventArgs.)
Public property | ClipRectangle | Gets the clip of the paint event (Inherited from CalendarRendererEventArgs.)
Public property | Graphics | Gets the device where to paint (Inherited from CalendarRendererEventArgs.)
Public property | IsFirst | Gets a value indicating if the bounds are the first of the item.
Public property | IsLast | Gets a value indicating if the bounds are the last of the item.
Public property | Item | Gets the Item being rendered (Inherited from CalendarRendererItemEventArgs.)
Public property | Tag | Gets or sets a tag for the event (Inherited from CalendarRendererEventArgs.)
Back to Top
See Also
CalendarRendererItemBoundsEventArgs Class


Bounds Property

CalendarRendererItemBoundsEventArgs Bounds Property A Sandcastle Documented Class Library
Send Feedback
Gets the bounds of the item to be rendered.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Bounds As Rectangle
    Get
Public ReadOnly Property Bounds As Rectangle
    Get
public Rectangle Bounds { get; }
public Rectangle Bounds { get; }
public:
property Rectangle Bounds {
    Rectangle get ();
}
public:
property Rectangle Bounds {
    Rectangle get ();
}
Remarks

            Items may have more than one bounds due to week segmentation.

See Also
CalendarRendererItemBoundsEventArgs Class
CalendarRendererItemBoundsEventArgs Members


IsFirst Property

CalendarRendererItemBoundsEventArgs IsFirst Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if the bounds are the first of the item.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property IsFirst As Boolean
    Get
Public ReadOnly Property IsFirst As Boolean
    Get
public bool IsFirst { get; }
public bool IsFirst { get; }
public:
property bool IsFirst {
    bool get ();
}
public:
property bool IsFirst {
    bool get ();
}
Remarks

            Items may have more than one bounds due to week segmentation.

See Also
CalendarRendererItemBoundsEventArgs Class
CalendarRendererItemBoundsEventArgs Members


IsLast Property

CalendarRendererItemBoundsEventArgs IsLast Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if the bounds are the last of the item.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property IsLast As Boolean
    Get
    Set
Public Property IsLast As Boolean
    Get
    Set
public bool IsLast { get; set; }
public bool IsLast { get; set; }
public:
property bool IsLast {
    bool get ();
    void set (bool value);
}
public:
property bool IsLast {
    bool get ();
    void set (bool value);
}
Remarks

            Items may have more than one bounds due to week segmentation.

See Also
CalendarRendererItemBoundsEventArgs Class
CalendarRendererItemBoundsEventArgs Members


CalendarRendererItemEventArgs Class

CalendarRendererItemEventArgs Class A Sandcastle Documented Class Library
Send Feedback
Contains information to render an item
Inheritance Hierarchy
Online System Object
Online System EventArgs
WindowsFormsCalendar CalendarRendererEventArgs
WindowsFormsCalendar CalendarRendererItemEventArgs
WindowsFormsCalendar CalendarRendererItemBoundsEventArgs

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class CalendarRendererItemEventArgs _
    Inherits CalendarRendererEventArgs
Public Class CalendarRendererItemEventArgs _
    Inherits CalendarRendererEventArgs
public class CalendarRendererItemEventArgs : CalendarRendererEventArgs
public class CalendarRendererItemEventArgs : CalendarRendererEventArgs
public ref class CalendarRendererItemEventArgs : public CalendarRendererEventArgs
public ref class CalendarRendererItemEventArgs : public CalendarRendererEventArgs
See Also
CalendarRendererItemEventArgs Members


CalendarRendererItemEventArgs Members

CalendarRendererItemEventArgs Members A Sandcastle Documented Class Library
Send Feedback

The CalendarRendererItemEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | CalendarRendererItemEventArgs | Initializes a new instance of the CalendarRendererItemEventArgs class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Calendar | Gets the calendar where painting (Inherited from CalendarRendererEventArgs.)
Public property | ClipRectangle | Gets the clip of the paint event (Inherited from CalendarRendererEventArgs.)
Public property | Graphics | Gets the device where to paint (Inherited from CalendarRendererEventArgs.)
Public property | Item | Gets the Item being rendered
Public property | Tag | Gets or sets a tag for the event (Inherited from CalendarRendererEventArgs.)
Back to Top
See Also
CalendarRendererItemEventArgs Class


CalendarRendererItemEventArgs Constructor

CalendarRendererItemEventArgs Constructor A Sandcastle Documented Class Library
Send Feedback
Initializes a new instance of the CalendarRendererItemEventArgs class.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    original As CalendarRendererEventArgs, _
    item As CalendarItem _
)
Public Sub New ( _
    original As CalendarRendererEventArgs, _
    item As CalendarItem _
)
public CalendarRendererItemEventArgs(
    CalendarRendererEventArgs original,
    CalendarItem item
)
public CalendarRendererItemEventArgs(
    CalendarRendererEventArgs original,
    CalendarItem item
)
public:
CalendarRendererItemEventArgs(
    CalendarRendererEventArgs^ original,
    CalendarItem^ item
)
public:
CalendarRendererItemEventArgs(
    CalendarRendererEventArgs^ original,
    CalendarItem^ item
)
Parameters
original
Type: WindowsFormsCalendar CalendarRendererEventArgs
The CalendarRendererEventArgs instance containing the event data.
item
Type: WindowsFormsCalendar CalendarItem
The item.
See Also
CalendarRendererItemEventArgs Class
CalendarRendererItemEventArgs Members


CalendarRendererItemEventArgs Methods

CalendarRendererItemEventArgs Methods A Sandcastle Documented Class Library
Send Feedback
The CalendarRendererItemEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CalendarRendererItemEventArgs Class


CalendarRendererItemEventArgs Properties

CalendarRendererItemEventArgs Properties A Sandcastle Documented Class Library
Send Feedback
The CalendarRendererItemEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Calendar | Gets the calendar where painting (Inherited from CalendarRendererEventArgs.)
Public property | ClipRectangle | Gets the clip of the paint event (Inherited from CalendarRendererEventArgs.)
Public property | Graphics | Gets the device where to paint (Inherited from CalendarRendererEventArgs.)
Public property | Item | Gets the Item being rendered
Public property | Tag | Gets or sets a tag for the event (Inherited from CalendarRendererEventArgs.)
Back to Top
See Also
CalendarRendererItemEventArgs Class


Item Property

CalendarRendererItemEventArgs Item Property A Sandcastle Documented Class Library
Send Feedback
Gets the Item being rendered

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Item As CalendarItem
    Get
Public ReadOnly Property Item As CalendarItem
    Get
public CalendarItem Item { get; }
public CalendarItem Item { get; }
public:
property CalendarItem^ Item {
    CalendarItem^ get ();
}
public:
property CalendarItem^ Item {
    CalendarItem^ get ();
}
See Also
CalendarRendererItemEventArgs Class
CalendarRendererItemEventArgs Members


CalendarRendererTimeUnitEventArgs Class

CalendarRendererTimeUnitEventArgs Class A Sandcastle Documented Class Library
Send Feedback
Contains information about a CalendarTimeScaleUnit that is about to be painted
Inheritance Hierarchy
Online System Object
Online System EventArgs
WindowsFormsCalendar CalendarRendererEventArgs
WindowsFormsCalendar CalendarRendererTimeUnitEventArgs

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class CalendarRendererTimeUnitEventArgs _
    Inherits CalendarRendererEventArgs
Public Class CalendarRendererTimeUnitEventArgs _
    Inherits CalendarRendererEventArgs
public class CalendarRendererTimeUnitEventArgs : CalendarRendererEventArgs
public class CalendarRendererTimeUnitEventArgs : CalendarRendererEventArgs
public ref class CalendarRendererTimeUnitEventArgs : public CalendarRendererEventArgs
public ref class CalendarRendererTimeUnitEventArgs : public CalendarRendererEventArgs
See Also
CalendarRendererTimeUnitEventArgs Members


CalendarRendererTimeUnitEventArgs Members

CalendarRendererTimeUnitEventArgs Members A Sandcastle Documented Class Library
Send Feedback

The CalendarRendererTimeUnitEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | CalendarRendererTimeUnitEventArgs | Initializes a new instance of the CalendarRendererTimeUnitEventArgs class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Calendar | Gets the calendar where painting (Inherited from CalendarRendererEventArgs.)
Public property | ClipRectangle | Gets the clip of the paint event (Inherited from CalendarRendererEventArgs.)
Public property | Graphics | Gets the device where to paint (Inherited from CalendarRendererEventArgs.)
Public property | Tag | Gets or sets a tag for the event (Inherited from CalendarRendererEventArgs.)
Public property | Unit | Gets the unit that is about to be painted
Back to Top
See Also
CalendarRendererTimeUnitEventArgs Class


CalendarRendererTimeUnitEventArgs Constructor

CalendarRendererTimeUnitEventArgs Constructor A Sandcastle Documented Class Library
Send Feedback
Initializes a new instance of the CalendarRendererTimeUnitEventArgs class.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    original As CalendarRendererEventArgs, _
    unit As CalendarTimeScaleUnit _
)
Public Sub New ( _
    original As CalendarRendererEventArgs, _
    unit As CalendarTimeScaleUnit _
)
public CalendarRendererTimeUnitEventArgs(
    CalendarRendererEventArgs original,
    CalendarTimeScaleUnit unit
)
public CalendarRendererTimeUnitEventArgs(
    CalendarRendererEventArgs original,
    CalendarTimeScaleUnit unit
)
public:
CalendarRendererTimeUnitEventArgs(
    CalendarRendererEventArgs^ original,
    CalendarTimeScaleUnit^ unit
)
public:
CalendarRendererTimeUnitEventArgs(
    CalendarRendererEventArgs^ original,
    CalendarTimeScaleUnit^ unit
)
Parameters
original
Type: WindowsFormsCalendar CalendarRendererEventArgs
The CalendarRendererEventArgs instance containing the event data.
unit
Type: WindowsFormsCalendar CalendarTimeScaleUnit
The unit.
See Also
CalendarRendererTimeUnitEventArgs Class
CalendarRendererTimeUnitEventArgs Members


CalendarRendererTimeUnitEventArgs Methods

CalendarRendererTimeUnitEventArgs Methods A Sandcastle Documented Class Library
Send Feedback
The CalendarRendererTimeUnitEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CalendarRendererTimeUnitEventArgs Class


CalendarRendererTimeUnitEventArgs Properties

CalendarRendererTimeUnitEventArgs Properties A Sandcastle Documented Class Library
Send Feedback
The CalendarRendererTimeUnitEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Calendar | Gets the calendar where painting (Inherited from CalendarRendererEventArgs.)
Public property | ClipRectangle | Gets the clip of the paint event (Inherited from CalendarRendererEventArgs.)
Public property | Graphics | Gets the device where to paint (Inherited from CalendarRendererEventArgs.)
Public property | Tag | Gets or sets a tag for the event (Inherited from CalendarRendererEventArgs.)
Public property | Unit | Gets the unit that is about to be painted
Back to Top
See Also
CalendarRendererTimeUnitEventArgs Class


Unit Property

CalendarRendererTimeUnitEventArgs Unit Property A Sandcastle Documented Class Library
Send Feedback
Gets the unit that is about to be painted

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Unit As CalendarTimeScaleUnit
    Get
Public ReadOnly Property Unit As CalendarTimeScaleUnit
    Get
public CalendarTimeScaleUnit Unit { get; }
public CalendarTimeScaleUnit Unit { get; }
public:
property CalendarTimeScaleUnit^ Unit {
    CalendarTimeScaleUnit^ get ();
}
public:
property CalendarTimeScaleUnit^ Unit {
    CalendarTimeScaleUnit^ get ();
}
See Also
CalendarRendererTimeUnitEventArgs Class
CalendarRendererTimeUnitEventArgs Members


CalendarScrollBars Enumeration

CalendarScrollBars Enumeration A Sandcastle Documented Class Library
Send Feedback
Enumeration for the different type of scroll bars

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Enumeration CalendarScrollBars
Public Enumeration CalendarScrollBars
public enum CalendarScrollBars
public enum CalendarScrollBars
public enum class CalendarScrollBars
public enum class CalendarScrollBars
Members
Member name | Value | Description
None | 0 | No scroll bars
Both | 1 | Vertical and Horizontal scrollbars
Vertical | 2 | Only vertical scrollbars
Horizontal | 3 | Only horizontal scrollbars
See Also


CalendarSelectableElement Class

CalendarSelectableElement Class A Sandcastle Documented Class Library
Send Feedback
Implements a basic ICalendarSelectableElement
Inheritance Hierarchy
Online System Object
WindowsFormsCalendar CalendarSelectableElement
WindowsFormsCalendar CalendarDay
WindowsFormsCalendar CalendarDayTop
WindowsFormsCalendar CalendarItem
WindowsFormsCalendar CalendarTimeScaleUnit

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public MustInherit Class CalendarSelectableElement _
    Implements ICalendarSelectableElement, ISelectableElement, IComparable(Of ICalendarSelectableElement)
Public MustInherit Class CalendarSelectableElement _
    Implements ICalendarSelectableElement, ISelectableElement, IComparable(Of ICalendarSelectableElement)
public abstract class CalendarSelectableElement : ICalendarSelectableElement,
    ISelectableElement, IComparable<ICalendarSelectableElement>
public abstract class CalendarSelectableElement : ICalendarSelectableElement,
    ISelectableElement, IComparable<ICalendarSelectableElement>
public ref class CalendarSelectableElement abstract : ICalendarSelectableElement,
    ISelectableElement, IComparable<ICalendarSelectableElement^>
public ref class CalendarSelectableElement abstract : ICalendarSelectableElement,
    ISelectableElement, IComparable<ICalendarSelectableElement^>
See Also
CalendarSelectableElement Members


CalendarSelectableElement Members

CalendarSelectableElement Members A Sandcastle Documented Class Library
Send Feedback

The CalendarSelectableElement type exposes the following members.
Constructors
 | Name | Description
Public method | CalendarSelectableElement | Initializes a new instance of the CalendarSelectableElement class.
Back to Top
Methods
 | Name | Description
Public method | CompareTo | Compares this element with other using date as comparer
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Bounds | Gets the Bounds of the element on the Calendar window
Public property | Calendar | Gets the Calendar this element belongs to
Public property | Date | Gets the calendar
Public property | Selected | Gets a value indicating if the element is currently selected
Back to Top
See Also
CalendarSelectableElement Class


CalendarSelectableElement Constructor

CalendarSelectableElement Constructor A Sandcastle Documented Class Library
Send Feedback
Initializes a new instance of the CalendarSelectableElement class.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    calendar As Calendar _
)
Public Sub New ( _
    calendar As Calendar _
)
public CalendarSelectableElement(
    Calendar calendar
)
public CalendarSelectableElement(
    Calendar calendar
)
public:
CalendarSelectableElement(
    Calendar^ calendar
)
public:
CalendarSelectableElement(
    Calendar^ calendar
)
Parameters
calendar
Type: WindowsFormsCalendar Calendar
The calendar.
See Also
CalendarSelectableElement Class
CalendarSelectableElement Members


CalendarSelectableElement Methods

CalendarSelectableElement Methods A Sandcastle Documented Class Library
Send Feedback
The CalendarSelectableElement type exposes the following members.
Methods
 | Name | Description
Public method | CompareTo | Compares this element with other using date as comparer
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CalendarSelectableElement Class


CompareTo Method

CalendarSelectableElement CompareTo Method A Sandcastle Documented Class Library
Send Feedback
Compares this element with other using date as comparer

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable Function CompareTo ( _
    element As ICalendarSelectableElement _
) As Integer
Public Overridable Function CompareTo ( _
    element As ICalendarSelectableElement _
) As Integer
public virtual int CompareTo(
    ICalendarSelectableElement element
)
public virtual int CompareTo(
    ICalendarSelectableElement element
)
public:
virtual int CompareTo(
    ICalendarSelectableElement^ element
)
public:
virtual int CompareTo(
    ICalendarSelectableElement^ element
)
Parameters
element
Type: WindowsFormsCalendar ICalendarSelectableElement
[Missing <param name="element"/> documentation for "M:WindowsFormsCalendar.CalendarSelectableElement.CompareTo(WindowsFormsCalendar.ICalendarSelectableElement)"]
Return Value
[Missing <returns> documentation for "M:WindowsFormsCalendar.CalendarSelectableElement.CompareTo(WindowsFormsCalendar.ICalendarSelectableElement)"]
Implements
  Online IComparable T  CompareTo(T)
See Also
CalendarSelectableElement Class
CalendarSelectableElement Members


CalendarSelectableElement Properties

CalendarSelectableElement Properties A Sandcastle Documented Class Library
Send Feedback
The CalendarSelectableElement type exposes the following members.
Properties
 | Name | Description
Public property | Bounds | Gets the Bounds of the element on the Calendar window
Public property | Calendar | Gets the Calendar this element belongs to
Public property | Date | Gets the calendar
Public property | Selected | Gets a value indicating if the element is currently selected
Back to Top
See Also
CalendarSelectableElement Class


Bounds Property

CalendarSelectableElement Bounds Property A Sandcastle Documented Class Library
Send Feedback
Gets the Bounds of the element on the Calendar window

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable ReadOnly Property Bounds As Rectangle
    Get
Public Overridable ReadOnly Property Bounds As Rectangle
    Get
public virtual Rectangle Bounds { get; }
public virtual Rectangle Bounds { get; }
public:
virtual property Rectangle Bounds {
    Rectangle get ();
}
public:
virtual property Rectangle Bounds {
    Rectangle get ();
}
Implements
ISelectableElement Bounds
See Also
CalendarSelectableElement Class
CalendarSelectableElement Members


Calendar Property

CalendarSelectableElement Calendar Property A Sandcastle Documented Class Library
Send Feedback
Gets the Calendar this element belongs to

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable ReadOnly Property Calendar As Calendar
    Get
Public Overridable ReadOnly Property Calendar As Calendar
    Get
public virtual Calendar Calendar { get; }
public virtual Calendar Calendar { get; }
public:
virtual property Calendar^ Calendar {
    Calendar^ get ();
}
public:
virtual property Calendar^ Calendar {
    Calendar^ get ();
}
Implements
ICalendarSelectableElement Calendar
See Also
CalendarSelectableElement Class
CalendarSelectableElement Members


Date Property

CalendarSelectableElement Date Property A Sandcastle Documented Class Library
Send Feedback
Gets the calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable ReadOnly Property Date As DateTime
    Get
Public Overridable ReadOnly Property Date As DateTime
    Get
public virtual DateTime Date { get; }
public virtual DateTime Date { get; }
public:
virtual property DateTime Date {
    DateTime get ();
}
public:
virtual property DateTime Date {
    DateTime get ();
}
Implements
ICalendarSelectableElement Date
See Also
CalendarSelectableElement Class
CalendarSelectableElement Members


Selected Property

CalendarSelectableElement Selected Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if the element is currently selected

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overridable ReadOnly Property Selected As Boolean
    Get
Public Overridable ReadOnly Property Selected As Boolean
    Get
public virtual bool Selected { get; }
public virtual bool Selected { get; }
public:
virtual property bool Selected {
    bool get ();
}
public:
virtual property bool Selected {
    bool get ();
}
Implements
ISelectableElement Selected
See Also
CalendarSelectableElement Class
CalendarSelectableElement Members


CalendarState Enumeration

CalendarState Enumeration A Sandcastle Documented Class Library
Send Feedback
Possible states of the calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Enumeration CalendarState
Public Enumeration CalendarState
public enum CalendarState
public enum CalendarState
public enum class CalendarState
public enum class CalendarState
Members
Member name | Value | Description
Idle | 0 | Nothing happening
DraggingTimeSelection | 1 | User is currently dragging on view to select a time range
DraggingItem | 2 | User is currently dragging an item among the view
EditingItemText | 3 | User is editing an item's Text
ResizingItem | 4 | User is currently resizing an item
See Also


CalendarSystemRenderer Class

CalendarSystemRenderer Class A Sandcastle Documented Class Library
Send Feedback
CalendarRenderer that renders low-intensity calendar for slow computers
Inheritance Hierarchy
Online System Object
WindowsFormsCalendar CalendarRenderer
WindowsFormsCalendar CalendarSystemRenderer
WindowsFormsCalendar CalendarProfessionalRenderer

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class CalendarSystemRenderer _
    Inherits CalendarRenderer
Public Class CalendarSystemRenderer _
    Inherits CalendarRenderer
public class CalendarSystemRenderer : CalendarRenderer
public class CalendarSystemRenderer : CalendarRenderer
public ref class CalendarSystemRenderer : public CalendarRenderer
public ref class CalendarSystemRenderer : public CalendarRenderer
See Also
CalendarSystemRenderer Members


CalendarSystemRenderer Members

CalendarSystemRenderer Members A Sandcastle Documented Class Library
Send Feedback

The CalendarSystemRenderer type exposes the following members.
Constructors
 | Name | Description
Public method | CalendarSystemRenderer | Initializes a new instance of the CalendarSystemRenderer class.
Back to Top
Methods
 | Name | Description
Protected method | DrawStandarBoxText | Draws text using the information of the CalendarRendererBoxEventArgs (Inherited from CalendarRenderer.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetTimeY | Gets the exact Y coordinate that corresponds to the specified time. This only works when in Expanded mode. (Inherited from CalendarRenderer.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | ItemBorder | Draws the specified rectangle with item border roundnesss (Inherited from CalendarRenderer.)
Public method | ItemFill | Fills the specified rectangle with item border roundness (Inherited from CalendarRenderer.)
Public method | ItemPattern | Items the pattern. (Inherited from CalendarRenderer.)
Public method | ItemRectangle | Creates a rectangle with item roundess (Inherited from CalendarRenderer.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OnDrawBackground | Paints the background of the calendar (Overrides CalendarRenderer OnDrawBackground(CalendarRendererEventArgs).)
Public method | OnDrawDay | Paints the specified day on the calendar (Overrides CalendarRenderer OnDrawDay(CalendarRendererDayEventArgs).)
Public method | OnDrawDayBorder | Paints the border of the specified day (Overrides CalendarRenderer OnDrawDayBorder(CalendarRendererDayEventArgs).)
Public method | OnDrawDayHeaderBackground | Paints the background of the specified day's header (Overrides CalendarRenderer OnDrawDayHeaderBackground(CalendarRendererDayEventArgs).)
Public method | OnDrawDayHeaderText | Paints the header of the specified day (Inherited from CalendarRenderer.)
Public method | OnDrawDayNameHeader | Raises the [E:DrawDayNameHeader] event. (Overrides CalendarRenderer OnDrawDayNameHeader(CalendarRendererBoxEventArgs).)
Public method | OnDrawDayNameHeaders | Raises the [E:DrawDayNameHeaders] event. (Inherited from CalendarRenderer.)
Public method | OnDrawDayOverflowEnd | Draws the overflow to end of specified day (Overrides CalendarRenderer OnDrawDayOverflowEnd(CalendarRendererDayEventArgs).)
Public method | OnDrawDayOverflowStart | Draws the overflow to start of specified day (Inherited from CalendarRenderer.)
Public method | OnDrawDays | Paints the days on the current calendar view (Inherited from CalendarRenderer.)
Public method | OnDrawDayTimeUnit | Draws a time unit of a day (Overrides CalendarRenderer OnDrawDayTimeUnit(CalendarRendererTimeUnitEventArgs).)
Public method | OnDrawDayTimeUnits | Raises the [E:DrawDayTimeUnits] event. (Inherited from CalendarRenderer.)
Public method | OnDrawDayTop | Draws the all day items area (Overrides CalendarRenderer OnDrawDayTop(CalendarRendererDayEventArgs).)
Public method | OnDrawItem | Draws an item of the calendar (Inherited from CalendarRenderer.)
Public method | OnDrawItemBackground | Draws the background of the specified item (Overrides CalendarRenderer OnDrawItemBackground(CalendarRendererItemBoundsEventArgs).)
Public method | OnDrawItemBorder | Draws the border of the specified item (Overrides CalendarRenderer OnDrawItemBorder(CalendarRendererItemBoundsEventArgs).)
Public method | OnDrawItemContent | Draws the strings of an item. Strings inlude StartTime, EndTime and Text (Inherited from CalendarRenderer.)
Public method | OnDrawItemEndTime | Draws the end time of the item if applicable (Overrides CalendarRenderer OnDrawItemEndTime(CalendarRendererBoxEventArgs).)
Public method | OnDrawItemImage | Draws the image of an item (Inherited from CalendarRenderer.)
Public method | OnDrawItemPattern | Raises the [E:DrawItemPattern] event. (Inherited from CalendarRenderer.)
Public method | OnDrawItems | Draws the items of the calendar (Inherited from CalendarRenderer.)
Public method | OnDrawItemShadow | Draws the shadow of the specified item (Overrides CalendarRenderer OnDrawItemShadow(CalendarRendererItemBoundsEventArgs).)
Public method | OnDrawItemStartTime | Draws the starttime of the item if applicable (Overrides CalendarRenderer OnDrawItemStartTime(CalendarRendererBoxEventArgs).)
Public method | OnDrawItemText | Draws the text of an item (Overrides CalendarRenderer OnDrawItemText(CalendarRendererBoxEventArgs).)
Public method | OnDrawOverflows | Draws the overflows of days (Inherited from CalendarRenderer.)
Public method | OnDrawTimeScale | Paints the timescale of the calendar (Overrides CalendarRenderer OnDrawTimeScale(CalendarRendererEventArgs).)
Public method | OnDrawTimeScaleHour | Paints an hour of a timescale unit (Overrides CalendarRenderer OnDrawTimeScaleHour(CalendarRendererBoxEventArgs).)
Public method | OnDrawTimeScaleMinutes | Paints minutes of a timescale unit (Overrides CalendarRenderer OnDrawTimeScaleMinutes(CalendarRendererBoxEventArgs).)
Public method | OnDrawWeekHeader | Raises the [E:DrawWeekHeader] event. (Overrides CalendarRenderer OnDrawWeekHeader(CalendarRendererBoxEventArgs).)
Public method | OnDrawWeekHeaders | Raises the [E:DrawWeekHeaders] event. (Overrides CalendarRenderer OnDrawWeekHeaders(CalendarRendererEventArgs).)
Public method | OnInitialize | Initializes the Calendar (Inherited from CalendarRenderer.)
Public method | PerformItemsLayout | Updates the bounds of CalendarItems (Inherited from CalendarRenderer.)
Public method | PerformLayout | Peform layout of elements and items of the calendar (Inherited from CalendarRenderer.)
Public method | PerformLayout(Boolean) | Updates the bounds of graphical elements. Optionally calls PerformItemsLayout to update bounds of items. (Inherited from CalendarRenderer.)
Protected method | SetDayHeaderHeight | Sets the value of the DayHeaderHeight property (Inherited from CalendarRenderer.)
Protected method | SetDayNameHeadersHeight | Sets the value of the DayNameHeadersHeight property (Inherited from CalendarRenderer.)
Protected method | SetDayTopHeight | Sets the value of the DayTopHeight property (Inherited from CalendarRenderer.)
Protected method | SetTimeScaleUnitHeight | Sets the value of the TimeScaleUnitHeight property (Inherited from CalendarRenderer.)
Protected method | SetTimeScaleWidth | Sets the value of the TimeScaleWidth property (Inherited from CalendarRenderer.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Calendar | Gets the Calendar this renderer belongs to (Inherited from CalendarRenderer.)
Public property | ColorTable | Gets or sets the CalendarColorTable for this renderer
Public property | DayHeaderHeight | Gets the height of the header of days (Inherited from CalendarRenderer.)
Public property | DayNameHeaderColumns | Gets the bounds for day name headers (Inherited from CalendarRenderer.)
Public property | DayNameHeadersHeight | Gets the height of the day name headers (Inherited from CalendarRenderer.)
Public property | DayNameHeadersVisible | Gets a value indicating if the day names headers are visible (e.g. Monday, Tuesday, Wednesday ...) (Inherited from CalendarRenderer.)
Public property | DayTopHeight | Gets the current height of the all day items area (Inherited from CalendarRenderer.)
Public property | DayTopItemsPadding | Gets or sets the padding of the items that goes on the top part of the days, when in Expanded (Inherited from CalendarRenderer.)
Public property | DayTopMinHeight | Gets the minimum height for day tops (Inherited from CalendarRenderer.)
Public property | ItemInvalidateMargin | Gets or sets the extra margin for invalidating and redrawing items (Inherited from CalendarRenderer.)
Public property | ItemRoundness | Gets or sets the roundness of the item (Inherited from CalendarRenderer.)
Public property | ItemShadowPadding | Gets or sets the amount of pixels that the item's shadow is dropped (Inherited from CalendarRenderer.)
Public property | ItemsPadding | Gets or sets the padding of items on expanded mode (Inherited from CalendarRenderer.)
Public property | ItemTextMargin | Gets the margin of the text in the items (Inherited from CalendarRenderer.)
Public property | SelectedItemBorder | Gets or sets the size of the border of selected items
Public property | StandardItemHeight | Gets the height of items on day tops (Inherited from CalendarRenderer.)
Public property | TimeScaleBounds | Gets or sets the bounds of the timescale (Inherited from CalendarRenderer.)
Public property | TimeScaleUnitHeight | Gets the height of the time scale unit. (Inherited from CalendarRenderer.)
Public property | TimeScaleVisible | Gets a value indicating whether [time scale visible]. (Inherited from CalendarRenderer.)
Public property | TimeScaleWidth | Gets the width of the timescale (Inherited from CalendarRenderer.)
Public property | WeekHeaderWidth | Gets the width of the week header. (Inherited from CalendarRenderer.)
Back to Top
See Also
CalendarSystemRenderer Class


CalendarSystemRenderer Constructor

CalendarSystemRenderer Constructor A Sandcastle Documented Class Library
Send Feedback
Initializes a new instance of the CalendarSystemRenderer class.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    calendar As Calendar _
)
Public Sub New ( _
    calendar As Calendar _
)
public CalendarSystemRenderer(
    Calendar calendar
)
public CalendarSystemRenderer(
    Calendar calendar
)
public:
CalendarSystemRenderer(
    Calendar^ calendar
)
public:
CalendarSystemRenderer(
    Calendar^ calendar
)
Parameters
calendar
Type: WindowsFormsCalendar Calendar
[Missing <param name="calendar"/> documentation for "M:WindowsFormsCalendar.CalendarSystemRenderer.#ctor(WindowsFormsCalendar.Calendar)"]
See Also
CalendarSystemRenderer Class
CalendarSystemRenderer Members


CalendarSystemRenderer Methods

CalendarSystemRenderer Methods A Sandcastle Documented Class Library
Send Feedback
The CalendarSystemRenderer type exposes the following members.
Methods
 | Name | Description
Protected method | DrawStandarBoxText | Draws text using the information of the CalendarRendererBoxEventArgs (Inherited from CalendarRenderer.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetTimeY | Gets the exact Y coordinate that corresponds to the specified time. This only works when in Expanded mode. (Inherited from CalendarRenderer.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | ItemBorder | Draws the specified rectangle with item border roundnesss (Inherited from CalendarRenderer.)
Public method | ItemFill | Fills the specified rectangle with item border roundness (Inherited from CalendarRenderer.)
Public method | ItemPattern | Items the pattern. (Inherited from CalendarRenderer.)
Public method | ItemRectangle | Creates a rectangle with item roundess (Inherited from CalendarRenderer.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OnDrawBackground | Paints the background of the calendar (Overrides CalendarRenderer OnDrawBackground(CalendarRendererEventArgs).)
Public method | OnDrawDay | Paints the specified day on the calendar (Overrides CalendarRenderer OnDrawDay(CalendarRendererDayEventArgs).)
Public method | OnDrawDayBorder | Paints the border of the specified day (Overrides CalendarRenderer OnDrawDayBorder(CalendarRendererDayEventArgs).)
Public method | OnDrawDayHeaderBackground | Paints the background of the specified day's header (Overrides CalendarRenderer OnDrawDayHeaderBackground(CalendarRendererDayEventArgs).)
Public method | OnDrawDayHeaderText | Paints the header of the specified day (Inherited from CalendarRenderer.)
Public method | OnDrawDayNameHeader | Raises the [E:DrawDayNameHeader] event. (Overrides CalendarRenderer OnDrawDayNameHeader(CalendarRendererBoxEventArgs).)
Public method | OnDrawDayNameHeaders | Raises the [E:DrawDayNameHeaders] event. (Inherited from CalendarRenderer.)
Public method | OnDrawDayOverflowEnd | Draws the overflow to end of specified day (Overrides CalendarRenderer OnDrawDayOverflowEnd(CalendarRendererDayEventArgs).)
Public method | OnDrawDayOverflowStart | Draws the overflow to start of specified day (Inherited from CalendarRenderer.)
Public method | OnDrawDays | Paints the days on the current calendar view (Inherited from CalendarRenderer.)
Public method | OnDrawDayTimeUnit | Draws a time unit of a day (Overrides CalendarRenderer OnDrawDayTimeUnit(CalendarRendererTimeUnitEventArgs).)
Public method | OnDrawDayTimeUnits | Raises the [E:DrawDayTimeUnits] event. (Inherited from CalendarRenderer.)
Public method | OnDrawDayTop | Draws the all day items area (Overrides CalendarRenderer OnDrawDayTop(CalendarRendererDayEventArgs).)
Public method | OnDrawItem | Draws an item of the calendar (Inherited from CalendarRenderer.)
Public method | OnDrawItemBackground | Draws the background of the specified item (Overrides CalendarRenderer OnDrawItemBackground(CalendarRendererItemBoundsEventArgs).)
Public method | OnDrawItemBorder | Draws the border of the specified item (Overrides CalendarRenderer OnDrawItemBorder(CalendarRendererItemBoundsEventArgs).)
Public method | OnDrawItemContent | Draws the strings of an item. Strings inlude StartTime, EndTime and Text (Inherited from CalendarRenderer.)
Public method | OnDrawItemEndTime | Draws the end time of the item if applicable (Overrides CalendarRenderer OnDrawItemEndTime(CalendarRendererBoxEventArgs).)
Public method | OnDrawItemImage | Draws the image of an item (Inherited from CalendarRenderer.)
Public method | OnDrawItemPattern | Raises the [E:DrawItemPattern] event. (Inherited from CalendarRenderer.)
Public method | OnDrawItems | Draws the items of the calendar (Inherited from CalendarRenderer.)
Public method | OnDrawItemShadow | Draws the shadow of the specified item (Overrides CalendarRenderer OnDrawItemShadow(CalendarRendererItemBoundsEventArgs).)
Public method | OnDrawItemStartTime | Draws the starttime of the item if applicable (Overrides CalendarRenderer OnDrawItemStartTime(CalendarRendererBoxEventArgs).)
Public method | OnDrawItemText | Draws the text of an item (Overrides CalendarRenderer OnDrawItemText(CalendarRendererBoxEventArgs).)
Public method | OnDrawOverflows | Draws the overflows of days (Inherited from CalendarRenderer.)
Public method | OnDrawTimeScale | Paints the timescale of the calendar (Overrides CalendarRenderer OnDrawTimeScale(CalendarRendererEventArgs).)
Public method | OnDrawTimeScaleHour | Paints an hour of a timescale unit (Overrides CalendarRenderer OnDrawTimeScaleHour(CalendarRendererBoxEventArgs).)
Public method | OnDrawTimeScaleMinutes | Paints minutes of a timescale unit (Overrides CalendarRenderer OnDrawTimeScaleMinutes(CalendarRendererBoxEventArgs).)
Public method | OnDrawWeekHeader | Raises the [E:DrawWeekHeader] event. (Overrides CalendarRenderer OnDrawWeekHeader(CalendarRendererBoxEventArgs).)
Public method | OnDrawWeekHeaders | Raises the [E:DrawWeekHeaders] event. (Overrides CalendarRenderer OnDrawWeekHeaders(CalendarRendererEventArgs).)
Public method | OnInitialize | Initializes the Calendar (Inherited from CalendarRenderer.)
Public method | PerformItemsLayout | Updates the bounds of CalendarItems (Inherited from CalendarRenderer.)
Public method | PerformLayout | Peform layout of elements and items of the calendar (Inherited from CalendarRenderer.)
Public method | PerformLayout(Boolean) | Updates the bounds of graphical elements. Optionally calls PerformItemsLayout to update bounds of items. (Inherited from CalendarRenderer.)
Protected method | SetDayHeaderHeight | Sets the value of the DayHeaderHeight property (Inherited from CalendarRenderer.)
Protected method | SetDayNameHeadersHeight | Sets the value of the DayNameHeadersHeight property (Inherited from CalendarRenderer.)
Protected method | SetDayTopHeight | Sets the value of the DayTopHeight property (Inherited from CalendarRenderer.)
Protected method | SetTimeScaleUnitHeight | Sets the value of the TimeScaleUnitHeight property (Inherited from CalendarRenderer.)
Protected method | SetTimeScaleWidth | Sets the value of the TimeScaleWidth property (Inherited from CalendarRenderer.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
CalendarSystemRenderer Class


OnDrawBackground Method

CalendarSystemRenderer OnDrawBackground Method A Sandcastle Documented Class Library
Send Feedback
Paints the background of the calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Sub OnDrawBackground ( _
    e As CalendarRendererEventArgs _
)
Public Overrides Sub OnDrawBackground ( _
    e As CalendarRendererEventArgs _
)
public override void OnDrawBackground(
    CalendarRendererEventArgs e
)
public override void OnDrawBackground(
    CalendarRendererEventArgs e
)
public:
virtual void OnDrawBackground(
    CalendarRendererEventArgs^ e
) override
public:
virtual void OnDrawBackground(
    CalendarRendererEventArgs^ e
) override
Parameters
e
Type: WindowsFormsCalendar CalendarRendererEventArgs
Paint info
See Also
CalendarSystemRenderer Class
CalendarSystemRenderer Members


OnDrawDay Method

CalendarSystemRenderer OnDrawDay Method A Sandcastle Documented Class Library
Send Feedback
Paints the specified day on the calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Sub OnDrawDay ( _
    e As CalendarRendererDayEventArgs _
)
Public Overrides Sub OnDrawDay ( _
    e As CalendarRendererDayEventArgs _
)
public override void OnDrawDay(
    CalendarRendererDayEventArgs e
)
public override void OnDrawDay(
    CalendarRendererDayEventArgs e
)
public:
virtual void OnDrawDay(
    CalendarRendererDayEventArgs^ e
) override
public:
virtual void OnDrawDay(
    CalendarRendererDayEventArgs^ e
) override
Parameters
e
Type: WindowsFormsCalendar CalendarRendererDayEventArgs
Paint info
See Also
CalendarSystemRenderer Class
CalendarSystemRenderer Members


OnDrawDayBorder Method

CalendarSystemRenderer OnDrawDayBorder Method A Sandcastle Documented Class Library
Send Feedback
Paints the border of the specified day

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Sub OnDrawDayBorder ( _
    e As CalendarRendererDayEventArgs _
)
Public Overrides Sub OnDrawDayBorder ( _
    e As CalendarRendererDayEventArgs _
)
public override void OnDrawDayBorder(
    CalendarRendererDayEventArgs e
)
public override void OnDrawDayBorder(
    CalendarRendererDayEventArgs e
)
public:
virtual void OnDrawDayBorder(
    CalendarRendererDayEventArgs^ e
) override
public:
virtual void OnDrawDayBorder(
    CalendarRendererDayEventArgs^ e
) override
Parameters
e
Type: WindowsFormsCalendar CalendarRendererDayEventArgs
[Missing <param name="e"/> documentation for "M:WindowsFormsCalendar.CalendarSystemRenderer.OnDrawDayBorder(WindowsFormsCalendar.CalendarRendererDayEventArgs)"]
See Also
CalendarSystemRenderer Class
CalendarSystemRenderer Members


OnDrawDayHeaderBackground Method

CalendarSystemRenderer OnDrawDayHeaderBackground Method A Sandcastle Documented Class Library
Send Feedback
Paints the background of the specified day's header

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Sub OnDrawDayHeaderBackground ( _
    e As CalendarRendererDayEventArgs _
)
Public Overrides Sub OnDrawDayHeaderBackground ( _
    e As CalendarRendererDayEventArgs _
)
public override void OnDrawDayHeaderBackground(
    CalendarRendererDayEventArgs e
)
public override void OnDrawDayHeaderBackground(
    CalendarRendererDayEventArgs e
)
public:
virtual void OnDrawDayHeaderBackground(
    CalendarRendererDayEventArgs^ e
) override
public:
virtual void OnDrawDayHeaderBackground(
    CalendarRendererDayEventArgs^ e
) override
Parameters
e
Type: WindowsFormsCalendar CalendarRendererDayEventArgs
[Missing <param name="e"/> documentation for "M:WindowsFormsCalendar.CalendarSystemRenderer.OnDrawDayHeaderBackground(WindowsFormsCalendar.CalendarRendererDayEventArgs)"]
See Also
CalendarSystemRenderer Class
CalendarSystemRenderer Members


OnDrawDayNameHeader Method

CalendarSystemRenderer OnDrawDayNameHeader Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:DrawDayNameHeader] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Sub OnDrawDayNameHeader ( _
    e As CalendarRendererBoxEventArgs _
)
Public Overrides Sub OnDrawDayNameHeader ( _
    e As CalendarRendererBoxEventArgs _
)
public override void OnDrawDayNameHeader(
    CalendarRendererBoxEventArgs e
)
public override void OnDrawDayNameHeader(
    CalendarRendererBoxEventArgs e
)
public:
virtual void OnDrawDayNameHeader(
    CalendarRendererBoxEventArgs^ e
) override
public:
virtual void OnDrawDayNameHeader(
    CalendarRendererBoxEventArgs^ e
) override
Parameters
e
Type: WindowsFormsCalendar CalendarRendererBoxEventArgs
The CalendarRendererBoxEventArgs instance containing the event data.
See Also
CalendarSystemRenderer Class
CalendarSystemRenderer Members


OnDrawDayOverflowEnd Method

CalendarSystemRenderer OnDrawDayOverflowEnd Method A Sandcastle Documented Class Library
Send Feedback
Draws the overflow to end of specified day

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Sub OnDrawDayOverflowEnd ( _
    e As CalendarRendererDayEventArgs _
)
Public Overrides Sub OnDrawDayOverflowEnd ( _
    e As CalendarRendererDayEventArgs _
)
public override void OnDrawDayOverflowEnd(
    CalendarRendererDayEventArgs e
)
public override void OnDrawDayOverflowEnd(
    CalendarRendererDayEventArgs e
)
public:
virtual void OnDrawDayOverflowEnd(
    CalendarRendererDayEventArgs^ e
) override
public:
virtual void OnDrawDayOverflowEnd(
    CalendarRendererDayEventArgs^ e
) override
Parameters
e
Type: WindowsFormsCalendar CalendarRendererDayEventArgs
[Missing <param name="e"/> documentation for "M:WindowsFormsCalendar.CalendarSystemRenderer.OnDrawDayOverflowEnd(WindowsFormsCalendar.CalendarRendererDayEventArgs)"]
See Also
CalendarSystemRenderer Class
CalendarSystemRenderer Members


OnDrawDayTimeUnit Method

CalendarSystemRenderer OnDrawDayTimeUnit Method A Sandcastle Documented Class Library
Send Feedback
Draws a time unit of a day

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Sub OnDrawDayTimeUnit ( _
    e As CalendarRendererTimeUnitEventArgs _
)
Public Overrides Sub OnDrawDayTimeUnit ( _
    e As CalendarRendererTimeUnitEventArgs _
)
public override void OnDrawDayTimeUnit(
    CalendarRendererTimeUnitEventArgs e
)
public override void OnDrawDayTimeUnit(
    CalendarRendererTimeUnitEventArgs e
)
public:
virtual void OnDrawDayTimeUnit(
    CalendarRendererTimeUnitEventArgs^ e
) override
public:
virtual void OnDrawDayTimeUnit(
    CalendarRendererTimeUnitEventArgs^ e
) override
Parameters
e
Type: WindowsFormsCalendar CalendarRendererTimeUnitEventArgs
[Missing <param name="e"/> documentation for "M:WindowsFormsCalendar.CalendarSystemRenderer.OnDrawDayTimeUnit(WindowsFormsCalendar.CalendarRendererTimeUnitEventArgs)"]
See Also
CalendarSystemRenderer Class
CalendarSystemRenderer Members


OnDrawDayTop Method

CalendarSystemRenderer OnDrawDayTop Method A Sandcastle Documented Class Library
Send Feedback
Draws the all day items area

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Sub OnDrawDayTop ( _
    e As CalendarRendererDayEventArgs _
)
Public Overrides Sub OnDrawDayTop ( _
    e As CalendarRendererDayEventArgs _
)
public override void OnDrawDayTop(
    CalendarRendererDayEventArgs e
)
public override void OnDrawDayTop(
    CalendarRendererDayEventArgs e
)
public:
virtual void OnDrawDayTop(
    CalendarRendererDayEventArgs^ e
) override
public:
virtual void OnDrawDayTop(
    CalendarRendererDayEventArgs^ e
) override
Parameters
e
Type: WindowsFormsCalendar CalendarRendererDayEventArgs
Paint Info
See Also
CalendarSystemRenderer Class
CalendarSystemRenderer Members


OnDrawItemBackground Method

CalendarSystemRenderer OnDrawItemBackground Method A Sandcastle Documented Class Library
Send Feedback
Draws the background of the specified item

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Sub OnDrawItemBackground ( _
    e As CalendarRendererItemBoundsEventArgs _
)
Public Overrides Sub OnDrawItemBackground ( _
    e As CalendarRendererItemBoundsEventArgs _
)
public override void OnDrawItemBackground(
    CalendarRendererItemBoundsEventArgs e
)
public override void OnDrawItemBackground(
    CalendarRendererItemBoundsEventArgs e
)
public:
virtual void OnDrawItemBackground(
    CalendarRendererItemBoundsEventArgs^ e
) override
public:
virtual void OnDrawItemBackground(
    CalendarRendererItemBoundsEventArgs^ e
) override
Parameters
e
Type: WindowsFormsCalendar CalendarRendererItemBoundsEventArgs
Event Info
See Also
CalendarSystemRenderer Class
CalendarSystemRenderer Members


OnDrawItemBorder Method

CalendarSystemRenderer OnDrawItemBorder Method A Sandcastle Documented Class Library
Send Feedback
Draws the border of the specified item

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Sub OnDrawItemBorder ( _
    e As CalendarRendererItemBoundsEventArgs _
)
Public Overrides Sub OnDrawItemBorder ( _
    e As CalendarRendererItemBoundsEventArgs _
)
public override void OnDrawItemBorder(
    CalendarRendererItemBoundsEventArgs e
)
public override void OnDrawItemBorder(
    CalendarRendererItemBoundsEventArgs e
)
public:
virtual void OnDrawItemBorder(
    CalendarRendererItemBoundsEventArgs^ e
) override
public:
virtual void OnDrawItemBorder(
    CalendarRendererItemBoundsEventArgs^ e
) override
Parameters
e
Type: WindowsFormsCalendar CalendarRendererItemBoundsEventArgs
Event Info
See Also
CalendarSystemRenderer Class
CalendarSystemRenderer Members


OnDrawItemEndTime Method

CalendarSystemRenderer OnDrawItemEndTime Method A Sandcastle Documented Class Library
Send Feedback
Draws the end time of the item if applicable

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Sub OnDrawItemEndTime ( _
    e As CalendarRendererBoxEventArgs _
)
Public Overrides Sub OnDrawItemEndTime ( _
    e As CalendarRendererBoxEventArgs _
)
public override void OnDrawItemEndTime(
    CalendarRendererBoxEventArgs e
)
public override void OnDrawItemEndTime(
    CalendarRendererBoxEventArgs e
)
public:
virtual void OnDrawItemEndTime(
    CalendarRendererBoxEventArgs^ e
) override
public:
virtual void OnDrawItemEndTime(
    CalendarRendererBoxEventArgs^ e
) override
Parameters
e
Type: WindowsFormsCalendar CalendarRendererBoxEventArgs
Event data
See Also
CalendarSystemRenderer Class
CalendarSystemRenderer Members


OnDrawItemShadow Method

CalendarSystemRenderer OnDrawItemShadow Method A Sandcastle Documented Class Library
Send Feedback
Draws the shadow of the specified item

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Sub OnDrawItemShadow ( _
    e As CalendarRendererItemBoundsEventArgs _
)
Public Overrides Sub OnDrawItemShadow ( _
    e As CalendarRendererItemBoundsEventArgs _
)
public override void OnDrawItemShadow(
    CalendarRendererItemBoundsEventArgs e
)
public override void OnDrawItemShadow(
    CalendarRendererItemBoundsEventArgs e
)
public:
virtual void OnDrawItemShadow(
    CalendarRendererItemBoundsEventArgs^ e
) override
public:
virtual void OnDrawItemShadow(
    CalendarRendererItemBoundsEventArgs^ e
) override
Parameters
e
Type: WindowsFormsCalendar CalendarRendererItemBoundsEventArgs
[Missing <param name="e"/> documentation for "M:WindowsFormsCalendar.CalendarSystemRenderer.OnDrawItemShadow(WindowsFormsCalendar.CalendarRendererItemBoundsEventArgs)"]
See Also
CalendarSystemRenderer Class
CalendarSystemRenderer Members


OnDrawItemStartTime Method

CalendarSystemRenderer OnDrawItemStartTime Method A Sandcastle Documented Class Library
Send Feedback
Draws the starttime of the item if applicable

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Sub OnDrawItemStartTime ( _
    e As CalendarRendererBoxEventArgs _
)
Public Overrides Sub OnDrawItemStartTime ( _
    e As CalendarRendererBoxEventArgs _
)
public override void OnDrawItemStartTime(
    CalendarRendererBoxEventArgs e
)
public override void OnDrawItemStartTime(
    CalendarRendererBoxEventArgs e
)
public:
virtual void OnDrawItemStartTime(
    CalendarRendererBoxEventArgs^ e
) override
public:
virtual void OnDrawItemStartTime(
    CalendarRendererBoxEventArgs^ e
) override
Parameters
e
Type: WindowsFormsCalendar CalendarRendererBoxEventArgs
Event data
See Also
CalendarSystemRenderer Class
CalendarSystemRenderer Members


OnDrawItemText Method

CalendarSystemRenderer OnDrawItemText Method A Sandcastle Documented Class Library
Send Feedback
Draws the text of an item

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Sub OnDrawItemText ( _
    e As CalendarRendererBoxEventArgs _
)
Public Overrides Sub OnDrawItemText ( _
    e As CalendarRendererBoxEventArgs _
)
public override void OnDrawItemText(
    CalendarRendererBoxEventArgs e
)
public override void OnDrawItemText(
    CalendarRendererBoxEventArgs e
)
public:
virtual void OnDrawItemText(
    CalendarRendererBoxEventArgs^ e
) override
public:
virtual void OnDrawItemText(
    CalendarRendererBoxEventArgs^ e
) override
Parameters
e
Type: WindowsFormsCalendar CalendarRendererBoxEventArgs
[Missing <param name="e"/> documentation for "M:WindowsFormsCalendar.CalendarSystemRenderer.OnDrawItemText(WindowsFormsCalendar.CalendarRendererBoxEventArgs)"]
See Also
CalendarSystemRenderer Class
CalendarSystemRenderer Members


OnDrawTimeScale Method

CalendarSystemRenderer OnDrawTimeScale Method A Sandcastle Documented Class Library
Send Feedback
Paints the timescale of the calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Sub OnDrawTimeScale ( _
    e As CalendarRendererEventArgs _
)
Public Overrides Sub OnDrawTimeScale ( _
    e As CalendarRendererEventArgs _
)
public override void OnDrawTimeScale(
    CalendarRendererEventArgs e
)
public override void OnDrawTimeScale(
    CalendarRendererEventArgs e
)
public:
virtual void OnDrawTimeScale(
    CalendarRendererEventArgs^ e
) override
public:
virtual void OnDrawTimeScale(
    CalendarRendererEventArgs^ e
) override
Parameters
e
Type: WindowsFormsCalendar CalendarRendererEventArgs
Paint info
See Also
CalendarSystemRenderer Class
CalendarSystemRenderer Members


OnDrawTimeScaleHour Method

CalendarSystemRenderer OnDrawTimeScaleHour Method A Sandcastle Documented Class Library
Send Feedback
Paints an hour of a timescale unit

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Sub OnDrawTimeScaleHour ( _
    e As CalendarRendererBoxEventArgs _
)
Public Overrides Sub OnDrawTimeScaleHour ( _
    e As CalendarRendererBoxEventArgs _
)
public override void OnDrawTimeScaleHour(
    CalendarRendererBoxEventArgs e
)
public override void OnDrawTimeScaleHour(
    CalendarRendererBoxEventArgs e
)
public:
virtual void OnDrawTimeScaleHour(
    CalendarRendererBoxEventArgs^ e
) override
public:
virtual void OnDrawTimeScaleHour(
    CalendarRendererBoxEventArgs^ e
) override
Parameters
e
Type: WindowsFormsCalendar CalendarRendererBoxEventArgs
Paint Info
See Also
CalendarSystemRenderer Class
CalendarSystemRenderer Members


OnDrawTimeScaleMinutes Method

CalendarSystemRenderer OnDrawTimeScaleMinutes Method A Sandcastle Documented Class Library
Send Feedback
Paints minutes of a timescale unit

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Sub OnDrawTimeScaleMinutes ( _
    e As CalendarRendererBoxEventArgs _
)
Public Overrides Sub OnDrawTimeScaleMinutes ( _
    e As CalendarRendererBoxEventArgs _
)
public override void OnDrawTimeScaleMinutes(
    CalendarRendererBoxEventArgs e
)
public override void OnDrawTimeScaleMinutes(
    CalendarRendererBoxEventArgs e
)
public:
virtual void OnDrawTimeScaleMinutes(
    CalendarRendererBoxEventArgs^ e
) override
public:
virtual void OnDrawTimeScaleMinutes(
    CalendarRendererBoxEventArgs^ e
) override
Parameters
e
Type: WindowsFormsCalendar CalendarRendererBoxEventArgs
Paint Info
See Also
CalendarSystemRenderer Class
CalendarSystemRenderer Members


OnDrawWeekHeader Method

CalendarSystemRenderer OnDrawWeekHeader Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:DrawWeekHeader] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Sub OnDrawWeekHeader ( _
    e As CalendarRendererBoxEventArgs _
)
Public Overrides Sub OnDrawWeekHeader ( _
    e As CalendarRendererBoxEventArgs _
)
public override void OnDrawWeekHeader(
    CalendarRendererBoxEventArgs e
)
public override void OnDrawWeekHeader(
    CalendarRendererBoxEventArgs e
)
public:
virtual void OnDrawWeekHeader(
    CalendarRendererBoxEventArgs^ e
) override
public:
virtual void OnDrawWeekHeader(
    CalendarRendererBoxEventArgs^ e
) override
Parameters
e
Type: WindowsFormsCalendar CalendarRendererBoxEventArgs
The CalendarRendererBoxEventArgs instance containing the event data.
See Also
CalendarSystemRenderer Class
CalendarSystemRenderer Members


OnDrawWeekHeaders Method

CalendarSystemRenderer OnDrawWeekHeaders Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:DrawWeekHeaders] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Sub OnDrawWeekHeaders ( _
    e As CalendarRendererEventArgs _
)
Public Overrides Sub OnDrawWeekHeaders ( _
    e As CalendarRendererEventArgs _
)
public override void OnDrawWeekHeaders(
    CalendarRendererEventArgs e
)
public override void OnDrawWeekHeaders(
    CalendarRendererEventArgs e
)
public:
virtual void OnDrawWeekHeaders(
    CalendarRendererEventArgs^ e
) override
public:
virtual void OnDrawWeekHeaders(
    CalendarRendererEventArgs^ e
) override
Parameters
e
Type: WindowsFormsCalendar CalendarRendererEventArgs
The CalendarRendererEventArgs instance containing the event data.
See Also
CalendarSystemRenderer Class
CalendarSystemRenderer Members


CalendarSystemRenderer Properties

CalendarSystemRenderer Properties A Sandcastle Documented Class Library
Send Feedback
The CalendarSystemRenderer type exposes the following members.
Properties
 | Name | Description
Public property | Calendar | Gets the Calendar this renderer belongs to (Inherited from CalendarRenderer.)
Public property | ColorTable | Gets or sets the CalendarColorTable for this renderer
Public property | DayHeaderHeight | Gets the height of the header of days (Inherited from CalendarRenderer.)
Public property | DayNameHeaderColumns | Gets the bounds for day name headers (Inherited from CalendarRenderer.)
Public property | DayNameHeadersHeight | Gets the height of the day name headers (Inherited from CalendarRenderer.)
Public property | DayNameHeadersVisible | Gets a value indicating if the day names headers are visible (e.g. Monday, Tuesday, Wednesday ...) (Inherited from CalendarRenderer.)
Public property | DayTopHeight | Gets the current height of the all day items area (Inherited from CalendarRenderer.)
Public property | DayTopItemsPadding | Gets or sets the padding of the items that goes on the top part of the days, when in Expanded (Inherited from CalendarRenderer.)
Public property | DayTopMinHeight | Gets the minimum height for day tops (Inherited from CalendarRenderer.)
Public property | ItemInvalidateMargin | Gets or sets the extra margin for invalidating and redrawing items (Inherited from CalendarRenderer.)
Public property | ItemRoundness | Gets or sets the roundness of the item (Inherited from CalendarRenderer.)
Public property | ItemShadowPadding | Gets or sets the amount of pixels that the item's shadow is dropped (Inherited from CalendarRenderer.)
Public property | ItemsPadding | Gets or sets the padding of items on expanded mode (Inherited from CalendarRenderer.)
Public property | ItemTextMargin | Gets the margin of the text in the items (Inherited from CalendarRenderer.)
Public property | SelectedItemBorder | Gets or sets the size of the border of selected items
Public property | StandardItemHeight | Gets the height of items on day tops (Inherited from CalendarRenderer.)
Public property | TimeScaleBounds | Gets or sets the bounds of the timescale (Inherited from CalendarRenderer.)
Public property | TimeScaleUnitHeight | Gets the height of the time scale unit. (Inherited from CalendarRenderer.)
Public property | TimeScaleVisible | Gets a value indicating whether [time scale visible]. (Inherited from CalendarRenderer.)
Public property | TimeScaleWidth | Gets the width of the timescale (Inherited from CalendarRenderer.)
Public property | WeekHeaderWidth | Gets the width of the week header. (Inherited from CalendarRenderer.)
Back to Top
See Also
CalendarSystemRenderer Class


ColorTable Property

CalendarSystemRenderer ColorTable Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the CalendarColorTable for this renderer

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property ColorTable As CalendarColorTable
    Get
    Set
Public Property ColorTable As CalendarColorTable
    Get
    Set
public CalendarColorTable ColorTable { get; set; }
public CalendarColorTable ColorTable { get; set; }
public:
property CalendarColorTable^ ColorTable {
    CalendarColorTable^ get ();
    void set (CalendarColorTable^ value);
}
public:
property CalendarColorTable^ ColorTable {
    CalendarColorTable^ get ();
    void set (CalendarColorTable^ value);
}
See Also
CalendarSystemRenderer Class
CalendarSystemRenderer Members


SelectedItemBorder Property

CalendarSystemRenderer SelectedItemBorder Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the size of the border of selected items

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property SelectedItemBorder As Single
    Get
    Set
Public Property SelectedItemBorder As Single
    Get
    Set
public float SelectedItemBorder { get; set; }
public float SelectedItemBorder { get; set; }
public:
property float SelectedItemBorder {
    float get ();
    void set (float value);
}
public:
property float SelectedItemBorder {
    float get ();
    void set (float value);
}
See Also
CalendarSystemRenderer Class
CalendarSystemRenderer Members


CalendarTextBox Class

CalendarTextBox Class A Sandcastle Documented Class Library
A text box control used in the calendar
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.ComponentModel Component
Online System.Windows.Forms Control
Online System.Windows.Forms TextBoxBase
Online System.Windows.Forms TextBox
WindowsFormsCalendar CalendarTextBox

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class CalendarTextBox _
    Inherits TextBox
Public Class CalendarTextBox _
    Inherits TextBox
public class CalendarTextBox : TextBox
public class CalendarTextBox : TextBox
public ref class CalendarTextBox : public TextBox
public ref class CalendarTextBox : public TextBox
See Also
CalendarTextBox Members


CalendarTextBox Members

CalendarTextBox Members A Sandcastle Documented Class Library
Send Feedback

The CalendarTextBox type exposes the following members.
Constructors
 | Name | Description
Public method | CalendarTextBox | Creates a new CalendarTextBox for the specified Calendar
Back to Top
Methods
 | Name | Description
Protected method | Online AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified Online AccessibleEvents for the specified child control. (Inherited from Online Control.)
Protected method | Online AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified Online AccessibleEvents for the specified child control . (Inherited from Online Control.)
Public method | Online AppendText | Appends text to the current text of a text box. (Inherited from Online TextBoxBase.)
Public method | Online BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Online Control.)
Public method | Online BeginInvoke(Delegate, Object ) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Online Control.)
Public method | Online BringToFront | Brings the control to the front of the z-order. (Inherited from Online Control.)
Public method | Online Clear | Clears all text from the text box control. (Inherited from Online TextBoxBase.)
Public method | Online ClearUndo | Clears information about the most recent operation from the undo buffer of the text box. (Inherited from Online TextBoxBase.)
Public method | Online Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Online Control.)
Public method | Online Copy | Copies the current selection in the text box to the Clipboard. (Inherited from Online TextBoxBase.)
Protected method | Online CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Online Control.)
Public method | Online CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Online Control.)
Protected method | Online CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Online Control.)
Public method | Online CreateGraphics | Creates the Online Graphics for the control. (Inherited from Online Control.)
Protected method | Online CreateHandle | (Inherited from Online TextBoxBase.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online Cut | Moves the current selection in the text box to the Clipboard. (Inherited from Online TextBoxBase.)
Protected method | Online DefWndProc | Sends the specified message to the default window procedure. (Inherited from Online Control.)
Public method | Online DeselectAll | Specifies that the value of the Online SelectionLength property is zero so that no characters are selected in the control. (Inherited from Online TextBoxBase.)
Protected method | Online DestroyHandle | Destroys the handle associated with the control. (Inherited from Online Control.)
Public method | Online Dispose | Releases all resources used by the Online Component. (Inherited from Online Component.)
Protected method | Online Dispose(Boolean) | Releases the unmanaged resources used by the Online TextBox and optionally releases the managed resources. (Inherited from Online TextBox.)
Public method | Online DoDragDrop | Begins a drag-and-drop operation. (Inherited from Online Control.)
Public method | Online DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Online Control.)
Public method | Online EndInvoke | Retrieves the return value of the asynchronous operation represented by the Online IAsyncResult passed. (Inherited from Online Control.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Releases unmanaged resources and performs other cleanup operations before the Online Component is reclaimed by garbage collection. (Inherited from Online Component.)
Public method | Online FindForm | Retrieves the form that the control is on. (Inherited from Online Control.)
Public method | Online Focus | Sets input focus to the control. (Inherited from Online Control.)
Protected method | Online GetAccessibilityObjectById | Retrieves the specified Online AccessibleObject. (Inherited from Online Control.)
Protected method | Online GetAutoSizeMode | Retrieves a value indicating how a control will behave when its Online AutoSize property is enabled. (Inherited from Online Control.)
Public method | Online GetCharFromPosition | Retrieves the character that is closest to the specified location within the control. (Inherited from Online TextBoxBase.)
Public method | Online GetCharIndexFromPosition | Retrieves the index of the character nearest to the specified location. (Inherited from Online TextBoxBase.)
Public method | Online GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Online Control.)
Public method | Online GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Online Control.)
Public method | Online GetContainerControl | Returns the next Online ContainerControl up the control's chain of parent controls. (Inherited from Online Control.)
Public method | Online GetFirstCharIndexFromLine | Retrieves the index of the first character of a given line. (Inherited from Online TextBoxBase.)
Public method | Online GetFirstCharIndexOfCurrentLine | Retrieves the index of the first character of the current line. (Inherited from Online TextBoxBase.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetLineFromCharIndex | Retrieves the line number from the specified character position within the text of the control. (Inherited from Online TextBoxBase.)
Public method | Online GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Online Control.)
Public method | Online GetPositionFromCharIndex | Retrieves the location within the control at the specified character index. (Inherited from Online TextBoxBase.)
Public method | Online GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Online Control.)
Protected method | Online GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Online Control.)
Protected method | Online GetService | Returns an object that represents a service provided by the Online Component or by its Online Container. (Inherited from Online Component.)
Protected method | Online GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Online Control.)
Protected method | Online GetTopLevel | Determines if the control is a top-level control. (Inherited from Online Control.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online Hide | Conceals the control from the user. (Inherited from Online Control.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online InitLayout | Called after the control has been added to another container. (Inherited from Online Control.)
Public method | Online Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Online Control.)
Public method | Online Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Online Control.)
Public method | Online Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Online Control.)
Public method | Online Invoke(Delegate, Object ) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Online Control.)
Protected method | Online InvokeGotFocus | Raises the Online GotFocus event for the specified control. (Inherited from Online Control.)
Protected method | Online InvokeLostFocus | Raises the Online LostFocus event for the specified control. (Inherited from Online Control.)
Protected method | Online InvokeOnClick | Raises the Online Click event for the specified control. (Inherited from Online Control.)
Protected method | Online InvokePaint | Raises the Online Paint event for the specified control. (Inherited from Online Control.)
Protected method | Online InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Online Control.)
Protected method | Online IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Online Control.)
Protected method | Online IsInputKey | Determines whether the specified key is an input key or a special key that requires preprocessing. (Inherited from Online TextBox.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online NotifyInvalidate | Raises the Online Invalidated event with a specified region of the control to invalidate. (Inherited from Online Control.)
Protected method | Online OnAcceptsTabChanged | Raises the Online AcceptsTabChanged event. (Inherited from Online TextBoxBase.)
Protected method | Online OnAutoSizeChanged | Raises the Online AutoSizeChanged event. (Inherited from Online Control.)
Protected method | Online OnBackColorChanged | Raises the Online BackColorChanged event. (Inherited from Online TextBox.)
Protected method | Online OnBackgroundImageChanged | Raises the Online BackgroundImageChanged event. (Inherited from Online Control.)
Protected method | Online OnBackgroundImageLayoutChanged | Raises the Online BackgroundImageLayoutChanged event. (Inherited from Online Control.)
Protected method | Online OnBindingContextChanged | Raises the Online BindingContextChanged event. (Inherited from Online Control.)
Protected method | Online OnBorderStyleChanged | Raises the Online BorderStyleChanged event. (Inherited from Online TextBoxBase.)
Protected method | Online OnCausesValidationChanged | Raises the Online CausesValidationChanged event. (Inherited from Online Control.)
Protected method | Online OnChangeUICues | Raises the Online ChangeUICues event. (Inherited from Online Control.)
Protected method | Online OnClick | Raises the Online Click event. (Inherited from Online Control.)
Protected method | Online OnClientSizeChanged | Raises the Online ClientSizeChanged event. (Inherited from Online Control.)
Protected method | Online OnContextMenuChanged | Raises the Online ContextMenuChanged event. (Inherited from Online Control.)
Protected method | Online OnContextMenuStripChanged | Raises the Online ContextMenuStripChanged event. (Inherited from Online Control.)
Protected method | Online OnControlAdded | Raises the Online ControlAdded event. (Inherited from Online Control.)
Protected method | Online OnControlRemoved | Raises the Online ControlRemoved event. (Inherited from Online Control.)
Protected method | Online OnCreateControl | Raises the Online CreateControl method. (Inherited from Online Control.)
Protected method | Online OnCursorChanged | Raises the Online CursorChanged event. (Inherited from Online Control.)
Protected method | Online OnDockChanged | Raises the Online DockChanged event. (Inherited from Online Control.)
Protected method | Online OnDoubleClick | Raises the Online DoubleClick event. (Inherited from Online Control.)
Protected method | Online OnDragDrop | Raises the Online DragDrop event. (Inherited from Online Control.)
Protected method | Online OnDragEnter | Raises the Online DragEnter event. (Inherited from Online Control.)
Protected method | Online OnDragLeave | Raises the Online DragLeave event. (Inherited from Online Control.)
Protected method | Online OnDragOver | Raises the Online DragOver event. (Inherited from Online Control.)
Protected method | Online OnEnabledChanged | Raises the Online EnabledChanged event. (Inherited from Online Control.)
Protected method | Online OnEnter | Raises the Online Enter event. (Inherited from Online Control.)
Protected method | Online OnFontChanged | Raises the Online FontChanged event. (Inherited from Online TextBox.)
Protected method | Online OnForeColorChanged | Raises the Online ForeColorChanged event. (Inherited from Online Control.)
Protected method | Online OnGiveFeedback | Raises the Online GiveFeedback event. (Inherited from Online Control.)
Protected method | Online OnGotFocus | Raises the Online GotFocus event. (Inherited from Online TextBox.)
Protected method | Online OnHandleCreated | Raises the Online HandleCreated event. (Inherited from Online TextBox.)
Protected method | Online OnHandleDestroyed | Raises the Online OnHandleDestroyed(EventArgs) event. (Inherited from Online TextBox.)
Protected method | Online OnHelpRequested | Raises the Online HelpRequested event. (Inherited from Online Control.)
Protected method | Online OnHideSelectionChanged | Raise the Online HideSelectionChanged event. (Inherited from Online TextBoxBase.)
Protected method | Online OnImeModeChanged | Raises the Online ImeModeChanged event. (Inherited from Online Control.)
Protected method | Online OnInvalidated | Raises the Online Invalidated event. (Inherited from Online Control.)
Protected method | Online OnKeyDown | Raises the Online KeyDown event. (Inherited from Online Control.)
Protected method | Online OnKeyPress | Raises the Online KeyPress event. (Inherited from Online Control.)
Protected method | Online OnKeyUp | Raises the Online KeyUp event. (Inherited from Online Control.)
Protected method | Online OnLayout | Raises the Online Layout event. (Inherited from Online Control.)
Protected method | Online OnLeave | Raises the Online Leave event. (Inherited from Online Control.)
Protected method | Online OnLocationChanged | Raises the Online LocationChanged event. (Inherited from Online Control.)
Protected method | Online OnLostFocus | Raises the Online LostFocus event. (Inherited from Online Control.)
Protected method | Online OnMarginChanged | Raises the Online MarginChanged event. (Inherited from Online Control.)
Protected method | Online OnModifiedChanged | Raises the Online ModifiedChanged event. (Inherited from Online TextBoxBase.)
Protected method | Online OnMouseCaptureChanged | Raises the Online MouseCaptureChanged event. (Inherited from Online Control.)
Protected method | Online OnMouseClick | Raises the Online MouseClick event. (Inherited from Online Control.)
Protected method | Online OnMouseDoubleClick | Raises the Online MouseDoubleClick event. (Inherited from Online Control.)
Protected method | Online OnMouseDown | Raises the Online MouseDown event. (Inherited from Online Control.)
Protected method | Online OnMouseEnter | Raises the Online MouseEnter event. (Inherited from Online Control.)
Protected method | Online OnMouseHover | Raises the Online MouseHover event. (Inherited from Online Control.)
Protected method | Online OnMouseLeave | Raises the Online MouseLeave event. (Inherited from Online Control.)
Protected method | Online OnMouseMove | Raises the Online MouseMove event. (Inherited from Online Control.)
Protected method | Online OnMouseUp | Raises the Online MouseUp event. (Inherited from Online TextBoxBase.)
Protected method | Online OnMouseWheel | Raises the Online MouseWheel event. (Inherited from Online Control.)
Protected method | Online OnMove | Raises the Online Move event. (Inherited from Online Control.)
Protected method | Online OnMultilineChanged | Raises the Online MultilineChanged event. (Inherited from Online TextBoxBase.)
Protected method | Online OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Online Control.)
Protected method | Online OnPaddingChanged | This method is not relevant for this class. (Inherited from Online TextBoxBase.)
Protected method | Online OnPaint | Raises the Online Paint event. (Inherited from Online Control.)
Protected method | Online OnPaintBackground | Paints the background of the control. (Inherited from Online Control.)
Protected method | Online OnParentBackColorChanged | Raises the Online BackColorChanged event when the Online BackColor property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentBackgroundImageChanged | Raises the Online BackgroundImageChanged event when the Online BackgroundImage property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentBindingContextChanged | Raises the Online BindingContextChanged event when the Online BindingContext property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentChanged | Raises the Online ParentChanged event. (Inherited from Online Control.)
Protected method | Online OnParentCursorChanged | Raises the Online CursorChanged event. (Inherited from Online Control.)
Protected method | Online OnParentEnabledChanged | Raises the Online EnabledChanged event when the Online Enabled property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentFontChanged | Raises the Online FontChanged event when the Online Font property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentForeColorChanged | Raises the Online ForeColorChanged event when the Online ForeColor property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentRightToLeftChanged | Raises the Online RightToLeftChanged event when the Online RightToLeft property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentVisibleChanged | Raises the Online VisibleChanged event when the Online Visible property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnPreviewKeyDown | Raises the Online PreviewKeyDown event. (Inherited from Online Control.)
Protected method | Online OnPrint | Raises the Online Paint event. (Inherited from Online Control.)
Protected method | Online OnQueryContinueDrag | Raises the Online QueryContinueDrag event. (Inherited from Online Control.)
Protected method | Online OnReadOnlyChanged | Raises the Online ReadOnlyChanged event. (Inherited from Online TextBoxBase.)
Protected method | Online OnRegionChanged | Raises the Online RegionChanged event. (Inherited from Online Control.)
Protected method | Online OnResize | Raises the Online Resize event. (Inherited from Online Control.)
Protected method | Online OnRightToLeftChanged | Raises the Online RightToLeftChanged event. (Inherited from Online Control.)
Protected method | Online OnSizeChanged | Raises the Online SizeChanged event. (Inherited from Online Control.)
Protected method | Online OnStyleChanged | Raises the Online StyleChanged event. (Inherited from Online Control.)
Protected method | Online OnSystemColorsChanged | Raises the Online SystemColorsChanged event. (Inherited from Online Control.)
Protected method | Online OnTabIndexChanged | Raises the Online TabIndexChanged event. (Inherited from Online Control.)
Protected method | Online OnTabStopChanged | Raises the Online TabStopChanged event. (Inherited from Online Control.)
Protected method | Online OnTextAlignChanged | Raises the Online TextAlignChanged event. (Inherited from Online TextBox.)
Protected method | Online OnTextChanged | (Inherited from Online TextBoxBase.)
Protected method | Online OnValidated | Raises the Online Validated event. (Inherited from Online Control.)
Protected method | Online OnValidating | Raises the Online Validating event. (Inherited from Online Control.)
Protected method | Online OnVisibleChanged | Raises the Online VisibleChanged event. (Inherited from Online Control.)
Public method | Online Paste | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from Online TextBoxBase.)
Public method | Online Paste(String) | Sets the selected text to the specified text without clearing the undo buffer. (Inherited from Online TextBox.)
Public method | Online PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Online Control.)
Public method | Online PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Online Control.)
Public method | Online PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Online Control.)
Public method | Online PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Online Control.)
Public method | Online PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Online Control.)
Public method | Online PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Online Control.)
Protected method | Online ProcessCmdKey | Processes a command key. (Inherited from Online TextBoxBase.)
Protected method | Online ProcessDialogChar | Processes a dialog character. (Inherited from Online Control.)
Protected method | Online ProcessDialogKey | (Inherited from Online TextBoxBase.)
Protected method | Online ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Online Control.)
Protected method | Online ProcessKeyMessage | Processes a keyboard message. (Inherited from Online Control.)
Protected method | Online ProcessKeyPreview | Previews a keyboard message. (Inherited from Online Control.)
Protected method | Online ProcessMnemonic | Processes a mnemonic character. (Inherited from Online Control.)
Protected method | Online RaiseDragEvent | Raises the appropriate drag event. (Inherited from Online Control.)
Protected method | Online RaiseKeyEvent | Raises the appropriate key event. (Inherited from Online Control.)
Protected method | Online RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Online Control.)
Protected method | Online RaisePaintEvent | Raises the appropriate paint event. (Inherited from Online Control.)
Protected method | Online RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Online Control.)
Public method | Online RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Online Control.)
Public method | Online RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Online Control.)
Public method | Online Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Online Control.)
Public method | Online ResetBackColor | Resets the Online BackColor property to its default value. (Inherited from Online Control.)
Public method | Online ResetBindings | Causes a control bound to the Online BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Online Control.)
Public method | Online ResetCursor | Resets the Online Cursor property to its default value. (Inherited from Online Control.)
Public method | Online ResetFont | Resets the Online Font property to its default value. (Inherited from Online Control.)
Public method | Online ResetForeColor | Resets the Online ForeColor property to its default value. (Inherited from Online Control.)
Public method | Online ResetImeMode | Resets the Online ImeMode property to its default value. (Inherited from Online Control.)
Protected method | Online ResetMouseEventArgs | Resets the control to handle the Online MouseLeave event. (Inherited from Online Control.)
Public method | Online ResetRightToLeft | Resets the Online RightToLeft property to its default value. (Inherited from Online Control.)
Public method | Online ResetText | Resets the Online Text property to its default value. (Inherited from Online Control.)
Public method | Online ResumeLayout | Resumes usual layout logic. (Inherited from Online Control.)
Public method | Online ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Online Control.)
Protected method | Online RtlTranslateAlignment(HorizontalAlignment) | Converts the specified Online HorizontalAlignment to the appropriate Online HorizontalAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateAlignment(LeftRightAlignment) | Converts the specified Online LeftRightAlignment to the appropriate Online LeftRightAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateAlignment(ContentAlignment) | Converts the specified Online ContentAlignment to the appropriate Online ContentAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateContent | Converts the specified Online ContentAlignment to the appropriate Online ContentAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateHorizontal | Converts the specified Online HorizontalAlignment to the appropriate Online HorizontalAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateLeftRight | Converts the specified Online LeftRightAlignment to the appropriate Online LeftRightAlignment to support right-to-left text. (Inherited from Online Control.)
Public method | Online Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Online Control.)
Public method | Online Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Online Control.)
Public method | Online Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Online Control.)
Protected method | Online ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Online Control.)
Protected method | Online ScaleCore | This method is not relevant for this class. (Inherited from Online Control.)
Public method | Online ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from Online TextBoxBase.)
Public method | Online Select | Activates the control. (Inherited from Online Control.)
Public method | Online Select(Int32, Int32) | Selects a range of text in the text box. (Inherited from Online TextBoxBase.)
Protected method | Online Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Online Control.)
Public method | Online SelectAll | Selects all text in the text box. (Inherited from Online TextBoxBase.)
Public method | Online SelectNextControl | Activates the next control. (Inherited from Online Control.)
Public method | Online SendToBack | Sends the control to the back of the z-order. (Inherited from Online Control.)
Protected method | Online SetAutoSizeMode | Sets a value indicating how a control will behave when its Online AutoSize property is enabled. (Inherited from Online Control.)
Public method | Online SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Online Control.)
Public method | Online SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Online Control.)
Protected method | Online SetBoundsCore | Sets the specified bounds of the Online TextBoxBase control. (Inherited from Online TextBoxBase.)
Protected method | Online SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Online Control.)
Protected method | Online SetStyle | Sets a specified Online ControlStyles flag to either true or false. (Inherited from Online Control.)
Protected method | Online SetTopLevel | Sets the control as the top-level control. (Inherited from Online Control.)
Protected method | Online SetVisibleCore | Sets the control to the specified visible state. (Inherited from Online Control.)
Public method | Online Show | Displays the control to the user. (Inherited from Online Control.)
Protected method | Online SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Online Control.)
Public method | Online SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Online Control.)
Public method | Online ToString | Returns a string that represents the Online TextBoxBase control. (Inherited from Online TextBoxBase.)
Public method | Online Undo | Undoes the last edit operation in the text box. (Inherited from Online TextBoxBase.)
Public method | Online Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Online Control.)
Protected method | Online UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Online Control.)
Protected method | Online UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Online Control.)
Protected method | Online UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Online Control.)
Protected method | Online UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Online Control.)
Protected method | Online UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Online Control.)
Protected method | Online WndProc | Processes Windows messages. (Inherited from Online TextBox.)
Back to Top
Properties
 | Name | Description
Public property | Online AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline Online TextBox control creates a new line of text in the control or activates the default button for the form. (Inherited from Online TextBox.)
Public property | Online AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. (Inherited from Online TextBoxBase.)
Public property | Online AccessibilityObject | Gets the Online AccessibleObject assigned to the control. (Inherited from Online Control.)
Public property | Online AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Online Control.)
Public property | Online AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Online Control.)
Public property | Online AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Online Control.)
Public property | Online AccessibleRole | Gets or sets the accessible role of the control (Inherited from Online Control.)
Public property | Online AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Online Control.)
Public property | Online Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Online Control.)
Public property | Online AutoCompleteCustomSource | Gets or sets a custom Online StringCollection to use when the Online AutoCompleteSource property is set to CustomSource. (Inherited from Online TextBox.)
Public property | Online AutoCompleteMode | Gets or sets an option that controls how automatic completion works for the Online TextBox. (Inherited from Online TextBox.)
Public property | Online AutoCompleteSource | Gets or sets a value specifying the source of complete strings used for automatic completion. (Inherited from Online TextBox.)
Public property | Online AutoScrollOffset | Gets or sets where this control is scrolled to in Online ScrollControlIntoView(Control). (Inherited from Online Control.)
Public property | Online AutoSize | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed. (Inherited from Online TextBoxBase.)
Public property | Online BackColor | Gets or sets the background color of the control. (Inherited from Online TextBoxBase.)
Public property | Online BackgroundImage | This property is not relevant for this class. (Inherited from Online TextBoxBase.)
Public property | Online BackgroundImageLayout | This property is not relevant for this class. (Inherited from Online TextBoxBase.)
Public property | Online BindingContext | Gets or sets the Online BindingContext for the control. (Inherited from Online Control.)
Public property | Online BorderStyle | Gets or sets the border type of the text box control. (Inherited from Online TextBoxBase.)
Public property | Online Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Online Control.)
Public property | Online Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Online Control.)
Public property | Calendar | Gets the calendar where this control lives
Protected property | Online CanEnableIme | Gets a value indicating whether the Online ImeMode property can be set to an active value, to enable IME support. (Inherited from Online TextBoxBase.)
Public property | Online CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Online Control.)
Protected property | Online CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Online Control.)
Public property | Online CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Online Control.)
Public property | Online CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from Online TextBoxBase.)
Public property | Online Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Online Control.)
Public property | Online CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Online Control.)
Public property | Online CharacterCasing | Gets or sets whether the Online TextBox control modifies the case of characters as they are typed. (Inherited from Online TextBox.)
Public property | Online ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Online Control.)
Public property | Online ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Online Control.)
Public property | Online CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Online Control.)
Public property | Online Container | Gets the Online IContainer that contains the Online Component. (Inherited from Online Component.)
Public property | Online ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Online Control.)
Public property | Online ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Online Control.)
Public property | Online ContextMenuStrip | Gets or sets the Online ContextMenuStrip associated with this control. (Inherited from Online Control.)
Public property | Online Controls | Gets the collection of controls contained within the control. (Inherited from Online Control.)
Public property | Online Created | Gets a value indicating whether the control has been created. (Inherited from Online Control.)
Protected property | Online CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Online TextBox.)
Public property | Online Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Online Control.)
Public property | Online DataBindings | Gets the data bindings for the control. (Inherited from Online Control.)
Protected property | Online DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Online TextBoxBase.)
Protected property | Online DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Online Control.)
Protected property | Online DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Online Control.)
Protected property | Online DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Online Control.)
Protected property | Online DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Online Control.)
Protected property | Online DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Online Control.)
Protected property | Online DefaultSize | (Inherited from Online TextBoxBase.)
Protected property | Online DesignMode | Gets a value that indicates whether the Online Component is currently in design mode. (Inherited from Online Component.)
Public property | Online DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Online Control.)
Public property | Online Disposing | Gets a value indicating whether the base Online Control class is in the process of disposing. (Inherited from Online Control.)
Public property | Online Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Online Control.)
Protected property | Online DoubleBuffered | Gets or sets a value indicating whether control drawing is done in a buffer before the control is displayed. This property is not relevant for this class. (Inherited from Online TextBoxBase.)
Public property | Online Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Online Control.)
Protected property | Online Events | Gets the list of event handlers that are attached to this Online Component. (Inherited from Online Component.)
Public property | Online Focused | Gets a value indicating whether the control has input focus. (Inherited from Online Control.)
Public property | Online Font | Gets or sets the font of the text displayed by the control. (Inherited from Online Control.)
Protected property | Online FontHeight | Gets or sets the height of the font of the control. (Inherited from Online Control.)
Public property | Online ForeColor | Gets or sets the foreground color of the control. (Inherited from Online TextBoxBase.)
Public property | Online Handle | Gets the window handle that the control is bound to. (Inherited from Online Control.)
Public property | Online HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Online Control.)
Public property | Online Height | Gets or sets the height of the control. (Inherited from Online Control.)
Public property | Online HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (Inherited from Online TextBoxBase.)
Public property | Online ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Online Control.)
Protected property | Online ImeModeBase | Gets or sets the Input Method Editor (IME) mode of a control. (Inherited from Online TextBoxBase.)
Public property | Online InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Online Control.)
Public property | Online IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Online Control.)
Public property | Online IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Online Control.)
Public property | Online IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Online Control.)
Public property | Online IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Online Control.)
Public property | Online LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Online Control.)
Public property | Online Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Online Control.)
Public property | Online Lines | Gets or sets the lines of text in a text box control. (Inherited from Online TextBoxBase.)
Public property | Online Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Online Control.)
Public property | Online Margin | Gets or sets the space between controls. (Inherited from Online Control.)
Public property | Online MaximumSize | Gets or sets the size that is the upper limit that Online GetPreferredSize(Size) can specify. (Inherited from Online Control.)
Public property | Online MaxLength | Gets or sets the maximum number of characters the user can type or paste into the text box control. (Inherited from Online TextBoxBase.)
Public property | Online MinimumSize | Gets or sets the size that is the lower limit that Online GetPreferredSize(Size) can specify. (Inherited from Online Control.)
Public property | Online Modified | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set. (Inherited from Online TextBoxBase.)
Public property | Online Multiline | Gets or sets a value indicating whether this is a multiline Online TextBox control. (Inherited from Online TextBox.)
Public property | Online Name | Gets or sets the name of the control. (Inherited from Online Control.)
Public property | Online Padding | This property is not relevant for this class. (Inherited from Online TextBoxBase.)
Public property | Online Parent | Gets or sets the parent container of the control. (Inherited from Online Control.)
Public property | Online PasswordChar | Gets or sets the character used to mask characters of a password in a single-line Online TextBox control. (Inherited from Online TextBox.)
Public property | Online PreferredHeight | Gets the preferred height for a text box. (Inherited from Online TextBoxBase.)
Public property | Online PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Online Control.)
Public property | Online ProductName | Gets the product name of the assembly containing the control. (Inherited from Online Control.)
Public property | Online ProductVersion | Gets the version of the assembly containing the control. (Inherited from Online Control.)
Public property | Online ReadOnly | Gets or sets a value indicating whether text in the text box is read-only. (Inherited from Online TextBoxBase.)
Public property | Online RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Online Control.)
Public property | Online Region | Gets or sets the window region associated with the control. (Inherited from Online Control.)
Protected property | Online RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Online Control.)
Protected property | Online ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Online Control.)
Public property | Online Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Online Control.)
Public property | Online RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Online Control.)
Protected property | Online ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Online Control.)
Public property | Online ScrollBars | Gets or sets which scroll bars should appear in a multiline Online TextBox control. (Inherited from Online TextBox.)
Public property | Online SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from Online TextBoxBase.)
Public property | Online SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from Online TextBoxBase.)
Public property | Online SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from Online TextBoxBase.)
Public property | Online ShortcutsEnabled | Gets or sets a value indicating whether the defined shortcuts are enabled. (Inherited from Online TextBoxBase.)
Protected property | Online ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Online Control.)
Protected property | Online ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Online Control.)
Public property | Online Site | Gets or sets the site of the control. (Inherited from Online Control.)
Public property | Online Size | Gets or sets the height and width of the control. (Inherited from Online Control.)
Public property | Online TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Online Control.)
Public property | Online TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Online Control.)
Public property | Online Tag | Gets or sets the object that contains data about the control. (Inherited from Online Control.)
Public property | Online Text | Gets or sets the current text in the Online TextBox. (Inherited from Online TextBox.)
Public property | Online TextAlign | Gets or sets how text is aligned in a Online TextBox control. (Inherited from Online TextBox.)
Public property | Online TextLength | Gets the length of text in the control. (Inherited from Online TextBoxBase.)
Public property | Online Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Online Control.)
Public property | Online TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Online Form that the control is contained in. (Inherited from Online Control.)
Public property | Online UseSystemPasswordChar | Gets or sets a value indicating whether the text in the Online TextBox control should appear as the default password character. (Inherited from Online TextBox.)
Public property | Online UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Online Control.)
Public property | Online Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Online Control.)
Public property | Online Width | Gets or sets the width of the control. (Inherited from Online Control.)
Public property | Online WindowTarget | This property is not relevant for this class. (Inherited from Online Control.)
Public property | Online WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. (Inherited from Online TextBoxBase.)
Back to Top
Events
 | Name | Description
Public event | Online AcceptsTabChanged | Occurs when the value of the Online AcceptsTab property has changed. (Inherited from Online TextBoxBase.)
Public event | Online AutoSizeChanged | This event is not relevant for this class. (Inherited from Online TextBoxBase.)
Public event | Online BackColorChanged | Occurs when the value of the Online BackColor property changes. (Inherited from Online Control.)
Public event | Online BackgroundImageChanged | Occurs when the value of the Online BackgroundImage property changes. This event is not relevant for this class. (Inherited from Online TextBoxBase.)
Public event | Online BackgroundImageLayoutChanged | Occurs when the value of the Online BackgroundImageLayout property changes. This event is not relevant for this class. (Inherited from Online TextBoxBase.)
Public event | Online BindingContextChanged | Occurs when the value of the Online BindingContext property changes. (Inherited from Online Control.)
Public event | Online BorderStyleChanged | Occurs when the value of the Online BorderStyle property has changed. (Inherited from Online TextBoxBase.)
Public event | Online CausesValidationChanged | Occurs when the value of the Online CausesValidation property changes. (Inherited from Online Control.)
Public event | Online ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Online Control.)
Public event | Online Click | Occurs when the text box is clicked. (Inherited from Online TextBoxBase.)
Public event | Online ClientSizeChanged | Occurs when the value of the Online ClientSize property changes. (Inherited from Online Control.)
Public event | Online ContextMenuChanged | Occurs when the value of the Online ContextMenu property changes. (Inherited from Online Control.)
Public event | Online ContextMenuStripChanged | Occurs when the value of the Online ContextMenuStrip property changes. (Inherited from Online Control.)
Public event | Online ControlAdded | Occurs when a new control is added to the Online Control ControlCollection. (Inherited from Online Control.)
Public event | Online ControlRemoved | Occurs when a control is removed from the Online Control ControlCollection. (Inherited from Online Control.)
Public event | Online CursorChanged | Occurs when the value of the Online Cursor property changes. (Inherited from Online Control.)
Public event | Online Disposed | Occurs when the component is disposed by a call to the Online Dispose method. (Inherited from Online Component.)
Public event | Online DockChanged | Occurs when the value of the Online Dock property changes. (Inherited from Online Control.)
Public event | Online DoubleClick | Occurs when the control is double-clicked. (Inherited from Online Control.)
Public event | Online DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Online Control.)
Public event | Online DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Online Control.)
Public event | Online DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Online Control.)
Public event | Online DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Online Control.)
Public event | Online EnabledChanged | Occurs when the Online Enabled property value has changed. (Inherited from Online Control.)
Public event | Online Enter | Occurs when the control is entered. (Inherited from Online Control.)
Public event | Online FontChanged | Occurs when the Online Font property value changes. (Inherited from Online Control.)
Public event | Online ForeColorChanged | Occurs when the Online ForeColor property value changes. (Inherited from Online Control.)
Public event | Online GiveFeedback | Occurs during a drag operation. (Inherited from Online Control.)
Public event | Online GotFocus | Occurs when the control receives focus. (Inherited from Online Control.)
Public event | Online HandleCreated | Occurs when a handle is created for the control. (Inherited from Online Control.)
Public event | Online HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Online Control.)
Public event | Online HelpRequested | Occurs when the user requests help for a control. (Inherited from Online Control.)
Public event | Online HideSelectionChanged | Occurs when the value of the Online HideSelection property has changed. (Inherited from Online TextBoxBase.)
Public event | Online ImeModeChanged | Occurs when the Online ImeMode property has changed. (Inherited from Online Control.)
Public event | Online Invalidated | Occurs when a control's display requires redrawing. (Inherited from Online Control.)
Public event | Online KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Online Control.)
Public event | Online KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Online Control.)
Public event | Online KeyUp | Occurs when a key is released while the control has focus. (Inherited from Online Control.)
Public event | Online Layout | Occurs when a control should reposition its child controls. (Inherited from Online Control.)
Public event | Online Leave | Occurs when the input focus leaves the control. (Inherited from Online Control.)
Public event | Online LocationChanged | Occurs when the Online Location property value has changed. (Inherited from Online Control.)
Public event | Online LostFocus | Occurs when the control loses focus. (Inherited from Online Control.)
Public event | Online MarginChanged | Occurs when the control's margin changes. (Inherited from Online Control.)
Public event | Online ModifiedChanged | Occurs when the value of the Online Modified property has changed. (Inherited from Online TextBoxBase.)
Public event | Online MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Online Control.)
Public event | Online MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Online TextBoxBase.)
Public event | Online MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Online Control.)
Public event | Online MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Online Control.)
Public event | Online MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Online Control.)
Public event | Online MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Online Control.)
Public event | Online MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Online Control.)
Public event | Online MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Online Control.)
Public event | Online MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Online Control.)
Public event | Online MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Online Control.)
Public event | Online Move | Occurs when the control is moved. (Inherited from Online Control.)
Public event | Online MultilineChanged | Occurs when the value of the Online Multiline property has changed. (Inherited from Online TextBoxBase.)
Public event | Online PaddingChanged | This event is not relevant for this class. (Inherited from Online TextBoxBase.)
Public event | Online Paint | Occurs when the control is redrawn. This event is not relevant for this class. (Inherited from Online TextBoxBase.)
Public event | Online ParentChanged | Occurs when the Online Parent property value changes. (Inherited from Online Control.)
Public event | Online PreviewKeyDown | Occurs before the Online KeyDown event when a key is pressed while focus is on this control. (Inherited from Online Control.)
Public event | Online QueryAccessibilityHelp | Occurs when Online AccessibleObject is providing help to accessibility applications. (Inherited from Online Control.)
Public event | Online QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Online Control.)
Public event | Online ReadOnlyChanged | Occurs when the value of the Online ReadOnly property has changed. (Inherited from Online TextBoxBase.)
Public event | Online RegionChanged | Occurs when the value of the Online Region property changes. (Inherited from Online Control.)
Public event | Online Resize | Occurs when the control is resized. (Inherited from Online Control.)
Public event | Online RightToLeftChanged | Occurs when the Online RightToLeft property value changes. (Inherited from Online Control.)
Public event | Online SizeChanged | Occurs when the Online Size property value changes. (Inherited from Online Control.)
Public event | Online StyleChanged | Occurs when the control style changes. (Inherited from Online Control.)
Public event | Online SystemColorsChanged | Occurs when the system colors change. (Inherited from Online Control.)
Public event | Online TabIndexChanged | Occurs when the Online TabIndex property value changes. (Inherited from Online Control.)
Public event | Online TabStopChanged | Occurs when the Online TabStop property value changes. (Inherited from Online Control.)
Public event | Online TextAlignChanged | Occurs when the value of the Online TextAlign property has changed. (Inherited from Online TextBox.)
Public event | Online TextChanged | Occurs when the Online Text property value changes. (Inherited from Online Control.)
Public event | Online Validated | Occurs when the control is finished validating. (Inherited from Online Control.)
Public event | Online Validating | Occurs when the control is validating. (Inherited from Online Control.)
Public event | Online VisibleChanged | Occurs when the Online Visible property value changes. (Inherited from Online Control.)
Back to Top
See Also
CalendarTextBox Class


CalendarTextBox Constructor

CalendarTextBox Constructor A Sandcastle Documented Class Library
Send Feedback
Creates a new CalendarTextBox for the specified Calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New ( _
    calendar As Calendar _
)
Public Sub New ( _
    calendar As Calendar _
)
public CalendarTextBox(
    Calendar calendar
)
public CalendarTextBox(
    Calendar calendar
)
public:
CalendarTextBox(
    Calendar^ calendar
)
public:
CalendarTextBox(
    Calendar^ calendar
)
Parameters
calendar
Type: WindowsFormsCalendar Calendar
Calendar where this control lives
See Also
CalendarTextBox Class
CalendarTextBox Members


CalendarTextBox Methods

CalendarTextBox Methods A Sandcastle Documented Class Library
Send Feedback
The CalendarTextBox type exposes the following members.
Methods
 | Name | Description
Protected method | Online AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified Online AccessibleEvents for the specified child control. (Inherited from Online Control.)
Protected method | Online AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified Online AccessibleEvents for the specified child control . (Inherited from Online Control.)
Public method | Online AppendText | Appends text to the current text of a text box. (Inherited from Online TextBoxBase.)
Public method | Online BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Online Control.)
Public method | Online BeginInvoke(Delegate, Object ) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Online Control.)
Public method | Online BringToFront | Brings the control to the front of the z-order. (Inherited from Online Control.)
Public method | Online Clear | Clears all text from the text box control. (Inherited from Online TextBoxBase.)
Public method | Online ClearUndo | Clears information about the most recent operation from the undo buffer of the text box. (Inherited from Online TextBoxBase.)
Public method | Online Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Online Control.)
Public method | Online Copy | Copies the current selection in the text box to the Clipboard. (Inherited from Online TextBoxBase.)
Protected method | Online CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Online Control.)
Public method | Online CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Online Control.)
Protected method | Online CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Online Control.)
Public method | Online CreateGraphics | Creates the Online Graphics for the control. (Inherited from Online Control.)
Protected method | Online CreateHandle | (Inherited from Online TextBoxBase.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online Cut | Moves the current selection in the text box to the Clipboard. (Inherited from Online TextBoxBase.)
Protected method | Online DefWndProc | Sends the specified message to the default window procedure. (Inherited from Online Control.)
Public method | Online DeselectAll | Specifies that the value of the Online SelectionLength property is zero so that no characters are selected in the control. (Inherited from Online TextBoxBase.)
Protected method | Online DestroyHandle | Destroys the handle associated with the control. (Inherited from Online Control.)
Public method | Online Dispose | Releases all resources used by the Online Component. (Inherited from Online Component.)
Protected method | Online Dispose(Boolean) | Releases the unmanaged resources used by the Online TextBox and optionally releases the managed resources. (Inherited from Online TextBox.)
Public method | Online DoDragDrop | Begins a drag-and-drop operation. (Inherited from Online Control.)
Public method | Online DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Online Control.)
Public method | Online EndInvoke | Retrieves the return value of the asynchronous operation represented by the Online IAsyncResult passed. (Inherited from Online Control.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Releases unmanaged resources and performs other cleanup operations before the Online Component is reclaimed by garbage collection. (Inherited from Online Component.)
Public method | Online FindForm | Retrieves the form that the control is on. (Inherited from Online Control.)
Public method | Online Focus | Sets input focus to the control. (Inherited from Online Control.)
Protected method | Online GetAccessibilityObjectById | Retrieves the specified Online AccessibleObject. (Inherited from Online Control.)
Protected method | Online GetAutoSizeMode | Retrieves a value indicating how a control will behave when its Online AutoSize property is enabled. (Inherited from Online Control.)
Public method | Online GetCharFromPosition | Retrieves the character that is closest to the specified location within the control. (Inherited from Online TextBoxBase.)
Public method | Online GetCharIndexFromPosition | Retrieves the index of the character nearest to the specified location. (Inherited from Online TextBoxBase.)
Public method | Online GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Online Control.)
Public method | Online GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Online Control.)
Public method | Online GetContainerControl | Returns the next Online ContainerControl up the control's chain of parent controls. (Inherited from Online Control.)
Public method | Online GetFirstCharIndexFromLine | Retrieves the index of the first character of a given line. (Inherited from Online TextBoxBase.)
Public method | Online GetFirstCharIndexOfCurrentLine | Retrieves the index of the first character of the current line. (Inherited from Online TextBoxBase.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetLineFromCharIndex | Retrieves the line number from the specified character position within the text of the control. (Inherited from Online TextBoxBase.)
Public method | Online GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Online Control.)
Public method | Online GetPositionFromCharIndex | Retrieves the location within the control at the specified character index. (Inherited from Online TextBoxBase.)
Public method | Online GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Online Control.)
Protected method | Online GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Online Control.)
Protected method | Online GetService | Returns an object that represents a service provided by the Online Component or by its Online Container. (Inherited from Online Component.)
Protected method | Online GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Online Control.)
Protected method | Online GetTopLevel | Determines if the control is a top-level control. (Inherited from Online Control.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online Hide | Conceals the control from the user. (Inherited from Online Control.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online InitLayout | Called after the control has been added to another container. (Inherited from Online Control.)
Public method | Online Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Online Control.)
Public method | Online Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Online Control.)
Public method | Online Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Online Control.)
Public method | Online Invoke(Delegate, Object ) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Online Control.)
Protected method | Online InvokeGotFocus | Raises the Online GotFocus event for the specified control. (Inherited from Online Control.)
Protected method | Online InvokeLostFocus | Raises the Online LostFocus event for the specified control. (Inherited from Online Control.)
Protected method | Online InvokeOnClick | Raises the Online Click event for the specified control. (Inherited from Online Control.)
Protected method | Online InvokePaint | Raises the Online Paint event for the specified control. (Inherited from Online Control.)
Protected method | Online InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Online Control.)
Protected method | Online IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Online Control.)
Protected method | Online IsInputKey | Determines whether the specified key is an input key or a special key that requires preprocessing. (Inherited from Online TextBox.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online NotifyInvalidate | Raises the Online Invalidated event with a specified region of the control to invalidate. (Inherited from Online Control.)
Protected method | Online OnAcceptsTabChanged | Raises the Online AcceptsTabChanged event. (Inherited from Online TextBoxBase.)
Protected method | Online OnAutoSizeChanged | Raises the Online AutoSizeChanged event. (Inherited from Online Control.)
Protected method | Online OnBackColorChanged | Raises the Online BackColorChanged event. (Inherited from Online TextBox.)
Protected method | Online OnBackgroundImageChanged | Raises the Online BackgroundImageChanged event. (Inherited from Online Control.)
Protected method | Online OnBackgroundImageLayoutChanged | Raises the Online BackgroundImageLayoutChanged event. (Inherited from Online Control.)
Protected method | Online OnBindingContextChanged | Raises the Online BindingContextChanged event. (Inherited from Online Control.)
Protected method | Online OnBorderStyleChanged | Raises the Online BorderStyleChanged event. (Inherited from Online TextBoxBase.)
Protected method | Online OnCausesValidationChanged | Raises the Online CausesValidationChanged event. (Inherited from Online Control.)
Protected method | Online OnChangeUICues | Raises the Online ChangeUICues event. (Inherited from Online Control.)
Protected method | Online OnClick | Raises the Online Click event. (Inherited from Online Control.)
Protected method | Online OnClientSizeChanged | Raises the Online ClientSizeChanged event. (Inherited from Online Control.)
Protected method | Online OnContextMenuChanged | Raises the Online ContextMenuChanged event. (Inherited from Online Control.)
Protected method | Online OnContextMenuStripChanged | Raises the Online ContextMenuStripChanged event. (Inherited from Online Control.)
Protected method | Online OnControlAdded | Raises the Online ControlAdded event. (Inherited from Online Control.)
Protected method | Online OnControlRemoved | Raises the Online ControlRemoved event. (Inherited from Online Control.)
Protected method | Online OnCreateControl | Raises the Online CreateControl method. (Inherited from Online Control.)
Protected method | Online OnCursorChanged | Raises the Online CursorChanged event. (Inherited from Online Control.)
Protected method | Online OnDockChanged | Raises the Online DockChanged event. (Inherited from Online Control.)
Protected method | Online OnDoubleClick | Raises the Online DoubleClick event. (Inherited from Online Control.)
Protected method | Online OnDragDrop | Raises the Online DragDrop event. (Inherited from Online Control.)
Protected method | Online OnDragEnter | Raises the Online DragEnter event. (Inherited from Online Control.)
Protected method | Online OnDragLeave | Raises the Online DragLeave event. (Inherited from Online Control.)
Protected method | Online OnDragOver | Raises the Online DragOver event. (Inherited from Online Control.)
Protected method | Online OnEnabledChanged | Raises the Online EnabledChanged event. (Inherited from Online Control.)
Protected method | Online OnEnter | Raises the Online Enter event. (Inherited from Online Control.)
Protected method | Online OnFontChanged | Raises the Online FontChanged event. (Inherited from Online TextBox.)
Protected method | Online OnForeColorChanged | Raises the Online ForeColorChanged event. (Inherited from Online Control.)
Protected method | Online OnGiveFeedback | Raises the Online GiveFeedback event. (Inherited from Online Control.)
Protected method | Online OnGotFocus | Raises the Online GotFocus event. (Inherited from Online TextBox.)
Protected method | Online OnHandleCreated | Raises the Online HandleCreated event. (Inherited from Online TextBox.)
Protected method | Online OnHandleDestroyed | Raises the Online OnHandleDestroyed(EventArgs) event. (Inherited from Online TextBox.)
Protected method | Online OnHelpRequested | Raises the Online HelpRequested event. (Inherited from Online Control.)
Protected method | Online OnHideSelectionChanged | Raise the Online HideSelectionChanged event. (Inherited from Online TextBoxBase.)
Protected method | Online OnImeModeChanged | Raises the Online ImeModeChanged event. (Inherited from Online Control.)
Protected method | Online OnInvalidated | Raises the Online Invalidated event. (Inherited from Online Control.)
Protected method | Online OnKeyDown | Raises the Online KeyDown event. (Inherited from Online Control.)
Protected method | Online OnKeyPress | Raises the Online KeyPress event. (Inherited from Online Control.)
Protected method | Online OnKeyUp | Raises the Online KeyUp event. (Inherited from Online Control.)
Protected method | Online OnLayout | Raises the Online Layout event. (Inherited from Online Control.)
Protected method | Online OnLeave | Raises the Online Leave event. (Inherited from Online Control.)
Protected method | Online OnLocationChanged | Raises the Online LocationChanged event. (Inherited from Online Control.)
Protected method | Online OnLostFocus | Raises the Online LostFocus event. (Inherited from Online Control.)
Protected method | Online OnMarginChanged | Raises the Online MarginChanged event. (Inherited from Online Control.)
Protected method | Online OnModifiedChanged | Raises the Online ModifiedChanged event. (Inherited from Online TextBoxBase.)
Protected method | Online OnMouseCaptureChanged | Raises the Online MouseCaptureChanged event. (Inherited from Online Control.)
Protected method | Online OnMouseClick | Raises the Online MouseClick event. (Inherited from Online Control.)
Protected method | Online OnMouseDoubleClick | Raises the Online MouseDoubleClick event. (Inherited from Online Control.)
Protected method | Online OnMouseDown | Raises the Online MouseDown event. (Inherited from Online Control.)
Protected method | Online OnMouseEnter | Raises the Online MouseEnter event. (Inherited from Online Control.)
Protected method | Online OnMouseHover | Raises the Online MouseHover event. (Inherited from Online Control.)
Protected method | Online OnMouseLeave | Raises the Online MouseLeave event. (Inherited from Online Control.)
Protected method | Online OnMouseMove | Raises the Online MouseMove event. (Inherited from Online Control.)
Protected method | Online OnMouseUp | Raises the Online MouseUp event. (Inherited from Online TextBoxBase.)
Protected method | Online OnMouseWheel | Raises the Online MouseWheel event. (Inherited from Online Control.)
Protected method | Online OnMove | Raises the Online Move event. (Inherited from Online Control.)
Protected method | Online OnMultilineChanged | Raises the Online MultilineChanged event. (Inherited from Online TextBoxBase.)
Protected method | Online OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Online Control.)
Protected method | Online OnPaddingChanged | This method is not relevant for this class. (Inherited from Online TextBoxBase.)
Protected method | Online OnPaint | Raises the Online Paint event. (Inherited from Online Control.)
Protected method | Online OnPaintBackground | Paints the background of the control. (Inherited from Online Control.)
Protected method | Online OnParentBackColorChanged | Raises the Online BackColorChanged event when the Online BackColor property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentBackgroundImageChanged | Raises the Online BackgroundImageChanged event when the Online BackgroundImage property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentBindingContextChanged | Raises the Online BindingContextChanged event when the Online BindingContext property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentChanged | Raises the Online ParentChanged event. (Inherited from Online Control.)
Protected method | Online OnParentCursorChanged | Raises the Online CursorChanged event. (Inherited from Online Control.)
Protected method | Online OnParentEnabledChanged | Raises the Online EnabledChanged event when the Online Enabled property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentFontChanged | Raises the Online FontChanged event when the Online Font property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentForeColorChanged | Raises the Online ForeColorChanged event when the Online ForeColor property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentRightToLeftChanged | Raises the Online RightToLeftChanged event when the Online RightToLeft property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentVisibleChanged | Raises the Online VisibleChanged event when the Online Visible property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnPreviewKeyDown | Raises the Online PreviewKeyDown event. (Inherited from Online Control.)
Protected method | Online OnPrint | Raises the Online Paint event. (Inherited from Online Control.)
Protected method | Online OnQueryContinueDrag | Raises the Online QueryContinueDrag event. (Inherited from Online Control.)
Protected method | Online OnReadOnlyChanged | Raises the Online ReadOnlyChanged event. (Inherited from Online TextBoxBase.)
Protected method | Online OnRegionChanged | Raises the Online RegionChanged event. (Inherited from Online Control.)
Protected method | Online OnResize | Raises the Online Resize event. (Inherited from Online Control.)
Protected method | Online OnRightToLeftChanged | Raises the Online RightToLeftChanged event. (Inherited from Online Control.)
Protected method | Online OnSizeChanged | Raises the Online SizeChanged event. (Inherited from Online Control.)
Protected method | Online OnStyleChanged | Raises the Online StyleChanged event. (Inherited from Online Control.)
Protected method | Online OnSystemColorsChanged | Raises the Online SystemColorsChanged event. (Inherited from Online Control.)
Protected method | Online OnTabIndexChanged | Raises the Online TabIndexChanged event. (Inherited from Online Control.)
Protected method | Online OnTabStopChanged | Raises the Online TabStopChanged event. (Inherited from Online Control.)
Protected method | Online OnTextAlignChanged | Raises the Online TextAlignChanged event. (Inherited from Online TextBox.)
Protected method | Online OnTextChanged | (Inherited from Online TextBoxBase.)
Protected method | Online OnValidated | Raises the Online Validated event. (Inherited from Online Control.)
Protected method | Online OnValidating | Raises the Online Validating event. (Inherited from Online Control.)
Protected method | Online OnVisibleChanged | Raises the Online VisibleChanged event. (Inherited from Online Control.)
Public method | Online Paste | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from Online TextBoxBase.)
Public method | Online Paste(String) | Sets the selected text to the specified text without clearing the undo buffer. (Inherited from Online TextBox.)
Public method | Online PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Online Control.)
Public method | Online PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Online Control.)
Public method | Online PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Online Control.)
Public method | Online PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Online Control.)
Public method | Online PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Online Control.)
Public method | Online PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Online Control.)
Protected method | Online ProcessCmdKey | Processes a command key. (Inherited from Online TextBoxBase.)
Protected method | Online ProcessDialogChar | Processes a dialog character. (Inherited from Online Control.)
Protected method | Online ProcessDialogKey | (Inherited from Online TextBoxBase.)
Protected method | Online ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Online Control.)
Protected method | Online ProcessKeyMessage | Processes a keyboard message. (Inherited from Online Control.)
Protected method | Online ProcessKeyPreview | Previews a keyboard message. (Inherited from Online Control.)
Protected method | Online ProcessMnemonic | Processes a mnemonic character. (Inherited from Online Control.)
Protected method | Online RaiseDragEvent | Raises the appropriate drag event. (Inherited from Online Control.)
Protected method | Online RaiseKeyEvent | Raises the appropriate key event. (Inherited from Online Control.)
Protected method | Online RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Online Control.)
Protected method | Online RaisePaintEvent | Raises the appropriate paint event. (Inherited from Online Control.)
Protected method | Online RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Online Control.)
Public method | Online RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Online Control.)
Public method | Online RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Online Control.)
Public method | Online Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Online Control.)
Public method | Online ResetBackColor | Resets the Online BackColor property to its default value. (Inherited from Online Control.)
Public method | Online ResetBindings | Causes a control bound to the Online BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Online Control.)
Public method | Online ResetCursor | Resets the Online Cursor property to its default value. (Inherited from Online Control.)
Public method | Online ResetFont | Resets the Online Font property to its default value. (Inherited from Online Control.)
Public method | Online ResetForeColor | Resets the Online ForeColor property to its default value. (Inherited from Online Control.)
Public method | Online ResetImeMode | Resets the Online ImeMode property to its default value. (Inherited from Online Control.)
Protected method | Online ResetMouseEventArgs | Resets the control to handle the Online MouseLeave event. (Inherited from Online Control.)
Public method | Online ResetRightToLeft | Resets the Online RightToLeft property to its default value. (Inherited from Online Control.)
Public method | Online ResetText | Resets the Online Text property to its default value. (Inherited from Online Control.)
Public method | Online ResumeLayout | Resumes usual layout logic. (Inherited from Online Control.)
Public method | Online ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Online Control.)
Protected method | Online RtlTranslateAlignment(HorizontalAlignment) | Converts the specified Online HorizontalAlignment to the appropriate Online HorizontalAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateAlignment(LeftRightAlignment) | Converts the specified Online LeftRightAlignment to the appropriate Online LeftRightAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateAlignment(ContentAlignment) | Converts the specified Online ContentAlignment to the appropriate Online ContentAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateContent | Converts the specified Online ContentAlignment to the appropriate Online ContentAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateHorizontal | Converts the specified Online HorizontalAlignment to the appropriate Online HorizontalAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateLeftRight | Converts the specified Online LeftRightAlignment to the appropriate Online LeftRightAlignment to support right-to-left text. (Inherited from Online Control.)
Public method | Online Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Online Control.)
Public method | Online Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Online Control.)
Public method | Online Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Online Control.)
Protected method | Online ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Online Control.)
Protected method | Online ScaleCore | This method is not relevant for this class. (Inherited from Online Control.)
Public method | Online ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from Online TextBoxBase.)
Public method | Online Select | Activates the control. (Inherited from Online Control.)
Public method | Online Select(Int32, Int32) | Selects a range of text in the text box. (Inherited from Online TextBoxBase.)
Protected method | Online Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Online Control.)
Public method | Online SelectAll | Selects all text in the text box. (Inherited from Online TextBoxBase.)
Public method | Online SelectNextControl | Activates the next control. (Inherited from Online Control.)
Public method | Online SendToBack | Sends the control to the back of the z-order. (Inherited from Online Control.)
Protected method | Online SetAutoSizeMode | Sets a value indicating how a control will behave when its Online AutoSize property is enabled. (Inherited from Online Control.)
Public method | Online SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Online Control.)
Public method | Online SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Online Control.)
Protected method | Online SetBoundsCore | Sets the specified bounds of the Online TextBoxBase control. (Inherited from Online TextBoxBase.)
Protected method | Online SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Online Control.)
Protected method | Online SetStyle | Sets a specified Online ControlStyles flag to either true or false. (Inherited from Online Control.)
Protected method | Online SetTopLevel | Sets the control as the top-level control. (Inherited from Online Control.)
Protected method | Online SetVisibleCore | Sets the control to the specified visible state. (Inherited from Online Control.)
Public method | Online Show | Displays the control to the user. (Inherited from Online Control.)
Protected method | Online SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Online Control.)
Public method | Online SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Online Control.)
Public method | Online ToString | Returns a string that represents the Online TextBoxBase control. (Inherited from Online TextBoxBase.)
Public method | Online Undo | Undoes the last edit operation in the text box. (Inherited from Online TextBoxBase.)
Public method | Online Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Online Control.)
Protected method | Online UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Online Control.)
Protected method | Online UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Online Control.)
Protected method | Online UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Online Control.)
Protected method | Online UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Online Control.)
Protected method | Online UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Online Control.)
Protected method | Online WndProc | Processes Windows messages. (Inherited from Online TextBox.)
Back to Top
See Also
CalendarTextBox Class


CalendarTextBox Properties

CalendarTextBox Properties A Sandcastle Documented Class Library
Send Feedback
The CalendarTextBox type exposes the following members.
Properties
 | Name | Description
Public property | Online AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline Online TextBox control creates a new line of text in the control or activates the default button for the form. (Inherited from Online TextBox.)
Public property | Online AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. (Inherited from Online TextBoxBase.)
Public property | Online AccessibilityObject | Gets the Online AccessibleObject assigned to the control. (Inherited from Online Control.)
Public property | Online AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Online Control.)
Public property | Online AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Online Control.)
Public property | Online AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Online Control.)
Public property | Online AccessibleRole | Gets or sets the accessible role of the control (Inherited from Online Control.)
Public property | Online AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Online Control.)
Public property | Online Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Online Control.)
Public property | Online AutoCompleteCustomSource | Gets or sets a custom Online StringCollection to use when the Online AutoCompleteSource property is set to CustomSource. (Inherited from Online TextBox.)
Public property | Online AutoCompleteMode | Gets or sets an option that controls how automatic completion works for the Online TextBox. (Inherited from Online TextBox.)
Public property | Online AutoCompleteSource | Gets or sets a value specifying the source of complete strings used for automatic completion. (Inherited from Online TextBox.)
Public property | Online AutoScrollOffset | Gets or sets where this control is scrolled to in Online ScrollControlIntoView(Control). (Inherited from Online Control.)
Public property | Online AutoSize | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed. (Inherited from Online TextBoxBase.)
Public property | Online BackColor | Gets or sets the background color of the control. (Inherited from Online TextBoxBase.)
Public property | Online BackgroundImage | This property is not relevant for this class. (Inherited from Online TextBoxBase.)
Public property | Online BackgroundImageLayout | This property is not relevant for this class. (Inherited from Online TextBoxBase.)
Public property | Online BindingContext | Gets or sets the Online BindingContext for the control. (Inherited from Online Control.)
Public property | Online BorderStyle | Gets or sets the border type of the text box control. (Inherited from Online TextBoxBase.)
Public property | Online Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Online Control.)
Public property | Online Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Online Control.)
Public property | Calendar | Gets the calendar where this control lives
Protected property | Online CanEnableIme | Gets a value indicating whether the Online ImeMode property can be set to an active value, to enable IME support. (Inherited from Online TextBoxBase.)
Public property | Online CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Online Control.)
Protected property | Online CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Online Control.)
Public property | Online CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Online Control.)
Public property | Online CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from Online TextBoxBase.)
Public property | Online Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Online Control.)
Public property | Online CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Online Control.)
Public property | Online CharacterCasing | Gets or sets whether the Online TextBox control modifies the case of characters as they are typed. (Inherited from Online TextBox.)
Public property | Online ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Online Control.)
Public property | Online ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Online Control.)
Public property | Online CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Online Control.)
Public property | Online Container | Gets the Online IContainer that contains the Online Component. (Inherited from Online Component.)
Public property | Online ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Online Control.)
Public property | Online ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Online Control.)
Public property | Online ContextMenuStrip | Gets or sets the Online ContextMenuStrip associated with this control. (Inherited from Online Control.)
Public property | Online Controls | Gets the collection of controls contained within the control. (Inherited from Online Control.)
Public property | Online Created | Gets a value indicating whether the control has been created. (Inherited from Online Control.)
Protected property | Online CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Online TextBox.)
Public property | Online Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Online Control.)
Public property | Online DataBindings | Gets the data bindings for the control. (Inherited from Online Control.)
Protected property | Online DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Online TextBoxBase.)
Protected property | Online DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Online Control.)
Protected property | Online DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Online Control.)
Protected property | Online DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Online Control.)
Protected property | Online DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Online Control.)
Protected property | Online DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Online Control.)
Protected property | Online DefaultSize | (Inherited from Online TextBoxBase.)
Protected property | Online DesignMode | Gets a value that indicates whether the Online Component is currently in design mode. (Inherited from Online Component.)
Public property | Online DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Online Control.)
Public property | Online Disposing | Gets a value indicating whether the base Online Control class is in the process of disposing. (Inherited from Online Control.)
Public property | Online Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Online Control.)
Protected property | Online DoubleBuffered | Gets or sets a value indicating whether control drawing is done in a buffer before the control is displayed. This property is not relevant for this class. (Inherited from Online TextBoxBase.)
Public property | Online Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Online Control.)
Protected property | Online Events | Gets the list of event handlers that are attached to this Online Component. (Inherited from Online Component.)
Public property | Online Focused | Gets a value indicating whether the control has input focus. (Inherited from Online Control.)
Public property | Online Font | Gets or sets the font of the text displayed by the control. (Inherited from Online Control.)
Protected property | Online FontHeight | Gets or sets the height of the font of the control. (Inherited from Online Control.)
Public property | Online ForeColor | Gets or sets the foreground color of the control. (Inherited from Online TextBoxBase.)
Public property | Online Handle | Gets the window handle that the control is bound to. (Inherited from Online Control.)
Public property | Online HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Online Control.)
Public property | Online Height | Gets or sets the height of the control. (Inherited from Online Control.)
Public property | Online HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (Inherited from Online TextBoxBase.)
Public property | Online ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Online Control.)
Protected property | Online ImeModeBase | Gets or sets the Input Method Editor (IME) mode of a control. (Inherited from Online TextBoxBase.)
Public property | Online InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Online Control.)
Public property | Online IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Online Control.)
Public property | Online IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Online Control.)
Public property | Online IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Online Control.)
Public property | Online IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Online Control.)
Public property | Online LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Online Control.)
Public property | Online Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Online Control.)
Public property | Online Lines | Gets or sets the lines of text in a text box control. (Inherited from Online TextBoxBase.)
Public property | Online Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Online Control.)
Public property | Online Margin | Gets or sets the space between controls. (Inherited from Online Control.)
Public property | Online MaximumSize | Gets or sets the size that is the upper limit that Online GetPreferredSize(Size) can specify. (Inherited from Online Control.)
Public property | Online MaxLength | Gets or sets the maximum number of characters the user can type or paste into the text box control. (Inherited from Online TextBoxBase.)
Public property | Online MinimumSize | Gets or sets the size that is the lower limit that Online GetPreferredSize(Size) can specify. (Inherited from Online Control.)
Public property | Online Modified | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set. (Inherited from Online TextBoxBase.)
Public property | Online Multiline | Gets or sets a value indicating whether this is a multiline Online TextBox control. (Inherited from Online TextBox.)
Public property | Online Name | Gets or sets the name of the control. (Inherited from Online Control.)
Public property | Online Padding | This property is not relevant for this class. (Inherited from Online TextBoxBase.)
Public property | Online Parent | Gets or sets the parent container of the control. (Inherited from Online Control.)
Public property | Online PasswordChar | Gets or sets the character used to mask characters of a password in a single-line Online TextBox control. (Inherited from Online TextBox.)
Public property | Online PreferredHeight | Gets the preferred height for a text box. (Inherited from Online TextBoxBase.)
Public property | Online PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Online Control.)
Public property | Online ProductName | Gets the product name of the assembly containing the control. (Inherited from Online Control.)
Public property | Online ProductVersion | Gets the version of the assembly containing the control. (Inherited from Online Control.)
Public property | Online ReadOnly | Gets or sets a value indicating whether text in the text box is read-only. (Inherited from Online TextBoxBase.)
Public property | Online RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Online Control.)
Public property | Online Region | Gets or sets the window region associated with the control. (Inherited from Online Control.)
Protected property | Online RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Online Control.)
Protected property | Online ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Online Control.)
Public property | Online Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Online Control.)
Public property | Online RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Online Control.)
Protected property | Online ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Online Control.)
Public property | Online ScrollBars | Gets or sets which scroll bars should appear in a multiline Online TextBox control. (Inherited from Online TextBox.)
Public property | Online SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from Online TextBoxBase.)
Public property | Online SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from Online TextBoxBase.)
Public property | Online SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from Online TextBoxBase.)
Public property | Online ShortcutsEnabled | Gets or sets a value indicating whether the defined shortcuts are enabled. (Inherited from Online TextBoxBase.)
Protected property | Online ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Online Control.)
Protected property | Online ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Online Control.)
Public property | Online Site | Gets or sets the site of the control. (Inherited from Online Control.)
Public property | Online Size | Gets or sets the height and width of the control. (Inherited from Online Control.)
Public property | Online TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Online Control.)
Public property | Online TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Online Control.)
Public property | Online Tag | Gets or sets the object that contains data about the control. (Inherited from Online Control.)
Public property | Online Text | Gets or sets the current text in the Online TextBox. (Inherited from Online TextBox.)
Public property | Online TextAlign | Gets or sets how text is aligned in a Online TextBox control. (Inherited from Online TextBox.)
Public property | Online TextLength | Gets the length of text in the control. (Inherited from Online TextBoxBase.)
Public property | Online Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Online Control.)
Public property | Online TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Online Form that the control is contained in. (Inherited from Online Control.)
Public property | Online UseSystemPasswordChar | Gets or sets a value indicating whether the text in the Online TextBox control should appear as the default password character. (Inherited from Online TextBox.)
Public property | Online UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Online Control.)
Public property | Online Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Online Control.)
Public property | Online Width | Gets or sets the width of the control. (Inherited from Online Control.)
Public property | Online WindowTarget | This property is not relevant for this class. (Inherited from Online Control.)
Public property | Online WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. (Inherited from Online TextBoxBase.)
Back to Top
See Also
CalendarTextBox Class


Calendar Property

CalendarTextBox Calendar Property A Sandcastle Documented Class Library
Send Feedback
Gets the calendar where this control lives

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Calendar As Calendar
    Get
Public ReadOnly Property Calendar As Calendar
    Get
public Calendar Calendar { get; }
public Calendar Calendar { get; }
public:
property Calendar^ Calendar {
    Calendar^ get ();
}
public:
property Calendar^ Calendar {
    Calendar^ get ();
}
See Also
CalendarTextBox Class
CalendarTextBox Members


CalendarTextBox Events

CalendarTextBox Events A Sandcastle Documented Class Library
The CalendarTextBox type exposes the following members.
Events
 | Name | Description
Public event | Online AcceptsTabChanged | Occurs when the value of the Online AcceptsTab property has changed. (Inherited from Online TextBoxBase.)
Public event | Online AutoSizeChanged | This event is not relevant for this class. (Inherited from Online TextBoxBase.)
Public event | Online BackColorChanged | Occurs when the value of the Online BackColor property changes. (Inherited from Online Control.)
Public event | Online BackgroundImageChanged | Occurs when the value of the Online BackgroundImage property changes. This event is not relevant for this class. (Inherited from Online TextBoxBase.)
Public event | Online BackgroundImageLayoutChanged | Occurs when the value of the Online BackgroundImageLayout property changes. This event is not relevant for this class. (Inherited from Online TextBoxBase.)
Public event | Online BindingContextChanged | Occurs when the value of the Online BindingContext property changes. (Inherited from Online Control.)
Public event | Online BorderStyleChanged | Occurs when the value of the Online BorderStyle property has changed. (Inherited from Online TextBoxBase.)
Public event | Online CausesValidationChanged | Occurs when the value of the Online CausesValidation property changes. (Inherited from Online Control.)
Public event | Online ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Online Control.)
Public event | Online Click | Occurs when the text box is clicked. (Inherited from Online TextBoxBase.)
Public event | Online ClientSizeChanged | Occurs when the value of the Online ClientSize property changes. (Inherited from Online Control.)
Public event | Online ContextMenuChanged | Occurs when the value of the Online ContextMenu property changes. (Inherited from Online Control.)
Public event | Online ContextMenuStripChanged | Occurs when the value of the Online ContextMenuStrip property changes. (Inherited from Online Control.)
Public event | Online ControlAdded | Occurs when a new control is added to the Online Control ControlCollection. (Inherited from Online Control.)
Public event | Online ControlRemoved | Occurs when a control is removed from the Online Control ControlCollection. (Inherited from Online Control.)
Public event | Online CursorChanged | Occurs when the value of the Online Cursor property changes. (Inherited from Online Control.)
Public event | Online Disposed | Occurs when the component is disposed by a call to the Online Dispose method. (Inherited from Online Component.)
Public event | Online DockChanged | Occurs when the value of the Online Dock property changes. (Inherited from Online Control.)
Public event | Online DoubleClick | Occurs when the control is double-clicked. (Inherited from Online Control.)
Public event | Online DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Online Control.)
Public event | Online DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Online Control.)
Public event | Online DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Online Control.)
Public event | Online DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Online Control.)
Public event | Online EnabledChanged | Occurs when the Online Enabled property value has changed. (Inherited from Online Control.)
Public event | Online Enter | Occurs when the control is entered. (Inherited from Online Control.)
Public event | Online FontChanged | Occurs when the Online Font property value changes. (Inherited from Online Control.)
Public event | Online ForeColorChanged | Occurs when the Online ForeColor property value changes. (Inherited from Online Control.)
Public event | Online GiveFeedback | Occurs during a drag operation. (Inherited from Online Control.)
Public event | Online GotFocus | Occurs when the control receives focus. (Inherited from Online Control.)
Public event | Online HandleCreated | Occurs when a handle is created for the control. (Inherited from Online Control.)
Public event | Online HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Online Control.)
Public event | Online HelpRequested | Occurs when the user requests help for a control. (Inherited from Online Control.)
Public event | Online HideSelectionChanged | Occurs when the value of the Online HideSelection property has changed. (Inherited from Online TextBoxBase.)
Public event | Online ImeModeChanged | Occurs when the Online ImeMode property has changed. (Inherited from Online Control.)
Public event | Online Invalidated | Occurs when a control's display requires redrawing. (Inherited from Online Control.)
Public event | Online KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Online Control.)
Public event | Online KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Online Control.)
Public event | Online KeyUp | Occurs when a key is released while the control has focus. (Inherited from Online Control.)
Public event | Online Layout | Occurs when a control should reposition its child controls. (Inherited from Online Control.)
Public event | Online Leave | Occurs when the input focus leaves the control. (Inherited from Online Control.)
Public event | Online LocationChanged | Occurs when the Online Location property value has changed. (Inherited from Online Control.)
Public event | Online LostFocus | Occurs when the control loses focus. (Inherited from Online Control.)
Public event | Online MarginChanged | Occurs when the control's margin changes. (Inherited from Online Control.)
Public event | Online ModifiedChanged | Occurs when the value of the Online Modified property has changed. (Inherited from Online TextBoxBase.)
Public event | Online MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Online Control.)
Public event | Online MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Online TextBoxBase.)
Public event | Online MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Online Control.)
Public event | Online MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Online Control.)
Public event | Online MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Online Control.)
Public event | Online MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Online Control.)
Public event | Online MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Online Control.)
Public event | Online MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Online Control.)
Public event | Online MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Online Control.)
Public event | Online MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Online Control.)
Public event | Online Move | Occurs when the control is moved. (Inherited from Online Control.)
Public event | Online MultilineChanged | Occurs when the value of the Online Multiline property has changed. (Inherited from Online TextBoxBase.)
Public event | Online PaddingChanged | This event is not relevant for this class. (Inherited from Online TextBoxBase.)
Public event | Online Paint | Occurs when the control is redrawn. This event is not relevant for this class. (Inherited from Online TextBoxBase.)
Public event | Online ParentChanged | Occurs when the Online Parent property value changes. (Inherited from Online Control.)
Public event | Online PreviewKeyDown | Occurs before the Online KeyDown event when a key is pressed while focus is on this control. (Inherited from Online Control.)
Public event | Online QueryAccessibilityHelp | Occurs when Online AccessibleObject is providing help to accessibility applications. (Inherited from Online Control.)
Public event | Online QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Online Control.)
Public event | Online ReadOnlyChanged | Occurs when the value of the Online ReadOnly property has changed. (Inherited from Online TextBoxBase.)
Public event | Online RegionChanged | Occurs when the value of the Online Region property changes. (Inherited from Online Control.)
Public event | Online Resize | Occurs when the control is resized. (Inherited from Online Control.)
Public event | Online RightToLeftChanged | Occurs when the Online RightToLeft property value changes. (Inherited from Online Control.)
Public event | Online SizeChanged | Occurs when the Online Size property value changes. (Inherited from Online Control.)
Public event | Online StyleChanged | Occurs when the control style changes. (Inherited from Online Control.)
Public event | Online SystemColorsChanged | Occurs when the system colors change. (Inherited from Online Control.)
Public event | Online TabIndexChanged | Occurs when the Online TabIndex property value changes. (Inherited from Online Control.)
Public event | Online TabStopChanged | Occurs when the Online TabStop property value changes. (Inherited from Online Control.)
Public event | Online TextAlignChanged | Occurs when the value of the Online TextAlign property has changed. (Inherited from Online TextBox.)
Public event | Online TextChanged | Occurs when the Online Text property value changes. (Inherited from Online Control.)
Public event | Online Validated | Occurs when the control is finished validating. (Inherited from Online Control.)
Public event | Online Validating | Occurs when the control is validating. (Inherited from Online Control.)
Public event | Online VisibleChanged | Occurs when the Online Visible property value changes. (Inherited from Online Control.)
Back to Top
See Also
CalendarTextBox Class


CalendarTimeFormat Enumeration

CalendarTimeFormat Enumeration A Sandcastle Documented Class Library
Send Feedback
An enumeration that represents the time format of the calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Enumeration CalendarTimeFormat
Public Enumeration CalendarTimeFormat
public enum CalendarTimeFormat
public enum CalendarTimeFormat
public enum class CalendarTimeFormat
public enum class CalendarTimeFormat
Members
Member name | Value | Description
TwelveHour | 0 | A twelve hour clock
TwentyFourHour | 1 | A twenty four hour clock
See Also


CalendarTimeScale Enumeration

CalendarTimeScale Enumeration A Sandcastle Documented Class Library
Send Feedback
Enumerates possible timescales for Calendar control

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Enumeration CalendarTimeScale
Public Enumeration CalendarTimeScale
public enum CalendarTimeScale
public enum CalendarTimeScale
public enum class CalendarTimeScale
public enum class CalendarTimeScale
Members
Member name | Value | Description
SixtyMinutes | 60 | Makes calendar show intervals of 60 minutes
ThirtyMinutes | 30 | Makes calendar show intervals of 30 minutes
FifteenMinutes | 15 | Makes calendar show intervals of 15 minutes
TenMinutes | 10 | Makes calendar show intervals of 10 minutes
SixMinutes | 6 | Makes calendar show intervals of 6 minutes
FiveMinutes | 5 | Makes calendar show intervals of 5 minutes
See Also


CalendarTimeScaleUnit Class

CalendarTimeScaleUnit Class A Sandcastle Documented Class Library
Send Feedback
Represents a selectable timescale unit on a CalendarDay
Inheritance Hierarchy
Online System Object
WindowsFormsCalendar CalendarSelectableElement
WindowsFormsCalendar CalendarTimeScaleUnit

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class CalendarTimeScaleUnit _
    Inherits CalendarSelectableElement
Public Class CalendarTimeScaleUnit _
    Inherits CalendarSelectableElement
public class CalendarTimeScaleUnit : CalendarSelectableElement
public class CalendarTimeScaleUnit : CalendarSelectableElement
public ref class CalendarTimeScaleUnit : public CalendarSelectableElement
public ref class CalendarTimeScaleUnit : public CalendarSelectableElement
See Also
CalendarTimeScaleUnit Members


CalendarTimeScaleUnit Members

CalendarTimeScaleUnit Members A Sandcastle Documented Class Library
Send Feedback

The CalendarTimeScaleUnit type exposes the following members.
Methods
 | Name | Description
Public method | CompareTo | Compares this element with other using date as comparer (Inherited from CalendarSelectableElement.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Returns a Online String that represents this instance. (Overrides Online Object ToString .)
Back to Top
Properties
 | Name | Description
Public property | Bounds | Gets the Bounds of the element on the Calendar window (Inherited from CalendarSelectableElement.)
Public property | Calendar | Gets the Calendar this element belongs to (Inherited from CalendarSelectableElement.)
Public property | Date | Gets the exact date when the unit starts (Overrides CalendarSelectableElement Date.)
Public property | Day | Gets the CalendarDay this unit belongs to
Public property | Duration | Gets the duration of the unit.
Public property | Highlighted | Gets if the unit is highlighted because it fits in some of the calendar's highlight ranges
Public property | Hours | Gets the hour when this unit starts
Public property | Index | Gets the index of the unit relative to the day
Public property | Minutes | Gets the minute when this unit starts
Public property | Selected | Gets a value indicating if the element is currently selected (Inherited from CalendarSelectableElement.)
Public property | Visible | Gets a value indicating if the unit is currently visible on viewport
Back to Top
See Also
CalendarTimeScaleUnit Class


CalendarTimeScaleUnit Methods

CalendarTimeScaleUnit Methods A Sandcastle Documented Class Library
Send Feedback
The CalendarTimeScaleUnit type exposes the following members.
Methods
 | Name | Description
Public method | CompareTo | Compares this element with other using date as comparer (Inherited from CalendarSelectableElement.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Returns a Online String that represents this instance. (Overrides Online Object ToString .)
Back to Top
See Also
CalendarTimeScaleUnit Class


ToString Method

CalendarTimeScaleUnit ToString Method A Sandcastle Documented Class Library
Send Feedback
Returns a Online String that represents this instance.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public override string ToString()
public override string ToString()
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
Return Value

            A   Online String that represents this instance.

See Also
CalendarTimeScaleUnit Class
CalendarTimeScaleUnit Members


CalendarTimeScaleUnit Properties

CalendarTimeScaleUnit Properties A Sandcastle Documented Class Library
Send Feedback
The CalendarTimeScaleUnit type exposes the following members.
Properties
 | Name | Description
Public property | Bounds | Gets the Bounds of the element on the Calendar window (Inherited from CalendarSelectableElement.)
Public property | Calendar | Gets the Calendar this element belongs to (Inherited from CalendarSelectableElement.)
Public property | Date | Gets the exact date when the unit starts (Overrides CalendarSelectableElement Date.)
Public property | Day | Gets the CalendarDay this unit belongs to
Public property | Duration | Gets the duration of the unit.
Public property | Highlighted | Gets if the unit is highlighted because it fits in some of the calendar's highlight ranges
Public property | Hours | Gets the hour when this unit starts
Public property | Index | Gets the index of the unit relative to the day
Public property | Minutes | Gets the minute when this unit starts
Public property | Selected | Gets a value indicating if the element is currently selected (Inherited from CalendarSelectableElement.)
Public property | Visible | Gets a value indicating if the unit is currently visible on viewport
Back to Top
See Also
CalendarTimeScaleUnit Class


Date Property

CalendarTimeScaleUnit Date Property A Sandcastle Documented Class Library
Send Feedback
Gets the exact date when the unit starts

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides ReadOnly Property Date As DateTime
    Get
Public Overrides ReadOnly Property Date As DateTime
    Get
public override DateTime Date { get; }
public override DateTime Date { get; }
public:
virtual property DateTime Date {
    DateTime get () override;
}
public:
virtual property DateTime Date {
    DateTime get () override;
}
Implements
ICalendarSelectableElement Date
See Also
CalendarTimeScaleUnit Class
CalendarTimeScaleUnit Members


Day Property

CalendarTimeScaleUnit Day Property A Sandcastle Documented Class Library
Send Feedback
Gets the CalendarDay this unit belongs to

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Day As CalendarDay
    Get
Public ReadOnly Property Day As CalendarDay
    Get
public CalendarDay Day { get; }
public CalendarDay Day { get; }
public:
property CalendarDay^ Day {
    CalendarDay^ get ();
}
public:
property CalendarDay^ Day {
    CalendarDay^ get ();
}
See Also
CalendarTimeScaleUnit Class
CalendarTimeScaleUnit Members


Duration Property

CalendarTimeScaleUnit Duration Property A Sandcastle Documented Class Library
Send Feedback
Gets the duration of the unit.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Duration As TimeSpan
    Get
Public ReadOnly Property Duration As TimeSpan
    Get
public TimeSpan Duration { get; }
public TimeSpan Duration { get; }
public:
property TimeSpan Duration {
    TimeSpan get ();
}
public:
property TimeSpan Duration {
    TimeSpan get ();
}
See Also
CalendarTimeScaleUnit Class
CalendarTimeScaleUnit Members


Highlighted Property

CalendarTimeScaleUnit Highlighted Property A Sandcastle Documented Class Library
Send Feedback
Gets if the unit is highlighted because it fits in some of the calendar's highlight ranges

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Highlighted As Boolean
    Get
Public ReadOnly Property Highlighted As Boolean
    Get
public bool Highlighted { get; }
public bool Highlighted { get; }
public:
property bool Highlighted {
    bool get ();
}
public:
property bool Highlighted {
    bool get ();
}
See Also
CalendarTimeScaleUnit Class
CalendarTimeScaleUnit Members


Hours Property

CalendarTimeScaleUnit Hours Property A Sandcastle Documented Class Library
Send Feedback
Gets the hour when this unit starts

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Hours As Integer
    Get
Public ReadOnly Property Hours As Integer
    Get
public int Hours { get; }
public int Hours { get; }
public:
property int Hours {
    int get ();
}
public:
property int Hours {
    int get ();
}
See Also
CalendarTimeScaleUnit Class
CalendarTimeScaleUnit Members


Index Property

CalendarTimeScaleUnit Index Property A Sandcastle Documented Class Library
Send Feedback
Gets the index of the unit relative to the day

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Index As Integer
    Get
Public ReadOnly Property Index As Integer
    Get
public int Index { get; }
public int Index { get; }
public:
property int Index {
    int get ();
}
public:
property int Index {
    int get ();
}
See Also
CalendarTimeScaleUnit Class
CalendarTimeScaleUnit Members


Minutes Property

CalendarTimeScaleUnit Minutes Property A Sandcastle Documented Class Library
Send Feedback
Gets the minute when this unit starts

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property Minutes As Integer
    Get
    Set
Public Property Minutes As Integer
    Get
    Set
public int Minutes { get; set; }
public int Minutes { get; set; }
public:
property int Minutes {
    int get ();
    void set (int value);
}
public:
property int Minutes {
    int get ();
    void set (int value);
}
See Also
CalendarTimeScaleUnit Class
CalendarTimeScaleUnit Members


Visible Property

CalendarTimeScaleUnit Visible Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if the unit is currently visible on viewport

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Visible As Boolean
    Get
Public ReadOnly Property Visible As Boolean
    Get
public bool Visible { get; }
public bool Visible { get; }
public:
property bool Visible {
    bool get ();
}
public:
property bool Visible {
    bool get ();
}
See Also
CalendarTimeScaleUnit Class
CalendarTimeScaleUnit Members


CalendarWeek Class

CalendarWeek Class A Sandcastle Documented Class Library
Represents a week displayed on the Calendar
Inheritance Hierarchy
Online System Object
WindowsFormsCalendar CalendarWeek

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class CalendarWeek
Public Class CalendarWeek
public class CalendarWeek
public class CalendarWeek
public ref class CalendarWeek
public ref class CalendarWeek
See Also
CalendarWeek Members


CalendarWeek Members

CalendarWeek Members A Sandcastle Documented Class Library

The CalendarWeek type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Returns a Online String that represents this instance. (Overrides Online Object ToString .)
Public method | ToStringLarge | Gets the large version of string representation
Public method | ToStringShort | Gets the short version of week's string representation
Back to Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounds of the week
Public property | Calendar | Gets the calendar this week belongs to
Public property | HeaderBounds | Gets the bounds of the week header
Public property | StartDate | Gets the sunday that starts the week
Back to Top
See Also
CalendarWeek Class


CalendarWeek Methods

CalendarWeek Methods A Sandcastle Documented Class Library
The CalendarWeek type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Returns a Online String that represents this instance. (Overrides Online Object ToString .)
Public method | ToStringLarge | Gets the large version of string representation
Public method | ToStringShort | Gets the short version of week's string representation
Back to Top
See Also
CalendarWeek Class


ToString Method

CalendarWeek ToString Method A Sandcastle Documented Class Library
Send Feedback
Returns a Online String that represents this instance.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public override string ToString()
public override string ToString()
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
Return Value

            A   Online String that represents this instance.

See Also
CalendarWeek Class
CalendarWeek Members


ToStringLarge Method

CalendarWeek ToStringLarge Method A Sandcastle Documented Class Library
Send Feedback
Gets the large version of string representation

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Function ToStringLarge As String
Public Function ToStringLarge As String
public string ToStringLarge()
public string ToStringLarge()
public:
String^ ToStringLarge()
public:
String^ ToStringLarge()
Return Value
The week in a string format
See Also
CalendarWeek Class
CalendarWeek Members


ToStringShort Method

CalendarWeek ToStringShort Method A Sandcastle Documented Class Library
Send Feedback
Gets the short version of week's string representation

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Function ToStringShort As String
Public Function ToStringShort As String
public string ToStringShort()
public string ToStringShort()
public:
String^ ToStringShort()
public:
String^ ToStringShort()
Return Value
[Missing <returns> documentation for "M:WindowsFormsCalendar.CalendarWeek.ToStringShort"]
See Also
CalendarWeek Class
CalendarWeek Members


CalendarWeek Properties

CalendarWeek Properties A Sandcastle Documented Class Library
Send Feedback
The CalendarWeek type exposes the following members.
Properties
 | Name | Description
Public property | Bounds | Gets the bounds of the week
Public property | Calendar | Gets the calendar this week belongs to
Public property | HeaderBounds | Gets the bounds of the week header
Public property | StartDate | Gets the sunday that starts the week
Back to Top
See Also
CalendarWeek Class


Bounds Property

CalendarWeek Bounds Property A Sandcastle Documented Class Library
Send Feedback
Gets the bounds of the week

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Bounds As Rectangle
    Get
Public ReadOnly Property Bounds As Rectangle
    Get
public Rectangle Bounds { get; }
public Rectangle Bounds { get; }
public:
property Rectangle Bounds {
    Rectangle get ();
}
public:
property Rectangle Bounds {
    Rectangle get ();
}
See Also
CalendarWeek Class
CalendarWeek Members


Calendar Property

CalendarWeek Calendar Property A Sandcastle Documented Class Library
Send Feedback
Gets the calendar this week belongs to

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Calendar As Calendar
    Get
Public ReadOnly Property Calendar As Calendar
    Get
public Calendar Calendar { get; }
public Calendar Calendar { get; }
public:
property Calendar^ Calendar {
    Calendar^ get ();
}
public:
property Calendar^ Calendar {
    Calendar^ get ();
}
See Also
CalendarWeek Class
CalendarWeek Members


HeaderBounds Property

CalendarWeek HeaderBounds Property A Sandcastle Documented Class Library
Send Feedback
Gets the bounds of the week header

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property HeaderBounds As Rectangle
    Get
Public ReadOnly Property HeaderBounds As Rectangle
    Get
public Rectangle HeaderBounds { get; }
public Rectangle HeaderBounds { get; }
public:
property Rectangle HeaderBounds {
    Rectangle get ();
}
public:
property Rectangle HeaderBounds {
    Rectangle get ();
}
See Also
CalendarWeek Class
CalendarWeek Members


StartDate Property

CalendarWeek StartDate Property A Sandcastle Documented Class Library
Send Feedback
Gets the sunday that starts the week

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property StartDate As DateTime
    Get
Public ReadOnly Property StartDate As DateTime
    Get
public DateTime StartDate { get; }
public DateTime StartDate { get; }
public:
property DateTime StartDate {
    DateTime get ();
}
public:
property DateTime StartDate {
    DateTime get ();
}
See Also
CalendarWeek Class
CalendarWeek Members


Corners Enumeration

Corners Enumeration A Sandcastle Documented Class Library
Possible corners to pass to the RoundRectangle method

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
<FlagsAttribute> _
Public Enumeration Corners
<FlagsAttribute> _
Public Enumeration Corners
[FlagsAttribute]
public enum Corners
[FlagsAttribute]
public enum Corners
[FlagsAttribute]
public enum class Corners
[FlagsAttribute]
public enum class Corners
Members
Member name | Value | Description
None | 0 | No corners
NorthWest | 2 | Northwest corner
NorthEast | 4 | Northeast corner
SouthEast | 8 | Southeast corner
SouthWest | 16 | Southwest corner
All | 30 | All corners
North | 6 | North corner
South | 24 | South corner
East | 12 | East Corner
West | 18 | West corner
See Also


ICalendarSelectableElement Interface

ICalendarSelectableElement Interface A Sandcastle Documented Class Library
Send Feedback
Interface implemented by every selectable element of the calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Interface ICalendarSelectableElement _
    Inherits ISelectableElement, IComparable(Of ICalendarSelectableElement)
Public Interface ICalendarSelectableElement _
    Inherits ISelectableElement, IComparable(Of ICalendarSelectableElement)
public interface ICalendarSelectableElement : ISelectableElement,
    IComparable<ICalendarSelectableElement>
public interface ICalendarSelectableElement : ISelectableElement,
    IComparable<ICalendarSelectableElement>
public interface class ICalendarSelectableElement : ISelectableElement,
    IComparable<ICalendarSelectableElement^>
public interface class ICalendarSelectableElement : ISelectableElement,
    IComparable<ICalendarSelectableElement^>
See Also
ICalendarSelectableElement Members


ICalendarSelectableElement Members

ICalendarSelectableElement Members A Sandcastle Documented Class Library
Send Feedback

The ICalendarSelectableElement type exposes the following members.
Methods
 | Name | Description
Public method | Online CompareTo | Compares the current object with another object of the same type. (Inherited from Online IComparable ICalendarSelectableElement .)
Back to Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounds of the element (Inherited from ISelectableElement.)
Public property | Calendar | Gets the calendar this element belongs to
Public property | Date | Gets the calendar
Public property | Selected | Gets if the element is currently selected (Inherited from ISelectableElement.)
Back to Top
See Also
ICalendarSelectableElement Interface


ICalendarSelectableElement Methods

ICalendarSelectableElement Methods A Sandcastle Documented Class Library
Send Feedback
The ICalendarSelectableElement type exposes the following members.
Methods
 | Name | Description
Public method | Online CompareTo | Compares the current object with another object of the same type. (Inherited from Online IComparable ICalendarSelectableElement .)
Back to Top
See Also
ICalendarSelectableElement Interface


ICalendarSelectableElement Properties

ICalendarSelectableElement Properties A Sandcastle Documented Class Library
Send Feedback
The ICalendarSelectableElement type exposes the following members.
Properties
 | Name | Description
Public property | Bounds | Gets the bounds of the element (Inherited from ISelectableElement.)
Public property | Calendar | Gets the calendar this element belongs to
Public property | Date | Gets the calendar
Public property | Selected | Gets if the element is currently selected (Inherited from ISelectableElement.)
Back to Top
See Also
ICalendarSelectableElement Interface


Calendar Property

ICalendarSelectableElement Calendar Property A Sandcastle Documented Class Library
Send Feedback
Gets the calendar this element belongs to

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
ReadOnly Property Calendar As Calendar
    Get
ReadOnly Property Calendar As Calendar
    Get
Calendar Calendar { get; }
Calendar Calendar { get; }
property Calendar^ Calendar {
    Calendar^ get ();
}
property Calendar^ Calendar {
    Calendar^ get ();
}
See Also
ICalendarSelectableElement Interface
ICalendarSelectableElement Members


Date Property

ICalendarSelectableElement Date Property A Sandcastle Documented Class Library
Send Feedback
Gets the calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
ReadOnly Property Date As DateTime
    Get
ReadOnly Property Date As DateTime
    Get
DateTime Date { get; }
DateTime Date { get; }
property DateTime Date {
    DateTime get ();
}
property DateTime Date {
    DateTime get ();
}
See Also
ICalendarSelectableElement Interface
ICalendarSelectableElement Members


ISelectableElement Interface

ISelectableElement Interface A Sandcastle Documented Class Library
Send Feedback
Represents a clickable element of MonthView control

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Interface ISelectableElement
Public Interface ISelectableElement
public interface ISelectableElement
public interface ISelectableElement
public interface class ISelectableElement
public interface class ISelectableElement
See Also
ISelectableElement Members


ISelectableElement Members

ISelectableElement Members A Sandcastle Documented Class Library
Send Feedback

The ISelectableElement type exposes the following members.
Properties
 | Name | Description
Public property | Bounds | Gets the bounds of the element
Public property | Selected | Gets if the element is currently selected
Back to Top
See Also
ISelectableElement Interface


ISelectableElement Properties

ISelectableElement Properties A Sandcastle Documented Class Library
Send Feedback
The ISelectableElement type exposes the following members.
Properties
 | Name | Description
Public property | Bounds | Gets the bounds of the element
Public property | Selected | Gets if the element is currently selected
Back to Top
See Also
ISelectableElement Interface


Bounds Property

ISelectableElement Bounds Property A Sandcastle Documented Class Library
Send Feedback
Gets the bounds of the element

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
ReadOnly Property Bounds As Rectangle
    Get
ReadOnly Property Bounds As Rectangle
    Get
Rectangle Bounds { get; }
Rectangle Bounds { get; }
property Rectangle Bounds {
    Rectangle get ();
}
property Rectangle Bounds {
    Rectangle get ();
}
See Also
ISelectableElement Interface
ISelectableElement Members


Selected Property

ISelectableElement Selected Property A Sandcastle Documented Class Library
Send Feedback
Gets if the element is currently selected

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
ReadOnly Property Selected As Boolean
    Get
ReadOnly Property Selected As Boolean
    Get
bool Selected { get; }
bool Selected { get; }
property bool Selected {
    bool get ();
}
property bool Selected {
    bool get ();
}
See Also
ISelectableElement Interface
ISelectableElement Members


MonthView Class

MonthView Class A Sandcastle Documented Class Library
Hosts a month-level calendar where user can select day-based dates
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.ComponentModel Component
Online System.Windows.Forms Control
Online System.Windows.Forms ScrollableControl
Online System.Windows.Forms ContainerControl
WindowsFormsCalendar MonthView

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class MonthView _
    Inherits ContainerControl
Public Class MonthView _
    Inherits ContainerControl
public class MonthView : ContainerControl
public class MonthView : ContainerControl
public ref class MonthView : public ContainerControl
public ref class MonthView : public ContainerControl
See Also
MonthView Members


MonthView Members

MonthView Members A Sandcastle Documented Class Library

The MonthView type exposes the following members.
Constructors
 | Name | Description
Public method | MonthView | Initializes a new instance of the MonthView class.
Back to Top
Methods
 | Name | Description
Protected method | Online AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified Online AccessibleEvents for the specified child control. (Inherited from Online Control.)
Protected method | Online AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified Online AccessibleEvents for the specified child control . (Inherited from Online Control.)
Protected method | Online AdjustFormScrollbars | (Inherited from Online ContainerControl.)
Public method | Online BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Online Control.)
Public method | Online BeginInvoke(Delegate, Object ) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Online Control.)
Public method | Online BringToFront | Brings the control to the front of the z-order. (Inherited from Online Control.)
Public method | Online Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Online Control.)
Protected method | Online CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Online Control.)
Public method | Online CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Online Control.)
Protected method | Online CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Online Control.)
Public method | Online CreateGraphics | Creates the Online Graphics for the control. (Inherited from Online Control.)
Protected method | Online CreateHandle | Creates a handle for the control. (Inherited from Online Control.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Protected method | Online DefWndProc | Sends the specified message to the default window procedure. (Inherited from Online Control.)
Protected method | Online DestroyHandle | Destroys the handle associated with the control. (Inherited from Online Control.)
Public method | Online Dispose | Releases all resources used by the Online Component. (Inherited from Online Component.)
Protected method | Online Dispose(Boolean) | (Inherited from Online ContainerControl.)
Public method | Online DoDragDrop | Begins a drag-and-drop operation. (Inherited from Online Control.)
Public method | Online DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Online Control.)
Public method | Online EndInvoke | Retrieves the return value of the asynchronous operation represented by the Online IAsyncResult passed. (Inherited from Online Control.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Releases unmanaged resources and performs other cleanup operations before the Online Component is reclaimed by garbage collection. (Inherited from Online Component.)
Public method | Online FindForm | Retrieves the form that the control is on. (Inherited from Online Control.)
Public method | Online Focus | Sets input focus to the control. (Inherited from Online Control.)
Protected method | Online GetAccessibilityObjectById | Retrieves the specified Online AccessibleObject. (Inherited from Online Control.)
Protected method | Online GetAutoSizeMode | Retrieves a value indicating how a control will behave when its Online AutoSize property is enabled. (Inherited from Online Control.)
Public method | Online GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Online Control.)
Public method | Online GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Online Control.)
Public method | Online GetContainerControl | Returns the next Online ContainerControl up the control's chain of parent controls. (Inherited from Online Control.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Online Control.)
Public method | Online GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Online Control.)
Protected method | Online GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Online Control.)
Protected method | Online GetScrollState | Determines whether the specified flag has been set. (Inherited from Online ScrollableControl.)
Protected method | Online GetService | Returns an object that represents a service provided by the Online Component or by its Online Container. (Inherited from Online Component.)
Protected method | Online GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Online Control.)
Protected method | Online GetTopLevel | Determines if the control is a top-level control. (Inherited from Online Control.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GoBackward | Moves the view one month backward
Public method | GoForward | Moves the view one month forward
Public method | Online Hide | Conceals the control from the user. (Inherited from Online Control.)
Public method | HitTest | Checks if a day is hitted on the specified point
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online InitLayout | Called after the control has been added to another container. (Inherited from Online Control.)
Public method | Online Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Online Control.)
Public method | Online Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Online Control.)
Public method | Online Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Online Control.)
Public method | Online Invoke(Delegate, Object ) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Online Control.)
Protected method | Online InvokeGotFocus | Raises the Online GotFocus event for the specified control. (Inherited from Online Control.)
Protected method | Online InvokeLostFocus | Raises the Online LostFocus event for the specified control. (Inherited from Online Control.)
Protected method | Online InvokeOnClick | Raises the Online Click event for the specified control. (Inherited from Online Control.)
Protected method | Online InvokePaint | Raises the Online Paint event for the specified control. (Inherited from Online Control.)
Protected method | Online InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Online Control.)
Protected method | Online IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Online Control.)
Protected method | Online IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Online Control.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online NotifyInvalidate | Raises the Online Invalidated event with a specified region of the control to invalidate. (Inherited from Online Control.)
Protected method | Online OnAutoSizeChanged | Raises the Online AutoSizeChanged event. (Inherited from Online Control.)
Protected method | Online OnAutoValidateChanged | Raises the Online AutoValidateChanged event. (Inherited from Online ContainerControl.)
Protected method | Online OnBackColorChanged | Raises the Online BackColorChanged event. (Inherited from Online Control.)
Protected method | Online OnBackgroundImageChanged | Raises the Online BackgroundImageChanged event. (Inherited from Online Control.)
Protected method | Online OnBackgroundImageLayoutChanged | Raises the Online BackgroundImageLayoutChanged event. (Inherited from Online Control.)
Protected method | Online OnBindingContextChanged | Raises the Online BindingContextChanged event. (Inherited from Online Control.)
Protected method | Online OnCausesValidationChanged | Raises the Online CausesValidationChanged event. (Inherited from Online Control.)
Protected method | Online OnChangeUICues | Raises the Online ChangeUICues event. (Inherited from Online Control.)
Protected method | Online OnClick | Raises the Online Click event. (Inherited from Online Control.)
Protected method | Online OnClientSizeChanged | Raises the Online ClientSizeChanged event. (Inherited from Online Control.)
Protected method | Online OnContextMenuChanged | Raises the Online ContextMenuChanged event. (Inherited from Online Control.)
Protected method | Online OnContextMenuStripChanged | Raises the Online ContextMenuStripChanged event. (Inherited from Online Control.)
Protected method | Online OnControlAdded | Raises the Online ControlAdded event. (Inherited from Online Control.)
Protected method | Online OnControlRemoved | Raises the Online ControlRemoved event. (Inherited from Online Control.)
Protected method | Online OnCreateControl | (Inherited from Online ContainerControl.)
Protected method | Online OnCursorChanged | Raises the Online CursorChanged event. (Inherited from Online Control.)
Protected method | Online OnDockChanged | Raises the Online DockChanged event. (Inherited from Online Control.)
Protected method | Online OnDoubleClick | Raises the Online DoubleClick event. (Inherited from Online Control.)
Protected method | Online OnDragDrop | Raises the Online DragDrop event. (Inherited from Online Control.)
Protected method | Online OnDragEnter | Raises the Online DragEnter event. (Inherited from Online Control.)
Protected method | Online OnDragLeave | Raises the Online DragLeave event. (Inherited from Online Control.)
Protected method | Online OnDragOver | Raises the Online DragOver event. (Inherited from Online Control.)
Protected method | Online OnEnabledChanged | Raises the Online EnabledChanged event. (Inherited from Online Control.)
Protected method | Online OnEnter | Raises the Online Enter event. (Inherited from Online Control.)
Protected method | Online OnFontChanged | Raises the Online FontChanged event. (Inherited from Online ContainerControl.)
Protected method | Online OnForeColorChanged | Raises the Online ForeColorChanged event. (Inherited from Online Control.)
Protected method | Online OnGiveFeedback | Raises the Online GiveFeedback event. (Inherited from Online Control.)
Protected method | OnGotFocus | Raises the Online GotFocus event. (Overrides Online Control OnGotFocus(EventArgs).)
Protected method | Online OnHandleCreated | Raises the Online HandleCreated event. (Inherited from Online Control.)
Protected method | Online OnHandleDestroyed | Raises the Online HandleDestroyed event. (Inherited from Online Control.)
Protected method | Online OnHelpRequested | Raises the Online HelpRequested event. (Inherited from Online Control.)
Protected method | Online OnImeModeChanged | Raises the Online ImeModeChanged event. (Inherited from Online Control.)
Protected method | Online OnInvalidated | Raises the Online Invalidated event. (Inherited from Online Control.)
Protected method | Online OnKeyDown | Raises the Online KeyDown event. (Inherited from Online Control.)
Protected method | Online OnKeyPress | Raises the Online KeyPress event. (Inherited from Online Control.)
Protected method | Online OnKeyUp | Raises the Online KeyUp event. (Inherited from Online Control.)
Protected method | Online OnLayout | Raises the Online Layout event. (Inherited from Online ContainerControl.)
Protected method | Online OnLeave | Raises the Online Leave event. (Inherited from Online Control.)
Protected method | Online OnLocationChanged | Raises the Online LocationChanged event. (Inherited from Online Control.)
Protected method | OnLostFocus | Raises the Online LostFocus event. (Overrides Online Control OnLostFocus(EventArgs).)
Protected method | Online OnMarginChanged | Raises the Online MarginChanged event. (Inherited from Online Control.)
Protected method | Online OnMouseCaptureChanged | Raises the Online MouseCaptureChanged event. (Inherited from Online Control.)
Protected method | Online OnMouseClick | Raises the Online MouseClick event. (Inherited from Online Control.)
Protected method | Online OnMouseDoubleClick | Raises the Online MouseDoubleClick event. (Inherited from Online Control.)
Protected method | OnMouseDown | Raises the Online MouseDown event. (Overrides Online Control OnMouseDown(MouseEventArgs).)
Protected method | Online OnMouseEnter | Raises the Online MouseEnter event. (Inherited from Online Control.)
Protected method | Online OnMouseHover | Raises the Online MouseHover event. (Inherited from Online Control.)
Protected method | Online OnMouseLeave | Raises the Online MouseLeave event. (Inherited from Online Control.)
Protected method | OnMouseMove | Raises the Online MouseMove event. (Overrides Online Control OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the Online MouseUp event. (Overrides Online Control OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the Online MouseWheel event. (Overrides Online ScrollableControl OnMouseWheel(MouseEventArgs).)
Protected method | Online OnMove | Raises the Online Move event. (Inherited from Online Control.)
Protected method | Online OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Online Control.)
Protected method | Online OnPaddingChanged | Raises the Online PaddingChanged event. (Inherited from Online ScrollableControl.)
Protected method | OnPaint | Raises the Online Paint event. (Overrides Online Control OnPaint(PaintEventArgs).)
Protected method | Online OnPaintBackground | Paints the background of the control. (Inherited from Online ScrollableControl.)
Protected method | Online OnParentBackColorChanged | Raises the Online BackColorChanged event when the Online BackColor property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentBackgroundImageChanged | Raises the Online BackgroundImageChanged event when the Online BackgroundImage property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentBindingContextChanged | Raises the Online BindingContextChanged event when the Online BindingContext property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentChanged | (Inherited from Online ContainerControl.)
Protected method | Online OnParentCursorChanged | Raises the Online CursorChanged event. (Inherited from Online Control.)
Protected method | Online OnParentEnabledChanged | Raises the Online EnabledChanged event when the Online Enabled property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentFontChanged | Raises the Online FontChanged event when the Online Font property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentForeColorChanged | Raises the Online ForeColorChanged event when the Online ForeColor property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentRightToLeftChanged | Raises the Online RightToLeftChanged event when the Online RightToLeft property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentVisibleChanged | Raises the Online VisibleChanged event when the Online Visible property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnPreviewKeyDown | Raises the Online PreviewKeyDown event. (Inherited from Online Control.)
Protected method | Online OnPrint | Raises the Online Paint event. (Inherited from Online Control.)
Protected method | Online OnQueryContinueDrag | Raises the Online QueryContinueDrag event. (Inherited from Online Control.)
Protected method | Online OnRegionChanged | Raises the Online RegionChanged event. (Inherited from Online Control.)
Protected method | OnResize | Raises the Online Resize event. (Overrides Online Control OnResize(EventArgs).)
Protected method | Online OnRightToLeftChanged | (Inherited from Online ScrollableControl.)
Protected method | Online OnScroll | Raises the Online Scroll event. (Inherited from Online ScrollableControl.)
Protected method | OnSelectionChanged | Raises the [E:SelectionChanged] event.
Protected method | Online OnSizeChanged | Raises the Online SizeChanged event. (Inherited from Online Control.)
Protected method | Online OnStyleChanged | Raises the Online StyleChanged event. (Inherited from Online Control.)
Protected method | Online OnSystemColorsChanged | Raises the Online SystemColorsChanged event. (Inherited from Online Control.)
Protected method | Online OnTabIndexChanged | Raises the Online TabIndexChanged event. (Inherited from Online Control.)
Protected method | Online OnTabStopChanged | Raises the Online TabStopChanged event. (Inherited from Online Control.)
Protected method | Online OnTextChanged | Raises the Online TextChanged event. (Inherited from Online Control.)
Protected method | Online OnValidated | Raises the Online Validated event. (Inherited from Online Control.)
Protected method | Online OnValidating | Raises the Online Validating event. (Inherited from Online Control.)
Protected method | Online OnVisibleChanged | (Inherited from Online ScrollableControl.)
Public method | Online PerformAutoScale | Performs scaling of the container control and its children. (Inherited from Online ContainerControl.)
Public method | Online PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Online Control.)
Public method | Online PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Online Control.)
Public method | Online PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Online Control.)
Public method | Online PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Online Control.)
Public method | Online PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Online Control.)
Public method | Online PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Online Control.)
Protected method | Online ProcessCmdKey | (Inherited from Online ContainerControl.)
Protected method | Online ProcessDialogChar | (Inherited from Online ContainerControl.)
Protected method | Online ProcessDialogKey | (Inherited from Online ContainerControl.)
Protected method | Online ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Online Control.)
Protected method | Online ProcessKeyMessage | Processes a keyboard message. (Inherited from Online Control.)
Protected method | Online ProcessKeyPreview | Previews a keyboard message. (Inherited from Online Control.)
Protected method | Online ProcessMnemonic | (Inherited from Online ContainerControl.)
Protected method | Online ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Online ContainerControl.)
Protected method | Online RaiseDragEvent | Raises the appropriate drag event. (Inherited from Online Control.)
Protected method | Online RaiseKeyEvent | Raises the appropriate key event. (Inherited from Online Control.)
Protected method | Online RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Online Control.)
Protected method | Online RaisePaintEvent | Raises the appropriate paint event. (Inherited from Online Control.)
Protected method | Online RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Online Control.)
Public method | Online RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Online Control.)
Public method | Online RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Online Control.)
Public method | Online Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Online Control.)
Public method | Online ResetBackColor | Resets the Online BackColor property to its default value. (Inherited from Online Control.)
Public method | Online ResetBindings | Causes a control bound to the Online BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Online Control.)
Public method | Online ResetCursor | Resets the Online Cursor property to its default value. (Inherited from Online Control.)
Public method | Online ResetFont | Resets the Online Font property to its default value. (Inherited from Online Control.)
Public method | Online ResetForeColor | Resets the Online ForeColor property to its default value. (Inherited from Online Control.)
Public method | Online ResetImeMode | Resets the Online ImeMode property to its default value. (Inherited from Online Control.)
Protected method | Online ResetMouseEventArgs | Resets the control to handle the Online MouseLeave event. (Inherited from Online Control.)
Public method | Online ResetRightToLeft | Resets the Online RightToLeft property to its default value. (Inherited from Online Control.)
Public method | Online ResetText | Resets the Online Text property to its default value. (Inherited from Online Control.)
Public method | Online ResumeLayout | Resumes usual layout logic. (Inherited from Online Control.)
Public method | Online ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Online Control.)
Protected method | Online RtlTranslateAlignment(HorizontalAlignment) | Converts the specified Online HorizontalAlignment to the appropriate Online HorizontalAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateAlignment(LeftRightAlignment) | Converts the specified Online LeftRightAlignment to the appropriate Online LeftRightAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateAlignment(ContentAlignment) | Converts the specified Online ContentAlignment to the appropriate Online ContentAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateContent | Converts the specified Online ContentAlignment to the appropriate Online ContentAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateHorizontal | Converts the specified Online HorizontalAlignment to the appropriate Online HorizontalAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateLeftRight | Converts the specified Online LeftRightAlignment to the appropriate Online LeftRightAlignment to support right-to-left text. (Inherited from Online Control.)
Public method | Online Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Online Control.)
Public method | Online Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Online Control.)
Public method | Online Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Online Control.)
Protected method | Online ScaleControl | (Inherited from Online ScrollableControl.)
Protected method | Online ScaleCore | (Inherited from Online ScrollableControl.)
Public method | Online ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from Online ScrollableControl.)
Protected method | Online ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from Online ScrollableControl.)
Public method | Online Select | Activates the control. (Inherited from Online Control.)
Protected method | Online Select(Boolean, Boolean) | (Inherited from Online ContainerControl.)
Public method | Online SelectNextControl | Activates the next control. (Inherited from Online Control.)
Public method | Online SendToBack | Sends the control to the back of the z-order. (Inherited from Online Control.)
Public method | Online SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from Online ScrollableControl.)
Protected method | Online SetAutoSizeMode | Sets a value indicating how a control will behave when its Online AutoSize property is enabled. (Inherited from Online Control.)
Public method | Online SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Online Control.)
Public method | Online SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Online Control.)
Protected method | Online SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Online Control.)
Protected method | Online SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Online Control.)
Protected method | Online SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from Online ScrollableControl.)
Protected method | Online SetScrollState | Sets the specified scroll state flag. (Inherited from Online ScrollableControl.)
Protected method | Online SetStyle | Sets a specified Online ControlStyles flag to either true or false. (Inherited from Online Control.)
Protected method | Online SetTopLevel | Sets the control as the top-level control. (Inherited from Online Control.)
Protected method | Online SetVisibleCore | Sets the control to the specified visible state. (Inherited from Online Control.)
Public method | Online Show | Displays the control to the user. (Inherited from Online Control.)
Protected method | Online SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Online Control.)
Public method | Online SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Online Control.)
Public method | Online ToString | Returns a Online String containing the name of the Online Component, if any. This method should not be overridden. (Inherited from Online Component.)
Public method | Online Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Online Control.)
Protected method | Online UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Online Control.)
Protected method | Online UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Online Control.)
Protected method | Online UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Online Control.)
Protected method | Online UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from Online ContainerControl.)
Protected method | Online UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Online Control.)
Protected method | Online UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Online Control.)
Public method | Online Validate | Verifies the value of the control losing focus by causing the Online Validating and Online Validated events to occur, in that order. (Inherited from Online ContainerControl.)
Public method | Online Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from Online ContainerControl.)
Public method | Online ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Online ContainerControl.)
Public method | Online ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Online ContainerControl.)
Protected method | Online WndProc | Processes Windows messages. (Inherited from Online ContainerControl.)
Back to Top
Properties
 | Name | Description
Public property | Online AccessibilityObject | Gets the Online AccessibleObject assigned to the control. (Inherited from Online Control.)
Public property | Online AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Online Control.)
Public property | Online AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Online Control.)
Public property | Online AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Online Control.)
Public property | Online AccessibleRole | Gets or sets the accessible role of the control (Inherited from Online Control.)
Public property | Online ActiveControl | Gets or sets the active control on the container control. (Inherited from Online ContainerControl.)
Public property | Online AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Online Control.)
Public property | Online Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Online Control.)
Public property | ArrowsColor | Gets or sets the color of the arrows.
Public property | ArrowsSelectedColor | Gets or sets the color of the arrows selected.
Public property | Online AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from Online ContainerControl.)
Protected property | Online AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from Online ContainerControl.)
Public property | Online AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from Online ContainerControl.)
Public property | Online AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from Online ScrollableControl.)
Public property | Online AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from Online ScrollableControl.)
Public property | Online AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from Online ScrollableControl.)
Public property | Online AutoScrollOffset | Gets or sets where this control is scrolled to in Online ScrollControlIntoView(Control). (Inherited from Online Control.)
Public property | Online AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from Online ScrollableControl.)
Public property | Online AutoSize | This property is not relevant for this class. (Inherited from Online Control.)
Public property | Online AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Online ContainerControl.)
Public property | Online BackColor | Gets or sets the background color for the control. (Inherited from Online Control.)
Public property | Online BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Online Control.)
Public property | Online BackgroundImageLayout | Gets or sets the background image layout as defined in the Online ImageLayout enumeration. (Inherited from Online Control.)
Public property | BackwardButtonBounds | Gets the bounds of the backward button
Public property | BackwardButtonSelected | Gets a value indicating if the backward button is selected
Public property | Online BindingContext | (Inherited from Online ContainerControl.)
Public property | Online Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Online Control.)
Public property | Online Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Online Control.)
Protected property | Online CanEnableIme | Gets a value indicating whether the Online ImeMode property can be set to an active value, to enable IME support. (Inherited from Online ContainerControl.)
Public property | Online CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Online Control.)
Protected property | Online CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Online Control.)
Public property | Online CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Online Control.)
Public property | Online Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Online Control.)
Public property | Online CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Online Control.)
Public property | Online ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Online Control.)
Public property | Online ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Online Control.)
Public property | Online CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Online Control.)
Public property | Online Container | Gets the Online IContainer that contains the Online Component. (Inherited from Online Component.)
Public property | Online ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Online Control.)
Public property | Online ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Online Control.)
Public property | Online ContextMenuStrip | Gets or sets the Online ContextMenuStrip associated with this control. (Inherited from Online Control.)
Public property | Online Controls | Gets the collection of controls contained within the control. (Inherited from Online Control.)
Public property | Online Created | Gets a value indicating whether the control has been created. (Inherited from Online Control.)
Protected property | Online CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Online ContainerControl.)
Public property | Online CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from Online ContainerControl.)
Public property | Online Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Online Control.)
Public property | Online DataBindings | Gets the data bindings for the control. (Inherited from Online Control.)
Public property | DayBackgroundColor | Gets or sets the color of the day background.
Public property | DayGrayedText | Gets or sets the day grayed text.
Public property | DayNamesFormat | Gets or sets the format of day names
Public property | DayNamesLength | Gets or sets how many characters of day names should be displayed
Public property | DayNamesVisible | Gets or sets a value indicating if day names should be visible
Public property | DaySelectedBackgroundColor | Gets or sets the color of the day selected background.
Public property | DaySelectedColor | Gets or sets the color of the day selected.
Public property | DaySelectedTextColor | Gets or sets the color of the day selected text.
Public property | DaySize | Gets the size of days rectangles
Protected property | Online DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Online Control.)
Protected property | Online DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Online Control.)
Protected property | Online DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Online Control.)
Protected property | Online DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Online Control.)
Protected property | Online DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Online Control.)
Protected property | Online DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Online Control.)
Protected property | Online DefaultSize | Gets the default size of the control. (Inherited from Online Control.)
Protected property | Online DesignMode | Gets a value that indicates whether the Online Component is currently in design mode. (Inherited from Online Component.)
Public property | Online DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from Online ScrollableControl.)
Public property | Online Disposing | Gets a value indicating whether the base Online Control class is in the process of disposing. (Inherited from Online Control.)
Public property | Online Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Online Control.)
Public property | Online DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from Online ScrollableControl.)
Protected property | Online DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Online Control.)
Public property | Online Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Online Control.)
Protected property | Online Events | Gets the list of event handlers that are attached to this Online Component. (Inherited from Online Component.)
Public property | FirstDayOfWeek | Gets or sets what the first day of weeks should be
Public property | Online Focused | Gets a value indicating whether the control has input focus. (Inherited from Online Control.)
Public property | Font | Gets or sets the Font of the Control (Overrides Online Control Font.)
Protected property | Online FontHeight | Gets or sets the height of the font of the control. (Inherited from Online Control.)
Public property | Online ForeColor | Gets or sets the foreground color of the control. (Inherited from Online Control.)
Public property | ForwardButtonBounds | Gets the bounds of the forward button
Public property | ForwardButtonSelected | Gets a value indicating if the forward button is selected
Public property | Online Handle | Gets the window handle that the control is bound to. (Inherited from Online Control.)
Public property | Online HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Online Control.)
Public property | Online Height | Gets or sets the height of the control. (Inherited from Online Control.)
Public property | Online HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from Online ScrollableControl.)
Protected property | Online HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from Online ScrollableControl.)
Public property | Online ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Online Control.)
Protected property | Online ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Online Control.)
Public property | Online InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Online Control.)
Public property | Online IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Online Control.)
Public property | Online IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Online Control.)
Public property | Online IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Online Control.)
Public property | Online IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Online Control.)
Public property | ItemPadding | Gets or sets the internal padding of items (Days, day names, month names)
Public property | Online LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Online Control.)
Public property | Online Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Online Control.)
Public property | Online Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Online Control.)
Public property | Online Margin | Gets or sets the space between controls. (Inherited from Online Control.)
Public property | Online MaximumSize | Gets or sets the size that is the upper limit that Online GetPreferredSize(Size) can specify. (Inherited from Online Control.)
Public property | MaxSelectionCount | Gets or sets the maximum selection count of days
Public property | Online MinimumSize | Gets or sets the size that is the lower limit that Online GetPreferredSize(Size) can specify. (Inherited from Online Control.)
Public property | Months | Gets the Months currently displayed on the calendar
Public property | MonthSize | Gets the size of an entire month inside the MonthView
Public property | MonthTitleColor | Gets or sets the color of the month title.
Public property | MonthTitleColorInactive | Gets or sets the month title color inactive.
Public property | MonthTitleFormat | Gets or sets the format of month titles
Public property | MonthTitleTextColor | Gets or sets the color of the month title text.
Public property | MonthTitleTextColorInactive | Gets or sets the month title text color inactive.
Public property | Online Name | Gets or sets the name of the control. (Inherited from Online Control.)
Public property | Online Padding | Gets or sets padding within the control. (Inherited from Online Control.)
Public property | Online Parent | Gets or sets the parent container of the control. (Inherited from Online Control.)
Public property | Online ParentForm | Gets the form that the container control is assigned to. (Inherited from Online ContainerControl.)
Public property | Online PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Online Control.)
Public property | Online ProductName | Gets the product name of the assembly containing the control. (Inherited from Online Control.)
Public property | Online ProductVersion | Gets the version of the assembly containing the control. (Inherited from Online Control.)
Public property | Online RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Online Control.)
Public property | Online Region | Gets or sets the window region associated with the control. (Inherited from Online Control.)
Protected property | Online RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Online Control.)
Protected property | Online ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Online Control.)
Public property | Online Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Online Control.)
Public property | Online RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Online Control.)
Protected property | Online ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Online Control.)
Public property | SelectionEnd | Gets or sets the end of selection
Public property | SelectionMode | Gets or sets the selection mode of MonthView
Public property | SelectionStart | Gets or sets the start of selection
Protected property | Online ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Online Control.)
Protected property | Online ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Online Control.)
Public property | Online Site | Gets or sets the site of the control. (Inherited from Online Control.)
Public property | Online Size | Gets or sets the height and width of the control. (Inherited from Online Control.)
Public property | Online TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Online Control.)
Public property | Online TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Online Control.)
Public property | Online Tag | Gets or sets the object that contains data about the control. (Inherited from Online Control.)
Public property | Online Text | Gets or sets the text associated with this control. (Inherited from Online Control.)
Public property | TodayBorderColor | Gets or sets the color of the today day border color
Public property | Online Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Online Control.)
Public property | Online TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Online Form that the control is contained in. (Inherited from Online Control.)
Public property | Online UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Online Control.)
Public property | Online VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from Online ScrollableControl.)
Public property | ViewEnd | Gets the last day of the last month showed on the view.
Public property | ViewStart | Gets or sets the date of the first displayed month
Public property | Online Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Online Control.)
Protected property | Online VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from Online ScrollableControl.)
Public property | Online Width | Gets or sets the width of the control. (Inherited from Online Control.)
Public property | Online WindowTarget | This property is not relevant for this class. (Inherited from Online Control.)
Public property | WorkWeekEnd | Gets or sets the day that ends a work-week
Public property | WorkWeekStart | Gets or sets the day that starts a work-week
Back to Top
Events
 | Name | Description
Public event | Online AutoSizeChanged | This event is not relevant for this class. (Inherited from Online Control.)
Public event | Online AutoValidateChanged | Occurs when the Online AutoValidate property changes. (Inherited from Online ContainerControl.)
Public event | Online BackColorChanged | Occurs when the value of the Online BackColor property changes. (Inherited from Online Control.)
Public event | Online BackgroundImageChanged | Occurs when the value of the Online BackgroundImage property changes. (Inherited from Online Control.)
Public event | Online BackgroundImageLayoutChanged | Occurs when the Online BackgroundImageLayout property changes. (Inherited from Online Control.)
Public event | Online BindingContextChanged | Occurs when the value of the Online BindingContext property changes. (Inherited from Online Control.)
Public event | Online CausesValidationChanged | Occurs when the value of the Online CausesValidation property changes. (Inherited from Online Control.)
Public event | Online ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Online Control.)
Public event | Online Click | Occurs when the control is clicked. (Inherited from Online Control.)
Public event | Online ClientSizeChanged | Occurs when the value of the Online ClientSize property changes. (Inherited from Online Control.)
Public event | Online ContextMenuChanged | Occurs when the value of the Online ContextMenu property changes. (Inherited from Online Control.)
Public event | Online ContextMenuStripChanged | Occurs when the value of the Online ContextMenuStrip property changes. (Inherited from Online Control.)
Public event | Online ControlAdded | Occurs when a new control is added to the Online Control ControlCollection. (Inherited from Online Control.)
Public event | Online ControlRemoved | Occurs when a control is removed from the Online Control ControlCollection. (Inherited from Online Control.)
Public event | Online CursorChanged | Occurs when the value of the Online Cursor property changes. (Inherited from Online Control.)
Public event | Online Disposed | Occurs when the component is disposed by a call to the Online Dispose method. (Inherited from Online Component.)
Public event | Online DockChanged | Occurs when the value of the Online Dock property changes. (Inherited from Online Control.)
Public event | Online DoubleClick | Occurs when the control is double-clicked. (Inherited from Online Control.)
Public event | Online DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Online Control.)
Public event | Online DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Online Control.)
Public event | Online DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Online Control.)
Public event | Online DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Online Control.)
Public event | Online EnabledChanged | Occurs when the Online Enabled property value has changed. (Inherited from Online Control.)
Public event | Online Enter | Occurs when the control is entered. (Inherited from Online Control.)
Public event | Online FontChanged | Occurs when the Online Font property value changes. (Inherited from Online Control.)
Public event | Online ForeColorChanged | Occurs when the Online ForeColor property value changes. (Inherited from Online Control.)
Public event | Online GiveFeedback | Occurs during a drag operation. (Inherited from Online Control.)
Public event | Online GotFocus | Occurs when the control receives focus. (Inherited from Online Control.)
Public event | Online HandleCreated | Occurs when a handle is created for the control. (Inherited from Online Control.)
Public event | Online HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Online Control.)
Public event | Online HelpRequested | Occurs when the user requests help for a control. (Inherited from Online Control.)
Public event | Online ImeModeChanged | Occurs when the Online ImeMode property has changed. (Inherited from Online Control.)
Public event | Online Invalidated | Occurs when a control's display requires redrawing. (Inherited from Online Control.)
Public event | Online KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Online Control.)
Public event | Online KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Online Control.)
Public event | Online KeyUp | Occurs when a key is released while the control has focus. (Inherited from Online Control.)
Public event | Online Layout | Occurs when a control should reposition its child controls. (Inherited from Online Control.)
Public event | Online Leave | Occurs when the input focus leaves the control. (Inherited from Online Control.)
Public event | Online LocationChanged | Occurs when the Online Location property value has changed. (Inherited from Online Control.)
Public event | Online LostFocus | Occurs when the control loses focus. (Inherited from Online Control.)
Public event | Online MarginChanged | Occurs when the control's margin changes. (Inherited from Online Control.)
Public event | Online MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Online Control.)
Public event | Online MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Online Control.)
Public event | Online MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Online Control.)
Public event | Online MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Online Control.)
Public event | Online MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Online Control.)
Public event | Online MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Online Control.)
Public event | Online MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Online Control.)
Public event | Online MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Online Control.)
Public event | Online MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Online Control.)
Public event | Online MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Online Control.)
Public event | Online Move | Occurs when the control is moved. (Inherited from Online Control.)
Public event | Online PaddingChanged | Occurs when the control's padding changes. (Inherited from Online Control.)
Public event | Online Paint | Occurs when the control is redrawn. (Inherited from Online Control.)
Public event | Online ParentChanged | Occurs when the Online Parent property value changes. (Inherited from Online Control.)
Public event | Online PreviewKeyDown | Occurs before the Online KeyDown event when a key is pressed while focus is on this control. (Inherited from Online Control.)
Public event | Online QueryAccessibilityHelp | Occurs when Online AccessibleObject is providing help to accessibility applications. (Inherited from Online Control.)
Public event | Online QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Online Control.)
Public event | Online RegionChanged | Occurs when the value of the Online Region property changes. (Inherited from Online Control.)
Public event | Online Resize | Occurs when the control is resized. (Inherited from Online Control.)
Public event | Online RightToLeftChanged | Occurs when the Online RightToLeft property value changes. (Inherited from Online Control.)
Public event | Online Scroll | Occurs when the user or code scrolls through the client area. (Inherited from Online ScrollableControl.)
Public event | SelectionChanged | Occurs when selection has changed.
Public event | Online SizeChanged | Occurs when the Online Size property value changes. (Inherited from Online Control.)
Public event | Online StyleChanged | Occurs when the control style changes. (Inherited from Online Control.)
Public event | Online SystemColorsChanged | Occurs when the system colors change. (Inherited from Online Control.)
Public event | Online TabIndexChanged | Occurs when the Online TabIndex property value changes. (Inherited from Online Control.)
Public event | Online TabStopChanged | Occurs when the Online TabStop property value changes. (Inherited from Online Control.)
Public event | Online TextChanged | Occurs when the Online Text property value changes. (Inherited from Online Control.)
Public event | Online Validated | Occurs when the control is finished validating. (Inherited from Online Control.)
Public event | Online Validating | Occurs when the control is validating. (Inherited from Online Control.)
Public event | Online VisibleChanged | Occurs when the Online Visible property value changes. (Inherited from Online Control.)
Back to Top
See Also
MonthView Class


MonthView Constructor

MonthView Constructor A Sandcastle Documented Class Library
Initializes a new instance of the MonthView class.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New
Public Sub New
public MonthView()
public MonthView()
public:
MonthView()
public:
MonthView()
See Also
MonthView Class
MonthView Members


MonthView Methods

MonthView Methods A Sandcastle Documented Class Library
The MonthView type exposes the following members.
Methods
 | Name | Description
Protected method | Online AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified Online AccessibleEvents for the specified child control. (Inherited from Online Control.)
Protected method | Online AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified Online AccessibleEvents for the specified child control . (Inherited from Online Control.)
Protected method | Online AdjustFormScrollbars | (Inherited from Online ContainerControl.)
Public method | Online BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Online Control.)
Public method | Online BeginInvoke(Delegate, Object ) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Online Control.)
Public method | Online BringToFront | Brings the control to the front of the z-order. (Inherited from Online Control.)
Public method | Online Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Online Control.)
Protected method | Online CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Online Control.)
Public method | Online CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Online Control.)
Protected method | Online CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Online Control.)
Public method | Online CreateGraphics | Creates the Online Graphics for the control. (Inherited from Online Control.)
Protected method | Online CreateHandle | Creates a handle for the control. (Inherited from Online Control.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Protected method | Online DefWndProc | Sends the specified message to the default window procedure. (Inherited from Online Control.)
Protected method | Online DestroyHandle | Destroys the handle associated with the control. (Inherited from Online Control.)
Public method | Online Dispose | Releases all resources used by the Online Component. (Inherited from Online Component.)
Protected method | Online Dispose(Boolean) | (Inherited from Online ContainerControl.)
Public method | Online DoDragDrop | Begins a drag-and-drop operation. (Inherited from Online Control.)
Public method | Online DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Online Control.)
Public method | Online EndInvoke | Retrieves the return value of the asynchronous operation represented by the Online IAsyncResult passed. (Inherited from Online Control.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Releases unmanaged resources and performs other cleanup operations before the Online Component is reclaimed by garbage collection. (Inherited from Online Component.)
Public method | Online FindForm | Retrieves the form that the control is on. (Inherited from Online Control.)
Public method | Online Focus | Sets input focus to the control. (Inherited from Online Control.)
Protected method | Online GetAccessibilityObjectById | Retrieves the specified Online AccessibleObject. (Inherited from Online Control.)
Protected method | Online GetAutoSizeMode | Retrieves a value indicating how a control will behave when its Online AutoSize property is enabled. (Inherited from Online Control.)
Public method | Online GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Online Control.)
Public method | Online GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Online Control.)
Public method | Online GetContainerControl | Returns the next Online ContainerControl up the control's chain of parent controls. (Inherited from Online Control.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Online Control.)
Public method | Online GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Online Control.)
Protected method | Online GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Online Control.)
Protected method | Online GetScrollState | Determines whether the specified flag has been set. (Inherited from Online ScrollableControl.)
Protected method | Online GetService | Returns an object that represents a service provided by the Online Component or by its Online Container. (Inherited from Online Component.)
Protected method | Online GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Online Control.)
Protected method | Online GetTopLevel | Determines if the control is a top-level control. (Inherited from Online Control.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GoBackward | Moves the view one month backward
Public method | GoForward | Moves the view one month forward
Public method | Online Hide | Conceals the control from the user. (Inherited from Online Control.)
Public method | HitTest | Checks if a day is hitted on the specified point
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online InitLayout | Called after the control has been added to another container. (Inherited from Online Control.)
Public method | Online Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Online Control.)
Public method | Online Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Online Control.)
Public method | Online Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Online Control.)
Public method | Online Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Online Control.)
Public method | Online Invoke(Delegate, Object ) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Online Control.)
Protected method | Online InvokeGotFocus | Raises the Online GotFocus event for the specified control. (Inherited from Online Control.)
Protected method | Online InvokeLostFocus | Raises the Online LostFocus event for the specified control. (Inherited from Online Control.)
Protected method | Online InvokeOnClick | Raises the Online Click event for the specified control. (Inherited from Online Control.)
Protected method | Online InvokePaint | Raises the Online Paint event for the specified control. (Inherited from Online Control.)
Protected method | Online InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Online Control.)
Protected method | Online IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Online Control.)
Protected method | Online IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Online Control.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online NotifyInvalidate | Raises the Online Invalidated event with a specified region of the control to invalidate. (Inherited from Online Control.)
Protected method | Online OnAutoSizeChanged | Raises the Online AutoSizeChanged event. (Inherited from Online Control.)
Protected method | Online OnAutoValidateChanged | Raises the Online AutoValidateChanged event. (Inherited from Online ContainerControl.)
Protected method | Online OnBackColorChanged | Raises the Online BackColorChanged event. (Inherited from Online Control.)
Protected method | Online OnBackgroundImageChanged | Raises the Online BackgroundImageChanged event. (Inherited from Online Control.)
Protected method | Online OnBackgroundImageLayoutChanged | Raises the Online BackgroundImageLayoutChanged event. (Inherited from Online Control.)
Protected method | Online OnBindingContextChanged | Raises the Online BindingContextChanged event. (Inherited from Online Control.)
Protected method | Online OnCausesValidationChanged | Raises the Online CausesValidationChanged event. (Inherited from Online Control.)
Protected method | Online OnChangeUICues | Raises the Online ChangeUICues event. (Inherited from Online Control.)
Protected method | Online OnClick | Raises the Online Click event. (Inherited from Online Control.)
Protected method | Online OnClientSizeChanged | Raises the Online ClientSizeChanged event. (Inherited from Online Control.)
Protected method | Online OnContextMenuChanged | Raises the Online ContextMenuChanged event. (Inherited from Online Control.)
Protected method | Online OnContextMenuStripChanged | Raises the Online ContextMenuStripChanged event. (Inherited from Online Control.)
Protected method | Online OnControlAdded | Raises the Online ControlAdded event. (Inherited from Online Control.)
Protected method | Online OnControlRemoved | Raises the Online ControlRemoved event. (Inherited from Online Control.)
Protected method | Online OnCreateControl | (Inherited from Online ContainerControl.)
Protected method | Online OnCursorChanged | Raises the Online CursorChanged event. (Inherited from Online Control.)
Protected method | Online OnDockChanged | Raises the Online DockChanged event. (Inherited from Online Control.)
Protected method | Online OnDoubleClick | Raises the Online DoubleClick event. (Inherited from Online Control.)
Protected method | Online OnDragDrop | Raises the Online DragDrop event. (Inherited from Online Control.)
Protected method | Online OnDragEnter | Raises the Online DragEnter event. (Inherited from Online Control.)
Protected method | Online OnDragLeave | Raises the Online DragLeave event. (Inherited from Online Control.)
Protected method | Online OnDragOver | Raises the Online DragOver event. (Inherited from Online Control.)
Protected method | Online OnEnabledChanged | Raises the Online EnabledChanged event. (Inherited from Online Control.)
Protected method | Online OnEnter | Raises the Online Enter event. (Inherited from Online Control.)
Protected method | Online OnFontChanged | Raises the Online FontChanged event. (Inherited from Online ContainerControl.)
Protected method | Online OnForeColorChanged | Raises the Online ForeColorChanged event. (Inherited from Online Control.)
Protected method | Online OnGiveFeedback | Raises the Online GiveFeedback event. (Inherited from Online Control.)
Protected method | OnGotFocus | Raises the Online GotFocus event. (Overrides Online Control OnGotFocus(EventArgs).)
Protected method | Online OnHandleCreated | Raises the Online HandleCreated event. (Inherited from Online Control.)
Protected method | Online OnHandleDestroyed | Raises the Online HandleDestroyed event. (Inherited from Online Control.)
Protected method | Online OnHelpRequested | Raises the Online HelpRequested event. (Inherited from Online Control.)
Protected method | Online OnImeModeChanged | Raises the Online ImeModeChanged event. (Inherited from Online Control.)
Protected method | Online OnInvalidated | Raises the Online Invalidated event. (Inherited from Online Control.)
Protected method | Online OnKeyDown | Raises the Online KeyDown event. (Inherited from Online Control.)
Protected method | Online OnKeyPress | Raises the Online KeyPress event. (Inherited from Online Control.)
Protected method | Online OnKeyUp | Raises the Online KeyUp event. (Inherited from Online Control.)
Protected method | Online OnLayout | Raises the Online Layout event. (Inherited from Online ContainerControl.)
Protected method | Online OnLeave | Raises the Online Leave event. (Inherited from Online Control.)
Protected method | Online OnLocationChanged | Raises the Online LocationChanged event. (Inherited from Online Control.)
Protected method | OnLostFocus | Raises the Online LostFocus event. (Overrides Online Control OnLostFocus(EventArgs).)
Protected method | Online OnMarginChanged | Raises the Online MarginChanged event. (Inherited from Online Control.)
Protected method | Online OnMouseCaptureChanged | Raises the Online MouseCaptureChanged event. (Inherited from Online Control.)
Protected method | Online OnMouseClick | Raises the Online MouseClick event. (Inherited from Online Control.)
Protected method | Online OnMouseDoubleClick | Raises the Online MouseDoubleClick event. (Inherited from Online Control.)
Protected method | OnMouseDown | Raises the Online MouseDown event. (Overrides Online Control OnMouseDown(MouseEventArgs).)
Protected method | Online OnMouseEnter | Raises the Online MouseEnter event. (Inherited from Online Control.)
Protected method | Online OnMouseHover | Raises the Online MouseHover event. (Inherited from Online Control.)
Protected method | Online OnMouseLeave | Raises the Online MouseLeave event. (Inherited from Online Control.)
Protected method | OnMouseMove | Raises the Online MouseMove event. (Overrides Online Control OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the Online MouseUp event. (Overrides Online Control OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the Online MouseWheel event. (Overrides Online ScrollableControl OnMouseWheel(MouseEventArgs).)
Protected method | Online OnMove | Raises the Online Move event. (Inherited from Online Control.)
Protected method | Online OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Online Control.)
Protected method | Online OnPaddingChanged | Raises the Online PaddingChanged event. (Inherited from Online ScrollableControl.)
Protected method | OnPaint | Raises the Online Paint event. (Overrides Online Control OnPaint(PaintEventArgs).)
Protected method | Online OnPaintBackground | Paints the background of the control. (Inherited from Online ScrollableControl.)
Protected method | Online OnParentBackColorChanged | Raises the Online BackColorChanged event when the Online BackColor property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentBackgroundImageChanged | Raises the Online BackgroundImageChanged event when the Online BackgroundImage property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentBindingContextChanged | Raises the Online BindingContextChanged event when the Online BindingContext property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentChanged | (Inherited from Online ContainerControl.)
Protected method | Online OnParentCursorChanged | Raises the Online CursorChanged event. (Inherited from Online Control.)
Protected method | Online OnParentEnabledChanged | Raises the Online EnabledChanged event when the Online Enabled property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentFontChanged | Raises the Online FontChanged event when the Online Font property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentForeColorChanged | Raises the Online ForeColorChanged event when the Online ForeColor property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentRightToLeftChanged | Raises the Online RightToLeftChanged event when the Online RightToLeft property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnParentVisibleChanged | Raises the Online VisibleChanged event when the Online Visible property value of the control's container changes. (Inherited from Online Control.)
Protected method | Online OnPreviewKeyDown | Raises the Online PreviewKeyDown event. (Inherited from Online Control.)
Protected method | Online OnPrint | Raises the Online Paint event. (Inherited from Online Control.)
Protected method | Online OnQueryContinueDrag | Raises the Online QueryContinueDrag event. (Inherited from Online Control.)
Protected method | Online OnRegionChanged | Raises the Online RegionChanged event. (Inherited from Online Control.)
Protected method | OnResize | Raises the Online Resize event. (Overrides Online Control OnResize(EventArgs).)
Protected method | Online OnRightToLeftChanged | (Inherited from Online ScrollableControl.)
Protected method | Online OnScroll | Raises the Online Scroll event. (Inherited from Online ScrollableControl.)
Protected method | OnSelectionChanged | Raises the [E:SelectionChanged] event.
Protected method | Online OnSizeChanged | Raises the Online SizeChanged event. (Inherited from Online Control.)
Protected method | Online OnStyleChanged | Raises the Online StyleChanged event. (Inherited from Online Control.)
Protected method | Online OnSystemColorsChanged | Raises the Online SystemColorsChanged event. (Inherited from Online Control.)
Protected method | Online OnTabIndexChanged | Raises the Online TabIndexChanged event. (Inherited from Online Control.)
Protected method | Online OnTabStopChanged | Raises the Online TabStopChanged event. (Inherited from Online Control.)
Protected method | Online OnTextChanged | Raises the Online TextChanged event. (Inherited from Online Control.)
Protected method | Online OnValidated | Raises the Online Validated event. (Inherited from Online Control.)
Protected method | Online OnValidating | Raises the Online Validating event. (Inherited from Online Control.)
Protected method | Online OnVisibleChanged | (Inherited from Online ScrollableControl.)
Public method | Online PerformAutoScale | Performs scaling of the container control and its children. (Inherited from Online ContainerControl.)
Public method | Online PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Online Control.)
Public method | Online PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Online Control.)
Public method | Online PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Online Control.)
Public method | Online PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Online Control.)
Public method | Online PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Online Control.)
Public method | Online PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Online Control.)
Protected method | Online ProcessCmdKey | (Inherited from Online ContainerControl.)
Protected method | Online ProcessDialogChar | (Inherited from Online ContainerControl.)
Protected method | Online ProcessDialogKey | (Inherited from Online ContainerControl.)
Protected method | Online ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Online Control.)
Protected method | Online ProcessKeyMessage | Processes a keyboard message. (Inherited from Online Control.)
Protected method | Online ProcessKeyPreview | Previews a keyboard message. (Inherited from Online Control.)
Protected method | Online ProcessMnemonic | (Inherited from Online ContainerControl.)
Protected method | Online ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Online ContainerControl.)
Protected method | Online RaiseDragEvent | Raises the appropriate drag event. (Inherited from Online Control.)
Protected method | Online RaiseKeyEvent | Raises the appropriate key event. (Inherited from Online Control.)
Protected method | Online RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Online Control.)
Protected method | Online RaisePaintEvent | Raises the appropriate paint event. (Inherited from Online Control.)
Protected method | Online RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Online Control.)
Public method | Online RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Online Control.)
Public method | Online RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Online Control.)
Public method | Online Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Online Control.)
Public method | Online ResetBackColor | Resets the Online BackColor property to its default value. (Inherited from Online Control.)
Public method | Online ResetBindings | Causes a control bound to the Online BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Online Control.)
Public method | Online ResetCursor | Resets the Online Cursor property to its default value. (Inherited from Online Control.)
Public method | Online ResetFont | Resets the Online Font property to its default value. (Inherited from Online Control.)
Public method | Online ResetForeColor | Resets the Online ForeColor property to its default value. (Inherited from Online Control.)
Public method | Online ResetImeMode | Resets the Online ImeMode property to its default value. (Inherited from Online Control.)
Protected method | Online ResetMouseEventArgs | Resets the control to handle the Online MouseLeave event. (Inherited from Online Control.)
Public method | Online ResetRightToLeft | Resets the Online RightToLeft property to its default value. (Inherited from Online Control.)
Public method | Online ResetText | Resets the Online Text property to its default value. (Inherited from Online Control.)
Public method | Online ResumeLayout | Resumes usual layout logic. (Inherited from Online Control.)
Public method | Online ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Online Control.)
Protected method | Online RtlTranslateAlignment(HorizontalAlignment) | Converts the specified Online HorizontalAlignment to the appropriate Online HorizontalAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateAlignment(LeftRightAlignment) | Converts the specified Online LeftRightAlignment to the appropriate Online LeftRightAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateAlignment(ContentAlignment) | Converts the specified Online ContentAlignment to the appropriate Online ContentAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateContent | Converts the specified Online ContentAlignment to the appropriate Online ContentAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateHorizontal | Converts the specified Online HorizontalAlignment to the appropriate Online HorizontalAlignment to support right-to-left text. (Inherited from Online Control.)
Protected method | Online RtlTranslateLeftRight | Converts the specified Online LeftRightAlignment to the appropriate Online LeftRightAlignment to support right-to-left text. (Inherited from Online Control.)
Public method | Online Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Online Control.)
Public method | Online Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Online Control.)
Public method | Online Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Online Control.)
Protected method | Online ScaleControl | (Inherited from Online ScrollableControl.)
Protected method | Online ScaleCore | (Inherited from Online ScrollableControl.)
Public method | Online ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from Online ScrollableControl.)
Protected method | Online ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from Online ScrollableControl.)
Public method | Online Select | Activates the control. (Inherited from Online Control.)
Protected method | Online Select(Boolean, Boolean) | (Inherited from Online ContainerControl.)
Public method | Online SelectNextControl | Activates the next control. (Inherited from Online Control.)
Public method | Online SendToBack | Sends the control to the back of the z-order. (Inherited from Online Control.)
Public method | Online SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from Online ScrollableControl.)
Protected method | Online SetAutoSizeMode | Sets a value indicating how a control will behave when its Online AutoSize property is enabled. (Inherited from Online Control.)
Public method | Online SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Online Control.)
Public method | Online SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Online Control.)
Protected method | Online SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Online Control.)
Protected method | Online SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Online Control.)
Protected method | Online SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from Online ScrollableControl.)
Protected method | Online SetScrollState | Sets the specified scroll state flag. (Inherited from Online ScrollableControl.)
Protected method | Online SetStyle | Sets a specified Online ControlStyles flag to either true or false. (Inherited from Online Control.)
Protected method | Online SetTopLevel | Sets the control as the top-level control. (Inherited from Online Control.)
Protected method | Online SetVisibleCore | Sets the control to the specified visible state. (Inherited from Online Control.)
Public method | Online Show | Displays the control to the user. (Inherited from Online Control.)
Protected method | Online SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Online Control.)
Public method | Online SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Online Control.)
Public method | Online ToString | Returns a Online String containing the name of the Online Component, if any. This method should not be overridden. (Inherited from Online Component.)
Public method | Online Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Online Control.)
Protected method | Online UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Online Control.)
Protected method | Online UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Online Control.)
Protected method | Online UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Online Control.)
Protected method | Online UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from Online ContainerControl.)
Protected method | Online UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Online Control.)
Protected method | Online UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Online Control.)
Public method | Online Validate | Verifies the value of the control losing focus by causing the Online Validating and Online Validated events to occur, in that order. (Inherited from Online ContainerControl.)
Public method | Online Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from Online ContainerControl.)
Public method | Online ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Online ContainerControl.)
Public method | Online ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Online ContainerControl.)
Protected method | Online WndProc | Processes Windows messages. (Inherited from Online ContainerControl.)
Back to Top
See Also
MonthView Class


GoBackward Method

MonthView GoBackward Method A Sandcastle Documented Class Library
Send Feedback
Moves the view one month backward

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub GoBackward
Public Sub GoBackward
public void GoBackward()
public void GoBackward()
public:
void GoBackward()
public:
void GoBackward()
See Also
MonthView Class
MonthView Members


GoForward Method

MonthView GoForward Method A Sandcastle Documented Class Library
Send Feedback
Moves the view one month forward

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub GoForward
Public Sub GoForward
public void GoForward()
public void GoForward()
public:
void GoForward()
public:
void GoForward()
See Also
MonthView Class
MonthView Members


HitTest Method

MonthView HitTest Method A Sandcastle Documented Class Library
Send Feedback
Checks if a day is hitted on the specified point

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Function HitTest ( _
    p As Point _
) As MonthViewDay
Public Function HitTest ( _
    p As Point _
) As MonthViewDay
public MonthViewDay HitTest(
    Point p
)
public MonthViewDay HitTest(
    Point p
)
public:
MonthViewDay^ HitTest(
    Point p
)
public:
MonthViewDay^ HitTest(
    Point p
)
Parameters
p
Type:   Online System.Drawing Point
[Missing <param name="p"/> documentation for "M:WindowsFormsCalendar.MonthView.HitTest(System.Drawing.Point)"]
Return Value
[Missing <returns> documentation for "M:WindowsFormsCalendar.MonthView.HitTest(System.Drawing.Point)"]
See Also
MonthView Class
MonthView Members


OnGotFocus Method

MonthView OnGotFocus Method A Sandcastle Documented Class Library
Send Feedback
Raises the Online GotFocus event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overrides Sub OnGotFocus ( _
    e As EventArgs _
)
Protected Overrides Sub OnGotFocus ( _
    e As EventArgs _
)
protected override void OnGotFocus(
    EventArgs e
)
protected override void OnGotFocus(
    EventArgs e
)
protected:
virtual void OnGotFocus(
    EventArgs^ e
) override
protected:
virtual void OnGotFocus(
    EventArgs^ e
) override
Parameters
e
Type:   Online System EventArgs
An   Online EventArgs that contains the event data.
See Also
MonthView Class
MonthView Members


OnLostFocus Method

MonthView OnLostFocus Method A Sandcastle Documented Class Library
Send Feedback
Raises the Online LostFocus event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overrides Sub OnLostFocus ( _
    e As EventArgs _
)
Protected Overrides Sub OnLostFocus ( _
    e As EventArgs _
)
protected override void OnLostFocus(
    EventArgs e
)
protected override void OnLostFocus(
    EventArgs e
)
protected:
virtual void OnLostFocus(
    EventArgs^ e
) override
protected:
virtual void OnLostFocus(
    EventArgs^ e
) override
Parameters
e
Type:   Online System EventArgs
An   Online EventArgs that contains the event data.
See Also
MonthView Class
MonthView Members


OnMouseDown Method

MonthView OnMouseDown Method A Sandcastle Documented Class Library
Send Feedback
Raises the Online MouseDown event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
protected override void OnMouseDown(
    MouseEventArgs e
)
protected override void OnMouseDown(
    MouseEventArgs e
)
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override
Parameters
e
Type:   Online System.Windows.Forms MouseEventArgs
A   Online MouseEventArgs that contains the event data.
See Also
MonthView Class
MonthView Members


OnMouseMove Method

MonthView OnMouseMove Method A Sandcastle Documented Class Library
Send Feedback
Raises the Online MouseMove event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
protected override void OnMouseMove(
    MouseEventArgs e
)
protected override void OnMouseMove(
    MouseEventArgs e
)
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override
Parameters
e
Type:   Online System.Windows.Forms MouseEventArgs
A   Online MouseEventArgs that contains the event data.
See Also
MonthView Class
MonthView Members


OnMouseUp Method

MonthView OnMouseUp Method A Sandcastle Documented Class Library
Send Feedback
Raises the Online MouseUp event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Protected Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
protected override void OnMouseUp(
    MouseEventArgs e
)
protected override void OnMouseUp(
    MouseEventArgs e
)
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override
Parameters
e
Type:   Online System.Windows.Forms MouseEventArgs
A   Online MouseEventArgs that contains the event data.
See Also
MonthView Class
MonthView Members


OnMouseWheel Method

MonthView OnMouseWheel Method A Sandcastle Documented Class Library
Send Feedback
Raises the Online MouseWheel event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overrides Sub OnMouseWheel ( _
    e As MouseEventArgs _
)
Protected Overrides Sub OnMouseWheel ( _
    e As MouseEventArgs _
)
protected override void OnMouseWheel(
    MouseEventArgs e
)
protected override void OnMouseWheel(
    MouseEventArgs e
)
protected:
virtual void OnMouseWheel(
    MouseEventArgs^ e
) override
protected:
virtual void OnMouseWheel(
    MouseEventArgs^ e
) override
Parameters
e
Type:   Online System.Windows.Forms MouseEventArgs
A   Online MouseEventArgs that contains the event data.
See Also
MonthView Class
MonthView Members


OnPaint Method

MonthView OnPaint Method A Sandcastle Documented Class Library
Send Feedback
Raises the Online Paint event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
protected override void OnPaint(
    PaintEventArgs e
)
protected override void OnPaint(
    PaintEventArgs e
)
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override
Parameters
e
Type:   Online System.Windows.Forms PaintEventArgs
A   Online PaintEventArgs that contains the event data.
See Also
MonthView Class
MonthView Members


OnResize Method

MonthView OnResize Method A Sandcastle Documented Class Library
Send Feedback
Raises the Online Resize event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Overrides Sub OnResize ( _
    e As EventArgs _
)
Protected Overrides Sub OnResize ( _
    e As EventArgs _
)
protected override void OnResize(
    EventArgs e
)
protected override void OnResize(
    EventArgs e
)
protected:
virtual void OnResize(
    EventArgs^ e
) override
protected:
virtual void OnResize(
    EventArgs^ e
) override
Parameters
e
Type:   Online System EventArgs
An   Online EventArgs that contains the event data.
See Also
MonthView Class
MonthView Members


OnSelectionChanged Method

MonthView OnSelectionChanged Method A Sandcastle Documented Class Library
Send Feedback
Raises the [E:SelectionChanged] event.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Protected Sub OnSelectionChanged ( _
    e As EventArgs _
)
Protected Sub OnSelectionChanged ( _
    e As EventArgs _
)
protected void OnSelectionChanged(
    EventArgs e
)
protected void OnSelectionChanged(
    EventArgs e
)
protected:
void OnSelectionChanged(
    EventArgs^ e
)
protected:
void OnSelectionChanged(
    EventArgs^ e
)
Parameters
e
Type:   Online System EventArgs
The   Online EventArgs instance containing the event data.
See Also
MonthView Class
MonthView Members


MonthView Properties

MonthView Properties A Sandcastle Documented Class Library
The MonthView type exposes the following members.
Properties
 | Name | Description
Public property | Online AccessibilityObject | Gets the Online AccessibleObject assigned to the control. (Inherited from Online Control.)
Public property | Online AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Online Control.)
Public property | Online AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Online Control.)
Public property | Online AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Online Control.)
Public property | Online AccessibleRole | Gets or sets the accessible role of the control (Inherited from Online Control.)
Public property | Online ActiveControl | Gets or sets the active control on the container control. (Inherited from Online ContainerControl.)
Public property | Online AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Online Control.)
Public property | Online Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Online Control.)
Public property | ArrowsColor | Gets or sets the color of the arrows.
Public property | ArrowsSelectedColor | Gets or sets the color of the arrows selected.
Public property | Online AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from Online ContainerControl.)
Protected property | Online AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from Online ContainerControl.)
Public property | Online AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from Online ContainerControl.)
Public property | Online AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from Online ScrollableControl.)
Public property | Online AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from Online ScrollableControl.)
Public property | Online AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from Online ScrollableControl.)
Public property | Online AutoScrollOffset | Gets or sets where this control is scrolled to in Online ScrollControlIntoView(Control). (Inherited from Online Control.)
Public property | Online AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from Online ScrollableControl.)
Public property | Online AutoSize | This property is not relevant for this class. (Inherited from Online Control.)
Public property | Online AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Online ContainerControl.)
Public property | Online BackColor | Gets or sets the background color for the control. (Inherited from Online Control.)
Public property | Online BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Online Control.)
Public property | Online BackgroundImageLayout | Gets or sets the background image layout as defined in the Online ImageLayout enumeration. (Inherited from Online Control.)
Public property | BackwardButtonBounds | Gets the bounds of the backward button
Public property | BackwardButtonSelected | Gets a value indicating if the backward button is selected
Public property | Online BindingContext | (Inherited from Online ContainerControl.)
Public property | Online Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Online Control.)
Public property | Online Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Online Control.)
Protected property | Online CanEnableIme | Gets a value indicating whether the Online ImeMode property can be set to an active value, to enable IME support. (Inherited from Online ContainerControl.)
Public property | Online CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Online Control.)
Protected property | Online CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Online Control.)
Public property | Online CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Online Control.)
Public property | Online Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Online Control.)
Public property | Online CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Online Control.)
Public property | Online ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Online Control.)
Public property | Online ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Online Control.)
Public property | Online CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Online Control.)
Public property | Online Container | Gets the Online IContainer that contains the Online Component. (Inherited from Online Component.)
Public property | Online ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Online Control.)
Public property | Online ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Online Control.)
Public property | Online ContextMenuStrip | Gets or sets the Online ContextMenuStrip associated with this control. (Inherited from Online Control.)
Public property | Online Controls | Gets the collection of controls contained within the control. (Inherited from Online Control.)
Public property | Online Created | Gets a value indicating whether the control has been created. (Inherited from Online Control.)
Protected property | Online CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Online ContainerControl.)
Public property | Online CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from Online ContainerControl.)
Public property | Online Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Online Control.)
Public property | Online DataBindings | Gets the data bindings for the control. (Inherited from Online Control.)
Public property | DayBackgroundColor | Gets or sets the color of the day background.
Public property | DayGrayedText | Gets or sets the day grayed text.
Public property | DayNamesFormat | Gets or sets the format of day names
Public property | DayNamesLength | Gets or sets how many characters of day names should be displayed
Public property | DayNamesVisible | Gets or sets a value indicating if day names should be visible
Public property | DaySelectedBackgroundColor | Gets or sets the color of the day selected background.
Public property | DaySelectedColor | Gets or sets the color of the day selected.
Public property | DaySelectedTextColor | Gets or sets the color of the day selected text.
Public property | DaySize | Gets the size of days rectangles
Protected property | Online DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Online Control.)
Protected property | Online DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Online Control.)
Protected property | Online DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Online Control.)
Protected property | Online DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Online Control.)
Protected property | Online DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Online Control.)
Protected property | Online DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Online Control.)
Protected property | Online DefaultSize | Gets the default size of the control. (Inherited from Online Control.)
Protected property | Online DesignMode | Gets a value that indicates whether the Online Component is currently in design mode. (Inherited from Online Component.)
Public property | Online DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from Online ScrollableControl.)
Public property | Online Disposing | Gets a value indicating whether the base Online Control class is in the process of disposing. (Inherited from Online Control.)
Public property | Online Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Online Control.)
Public property | Online DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from Online ScrollableControl.)
Protected property | Online DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Online Control.)
Public property | Online Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Online Control.)
Protected property | Online Events | Gets the list of event handlers that are attached to this Online Component. (Inherited from Online Component.)
Public property | FirstDayOfWeek | Gets or sets what the first day of weeks should be
Public property | Online Focused | Gets a value indicating whether the control has input focus. (Inherited from Online Control.)
Public property | Font | Gets or sets the Font of the Control (Overrides Online Control Font.)
Protected property | Online FontHeight | Gets or sets the height of the font of the control. (Inherited from Online Control.)
Public property | Online ForeColor | Gets or sets the foreground color of the control. (Inherited from Online Control.)
Public property | ForwardButtonBounds | Gets the bounds of the forward button
Public property | ForwardButtonSelected | Gets a value indicating if the forward button is selected
Public property | Online Handle | Gets the window handle that the control is bound to. (Inherited from Online Control.)
Public property | Online HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Online Control.)
Public property | Online Height | Gets or sets the height of the control. (Inherited from Online Control.)
Public property | Online HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from Online ScrollableControl.)
Protected property | Online HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from Online ScrollableControl.)
Public property | Online ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Online Control.)
Protected property | Online ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Online Control.)
Public property | Online InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Online Control.)
Public property | Online IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Online Control.)
Public property | Online IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Online Control.)
Public property | Online IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Online Control.)
Public property | Online IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Online Control.)
Public property | ItemPadding | Gets or sets the internal padding of items (Days, day names, month names)
Public property | Online LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Online Control.)
Public property | Online Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Online Control.)
Public property | Online Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Online Control.)
Public property | Online Margin | Gets or sets the space between controls. (Inherited from Online Control.)
Public property | Online MaximumSize | Gets or sets the size that is the upper limit that Online GetPreferredSize(Size) can specify. (Inherited from Online Control.)
Public property | MaxSelectionCount | Gets or sets the maximum selection count of days
Public property | Online MinimumSize | Gets or sets the size that is the lower limit that Online GetPreferredSize(Size) can specify. (Inherited from Online Control.)
Public property | Months | Gets the Months currently displayed on the calendar
Public property | MonthSize | Gets the size of an entire month inside the MonthView
Public property | MonthTitleColor | Gets or sets the color of the month title.
Public property | MonthTitleColorInactive | Gets or sets the month title color inactive.
Public property | MonthTitleFormat | Gets or sets the format of month titles
Public property | MonthTitleTextColor | Gets or sets the color of the month title text.
Public property | MonthTitleTextColorInactive | Gets or sets the month title text color inactive.
Public property | Online Name | Gets or sets the name of the control. (Inherited from Online Control.)
Public property | Online Padding | Gets or sets padding within the control. (Inherited from Online Control.)
Public property | Online Parent | Gets or sets the parent container of the control. (Inherited from Online Control.)
Public property | Online ParentForm | Gets the form that the container control is assigned to. (Inherited from Online ContainerControl.)
Public property | Online PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Online Control.)
Public property | Online ProductName | Gets the product name of the assembly containing the control. (Inherited from Online Control.)
Public property | Online ProductVersion | Gets the version of the assembly containing the control. (Inherited from Online Control.)
Public property | Online RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Online Control.)
Public property | Online Region | Gets or sets the window region associated with the control. (Inherited from Online Control.)
Protected property | Online RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Online Control.)
Protected property | Online ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Online Control.)
Public property | Online Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Online Control.)
Public property | Online RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Online Control.)
Protected property | Online ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Online Control.)
Public property | SelectionEnd | Gets or sets the end of selection
Public property | SelectionMode | Gets or sets the selection mode of MonthView
Public property | SelectionStart | Gets or sets the start of selection
Protected property | Online ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Online Control.)
Protected property | Online ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Online Control.)
Public property | Online Site | Gets or sets the site of the control. (Inherited from Online Control.)
Public property | Online Size | Gets or sets the height and width of the control. (Inherited from Online Control.)
Public property | Online TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Online Control.)
Public property | Online TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Online Control.)
Public property | Online Tag | Gets or sets the object that contains data about the control. (Inherited from Online Control.)
Public property | Online Text | Gets or sets the text associated with this control. (Inherited from Online Control.)
Public property | TodayBorderColor | Gets or sets the color of the today day border color
Public property | Online Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Online Control.)
Public property | Online TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Online Form that the control is contained in. (Inherited from Online Control.)
Public property | Online UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Online Control.)
Public property | Online VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from Online ScrollableControl.)
Public property | ViewEnd | Gets the last day of the last month showed on the view.
Public property | ViewStart | Gets or sets the date of the first displayed month
Public property | Online Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Online Control.)
Protected property | Online VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from Online ScrollableControl.)
Public property | Online Width | Gets or sets the width of the control. (Inherited from Online Control.)
Public property | Online WindowTarget | This property is not relevant for this class. (Inherited from Online Control.)
Public property | WorkWeekEnd | Gets or sets the day that ends a work-week
Public property | WorkWeekStart | Gets or sets the day that starts a work-week
Back to Top
See Also
MonthView Class


ArrowsColor Property

MonthView ArrowsColor Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the color of the arrows.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property ArrowsColor As Color
    Get
    Set
Public Property ArrowsColor As Color
    Get
    Set
public Color ArrowsColor { get; set; }
public Color ArrowsColor { get; set; }
public:
property Color ArrowsColor {
    Color get ();
    void set (Color value);
}
public:
property Color ArrowsColor {
    Color get ();
    void set (Color value);
}
Field Value

            The color of the arrows.

See Also
MonthView Class
MonthView Members


ArrowsSelectedColor Property

MonthView ArrowsSelectedColor Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the color of the arrows selected.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property ArrowsSelectedColor As Color
    Get
    Set
Public Property ArrowsSelectedColor As Color
    Get
    Set
public Color ArrowsSelectedColor { get; set; }
public Color ArrowsSelectedColor { get; set; }
public:
property Color ArrowsSelectedColor {
    Color get ();
    void set (Color value);
}
public:
property Color ArrowsSelectedColor {
    Color get ();
    void set (Color value);
}
Field Value

            The color of the arrows selected.

See Also
MonthView Class
MonthView Members


BackwardButtonBounds Property

MonthView BackwardButtonBounds Property A Sandcastle Documented Class Library
Send Feedback
Gets the bounds of the backward button

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property BackwardButtonBounds As Rectangle
    Get
Public ReadOnly Property BackwardButtonBounds As Rectangle
    Get
public Rectangle BackwardButtonBounds { get; }
public Rectangle BackwardButtonBounds { get; }
public:
property Rectangle BackwardButtonBounds {
    Rectangle get ();
}
public:
property Rectangle BackwardButtonBounds {
    Rectangle get ();
}
See Also
MonthView Class
MonthView Members


BackwardButtonSelected Property

MonthView BackwardButtonSelected Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if the backward button is selected

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property BackwardButtonSelected As Boolean
    Get
Public ReadOnly Property BackwardButtonSelected As Boolean
    Get
public bool BackwardButtonSelected { get; }
public bool BackwardButtonSelected { get; }
public:
property bool BackwardButtonSelected {
    bool get ();
}
public:
property bool BackwardButtonSelected {
    bool get ();
}
See Also
MonthView Class
MonthView Members


DayBackgroundColor Property

MonthView DayBackgroundColor Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the color of the day background.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property DayBackgroundColor As Color
    Get
    Set
Public Property DayBackgroundColor As Color
    Get
    Set
public Color DayBackgroundColor { get; set; }
public Color DayBackgroundColor { get; set; }
public:
property Color DayBackgroundColor {
    Color get ();
    void set (Color value);
}
public:
property Color DayBackgroundColor {
    Color get ();
    void set (Color value);
}
Field Value

            The color of the day background.

See Also
MonthView Class
MonthView Members


DayGrayedText Property

MonthView DayGrayedText Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the day grayed text.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property DayGrayedText As Color
    Get
    Set
Public Property DayGrayedText As Color
    Get
    Set
public Color DayGrayedText { get; set; }
public Color DayGrayedText { get; set; }
public:
property Color DayGrayedText {
    Color get ();
    void set (Color value);
}
public:
property Color DayGrayedText {
    Color get ();
    void set (Color value);
}
Field Value

            The day grayed text.

See Also
MonthView Class
MonthView Members


DayNamesFormat Property

MonthView DayNamesFormat Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the format of day names

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property DayNamesFormat As String
    Get
    Set
Public Property DayNamesFormat As String
    Get
    Set
public string DayNamesFormat { get; set; }
public string DayNamesFormat { get; set; }
public:
property String^ DayNamesFormat {
    String^ get ();
    void set (String^ value);
}
public:
property String^ DayNamesFormat {
    String^ get ();
    void set (String^ value);
}
See Also
MonthView Class
MonthView Members


DayNamesLength Property

MonthView DayNamesLength Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets how many characters of day names should be displayed

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property DayNamesLength As Integer
    Get
    Set
Public Property DayNamesLength As Integer
    Get
    Set
public int DayNamesLength { get; set; }
public int DayNamesLength { get; set; }
public:
property int DayNamesLength {
    int get ();
    void set (int value);
}
public:
property int DayNamesLength {
    int get ();
    void set (int value);
}
See Also
MonthView Class
MonthView Members


DayNamesVisible Property

MonthView DayNamesVisible Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets a value indicating if day names should be visible

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property DayNamesVisible As Boolean
    Get
    Set
Public Property DayNamesVisible As Boolean
    Get
    Set
public bool DayNamesVisible { get; set; }
public bool DayNamesVisible { get; set; }
public:
property bool DayNamesVisible {
    bool get ();
    void set (bool value);
}
public:
property bool DayNamesVisible {
    bool get ();
    void set (bool value);
}
See Also
MonthView Class
MonthView Members


DaySelectedBackgroundColor Property

MonthView DaySelectedBackgroundColor Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the color of the day selected background.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property DaySelectedBackgroundColor As Color
    Get
    Set
Public Property DaySelectedBackgroundColor As Color
    Get
    Set
public Color DaySelectedBackgroundColor { get; set; }
public Color DaySelectedBackgroundColor { get; set; }
public:
property Color DaySelectedBackgroundColor {
    Color get ();
    void set (Color value);
}
public:
property Color DaySelectedBackgroundColor {
    Color get ();
    void set (Color value);
}
Field Value

            The color of the day selected background.

See Also
MonthView Class
MonthView Members


DaySelectedColor Property

MonthView DaySelectedColor Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the color of the day selected.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property DaySelectedColor As Color
    Get
    Set
Public Property DaySelectedColor As Color
    Get
    Set
public Color DaySelectedColor { get; set; }
public Color DaySelectedColor { get; set; }
public:
property Color DaySelectedColor {
    Color get ();
    void set (Color value);
}
public:
property Color DaySelectedColor {
    Color get ();
    void set (Color value);
}
Field Value

            The color of the day selected.

See Also
MonthView Class
MonthView Members


DaySelectedTextColor Property

MonthView DaySelectedTextColor Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the color of the day selected text.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property DaySelectedTextColor As Color
    Get
    Set
Public Property DaySelectedTextColor As Color
    Get
    Set
public Color DaySelectedTextColor { get; set; }
public Color DaySelectedTextColor { get; set; }
public:
property Color DaySelectedTextColor {
    Color get ();
    void set (Color value);
}
public:
property Color DaySelectedTextColor {
    Color get ();
    void set (Color value);
}
Field Value

            The color of the day selected text.

See Also
MonthView Class
MonthView Members


DaySize Property

MonthView DaySize Property A Sandcastle Documented Class Library
Send Feedback
Gets the size of days rectangles

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property DaySize As Size
    Get
Public ReadOnly Property DaySize As Size
    Get
public Size DaySize { get; }
public Size DaySize { get; }
public:
property Size DaySize {
    Size get ();
}
public:
property Size DaySize {
    Size get ();
}
See Also
MonthView Class
MonthView Members


FirstDayOfWeek Property

MonthView FirstDayOfWeek Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets what the first day of weeks should be

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property FirstDayOfWeek As DayOfWeek
    Get
    Set
Public Property FirstDayOfWeek As DayOfWeek
    Get
    Set
public DayOfWeek FirstDayOfWeek { get; set; }
public DayOfWeek FirstDayOfWeek { get; set; }
public:
property DayOfWeek FirstDayOfWeek {
    DayOfWeek get ();
    void set (DayOfWeek value);
}
public:
property DayOfWeek FirstDayOfWeek {
    DayOfWeek get ();
    void set (DayOfWeek value);
}
See Also
MonthView Class
MonthView Members


Font Property

MonthView Font Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the Font of the Control

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Overrides Property Font As Font
    Get
    Set
Public Overrides Property Font As Font
    Get
    Set
public override Font Font { get; set; }
public override Font Font { get; set; }
public:
virtual property Font^ Font {
    Font^ get () override;
    void set (Font^ value) override;
}
public:
virtual property Font^ Font {
    Font^ get () override;
    void set (Font^ value) override;
}
See Also
MonthView Class
MonthView Members


ForwardButtonBounds Property

MonthView ForwardButtonBounds Property A Sandcastle Documented Class Library
Send Feedback
Gets the bounds of the forward button

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property ForwardButtonBounds As Rectangle
    Get
Public ReadOnly Property ForwardButtonBounds As Rectangle
    Get
public Rectangle ForwardButtonBounds { get; }
public Rectangle ForwardButtonBounds { get; }
public:
property Rectangle ForwardButtonBounds {
    Rectangle get ();
}
public:
property Rectangle ForwardButtonBounds {
    Rectangle get ();
}
See Also
MonthView Class
MonthView Members


ForwardButtonSelected Property

MonthView ForwardButtonSelected Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if the forward button is selected

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property ForwardButtonSelected As Boolean
    Get
Public ReadOnly Property ForwardButtonSelected As Boolean
    Get
public bool ForwardButtonSelected { get; }
public bool ForwardButtonSelected { get; }
public:
property bool ForwardButtonSelected {
    bool get ();
}
public:
property bool ForwardButtonSelected {
    bool get ();
}
See Also
MonthView Class
MonthView Members


ItemPadding Property

MonthView ItemPadding Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the internal padding of items (Days, day names, month names)

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property ItemPadding As Padding
    Get
    Set
Public Property ItemPadding As Padding
    Get
    Set
public Padding ItemPadding { get; set; }
public Padding ItemPadding { get; set; }
public:
property Padding ItemPadding {
    Padding get ();
    void set (Padding value);
}
public:
property Padding ItemPadding {
    Padding get ();
    void set (Padding value);
}
See Also
MonthView Class
MonthView Members


MaxSelectionCount Property

MonthView MaxSelectionCount Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the maximum selection count of days

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property MaxSelectionCount As Integer
    Get
    Set
Public Property MaxSelectionCount As Integer
    Get
    Set
public int MaxSelectionCount { get; set; }
public int MaxSelectionCount { get; set; }
public:
property int MaxSelectionCount {
    int get ();
    void set (int value);
}
public:
property int MaxSelectionCount {
    int get ();
    void set (int value);
}
See Also
MonthView Class
MonthView Members


Months Property

MonthView Months Property A Sandcastle Documented Class Library
Send Feedback
Gets the Months currently displayed on the calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Months As MonthViewMonth()
    Get
Public ReadOnly Property Months As MonthViewMonth()
    Get
public MonthViewMonth[] Months { get; }
public MonthViewMonth[] Months { get; }
public:
property array<MonthViewMonth^>^ Months {
    array<MonthViewMonth^>^ get ();
}
public:
property array<MonthViewMonth^>^ Months {
    array<MonthViewMonth^>^ get ();
}
See Also
MonthView Class
MonthView Members


MonthSize Property

MonthView MonthSize Property A Sandcastle Documented Class Library
Send Feedback
Gets the size of an entire month inside the MonthView

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property MonthSize As Size
    Get
Public ReadOnly Property MonthSize As Size
    Get
public Size MonthSize { get; }
public Size MonthSize { get; }
public:
property Size MonthSize {
    Size get ();
}
public:
property Size MonthSize {
    Size get ();
}
See Also
MonthView Class
MonthView Members


MonthTitleColor Property

MonthView MonthTitleColor Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the color of the month title.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property MonthTitleColor As Color
    Get
    Set
Public Property MonthTitleColor As Color
    Get
    Set
public Color MonthTitleColor { get; set; }
public Color MonthTitleColor { get; set; }
public:
property Color MonthTitleColor {
    Color get ();
    void set (Color value);
}
public:
property Color MonthTitleColor {
    Color get ();
    void set (Color value);
}
Field Value

            The color of the month title.

See Also
MonthView Class
MonthView Members


MonthTitleColorInactive Property

MonthView MonthTitleColorInactive Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the month title color inactive.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property MonthTitleColorInactive As Color
    Get
    Set
Public Property MonthTitleColorInactive As Color
    Get
    Set
public Color MonthTitleColorInactive { get; set; }
public Color MonthTitleColorInactive { get; set; }
public:
property Color MonthTitleColorInactive {
    Color get ();
    void set (Color value);
}
public:
property Color MonthTitleColorInactive {
    Color get ();
    void set (Color value);
}
Field Value

            The month title color inactive.

See Also
MonthView Class
MonthView Members


MonthTitleFormat Property

MonthView MonthTitleFormat Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the format of month titles

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property MonthTitleFormat As String
    Get
    Set
Public Property MonthTitleFormat As String
    Get
    Set
public string MonthTitleFormat { get; set; }
public string MonthTitleFormat { get; set; }
public:
property String^ MonthTitleFormat {
    String^ get ();
    void set (String^ value);
}
public:
property String^ MonthTitleFormat {
    String^ get ();
    void set (String^ value);
}
See Also
MonthView Class
MonthView Members


MonthTitleTextColor Property

MonthView MonthTitleTextColor Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the color of the month title text.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property MonthTitleTextColor As Color
    Get
    Set
Public Property MonthTitleTextColor As Color
    Get
    Set
public Color MonthTitleTextColor { get; set; }
public Color MonthTitleTextColor { get; set; }
public:
property Color MonthTitleTextColor {
    Color get ();
    void set (Color value);
}
public:
property Color MonthTitleTextColor {
    Color get ();
    void set (Color value);
}
Field Value

            The color of the month title text.

See Also
MonthView Class
MonthView Members


MonthTitleTextColorInactive Property

MonthView MonthTitleTextColorInactive Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the month title text color inactive.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property MonthTitleTextColorInactive As Color
    Get
    Set
Public Property MonthTitleTextColorInactive As Color
    Get
    Set
public Color MonthTitleTextColorInactive { get; set; }
public Color MonthTitleTextColorInactive { get; set; }
public:
property Color MonthTitleTextColorInactive {
    Color get ();
    void set (Color value);
}
public:
property Color MonthTitleTextColorInactive {
    Color get ();
    void set (Color value);
}
Field Value

            The month title text color inactive.

See Also
MonthView Class
MonthView Members


SelectionEnd Property

MonthView SelectionEnd Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the end of selection

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property SelectionEnd As DateTime
    Get
    Set
Public Property SelectionEnd As DateTime
    Get
    Set
public DateTime SelectionEnd { get; set; }
public DateTime SelectionEnd { get; set; }
public:
property DateTime SelectionEnd {
    DateTime get ();
    void set (DateTime value);
}
public:
property DateTime SelectionEnd {
    DateTime get ();
    void set (DateTime value);
}
See Also
MonthView Class
MonthView Members


SelectionMode Property

MonthView SelectionMode Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the selection mode of MonthView

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property SelectionMode As MonthViewSelection
    Get
    Set
Public Property SelectionMode As MonthViewSelection
    Get
    Set
public MonthViewSelection SelectionMode { get; set; }
public MonthViewSelection SelectionMode { get; set; }
public:
property MonthViewSelection SelectionMode {
    MonthViewSelection get ();
    void set (MonthViewSelection value);
}
public:
property MonthViewSelection SelectionMode {
    MonthViewSelection get ();
    void set (MonthViewSelection value);
}
See Also
MonthView Class
MonthView Members


SelectionStart Property

MonthView SelectionStart Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the start of selection

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property SelectionStart As DateTime
    Get
    Set
Public Property SelectionStart As DateTime
    Get
    Set
public DateTime SelectionStart { get; set; }
public DateTime SelectionStart { get; set; }
public:
property DateTime SelectionStart {
    DateTime get ();
    void set (DateTime value);
}
public:
property DateTime SelectionStart {
    DateTime get ();
    void set (DateTime value);
}
See Also
MonthView Class
MonthView Members


TodayBorderColor Property

MonthView TodayBorderColor Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the color of the today day border color

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property TodayBorderColor As Color
    Get
    Set
Public Property TodayBorderColor As Color
    Get
    Set
public Color TodayBorderColor { get; set; }
public Color TodayBorderColor { get; set; }
public:
property Color TodayBorderColor {
    Color get ();
    void set (Color value);
}
public:
property Color TodayBorderColor {
    Color get ();
    void set (Color value);
}
See Also
MonthView Class
MonthView Members


ViewEnd Property

MonthView ViewEnd Property A Sandcastle Documented Class Library
Send Feedback
Gets the last day of the last month showed on the view.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property ViewEnd As DateTime
    Get
Public ReadOnly Property ViewEnd As DateTime
    Get
public DateTime ViewEnd { get; }
public DateTime ViewEnd { get; }
public:
property DateTime ViewEnd {
    DateTime get ();
}
public:
property DateTime ViewEnd {
    DateTime get ();
}
See Also
MonthView Class
MonthView Members


ViewStart Property

MonthView ViewStart Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the date of the first displayed month

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property ViewStart As DateTime
    Get
    Set
Public Property ViewStart As DateTime
    Get
    Set
public DateTime ViewStart { get; set; }
public DateTime ViewStart { get; set; }
public:
property DateTime ViewStart {
    DateTime get ();
    void set (DateTime value);
}
public:
property DateTime ViewStart {
    DateTime get ();
    void set (DateTime value);
}
See Also
MonthView Class
MonthView Members


WorkWeekEnd Property

MonthView WorkWeekEnd Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the day that ends a work-week

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property WorkWeekEnd As DayOfWeek
    Get
    Set
Public Property WorkWeekEnd As DayOfWeek
    Get
    Set
public DayOfWeek WorkWeekEnd { get; set; }
public DayOfWeek WorkWeekEnd { get; set; }
public:
property DayOfWeek WorkWeekEnd {
    DayOfWeek get ();
    void set (DayOfWeek value);
}
public:
property DayOfWeek WorkWeekEnd {
    DayOfWeek get ();
    void set (DayOfWeek value);
}
See Also
MonthView Class
MonthView Members


WorkWeekStart Property

MonthView WorkWeekStart Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the day that starts a work-week

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property WorkWeekStart As DayOfWeek
    Get
    Set
Public Property WorkWeekStart As DayOfWeek
    Get
    Set
public DayOfWeek WorkWeekStart { get; set; }
public DayOfWeek WorkWeekStart { get; set; }
public:
property DayOfWeek WorkWeekStart {
    DayOfWeek get ();
    void set (DayOfWeek value);
}
public:
property DayOfWeek WorkWeekStart {
    DayOfWeek get ();
    void set (DayOfWeek value);
}
See Also
MonthView Class
MonthView Members


MonthView Events

MonthView Events A Sandcastle Documented Class Library
The MonthView type exposes the following members.
Events
 | Name | Description
Public event | Online AutoSizeChanged | This event is not relevant for this class. (Inherited from Online Control.)
Public event | Online AutoValidateChanged | Occurs when the Online AutoValidate property changes. (Inherited from Online ContainerControl.)
Public event | Online BackColorChanged | Occurs when the value of the Online BackColor property changes. (Inherited from Online Control.)
Public event | Online BackgroundImageChanged | Occurs when the value of the Online BackgroundImage property changes. (Inherited from Online Control.)
Public event | Online BackgroundImageLayoutChanged | Occurs when the Online BackgroundImageLayout property changes. (Inherited from Online Control.)
Public event | Online BindingContextChanged | Occurs when the value of the Online BindingContext property changes. (Inherited from Online Control.)
Public event | Online CausesValidationChanged | Occurs when the value of the Online CausesValidation property changes. (Inherited from Online Control.)
Public event | Online ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Online Control.)
Public event | Online Click | Occurs when the control is clicked. (Inherited from Online Control.)
Public event | Online ClientSizeChanged | Occurs when the value of the Online ClientSize property changes. (Inherited from Online Control.)
Public event | Online ContextMenuChanged | Occurs when the value of the Online ContextMenu property changes. (Inherited from Online Control.)
Public event | Online ContextMenuStripChanged | Occurs when the value of the Online ContextMenuStrip property changes. (Inherited from Online Control.)
Public event | Online ControlAdded | Occurs when a new control is added to the Online Control ControlCollection. (Inherited from Online Control.)
Public event | Online ControlRemoved | Occurs when a control is removed from the Online Control ControlCollection. (Inherited from Online Control.)
Public event | Online CursorChanged | Occurs when the value of the Online Cursor property changes. (Inherited from Online Control.)
Public event | Online Disposed | Occurs when the component is disposed by a call to the Online Dispose method. (Inherited from Online Component.)
Public event | Online DockChanged | Occurs when the value of the Online Dock property changes. (Inherited from Online Control.)
Public event | Online DoubleClick | Occurs when the control is double-clicked. (Inherited from Online Control.)
Public event | Online DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Online Control.)
Public event | Online DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Online Control.)
Public event | Online DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Online Control.)
Public event | Online DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Online Control.)
Public event | Online EnabledChanged | Occurs when the Online Enabled property value has changed. (Inherited from Online Control.)
Public event | Online Enter | Occurs when the control is entered. (Inherited from Online Control.)
Public event | Online FontChanged | Occurs when the Online Font property value changes. (Inherited from Online Control.)
Public event | Online ForeColorChanged | Occurs when the Online ForeColor property value changes. (Inherited from Online Control.)
Public event | Online GiveFeedback | Occurs during a drag operation. (Inherited from Online Control.)
Public event | Online GotFocus | Occurs when the control receives focus. (Inherited from Online Control.)
Public event | Online HandleCreated | Occurs when a handle is created for the control. (Inherited from Online Control.)
Public event | Online HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Online Control.)
Public event | Online HelpRequested | Occurs when the user requests help for a control. (Inherited from Online Control.)
Public event | Online ImeModeChanged | Occurs when the Online ImeMode property has changed. (Inherited from Online Control.)
Public event | Online Invalidated | Occurs when a control's display requires redrawing. (Inherited from Online Control.)
Public event | Online KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Online Control.)
Public event | Online KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Online Control.)
Public event | Online KeyUp | Occurs when a key is released while the control has focus. (Inherited from Online Control.)
Public event | Online Layout | Occurs when a control should reposition its child controls. (Inherited from Online Control.)
Public event | Online Leave | Occurs when the input focus leaves the control. (Inherited from Online Control.)
Public event | Online LocationChanged | Occurs when the Online Location property value has changed. (Inherited from Online Control.)
Public event | Online LostFocus | Occurs when the control loses focus. (Inherited from Online Control.)
Public event | Online MarginChanged | Occurs when the control's margin changes. (Inherited from Online Control.)
Public event | Online MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Online Control.)
Public event | Online MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Online Control.)
Public event | Online MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Online Control.)
Public event | Online MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Online Control.)
Public event | Online MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Online Control.)
Public event | Online MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Online Control.)
Public event | Online MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Online Control.)
Public event | Online MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Online Control.)
Public event | Online MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Online Control.)
Public event | Online MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Online Control.)
Public event | Online Move | Occurs when the control is moved. (Inherited from Online Control.)
Public event | Online PaddingChanged | Occurs when the control's padding changes. (Inherited from Online Control.)
Public event | Online Paint | Occurs when the control is redrawn. (Inherited from Online Control.)
Public event | Online ParentChanged | Occurs when the Online Parent property value changes. (Inherited from Online Control.)
Public event | Online PreviewKeyDown | Occurs before the Online KeyDown event when a key is pressed while focus is on this control. (Inherited from Online Control.)
Public event | Online QueryAccessibilityHelp | Occurs when Online AccessibleObject is providing help to accessibility applications. (Inherited from Online Control.)
Public event | Online QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Online Control.)
Public event | Online RegionChanged | Occurs when the value of the Online Region property changes. (Inherited from Online Control.)
Public event | Online Resize | Occurs when the control is resized. (Inherited from Online Control.)
Public event | Online RightToLeftChanged | Occurs when the Online RightToLeft property value changes. (Inherited from Online Control.)
Public event | Online Scroll | Occurs when the user or code scrolls through the client area. (Inherited from Online ScrollableControl.)
Public event | SelectionChanged | Occurs when selection has changed.
Public event | Online SizeChanged | Occurs when the Online Size property value changes. (Inherited from Online Control.)
Public event | Online StyleChanged | Occurs when the control style changes. (Inherited from Online Control.)
Public event | Online SystemColorsChanged | Occurs when the system colors change. (Inherited from Online Control.)
Public event | Online TabIndexChanged | Occurs when the Online TabIndex property value changes. (Inherited from Online Control.)
Public event | Online TabStopChanged | Occurs when the Online TabStop property value changes. (Inherited from Online Control.)
Public event | Online TextChanged | Occurs when the Online Text property value changes. (Inherited from Online Control.)
Public event | Online Validated | Occurs when the control is finished validating. (Inherited from Online Control.)
Public event | Online Validating | Occurs when the control is validating. (Inherited from Online Control.)
Public event | Online VisibleChanged | Occurs when the Online Visible property value changes. (Inherited from Online Control.)
Back to Top
See Also
MonthView Class


SelectionChanged Event

MonthView SelectionChanged Event A Sandcastle Documented Class Library
Send Feedback
Occurs when selection has changed.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Event SelectionChanged As EventHandler
Public Event SelectionChanged As EventHandler
public event EventHandler SelectionChanged
public event EventHandler SelectionChanged
public:
 event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
See Also
MonthView Class
MonthView Members


MonthViewBoxEventArgs Class

MonthViewBoxEventArgs Class A Sandcastle Documented Class Library
Send Feedback
Holds data about a box of text to be rendered on the month view
Inheritance Hierarchy
Online System Object
WindowsFormsCalendar MonthViewBoxEventArgs

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class MonthViewBoxEventArgs
Public Class MonthViewBoxEventArgs
public class MonthViewBoxEventArgs
public class MonthViewBoxEventArgs
public ref class MonthViewBoxEventArgs
public ref class MonthViewBoxEventArgs
See Also
MonthViewBoxEventArgs Members


MonthViewBoxEventArgs Members

MonthViewBoxEventArgs Members A Sandcastle Documented Class Library
Send Feedback

The MonthViewBoxEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | BackgroundColor | Gets or sets the background color of the box
Public property | BorderColor | Gets or sets the border color of the box
Public property | Bounds | Gets or sets the bounds of the box
Public property | Font | Gets or sets the font of the text. If null, default will be used.
Public property | Graphics | Gets or sets the Graphics object where to draw
Public property | Text | Gets or sets the text of the box
Public property | TextColor | Gets or sets the text color of the box
Public property | TextFlags | Gets or sets the flags of the text
Back to Top
See Also
MonthViewBoxEventArgs Class


MonthViewBoxEventArgs Methods

MonthViewBoxEventArgs Methods A Sandcastle Documented Class Library
Send Feedback
The MonthViewBoxEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MonthViewBoxEventArgs Class


MonthViewBoxEventArgs Properties

MonthViewBoxEventArgs Properties A Sandcastle Documented Class Library
Send Feedback
The MonthViewBoxEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | BackgroundColor | Gets or sets the background color of the box
Public property | BorderColor | Gets or sets the border color of the box
Public property | Bounds | Gets or sets the bounds of the box
Public property | Font | Gets or sets the font of the text. If null, default will be used.
Public property | Graphics | Gets or sets the Graphics object where to draw
Public property | Text | Gets or sets the text of the box
Public property | TextColor | Gets or sets the text color of the box
Public property | TextFlags | Gets or sets the flags of the text
Back to Top
See Also
MonthViewBoxEventArgs Class


BackgroundColor Property

MonthViewBoxEventArgs BackgroundColor Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the background color of the box

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property BackgroundColor As Color
    Get
    Set
Public Property BackgroundColor As Color
    Get
    Set
public Color BackgroundColor { get; set; }
public Color BackgroundColor { get; set; }
public:
property Color BackgroundColor {
    Color get ();
    void set (Color value);
}
public:
property Color BackgroundColor {
    Color get ();
    void set (Color value);
}
See Also
MonthViewBoxEventArgs Class
MonthViewBoxEventArgs Members


BorderColor Property

MonthViewBoxEventArgs BorderColor Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the border color of the box

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property BorderColor As Color
    Get
    Set
Public Property BorderColor As Color
    Get
    Set
public Color BorderColor { get; set; }
public Color BorderColor { get; set; }
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
See Also
MonthViewBoxEventArgs Class
MonthViewBoxEventArgs Members


Bounds Property

MonthViewBoxEventArgs Bounds Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the bounds of the box

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Bounds As Rectangle
    Get
Public ReadOnly Property Bounds As Rectangle
    Get
public Rectangle Bounds { get; }
public Rectangle Bounds { get; }
public:
property Rectangle Bounds {
    Rectangle get ();
}
public:
property Rectangle Bounds {
    Rectangle get ();
}
See Also
MonthViewBoxEventArgs Class
MonthViewBoxEventArgs Members


Font Property

MonthViewBoxEventArgs Font Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the font of the text. If null, default will be used.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property Font As Font
    Get
    Set
Public Property Font As Font
    Get
    Set
public Font Font { get; set; }
public Font Font { get; set; }
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
See Also
MonthViewBoxEventArgs Class
MonthViewBoxEventArgs Members


Graphics Property

MonthViewBoxEventArgs Graphics Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the Graphics object where to draw

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Graphics As Graphics
    Get
Public ReadOnly Property Graphics As Graphics
    Get
public Graphics Graphics { get; }
public Graphics Graphics { get; }
public:
property Graphics^ Graphics {
    Graphics^ get ();
}
public:
property Graphics^ Graphics {
    Graphics^ get ();
}
See Also
MonthViewBoxEventArgs Class
MonthViewBoxEventArgs Members


Text Property

MonthViewBoxEventArgs Text Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the text of the box

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property Text As String
    Get
    Set
Public Property Text As String
    Get
    Set
public string Text { get; set; }
public string Text { get; set; }
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
See Also
MonthViewBoxEventArgs Class
MonthViewBoxEventArgs Members


TextColor Property

MonthViewBoxEventArgs TextColor Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the text color of the box

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property TextColor As Color
    Get
    Set
Public Property TextColor As Color
    Get
    Set
public Color TextColor { get; set; }
public Color TextColor { get; set; }
public:
property Color TextColor {
    Color get ();
    void set (Color value);
}
public:
property Color TextColor {
    Color get ();
    void set (Color value);
}
See Also
MonthViewBoxEventArgs Class
MonthViewBoxEventArgs Members


TextFlags Property

MonthViewBoxEventArgs TextFlags Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the flags of the text

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property TextFlags As TextFormatFlags
    Get
    Set
Public Property TextFlags As TextFormatFlags
    Get
    Set
public TextFormatFlags TextFlags { get; set; }
public TextFormatFlags TextFlags { get; set; }
public:
property TextFormatFlags TextFlags {
    TextFormatFlags get ();
    void set (TextFormatFlags value);
}
public:
property TextFormatFlags TextFlags {
    TextFormatFlags get ();
    void set (TextFormatFlags value);
}
See Also
MonthViewBoxEventArgs Class
MonthViewBoxEventArgs Members


MonthViewDay Class

MonthViewDay Class A Sandcastle Documented Class Library
A class that represents a month view day
Inheritance Hierarchy
Online System Object
WindowsFormsCalendar MonthViewDay

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class MonthViewDay
Public Class MonthViewDay
public class MonthViewDay
public class MonthViewDay
public ref class MonthViewDay
public ref class MonthViewDay
See Also
MonthViewDay Members


MonthViewDay Members

MonthViewDay Members A Sandcastle Documented Class Library

The MonthViewDay type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounds of the day
Public property | Date | Gets the date this day represents
Public property | Grayed | Gets if the day is grayed
Public property | Month | Gets the parent MonthViewMonth
Public property | MonthView | Gets the parent MonthView
Public property | Selected | Gets or sets if the day is currently selected
Public property | Visible | Gets a value indicating if the day instance is visible on the calendar
Back to Top
See Also
MonthViewDay Class


MonthViewDay Methods

MonthViewDay Methods A Sandcastle Documented Class Library
The MonthViewDay type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MonthViewDay Class


MonthViewDay Properties

MonthViewDay Properties A Sandcastle Documented Class Library
Send Feedback
The MonthViewDay type exposes the following members.
Properties
 | Name | Description
Public property | Bounds | Gets the bounds of the day
Public property | Date | Gets the date this day represents
Public property | Grayed | Gets if the day is grayed
Public property | Month | Gets the parent MonthViewMonth
Public property | MonthView | Gets the parent MonthView
Public property | Selected | Gets or sets if the day is currently selected
Public property | Visible | Gets a value indicating if the day instance is visible on the calendar
Back to Top
See Also
MonthViewDay Class


Bounds Property

MonthViewDay Bounds Property A Sandcastle Documented Class Library
Send Feedback
Gets the bounds of the day

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Bounds As Rectangle
    Get
Public ReadOnly Property Bounds As Rectangle
    Get
public Rectangle Bounds { get; }
public Rectangle Bounds { get; }
public:
property Rectangle Bounds {
    Rectangle get ();
}
public:
property Rectangle Bounds {
    Rectangle get ();
}
See Also
MonthViewDay Class
MonthViewDay Members


Date Property

MonthViewDay Date Property A Sandcastle Documented Class Library
Send Feedback
Gets the date this day represents

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Date As DateTime
    Get
Public ReadOnly Property Date As DateTime
    Get
public DateTime Date { get; }
public DateTime Date { get; }
public:
property DateTime Date {
    DateTime get ();
}
public:
property DateTime Date {
    DateTime get ();
}
See Also
MonthViewDay Class
MonthViewDay Members


Grayed Property

MonthViewDay Grayed Property A Sandcastle Documented Class Library
Send Feedback
Gets if the day is grayed

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Grayed As Boolean
    Get
Public ReadOnly Property Grayed As Boolean
    Get
public bool Grayed { get; }
public bool Grayed { get; }
public:
property bool Grayed {
    bool get ();
}
public:
property bool Grayed {
    bool get ();
}
See Also
MonthViewDay Class
MonthViewDay Members


Month Property

MonthViewDay Month Property A Sandcastle Documented Class Library
Send Feedback
Gets the parent MonthViewMonth

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Month As MonthViewMonth
    Get
Public ReadOnly Property Month As MonthViewMonth
    Get
public MonthViewMonth Month { get; }
public MonthViewMonth Month { get; }
public:
property MonthViewMonth^ Month {
    MonthViewMonth^ get ();
}
public:
property MonthViewMonth^ Month {
    MonthViewMonth^ get ();
}
See Also
MonthViewDay Class
MonthViewDay Members


MonthView Property

MonthViewDay MonthView Property A Sandcastle Documented Class Library
Send Feedback
Gets the parent MonthView

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property MonthView As MonthView
    Get
    Set
Public Property MonthView As MonthView
    Get
    Set
public MonthView MonthView { get; set; }
public MonthView MonthView { get; set; }
public:
property MonthView^ MonthView {
    MonthView^ get ();
    void set (MonthView^ value);
}
public:
property MonthView^ MonthView {
    MonthView^ get ();
    void set (MonthView^ value);
}
See Also
MonthViewDay Class
MonthViewDay Members


Selected Property

MonthViewDay Selected Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets if the day is currently selected

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Selected As Boolean
    Get
Public ReadOnly Property Selected As Boolean
    Get
public bool Selected { get; }
public bool Selected { get; }
public:
property bool Selected {
    bool get ();
}
public:
property bool Selected {
    bool get ();
}
See Also
MonthViewDay Class
MonthViewDay Members


Visible Property

MonthViewDay Visible Property A Sandcastle Documented Class Library
Send Feedback
Gets a value indicating if the day instance is visible on the calendar

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Visible As Boolean
    Get
Public ReadOnly Property Visible As Boolean
    Get
public bool Visible { get; }
public bool Visible { get; }
public:
property bool Visible {
    bool get ();
}
public:
property bool Visible {
    bool get ();
}
See Also
MonthViewDay Class
MonthViewDay Members


MonthViewMontEventArgs Class

MonthViewMontEventArgs Class A Sandcastle Documented Class Library
Send Feedback
Month view event argument data
Inheritance Hierarchy
Online System Object
WindowsFormsCalendar MonthViewMontEventArgs

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class MonthViewMontEventArgs
Public Class MonthViewMontEventArgs
public class MonthViewMontEventArgs
public class MonthViewMontEventArgs
public ref class MonthViewMontEventArgs
public ref class MonthViewMontEventArgs
See Also
MonthViewMontEventArgs Members


MonthViewMontEventArgs Members

MonthViewMontEventArgs Members A Sandcastle Documented Class Library
Send Feedback

The MonthViewMontEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | MonthViewMontEventArgs | Initializes a new instance of the MonthViewMontEventArgs class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MonthViewMontEventArgs Class


MonthViewMontEventArgs Constructor

MonthViewMontEventArgs Constructor A Sandcastle Documented Class Library
Send Feedback
Initializes a new instance of the MonthViewMontEventArgs class

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Sub New
Public Sub New
public MonthViewMontEventArgs()
public MonthViewMontEventArgs()
public:
MonthViewMontEventArgs()
public:
MonthViewMontEventArgs()
See Also
MonthViewMontEventArgs Class
MonthViewMontEventArgs Members


MonthViewMontEventArgs Methods

MonthViewMontEventArgs Methods A Sandcastle Documented Class Library
Send Feedback
The MonthViewMontEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MonthViewMontEventArgs Class


MonthViewMonth Class

MonthViewMonth Class A Sandcastle Documented Class Library
Represents a month displayed"/>
Inheritance Hierarchy
Online System Object
WindowsFormsCalendar MonthViewMonth

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Class MonthViewMonth
Public Class MonthViewMonth
public class MonthViewMonth
public class MonthViewMonth
public ref class MonthViewMonth
public ref class MonthViewMonth
See Also
MonthViewMonth Members


MonthViewMonth Members

MonthViewMonth Members A Sandcastle Documented Class Library

The MonthViewMonth type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounds.
Public property | Date | Gets or sets the date of the first day of the month
Public property | DayHeaders | Gets or sets the day headers.
Public property | DayNamesBounds | Gets or sets the day names bounds.
Public property | Days | Gets or sets the days.
Public property | Location | Gets the location.
Public property | MonthNameBounds | Gets or sets the month name bounds.
Public property | MonthView | Gets the month view.
Public property | Size | Gets the size.
Back to Top
See Also
MonthViewMonth Class


MonthViewMonth Methods

MonthViewMonth Methods A Sandcastle Documented Class Library
The MonthViewMonth type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
MonthViewMonth Class


MonthViewMonth Properties

MonthViewMonth Properties A Sandcastle Documented Class Library
Send Feedback
The MonthViewMonth type exposes the following members.
Properties
 | Name | Description
Public property | Bounds | Gets the bounds.
Public property | Date | Gets or sets the date of the first day of the month
Public property | DayHeaders | Gets or sets the day headers.
Public property | DayNamesBounds | Gets or sets the day names bounds.
Public property | Days | Gets or sets the days.
Public property | Location | Gets the location.
Public property | MonthNameBounds | Gets or sets the month name bounds.
Public property | MonthView | Gets the month view.
Public property | Size | Gets the size.
Back to Top
See Also
MonthViewMonth Class


Bounds Property

MonthViewMonth Bounds Property A Sandcastle Documented Class Library
Send Feedback
Gets the bounds.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Bounds As Rectangle
    Get
Public ReadOnly Property Bounds As Rectangle
    Get
public Rectangle Bounds { get; }
public Rectangle Bounds { get; }
public:
property Rectangle Bounds {
    Rectangle get ();
}
public:
property Rectangle Bounds {
    Rectangle get ();
}
See Also
MonthViewMonth Class
MonthViewMonth Members


Date Property

MonthViewMonth Date Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the date of the first day of the month

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Date As DateTime
    Get
Public ReadOnly Property Date As DateTime
    Get
public DateTime Date { get; }
public DateTime Date { get; }
public:
property DateTime Date {
    DateTime get ();
}
public:
property DateTime Date {
    DateTime get ();
}
See Also
MonthViewMonth Class
MonthViewMonth Members


DayHeaders Property

MonthViewMonth DayHeaders Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the day headers.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property DayHeaders As String()
    Get
    Set
Public Property DayHeaders As String()
    Get
    Set
public string[] DayHeaders { get; set; }
public string[] DayHeaders { get; set; }
public:
property array<String^>^ DayHeaders {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
public:
property array<String^>^ DayHeaders {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
Field Value

            The day headers.

See Also
MonthViewMonth Class
MonthViewMonth Members


DayNamesBounds Property

MonthViewMonth DayNamesBounds Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the day names bounds.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property DayNamesBounds As Rectangle()
    Get
    Set
Public Property DayNamesBounds As Rectangle()
    Get
    Set
public Rectangle[] DayNamesBounds { get; set; }
public Rectangle[] DayNamesBounds { get; set; }
public:
property array<Rectangle>^ DayNamesBounds {
    array<Rectangle>^ get ();
    void set (array<Rectangle>^ value);
}
public:
property array<Rectangle>^ DayNamesBounds {
    array<Rectangle>^ get ();
    void set (array<Rectangle>^ value);
}
Field Value

            The day names bounds.

See Also
MonthViewMonth Class
MonthViewMonth Members


Days Property

MonthViewMonth Days Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the days.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property Days As MonthViewDay()
    Get
    Set
Public Property Days As MonthViewDay()
    Get
    Set
public MonthViewDay[] Days { get; set; }
public MonthViewDay[] Days { get; set; }
public:
property array<MonthViewDay^>^ Days {
    array<MonthViewDay^>^ get ();
    void set (array<MonthViewDay^>^ value);
}
public:
property array<MonthViewDay^>^ Days {
    array<MonthViewDay^>^ get ();
    void set (array<MonthViewDay^>^ value);
}
Field Value

            The days.

See Also
MonthViewMonth Class
MonthViewMonth Members


Location Property

MonthViewMonth Location Property A Sandcastle Documented Class Library
Send Feedback
Gets the location.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Location As Point
    Get
Public ReadOnly Property Location As Point
    Get
public Point Location { get; }
public Point Location { get; }
public:
property Point Location {
    Point get ();
}
public:
property Point Location {
    Point get ();
}
See Also
MonthViewMonth Class
MonthViewMonth Members


MonthNameBounds Property

MonthViewMonth MonthNameBounds Property A Sandcastle Documented Class Library
Send Feedback
Gets or sets the month name bounds.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Property MonthNameBounds As Rectangle
    Get
    Set
Public Property MonthNameBounds As Rectangle
    Get
    Set
public Rectangle MonthNameBounds { get; set; }
public Rectangle MonthNameBounds { get; set; }
public:
property Rectangle MonthNameBounds {
    Rectangle get ();
    void set (Rectangle value);
}
public:
property Rectangle MonthNameBounds {
    Rectangle get ();
    void set (Rectangle value);
}
Field Value

            The month name bounds.

See Also
MonthViewMonth Class
MonthViewMonth Members


MonthView Property

MonthViewMonth MonthView Property A Sandcastle Documented Class Library
Send Feedback
Gets the month view.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property MonthView As MonthView
    Get
Public ReadOnly Property MonthView As MonthView
    Get
public MonthView MonthView { get; }
public MonthView MonthView { get; }
public:
property MonthView^ MonthView {
    MonthView^ get ();
}
public:
property MonthView^ MonthView {
    MonthView^ get ();
}
See Also
MonthViewMonth Class
MonthViewMonth Members


Size Property

MonthViewMonth Size Property A Sandcastle Documented Class Library
Send Feedback
Gets the size.

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public ReadOnly Property Size As Size
    Get
Public ReadOnly Property Size As Size
    Get
public Size Size { get; }
public Size Size { get; }
public:
property Size Size {
    Size get ();
}
public:
property Size Size {
    Size get ();
}
See Also
MonthViewMonth Class
MonthViewMonth Members


MonthViewSelection Enumeration

MonthViewSelection Enumeration A Sandcastle Documented Class Library
Send Feedback
Represents the different kinds of selection in MonthView

Namespace: WindowsFormsCalendar
Assembly: WindowsFormsCalendar (in WindowsFormsCalendar.dll) Version: 1.0.4601.23235 (1.0.0.0)
Syntax
VB
C#
C++
F#
JScript
View Colorized Copy to Clipboard Print
Public Enumeration MonthViewSelection
Public Enumeration MonthViewSelection
public enum MonthViewSelection
public enum MonthViewSelection
public enum class MonthViewSelection
public enum class MonthViewSelection
Members
Member name | Value | Description
Manual | 0 | User can select whatever date available to mouse reach
Day | 1 | Selection is limited to just one day
WorkWeek | 2 | Selecion is limited to Online DayOfWeek weekly ranges
Week | 3 | Selection is limited to a full week
Month | 4 | Selection is limited to a full month
See Also